16:02:33 <angdraug> #startmeeting fuel
16:02:34 <openstack> Meeting started Thu Nov 26 16:02:33 2015 UTC and is due to finish in 60 minutes.  The chair is angdraug. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:37 <openstack> The meeting name has been set to 'fuel'
16:02:54 <angdraug> #topic Action items from last meeting
16:03:03 <angdraug> akislitsky_ will follow up on possible reasons for the high python bug trend
16:03:16 <angdraug> akislitsky_: around?
16:03:50 <angdraug> forgot the link to agenda:
16:03:54 <angdraug> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:04:01 <akislitsky_> hi
16:04:02 <angdraug> ok, next action was:
16:04:26 <angdraug> akislitsky_: great, any updates on your action from last week?
16:04:43 <akislitsky_> dpyzhov: is working on this action.
16:04:45 <xarses> o/
16:04:59 <angdraug> #chair xarses
16:05:00 <openstack> Current chairs: angdraug xarses
16:05:33 <angdraug> aroma to raise removing / blocking clusters with neutron GRE type in ML
16:06:05 <dpyzhov> akislitsky_: I have a report about python bugs
16:06:16 <angdraug> dpyzhov: please share. link?
16:06:34 <dpyzhov> Link is in 'bugs status' section
16:06:46 <dpyzhov> in agenda
16:06:46 <angdraug> ok, lets cover it when we get to it then
16:07:03 <angdraug> #link https://etherpad.openstack.org/p/fuel-bugs-status
16:07:15 <angdraug> aroma: around?
16:07:52 <aroma> angdraug:  created this thread, slightly before previous meeting, though it touches the subject pretty generally - http://lists.openstack.org/pipermail/openstack-dev/2015-November/079556.html
16:08:05 <aroma> hi, btw)
16:08:10 <angdraug> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079556.html
16:08:28 <angdraug> thanks, any further comments? moving on?
16:09:05 <angdraug> #topic Mixed team status (asaprykin)
16:09:59 <asaprykin> Hello everybody. Our team is on duty today. We are tracking swarm-blocker and triaged bugs queues.
16:10:36 <asaprykin> Also we are finishing work on PROD-2012. We have could of patches on review currently that are about to be merged.
16:10:49 <asaprykin> *couple of patches
16:10:55 <mihgen> what's prod-2012? bp link?
16:11:15 <aglarendil> mihgen: it is about post-deployment changes to OSt config
16:11:16 <asaprykin> https://blueprints.launchpad.net/fuel/+spec/openstack-config-change
16:11:41 <angdraug> folks, please use BP links
16:12:09 <angdraug> asaprykin: are all your patches for openstack-config-change ready for review?
16:12:19 <mihgen> did you guys try to test the whole pipeline?
16:12:55 <asaprykin> QA team have started the whole pipeline testing process.
16:13:01 <mihgen> I mean literally change something and see if it can propagate through nailgun/astute and can be applied by puppet
16:13:31 <mihgen> do we allow to change literally every param in the UI?
16:13:44 <mihgen> or there are params which still can't be changed?
16:13:51 <angdraug> is there a fuel-qa patch on review covering this?
16:14:07 <angdraug> there was a mention of expanding system tests to cover this BP
16:14:11 <asaprykin> Yes, our development patches are ready to review and currently in the middle of review process.
16:14:29 <mihgen> or it's CLI only?
16:14:36 <asaprykin> CLI only
16:15:59 <angdraug> so test status? is there a test case in fuel-qa?
16:16:11 <mihgen> did you guys think how complicated would it be to enable modifications of settings tab in UI?
16:17:11 <asaprykin> AFAIK there is not fuel-qa on review right now.
16:17:18 <asaprykin> *no
16:18:08 <angdraug> ok, I see that as a risk, we're days away from FF
16:18:11 <angdraug> moving on?
16:18:25 <angdraug> #topic Telco team status (dklenov)
16:18:32 <dklenov> hey
16:18:43 <dklenov> Fuel Telco team continues to work on Ubuntu bootstrap feature. Progress by areas:
16:18:43 <dklenov> 1. Fuel-agent - code is on review. Resolving some implementation concerns with maintainers.
16:18:43 <dklenov> 2. Bootstrap-manage script - import, delete, and list commands implementation are merged. Build command to be sent for review.
16:18:43 <dklenov> 3. Several UX improvements for Fuelmenu are on review.
16:18:43 <dklenov> 4. Library part is merged.
16:18:59 <angdraug> thanks for having the report prepared for paste in advance!
16:19:02 <angdraug> asaprykin: ^
16:19:16 <dklenov> sure, np
16:19:50 <angdraug> there were design disagreements in some of your reviews yesterday, is all of that resolved now?
16:19:57 <angdraug> any risks or blockers?
16:20:21 <dklenov> they were agreed with Alex Gordeev - core contributor
16:20:33 <dklenov> the plan is to review them with component lead as well
16:20:49 <dklenov> there is still risk that commits will not be merged in time
16:20:59 <angdraug> ok, thanks
16:21:14 <angdraug> team, please have a look and contribute to the discussion. constructively :)
16:21:15 <mihgen> what do we need to do to mitigate a risk.. ?
16:21:18 <aglarendil> well
16:21:32 <aglarendil> I heard there were very big concerns from holser regarding this feature
16:21:50 <angdraug> holser: ^
16:21:51 <dklenov> mihgen: work with reviewers closely
16:22:14 <aglarendil> and these are the same concerns from me
16:22:17 <dklenov> for the holser's concerns we have send a email to him and would like to get more info
16:22:28 <aglarendil> 1. the feature spec did not involve Fuel Library team at all
16:22:29 <dklenov> we think the case he is asking for is covered
16:22:44 <holser> dklenov: the problem is the plugin should change bootstrap image
16:22:48 <aglarendil> 2. the feature itself seems to be not-plugin aware
16:22:59 <dklenov> holser: you can do it via CLI call
16:23:02 <holser> for instance melanox plugin should be able to inject drivers to bootstral
16:23:12 <holser> CLI call is not the best UX
16:23:16 <dklenov> it can do it
16:23:23 <holser> and adding repos for plugin
16:23:24 <dklenov> please read emails to you with explanation
16:23:35 <mihgen> for 1) from aglarendil, angdraug - please reply with the plan here: http://permalink.gmane.org/gmane.comp.cloud.openstack.devel/70026
16:23:58 <holser> Okey ...
16:23:58 <aglarendil> dklenov: can we have this email in openstack-dev instead of doing bikeshedding on design again?
16:24:09 <holser> dklenov: let’s make a plan how we can fix
16:24:10 <romcheg> aglarendil ++
16:24:20 <holser> ++
16:24:41 <dklenov> ok
16:24:49 <aglarendil> mihgen: plan is trivial - involve SME's properly. somehow deployment engineers were not involved into the design of hardware discovery part
16:24:50 <angdraug> +1 on moving the discussion to ML, but holser please be constructive
16:24:55 <dklenov> holser: can you please start the thread with specific concerns?
16:25:00 <dklenov> I will address them
16:25:04 <holser> Sure ...
16:25:09 <dklenov> ok, thanks
16:25:11 <holser> Let’s make a followup
16:25:21 <dklenov> for spec review plan
16:25:28 <dklenov> I agree with proposed one
16:25:36 <holser> xarses: can you add action item
16:25:37 <mihgen> so to clear things up, are we fine with going original plan?
16:25:47 <mihgen> considering that it's 1 week left before FF?
16:25:48 * holser nods
16:25:50 <dklenov> and pleased to see that now it is shared to broad audience
16:26:05 <aglarendil> mihgen: I have not seen any emails on this yet - so let's discuss and decide what we can do
16:26:10 <mihgen> and do all gaps identified in 9.0
16:26:23 <angdraug> #action holser to report concerns with ubuntu bootstrap design on openstack-dev ML
16:26:29 <dklenov> folks, let's understand the concerns first
16:26:56 <angdraug> time people, lets move on
16:27:04 <mihgen> we can't wait really; let's do a quick turn over please..
16:27:21 <angdraug> mihgen: +1
16:28:00 <angdraug> #topic Enhancements Team Status (ashtokolov)
16:28:10 <ashtokolov> Enhancements weekly status: In progress - 13(was 12), On review - 25(was 24), QA - 10(was 10), Done - 35(was 31)
16:28:18 <ashtokolov> Fix committed+Fix released = 45 (was 41)
16:28:23 <ashtokolov> We are working on
16:28:32 <ashtokolov> 1. Shotgun improvements + Software RAID support (services request)
16:28:38 <ashtokolov> 2. Support for external dashboard plugin entries in Nailgun + astute improvements (e.g. stop deploy + task-based progress bar)
16:28:45 <ashtokolov> 3. Support for external dashboard plugin entries in Nailgun for Plugins with option to show them on the Equipment dashboard
16:28:59 <ashtokolov> 4. Install and use plugin on previously deployed environment
16:29:37 <mihgen> all these sound like pretty heavy pieces
16:29:49 <angdraug> considering we're less than a week away from FF, how confident are you that all of this will go in by then?
16:29:50 <mihgen> are you guys converging by FF? ..
16:30:04 <mihgen> especially with 4)
16:30:18 <ashtokolov> We have a few question with Software RAID support
16:30:38 <ashtokolov> I guess we can solve it
16:30:48 <ashtokolov> about 4) it looks ok
16:30:57 <angdraug> a related question is how much of this can be landed this week, so that we don't have a merge fest on Tuesday
16:31:08 <mihgen> testing of 4) is likely to generate a number of bugs..
16:31:14 <ashtokolov> we have patchs on review
16:31:53 <ashtokolov> Shotgun + Support for external dashboard plugin entries in Railgun + 3 and 4 can be merged this week
16:32:38 <ashtokolov> Software RAID support  + astute improvements are about next week
16:32:54 <ikalnitsky> this week?) it's only tomorrow left for *this week*
16:33:20 <ashtokolov> ikalnitsky + today in CA
16:33:21 <vkramskikh> the patches for plugin links are in pretty good shape - so this week LGTM too
16:33:37 <angdraug> ikalnitsky: tomorrow is 33% of the time left until FF
16:33:53 <ashtokolov> 25% !!!
16:34:20 <angdraug> I don't count the FF day itself
16:34:21 <vkramskikh> I see 20% - tomorrow + 4 days (europe time) next week :)
16:34:38 <angdraug> lets not bikeshed, just try to spread the merges out
16:34:38 <ashtokolov> 3 days actually
16:34:47 <ikalnitsky> ashtokolov: not so much
16:34:57 <ikalnitsky> especially if patches weren't reviewed by folks
16:35:04 <angdraug> btw today in CA is a public holiday, so doesn't count for much either
16:35:16 <angdraug> moving on?
16:35:32 <angdraug> #topic UI Team status (vkramskikh)
16:35:37 <vkramskikh> Hi, here is the status for the remaining features:
16:35:37 <vkramskikh> - Multirack support - almost everything is merged, we're waiting for support of storing filters/sorters state from the backend and fixing bugs for the networks tab - there are quite a few of them, but almost all of them are minor.
16:35:37 <vkramskikh> - Logical segmentation of the settings tab - mostly merged, https://blueprints.launchpad.net/fuel/+spec/reorganize-existing-settings-by-groups won't make it to 8.0 due to lack of resources and will become an epic for 9.0 - we plan to overhaul the settings tab completely.
16:35:37 <vkramskikh> - Support for external plugin dashboard links - backend development is still in progress, but overall looks good. But we still need QA for this feature - it's still not determined who is testing this feature since our QA team can't test this feature due to lack of resources.
16:35:41 <vkramskikh> So we're finishing our work on the features and switching to bugfixing. Questions?
16:37:24 <angdraug> nurla: can you comment about testing external plugin dashboard links?
16:37:28 <mihgen> vkramskikh: there is a spike of bugs identified in UI.. are you folks ok to deal with them sooner than later?
16:37:54 <nurla> @angdraug we sent request to partner team about it
16:38:02 <vkramskikh> mihgen: I think we are - most of them are low-hanging fruits or were promoted from medium
16:38:07 <nurla> still waiting answer
16:38:11 <vkramskikh> yep, no response yet
16:38:22 <vkramskikh> (2 days I think)
16:38:29 <nurla> yep
16:38:33 <angdraug> mihgen: can you prod partners folks?
16:38:49 <mihgen> vkramskikh: pls add me to the email..
16:38:54 <vkramskikh> mihgen: ok
16:39:02 <angdraug> moving on?
16:39:26 <angdraug> #topic code review backlog status: http://bit.ly/1Kp8BzM (mihgen)
16:39:57 <angdraug> #action vkramskikh to include mihgen in conversation about testing external plugin dashboard links
16:40:09 <mihgen> folks we are consistently behind in code review of some repos
16:40:30 <mihgen> now 1 before FF it's extemely important to spend time on reviews
16:40:43 <mihgen> I'd like to have action items in particular today
16:41:16 <mihgen> https://review.openstack.org/#/c/248115/, https://review.openstack.org/#/c/212732/, https://review.openstack.org/#/c/239195/, https://review.openstack.org/#/c/245181/, https://review.openstack.org/#/c/233431/ - patches in fuel-main
16:41:28 <mihgen> whom would we assign to review / merge, angdraug ?
16:42:14 <angdraug> #action kozhukalov review stuck fuel-main patches, delegate to skulanov as needed
16:42:49 <mihgen> https://review.openstack.org/#/c/237957/, https://review.openstack.org/#/c/239685/, https://review.openstack.org/#/c/239969/, https://review.openstack.org/#/c/240822/, https://review.openstack.org/#/c/238455/, https://review.openstack.org/#/c/236350/, https://review.openstack.org/#/c/243530/ - fuel-mirror
16:43:20 <mihgen> what do we do with these? if we deprecate the code there, we need to reply in reviews still and abandon those / keep bugs open though
16:43:30 <mihgen> and ensure that they are closed with new implmentation
16:44:33 <mihgen> is bulat here?
16:44:39 <angdraug> #action bgaifullin go over reviews in fuel-mirror, close obsolete ones and make sure all related bugs are addressed in new implementation
16:44:53 <mihgen> https://review.openstack.org/#/c/231433/ - nailgun-agent
16:45:28 <mihgen> https://review.openstack.org/#/c/230350/ - spec for ikalnitsky (holser provided his +1 already)
16:45:52 <holser> ohh yeah
16:45:56 <angdraug> #action warpc help with getting https://review.openstack.org/#/c/231433/ merged
16:46:28 <angdraug> #action ikalnitsky review refactor-cinder-vmware-role spec https://review.openstack.org/230350
16:46:44 <mihgen> https://review.openstack.org/#/c/238846/, https://review.openstack.org/#/c/245087/, https://review.openstack.org/#/c/247032/, https://review.openstack.org/#/c/247403/, https://review.openstack.org/#/c/243240/  - fuel-web
16:47:38 <mihgen> other design specs: https://review.openstack.org/#/c/242201/, https://review.openstack.org/#/c/213227/, https://review.openstack.org/#/c/232689/, https://review.openstack.org/#/c/246821/, https://review.openstack.org/#/c/247517/
16:48:25 <angdraug> #action ikalnitsky review stuck fuel-web CRs, delegate to maintainers where necessary
16:48:49 <angdraug> wow that's a lot of unmerged specs for the last week before FF
16:49:07 <holser> :/
16:49:30 <mihgen> angdraug: mention concrete links in action pls
16:49:33 <ogelbukh_> for  upgrade team, specs and the development itself are likely to move to 9.0
16:50:03 <ogelbukh_> and still we will need to ask for FFE for upgrade with backup/restore
16:50:12 <angdraug> https://review.openstack.org/213227 is stuck since Oct 13 :/
16:51:11 <angdraug> #action holser ikalnitsky review stuck specs, ping angdraug for merge when done
16:51:19 <mihgen> angdraug: can you do action items mentioning all links  please .. ?
16:51:22 <holser> k
16:51:34 <mihgen> so we can track it next week
16:52:39 <angdraug> mihgen: lets just use meeting log for links, or you can post them all to ML
16:52:53 <angdraug> mihgen: done?
16:53:01 <mihgen> yes
16:53:11 <angdraug> #topic     fuel inside openstack http://lists.openstack.org/pipermail/openstack-dev/2015-November/080477.html (akaszuba)
16:53:19 <akaszuba> hi, i want to ask you to look on problem described in this email http://lists.openstack.org/pipermail/openstack-dev/2015-November/080477.html
16:53:28 <akaszuba> maybe someone had similar situation and could give us some feedback
16:54:42 <angdraug> nurla: maybe someone from your team can help?
16:54:58 <angdraug> xenolog13: ^ thoughts?
16:55:11 <nurla> @angdraug it is good question
16:55:38 <nurla> I need take a look and find resources for this task
16:55:48 <holser> akaszuba: let’s make an action item on that
16:55:48 <angdraug> please follow up on ML
16:56:06 <angdraug> holser: don't we have enough of those?
16:56:12 <nurla> yep, I would take a action item
16:56:23 <holser> as many as we need
16:56:26 <angdraug> #action nurla follow up on http://lists.openstack.org/pipermail/openstack-dev/2015-November/080477.html
16:56:39 <angdraug> #topic Bugs status (dpyzhov) https://etherpad.openstack.org/p/fuel-bugs-status
16:56:43 <dpyzhov> hi guys
16:56:48 <holser> angdraug: thnx
16:56:49 <dpyzhov> we have only 4 minutes left
16:56:55 <dpyzhov> #link https://etherpad.openstack.org/p/fuel-bugs-status
16:56:58 <angdraug> please be brief )
16:57:09 <dpyzhov> I've updated bugs report
16:57:21 <dpyzhov> and split python bugs between teams
16:57:43 <dpyzhov> most of teams have less than 10 bugs in the queue
16:57:55 <mihgen> library folks pls help python folks where possible
16:57:57 <dpyzhov> situation seems to be under control
16:58:03 <mihgen> as we overloaded on python side
16:58:04 <angdraug> #topic Multi-rack status (alex_didenko)
16:58:18 <dpyzhov> )
16:58:20 <alex_didenko1> We're working on 2 user stories right now.
16:58:20 <alex_didenko1> One of them is "Provide an ability to share network L2/L3 parameters" and it's on review.
16:58:20 <alex_didenko1> And the second one is automatic configuration of new routes when new node groups are added. It's under development and we should be able to deliver it on time.
16:58:20 <alex_didenko1> 2 user stories are not going to make it in 8.0 due to lack of resources:
16:58:20 <alex_didenko1> #1 "Allow assignment of VIP for network managed by dhcp" - Fuel won't be able to automatically exclude admin VIP from DHCP ranges. But operator can do this manually. So it's rather 'nice to have' one.
16:58:21 <alex_didenko1> #2 "Possibility to select any network from existing ones where default gateway will be taken from" - this is not going to be implemented as well. Currently we're investigating the possibility to provide/docum
16:58:21 <alex_didenko1> ent a work-around for this feature.
16:58:22 <alex_didenko1> On QA side: tests for controllers from non-default node group are merged and are a part of swarm tests already (8.0.system_test.ubuntu.thread_7). Tests for 2 features we're working on are in development.
16:59:17 <angdraug> nice work!
16:59:18 <angdraug> #topic CentOS7 code reviews https://etherpad.openstack.org/p/fuel_on_centos7 (dteselkin_)
16:59:46 <angdraug> folks, please go through the reviews in the linked etherpad
16:59:54 <angdraug> it's a large and intrusive change
17:00:13 <dteselkin_> There is a big list of CRs that required for CentSO7 on master node, they listed in a list by the link above
17:00:13 <angdraug> but dteselkin_ did a nice job breaking it up, lets merge all backwards compatible stuff asap (first section of the pad)
17:00:25 <angdraug> and review everything in the last section
17:00:28 <angdraug> #link https://etherpad.openstack.org/p/fuel_on_centos7
17:00:29 <dteselkin_> And here https://review.openstack.org/#/q/status:open+topic:centos7-master-node,n,z
17:00:32 <angdraug> and time...
17:00:49 <angdraug> #endmeeting