16:01:17 <xarses> #startmeeting fuel
16:01:17 <xarses> #chair xarses
16:01:17 <xarses> Todays Agenda:
16:01:17 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:01:17 <xarses> Who's here?
16:01:18 <openstack> Meeting started Thu Dec  3 16:01:17 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:22 <openstack> The meeting name has been set to 'fuel'
16:01:24 <openstack> Current chairs: xarses
16:01:28 <ikalnitsky> \o/
16:01:31 <akislitsky_> hi
16:01:33 <fzhadaev> Hi!
16:01:35 <dbilunov> hi
16:01:37 <igorbelikov> o/
16:01:39 <ashtokolov> hi
16:01:40 <maximov_> hi
16:01:48 <vsakharov> hi
16:01:57 <yottatsa> hi
16:02:11 <xarses> #topic Action items from last meeting
16:02:26 <xarses> holser to report concerns with ubuntu bootstrap design on openstack-dev ML
16:03:08 <xarses> vkramskikh to include mihgen in conversation about testing external plugin dashboard links
16:03:26 <vkramskikh> xarses: done
16:03:28 <mihgen> included, vkramskikh did it go further?
16:03:31 <holser_> hi
16:03:38 <vkramskikh> mihgen: yep, we're fine
16:04:02 <mihgen> cool. xarses can you go back for holser_'s action?
16:04:04 <dpyzhov> hi
16:04:05 <xarses> (action from last week) holser_ to report concerns with ubuntu bootstrap design on openstack-dev ML
16:04:40 <holser_> I have investigated the status
16:04:58 <holser_> the problem is pluggability
16:05:23 <holser_> though we all agreed to create a blueprint and run in 9.0
16:05:46 <xarses> ok, letms make sure we don't miss that
16:05:52 <holser_> in 8.0 there will be instruction how to inject drivers to bootstrap
16:05:54 <dklenov> holser_: I still disagree with that problem
16:05:57 <xarses> is it already created?
16:06:07 <holser_> not yet ...
16:06:10 <xarses> is there a bug for the docs?
16:06:11 <mihgen> holser_: openstack-dev email pls
16:06:22 <holser_> k
16:06:40 <xarses> #action holser to follow up creating bp for plugging ubuntu bootstrap
16:06:59 <xarses> #action holser to follow up creating bug for injecting drivers into boostrap for 8.0
16:07:07 <xarses> ok, moving
16:07:08 <xarses> kozhukalov review stuck fuel-main patches, delegate to skulanov as needed
16:08:02 <bgaifullin> hi all
16:08:30 <xarses> ok, moving; bgaifullin go over reviews in fuel-mirror, close obsolete ones and make sure all related bugs are addressed in new implementation
16:08:40 <ashtokolov> Fuel-mirror was merged and I’ve reviewed all bugs, so Done (both points)
16:09:14 <xarses> thanks ashtokolov
16:09:19 <xarses> warpc help with getting https://review.openstack.org/#/c/231433/ merged
16:10:32 <xarses> its still open, so if we can get more eyes on that. that would be great
16:10:36 <xarses> ikalnitsky review refactor-cinder-vmware-role spec https://review.openstack.org/230350
16:10:40 <gomarivera> JOIN #openstack-meeting-4
16:10:46 <gomarivera> JOIN #fuel
16:10:54 <ikalnitsky> done, since it's merged
16:10:58 <xarses> =)
16:11:08 <xarses> ikalnitsky review stuck fuel-web CRs, delegate to maintainers where necessary
16:11:29 <ikalnitsky> i poked guys to review
16:11:41 <warpc> xares: looks good. What about mihgen question?
16:11:55 <ikalnitsky> honestly, i can't say it really stucks. we did have a more worst situations in recent releases
16:12:08 <ikalnitsky> i also sent an email to openstack-dev with python gerrit dashboard
16:12:16 <ikalnitsky> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/080774.html
16:12:28 <ikalnitsky> i think it should help to take care
16:12:57 <xarses> ok, lets keep on it. If you can come up with ways to improve the situation, that would be great
16:13:16 <ikalnitsky> we need more cores.. and more reviewers.
16:13:30 <xarses> warpc: I missed mihgen's question
16:13:31 <ikalnitsky> i'm going to work on it
16:13:43 <xarses> ikalnitsky: do we have more ready to join core?
16:14:29 <xarses> ok, moving
16:14:31 <mihgen> #link https://review.openstack.org/#/c/231433/1/specs/fuel-nailgun-agent.spec
16:14:37 <mihgen> question here perhaps about pkg naming
16:15:11 <mihgen> let's just provide feedback in the review request
16:15:43 <xarses> mihgen: yes why does it have that anyway
16:15:49 <xarses> its always the right version
16:16:00 <ikalnitsky> +1 on removing suffix.
16:16:07 <xarses> it doesn't need ~fuel anyway
16:16:30 <mihgen> in the changeset folks
16:17:12 <xarses> ok, moving
16:17:12 <mihgen> xarses: moving .. /
16:17:14 <xarses> holser ikalnitsky review stuck specs, ping angdraug for merge when done
16:18:02 <holser_> ok xarses
16:18:04 <ikalnitsky> i think there's no specs got 8.0
16:18:22 <holser_> all unmerged spec should go to 9.0
16:18:36 <ikalnitsky> holser_: +1
16:18:47 <ikalnitsky> we need to ping authors
16:19:04 <xarses> holser_: if they already landed though, we need to close them out
16:19:27 <holser_> yep :(
16:19:46 <xarses> keep in mind, angdraug will be out for a 1-2 weeks so we need to reach agreement with out him
16:20:14 <xarses> last one
16:20:15 <xarses> nurla follow up on http://lists.openstack.org/pipermail/openstack-dev/2015-November/080477.html
16:20:59 <nurla> okay, do you have any comments for me?
16:22:07 <xarses> I don't, just keep up on it. I'm curious to see how this ends up
16:22:23 <xarses> ok, for the main attraction...
16:22:27 <xarses> #topic 8.0 Feature Freeze http://lists.openstack.org/pipermail/openstack-dev/2015-December/081149.html (angdraug)
16:22:51 <xarses> angdraug is out, so I'll pipe up here
16:23:20 <xarses> we are now in FF, if you don't yet have a FF you are blocked until we branch
16:23:46 <xarses> we are planning on branching on SCF (~Dec 23) at which time, master will be open for features again
16:23:53 <mihgen> don't have a FF exception*
16:24:25 <xarses> mihgen: yes, correct. If you don't already have a FF exception, you are blocked until we branch
16:25:04 <xarses> any questions?
16:25:09 <maximov_> also we freeze all repos for today
16:25:20 <maximov_> according to our centos7 integration plan
16:25:27 <xarses> maximov_: for centos7? ya
16:25:31 <mihgen> today only or tomorrow too?
16:25:41 <ikalnitsky> maximov_: for today only? i thought it until it's merged
16:25:51 <maximov_> today evening we will assess the progress
16:25:59 <maximov_> and will extend to tomorrow
16:26:31 <mihgen> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/081230.html
16:26:50 <mihgen> let's use this thread as a source of truth and watch for updates
16:27:43 <mihgen> time folks, let's go quicker
16:27:46 <xarses> #topic Moving Fuel services out of Docker containers (kozhukalov)
16:29:26 <xarses> moving on then
16:29:29 <xarses> #topic Mixed team status (sslypushenko)
16:29:39 <sslypushenko_> Development on BP https://blueprints.launchpad.net/fuel/+spec/openstack-config-change finished and all patchsets merged.
16:29:57 <sslypushenko_> Manual testing in progress. Some bugs found and fixing is in progress
16:30:10 <mihgen> this is great, could you update status of this bp then.. ?
16:30:25 <sslypushenko_> ok, will do
16:30:40 <mihgen> it's in my list to ask for status update anyway. We want clear pic on what is in and what is out for 8.0
16:30:46 <mihgen> thx
16:31:08 <sslypushenko_> also automation tests is in progress to
16:31:23 <sslypushenko_> I think that is all from my side
16:31:31 <mihgen> if qa is not blocked, then we are good.
16:31:48 <sslypushenko_> We are working on it)
16:31:49 <xarses> sslypushenko_: thanks, this will become very useful
16:32:07 <xarses> #topic Telco Team Status (fzhadaev)
16:32:17 <fzhadaev> Fuel Telco team is finnishing work on Ubuntu bootstrap feature. Current status:
16:32:17 <fzhadaev> 1) All functional commites are merged.
16:32:17 <fzhadaev> 2) Writing automatic tests is in progress.
16:32:17 <fzhadaev> 3) We'll switch to Ubuntu bootstrap by default after tests will be done.
16:32:50 <xarses> fzhadaev: fantastic, thanks
16:32:54 <mihgen> during meeting yesterday, two commits were mentioned
16:33:02 <mihgen> as those need exception for enabling it
16:33:10 <fzhadaev> mihgen: they are merged
16:33:19 <mihgen> both merged, appears to be those are not for enabling ubuntu by default?
16:33:42 <mihgen> in my email: Ubuntu boostrap. Two patches requested for FFE: https://review.openstack.org/#/c/250504/, https://review.openstack.org/#/c/251873/. Both are merged. So I consider that this is actually done.
16:34:06 <mihgen> so then it is not a correct statement. Why didn't you folllow up in the email thread.. ?
16:34:25 <fzhadaev> yep. feature is done. switching the default os isn't part of feature.
16:34:34 <fzhadaev> it's just UX improvement
16:34:35 <mihgen> It IS part of the feature
16:34:45 <mihgen> if it's not tested now automatically
16:34:55 <mihgen> and by all who download and manually test ISO
16:35:11 <mihgen> that means we losing cycles of finding potential issues there
16:35:30 <mihgen> more over, it means that code is not complete if you can't just easily switch now
16:35:54 <dklenov> ok, let me comment
16:35:59 <mihgen> what is left to be done to switch it to be default one?
16:36:23 <dklenov> in the initial plan automatic tests are scheduled to be completed in the upcoming iteration
16:36:51 <dklenov> and we do not want to switch it by default unless it is run agaist these tests
16:37:07 <dklenov> switch is a small commit in a fuelmenu
16:37:17 <xarses> so, then the feature is out for 8.0, it needs to be moved to experimental
16:37:37 <dklenov> and I see more risk to switch to it without tests
16:37:53 <mihgen> I don't really get why it won't be tested if we switch to it by default?
16:37:56 <fzhadaev> BTW, Ubuntu is available in Fuel menu now. User can chose it as bootstrap os. It's just not default OS.
16:37:57 <dklenov> generally if needed we can switch to it even now
16:37:58 <mihgen> in all swarm & bvt
16:38:09 <ntrueblood> do we have documentation that explains how to build dynamic, ubuntu bootstrap if custom drivers are needed?
16:38:29 <dklenov> ntrueblood: doc will be completed in January
16:39:04 <dklenov> mihgen: we can generally switch even now by default to ubuntu
16:39:12 <mihgen> dklenov: unless it runs by default starting from now, I feel there is a large risk of releasing it as a production solution later
16:39:26 <mihgen> we need community, and other to start actually using it
16:39:44 <dklenov> ok, I would involve QA folks as well
16:39:46 <mihgen> and file bugs. Delaying a moment of running it by default means way less testing
16:40:06 <mihgen> dklenov: please follow up in my email about FF exceptions with detailed data and plan
16:40:32 <xarses> #topic Enhancements Team Status (ashtokolov)
16:40:51 <ashtokolov> Yesterday we finished feature development (except one FFE
16:40:58 <ashtokolov> Enhancements Team status:  Fix committed+Fix released = 51
16:41:25 <xarses> #action dklenov will follow up with with details on enabling ubuntu bootstrap on FFE thready
16:42:24 <holser_> ashtokolov one multi rack feature went out of scope of 8.0
16:42:38 <holser_> ashtokolov it was moved to 9.0
16:43:25 <ashtokolov> sorry, I had troubles with irc client
16:43:34 <mihgen> holser_: which one?
16:43:48 <holser_> adidenko knows better
16:44:07 <akasatkin> it is manual VIP address seting
16:44:15 <mihgen> ok
16:44:16 <akasatkin> setting*
16:44:16 <ashtokolov> it's about ATT task with VIP allocation
16:44:33 <ashtokolov> we faced with DB changes
16:44:37 <alex_didenko> The following BPs have been moved out of multirack scope and assigned to 9.0
16:44:37 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/allow-any-vip
16:44:37 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/dhcp-vips
16:44:37 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/selective-default-gateway-net
16:44:48 <xarses> ok
16:44:52 <ntrueblood> we also have not quite finished creating a document that describes how to set up controllers in HA across multiple racks.
16:45:02 <ntrueblood> multiple l3 segmented racks, that is.
16:45:03 <ashtokolov> and there was no way to fix it without DB changes
16:45:40 <xarses> ntrueblood: do we have the docs defect captured somewhere?
16:45:43 <mihgen> alex_didenko: is it in your todo list for HA across multiple racks docs.. ?
16:46:00 <xarses> #link https://bugs.launchpad.net/fuel/+bug/1476140 ?
16:46:00 <openstack> Launchpad bug 1476140 in Fuel for OpenStack "Nodegroup instructions improvement" [Medium,Confirmed] - Assigned to Fuel Documentation Team (fuel-docs)
16:46:43 <ntrueblood> We have a JIRA backlog item for it, but we probably also need an lp bp.   Not sure of status
16:46:56 <alex_didenko> mihgen: yes
16:46:58 <xarses> lets keep going, we have 14 min
16:47:04 <xarses> #topic UI Team status (vkramskikh).
16:47:09 <vkramskikh> Hi, we've merged all the features we planned to deliver without FFEs and switching to bugfixing and helping partners team to deliver Component registry. We have 7 High bugs and plan do fix them before SCF. Any questions?
16:47:16 <alex_didenko> mihgen: I'll update maybe on the next meeting about it
16:47:27 <mihgen> alex_didenko: cool, thx
16:47:51 <mihgen> vkramskikh: sounds good. thanks for keeping an eye on component registry FFE
16:48:13 <xarses> vkramskikh: great =)
16:48:23 <xarses> #topic Bugs team status (dpyzhov) https://etherpad.openstack.org/p/fuel-bugs-status
16:48:30 <dpyzhov> hi guys
16:48:37 <dpyzhov> I've update bugs statistics
16:49:00 <dpyzhov> Right now my team is focused on several high priority tricky bugs
16:49:15 <dpyzhov> We don't have many of them
16:49:21 <dpyzhov> and almost all of them are assigned
16:49:26 <xarses> anything that we should discuss?
16:49:27 <mihgen> dpyzhov: do you see an increasing # of incoming?
16:49:38 <dpyzhov> mihgen: not yet
16:49:44 <dpyzhov> Actually I have a question
16:50:02 <dpyzhov> Are we going to have more developers moved to bugfixing now?
16:50:08 <mihgen> qa is not at full speed then. Let's sync and help if needed, they might be blocked
16:50:26 <dpyzhov> We have a bunch of medium priority bugs
16:50:29 <mattymo_> One bug that is really impacting our ability to fix bugs is tracebacks in syslog in oslo.logging
16:50:43 <mattymo_> It was rejected as invalid by mos oslo team (dims) as a feature, not a bug
16:50:44 <mihgen> I expect all teams which were working on features to do bugfixes in their features implmeneted
16:51:01 <mattymo_> we have to reproduce the original problem in order to get the local trace that gets sent directly to file
16:51:09 <dpyzhov> And if we'll have more people than we'll need to think how to organize them all effectively
16:51:19 <xarses> mattymo: if not already, lets start a ML about that
16:51:40 <mihgen> mattymo: this would be great feedback to oslo team from operators, i.e. you, let's share in ML
16:51:51 <dpyzhov> mihgen: and what will happen when they fix their bugs?
16:51:59 <mihgen> work on other features
16:52:06 <mattymo_> xarses, sure. I've found another fun bug where some cinder errors don't log traceback to either)
16:52:09 <mihgen> master opens on SCF
16:52:11 <mattymo_> mihgen, I'll start a thread on it
16:52:17 <mihgen> cool
16:52:26 <dpyzhov> So noone is going to join the bugs backlog cleanup party
16:52:30 <dpyzhov> that's ok
16:52:31 <dpyzhov> thanks
16:52:48 <dpyzhov> I have no more questions
16:52:50 <xarses> #topic Let's clarify 8.0 blueprints statuses (mihgen)
16:53:24 <mihgen> folks let's go over some of bps, but I really need your help to go over them and just set rigth status or move out of 8.0
16:53:29 <mihgen> #link https://etherpad.openstack.org/p/8.0-features-status
16:53:30 <xarses> #action mattymo will create ML to discuss issues with oslo.logging not sending some tracebacks on syslog
16:53:30 <yottatsa> I need reviewers for Tenant IPv6 Docs and Tests spec https://blueprints.launchpad.net/fuel/+spec/provider-tenant-ipv6-networking
16:53:32 <mihgen> this is the list
16:53:36 <yottatsa> #link https://blueprints.launchpad.net/fuel/+spec/provider-tenant-ipv6-networking
16:54:07 <mihgen> nurla: can you find someone to help with tests spec for ^^ ..?
16:54:19 <dims_> mattymo_ : needs to be fixed upstream first https://bugs.launchpad.net/oslo.log/+bug/1514828
16:54:19 <openstack> Launchpad bug 1514828 in oslo.log "tracebacks are not logged to syslog" [Low,Triaged]
16:54:42 <nurla> yep, we agreed with Alekesey that we are staring work after FF
16:54:51 <mihgen> dims_: I doubt if it's Low if it makes life of ops very painful
16:54:58 <yottatsa> mihgen nurla: ashtokolov said we're staring doing QA on next week, QA engineer is alerady allocated
16:55:00 <mihgen> yottatsa: ping me offline for docs
16:55:08 <mihgen> other bps: #link https://blueprints.launchpad.net/fuel/+spec/support-ip-ranges-for-storage-management-networks-on-ui
16:55:08 <dims_> mihgen : welcome to bump up that importance :)
16:55:10 <mihgen> vkramskikh: ^^
16:55:25 <nurla> yottatsa: after FF :)
16:55:44 <yottatsa> nurla yes, on I-4
16:55:59 <mihgen> #link https://blueprints.launchpad.net/fuel/+spec/network-interfaces-naming-schema
16:56:06 <mihgen> holser_: do you status of this one ^^
16:56:47 <mihgen> alex_didenko: can we move https://blueprints.launchpad.net/fuel/+spec/l3-multiple-racks to implemented? what deployment status means?
16:57:15 <alex_didenko> mihgen: we have some QA BPs linked to this BP
16:57:22 <alex_didenko> and they are still in development
16:57:22 <mihgen> bgaifullin: https://blueprints.launchpad.net/fuel/+spec/refactor-local-mirror-scripts can this one be closed as Implemented.. ?
16:58:00 <xarses> 3 min
16:58:07 <xarses> well 2
16:58:28 <mihgen> alex_didenko: we need to think about how to do it in this case then. when I open https://launchpad.net/fuel/+milestone/8.0, I'd like to understand what is in and what is out..
16:58:40 <alex_didenko> actually, I've closed mine as implemented, we'll track system tests separately
16:58:42 <mihgen> may be deployment status is ok and we push all other out
16:58:45 <bgaifullin> mihgen, I think yes
16:58:58 <mihgen> vkramskikh: holser_ reply on those two first bps... ?
16:59:07 <mihgen> bgaifullin: cool,pls update
16:59:17 <mihgen> #link https://blueprints.launchpad.net/fuel/+spec/plugin-after-deployment
16:59:20 <mihgen> ikalnitsky: ^^
16:59:27 <mihgen> ashtokolov: ^^
16:59:43 <ashtokolov> Dine
16:59:47 <ashtokolov> Done
16:59:48 <ikalnitsky> it's done
16:59:48 <ikalnitsky> all patches are merged
17:00:09 <mihgen> pls update bp then
17:00:11 <xarses> time folks, lets wrap on #fuel-dev
17:00:20 <xarses> #endmeeting