16:00:09 <xarses> #startmeeting fuel
16:00:09 <xarses> #chair xarses
16:00:09 <xarses> Todays Agenda:
16:00:09 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:00:09 <xarses> Who's here?
16:00:09 <openstack> Meeting started Thu Dec 10 16:00:09 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'fuel'
16:00:14 <openstack> Current chairs: xarses
16:00:17 <maximov> hi
16:00:19 <mwhahaha> hi
16:00:22 <dbilunov> hi
16:00:22 <fzhadaev> Hi!
16:00:29 <asvechnikov_> hi
16:00:39 <dpyzhov> hi
16:00:50 <SheenaG> Hi guys
16:00:53 <alex_didenko> hi
16:00:56 <tatyana_> hi
16:00:58 <akislitsky_> hi
16:01:03 <yottatsa> hi
16:01:09 <holser_> o/
16:01:11 <romcheg> \0/
16:01:12 <vkramskikh> hi
16:01:28 <xarses> ok, lets get started with action items from last meeting
16:01:29 <igorbelikov> o/
16:01:45 <xarses> #topic last meeting actions
16:01:50 <xarses> holser to follow up creating bp for plugging ubuntu bootstrap
16:02:01 <sbog> hi
16:02:33 <xarses> holser_: ?
16:03:20 <ikalnitsky> \o
16:03:21 <holser_> we created plan but I’ve not not created blueprint
16:03:51 <xarses> ok, lets get a stub together then on launchpad so we don't loose it
16:03:59 <holser_> sure thing
16:04:12 <xarses> holser to follow up creating bug for injecting drivers into boostrap for 8.0
16:04:30 <holser_> it’s the same
16:04:34 <xarses> IIRC this was about creating a docs bugs
16:04:41 <xarses> ok
16:05:16 <xarses> dklenov will follow up with with details on enabling ubuntu bootstrap on FFE thready
16:05:30 <fzhadaev> It was done
16:05:37 <xarses> thanks
16:05:43 <xarses> mattymo will create ML to discuss issues with oslo.logging not sending some tracebacks on syslog
16:06:33 <dims_> mattymo : xarses : https://bugs.launchpad.net/oslo.log/+bug/1514828
16:06:33 <openstack> Launchpad bug 1514828 in oslo.log "tracebacks are not logged to syslog" [Low,Triaged]
16:06:59 <xarses> dims_: thanks, did we get anywhere with that?
16:07:14 <mmosesohn_> xarses, I didn't get to it. It was a bug directly in cinder code
16:07:18 <dims_> xarses : no one has looked in yet
16:07:22 <mmosesohn_> I'm still fixing the actual issue which is far more critical
16:07:53 <bgaifullin> hi all.
16:07:54 <xarses> dims_: what can we do to help this one get attention?
16:08:14 <mmosesohn_> dims_, is more aware of why trace logs don't get sent out
16:09:17 <dims_> xarses : need someone familiar with syslog that i can work with
16:09:27 <mmosesohn_> dims_, me
16:09:30 <warpc> hi!
16:09:38 <dims_> mmosesohn_ : yay!
16:09:55 <xarses> ok, I
16:10:05 <xarses> ok, I'll add an action for you to
16:10:20 <xarses> *too
16:10:26 <xarses> nope, two
16:10:37 <xarses> on to the main show
16:10:45 <xarses> #topic Moving Fuel services out of Docker containers (kozhukalov)
16:11:24 <xarses> #action dims and mattymo will follow up on https://bugs.launchpad.net/oslo.log/+bug/1514828
16:11:24 <openstack> Launchpad bug 1514828 in oslo.log "tracebacks are not logged to syslog" [Low,Triaged]
16:12:29 <xarses> ok, moving on
16:12:31 <xarses> #topic Adding Fuel CI jobs to puppet-openstack workflow
16:12:41 <xarses> the puppet-openstack guys have asked for some follow up on this. Who was leading this?
16:12:52 <degorenko> hey
16:12:59 <degorenko> as i know from alexandra fedorova
16:13:01 <bookwar> xarses: we have a pending hw request for this task
16:13:04 <degorenko> we are awaiting for hardware
16:13:22 <mwhahaha> we need to fix our code before the hardware
16:13:23 <bookwar> but i think we should start on the implementation part
16:13:32 <mwhahaha> cause it'll fail right now even without hardware
16:13:42 <xarses> ok I was going to ask that
16:13:55 <mwhahaha> we also need to figure out how to inject the upstream versions into our fuel-library build process
16:14:07 <mwhahaha> since we currently do not track upstream master
16:14:18 <bookwar> at the moment we don't have proper blueprint for this activity, but you can assign the action item on me to create one for next week
16:14:47 <xarses> I'd like to identify who will be responsible for the status, and I'd like to see some regular updates (ML is fine) so that the two teams know what's going on
16:15:51 <bookwar> i'll work with Dmitry B and others to track this properly
16:16:04 <xarses> ok, thanks
16:16:14 <xarses> #topic FFEs and their status (mihgen)
16:16:37 <mihgen> hi folks, I'd like to go one by one and check where we are
16:16:47 <mihgen> 1. CentOS 7. ETA: Monday 7th. Blueprint: https://blueprints.launchpad.net/fuel/+spec/master-on-centos7
16:16:52 <mihgen> all done, right?
16:16:58 <xarses> #action bookwar will create blueprint for Fuel CI on puppet-openstack projects
16:17:43 <mihgen> holser_: ikalnitsky: kozhukalov: bookwar ^^^ can we consider centos7 fully merged?
16:17:43 <xarses> mihgen: sounded that way, but I'd too like to hear its complete
16:17:57 <mihgen> including all CI pieces?
16:18:25 <ikalnitsky> from my pov - it's merged. we have files tech-debts, and they aren't resolved yet (afaik)
16:18:40 <ikalnitsky> s/files/filed/g
16:18:51 <bookwar> mihgen: yes
16:19:41 <mihgen> good.
16:19:43 <mihgen> 2. Disable queue mirroring for RPC queues in RabbitMQ. https://blueprints.launchpad.net/fuel/+spec/rabbitmq-disable-mirroring-for-rpc
16:20:02 <mihgen> didn't give second FFE so it goes to 9.0
16:20:21 <mihgen> ikalnitsky: holser_ Correct?
16:20:34 <ikalnitsky> correct
16:21:23 <mihgen> holser_: ?
16:21:34 <mihgen> confirm from library side
16:22:08 <xarses> mihgen: the library commit isn't merged
16:22:43 <nurla> xarses: what commit isn't merged? O_0
16:22:44 <holser_> correct
16:22:59 <xarses> #link https://review.openstack.org/#/c/249180/
16:23:06 <holser_> technically, centos7 is merged, though we still catch bugs
16:23:10 <mihgen> ok, so we are waiting for 9.0. No FFE. Moving on
16:23:21 <mihgen> 3. Task based deployment with Astute. ETA: Friday, 11th. https://blueprints.launchpad.net/fuel/+spec/task-based-deployment-astute
16:23:29 <ashtokolov> Task-based-deployment: Astute and Nailgun parts: code is ready and on review. 2 commits to nailgun are already merged. For 1 commit tests are in progress.
16:23:29 <mihgen> in progress?
16:23:40 <ashtokolov> Library part (aka cross-node dependencies are in progress) we are testing on real deployment cases.
16:23:49 <ashtokolov> Here is a list: https://review.openstack.org/#/q/branch:master+topic:bp/task-based-deployment-astute+NOT+status:abandoned+NOT+project:openstack/fuel-specs,n,z
16:24:02 <ashtokolov> #link https://review.openstack.org/#/q/branch:master+topic:bp/task-based-deployment-astute+NOT+status:abandoned+NOT+project:openstack/fuel-specs,n,z
16:24:06 <aglarendil> we are very close to finishing even library part
16:24:08 <ashtokolov> Today evening we are going to have final merge plan for library
16:24:28 <aglarendil> we have almost gotten to post-deployment stage. there was a bug in OCF script
16:24:33 <aglarendil> the fix is on review as well
16:24:56 <mihgen> sounds like running at full speed..are we converging to make it happen by the end of the week?
16:25:37 <ikalnitsky> from fuel-web pov, there're two patches. one of them is almost done. i think we can merge it today. the second one - i didn't review yet.
16:26:20 <ikalnitsky> i think we can manage to complete fuel-web part in time
16:26:20 <mihgen> aglarendil: ashtokolov are you guys targeting end of the week?
16:26:40 <ashtokolov> Yes we expect custom iso today evening
16:26:53 <ashtokolov> and finish till the end of this week
16:26:59 <mihgen> ok, great
16:27:01 <mihgen> 4. Component Registry. https://blueprints.launchpad.net/fuel/+spec/component-registry
16:27:05 <xarses> what is the impact of not merging any more of it?
16:27:26 <SheenaG> xarses: is your question about component registry?
16:27:44 <SheenaG> xarses: or task-based deployment?
16:27:57 <mihgen> Xarses: if you are about task-based, then you don't get task-based in 8.0 if you don't merge all those :)
16:28:06 <xarses> task based
16:28:09 <SheenaG> mihgen: I believe component registry merged yesterday
16:28:18 <aglarendil> xarses: it is completely backward-compatible
16:28:31 <mihgen> component registry - can we consider it's all done and qa can test it?
16:28:38 <ikalnitsky> xarses: it won't be default option, so..
16:28:44 <ikalnitsky> mihgen: yes, we can.
16:29:04 <mihgen> excellent.
16:29:12 <mihgen> 5. Add vmware cluster after deployment.  https://blueprints.launchpad.net/fuel/+spec/add-vmware-clusters
16:29:21 <SheenaG> mihgen: also merged
16:30:08 <mihgen> is assignee here of this bp.. ? If it's finished, we need to set Iplemented
16:30:30 <SheenaG> mihgen: I don't see Adrian here, but I can track this down with him
16:30:44 <mihgen> thanks
16:30:45 <mihgen> 6. Support murano service broker https://blueprints.launchpad.net/fuel/+spec/implement-support-for-murano-service-broker
16:30:55 <mihgen> is this one done too?
16:31:05 <IvanBerezovskiy> patches are merged
16:31:26 <mihgen> excellent
16:31:29 <mihgen> and the last one
16:31:32 <mihgen> 7. Ubuntu bootstrap
16:31:47 <mihgen> I saw email in openstack-dev, all done, right?
16:31:50 <fzhadaev> All commits are merged. Feature is done.
16:32:25 <mihgen> wonderful! thanks all, I'll provide summary in openstack-dev.
16:32:37 <mihgen> please update status of bps
16:33:08 <mihgen> I didn't throw away those 8.0 which are not in implemented status, but I still plan to do it
16:33:23 <mihgen> Xarses: moving on?
16:33:26 <xarses> #topic UI Team status (vkramskikh)
16:33:34 <vkramskikh> Hi, we're working on bugfixing and are doing it quite well. This week we've reduced the number of area-ui bugs from 63 to 36: http://i.imgur.com/9DhsD5x.png
16:33:34 <vkramskikh> We're on track of fixing all High bugs before SCF - there are 3 High bugs left.
16:33:34 <vkramskikh> UI for Component Registry blueprint (FFE) was merged yesterday, some extra fixes are expected.
16:33:34 <vkramskikh> Questions?
16:33:55 <xarses> awesome, images today
16:34:34 <mihgen> vkramskikh: great, any plans for what you could start working in terms of features?
16:34:38 <mihgen> we open master on SCF
16:35:06 <vkramskikh> probably we'll start first on separating vendor-specific code from core Fuel
16:35:15 <vkramskikh> but we also have some plans to solve tech debt
16:35:28 <dpyzhov> mihgen: is it a final decision to open master on SCF?
16:35:32 <mihgen> that sounds good.
16:35:49 <mihgen> dpyzhov: yes, I believe it was communicated by PTL quite a while ago
16:36:01 <mihgen> no one was opposed
16:36:23 <mihgen> is there any problem with it?
16:36:24 <dpyzhov> great
16:36:33 <dpyzhov> No, I'm happy )
16:36:35 <vkramskikh> totally support branching on SCF
16:36:38 <vkramskikh> ++
16:36:48 <mihgen> great then :)
16:36:54 <xarses> #topic Telco Team Status (fzhadaev)
16:36:58 <fzhadaev> Here is the current Fuel Telco team status:
16:36:58 <fzhadaev> 1) We're finnished work on ubuntu-bootstrap feature. Now it's enabled by default.
16:36:58 <fzhadaev> 2) The main activity for now is bug fixing.
16:37:43 <xarses> great to hear
16:38:00 <mihgen> I'm aware that you guys have identified things to be further improved in this feature
16:38:10 <mihgen> any public bp opened so far.. ?
16:38:35 <fzhadaev> Not yet. There are listed in internal ticket
16:39:04 <fzhadaev> BP will be created
16:39:16 <mihgen> please create public one. We want to track it, and ideally to start work on it while we still have fresh memory on the code )
16:39:36 <fzhadaev> sure
16:39:50 <xarses> #topic Bugs team status (dpyzhov) https://etherpad.openstack.org/p/fuel-bugs-status
16:40:02 <dpyzhov> I’ve updated statistics. It is not so оptimistic as usual. We have bunch of reports for new features.
16:40:08 <dpyzhov> I’ve checked with team leads and we are targeting to fix current high priority issues by SCF. However we’ll appreciate hints for bugs from SME.
16:40:13 <dpyzhov> I have a question. Do we have a preliminary date for QA acceptance results?
16:41:18 <xarses> dpyzhov: I though we agreed that SME's are supposed to help with bugs from their features
16:41:24 <dpyzhov> Right now we see really low number for late-discovery bugs income. We are fighting with several tricky bugs. It is almost the same bugs that we had last week
16:41:48 <dpyzhov> xarses: feature developers fixing their own bugs
16:41:52 <mihgen> I see 26 bugs income over the last week
16:41:58 <mihgen> high priority ones
16:42:00 <dpyzhov> I'm talking about tricky bugs in existing functionality
16:42:14 <mihgen> am I correct?
16:42:26 <dpyzhov> mihgen: yes, this is a raw income
16:42:46 <xarses> dpyzhov: ok good. Then are we having problems getting SME's to help?
16:43:07 <mihgen> oh it's just python. And it's not in the category of delivery teams
16:43:26 <mihgen> does it mean that we've got 26 bugs against old functionality which we released in 7.0... ?
16:43:27 <dpyzhov> It is a total income of python bugs with high priority
16:43:53 <dpyzhov> for all teams
16:44:19 <mihgen> how many bugs do we see coming for new functionality vs old 7.0
16:44:37 <dpyzhov> Launchpad is bad at statistics, really
16:44:47 <dpyzhov> I've walked through high bugs
16:45:08 <dpyzhov> And I've found only 1 real bug that is late discovery
16:45:19 <dpyzhov> Most of new bugs are about new functionality
16:45:30 <dpyzhov> It sounds optimistic
16:45:39 <dpyzhov> But we had a broken master this week
16:45:56 <dpyzhov> so there was no real chance for QA to find old bugs
16:45:57 <mihgen> is it all fixed now.. ?
16:46:12 <dpyzhov> ?
16:46:18 <dpyzhov> Master is fixed
16:46:25 <dpyzhov> Bugs are partially fixed
16:46:57 <mihgen> ok. thanks. I'd expect that delivery teams will be helping out initially quite actively
16:46:57 <dpyzhov> you can see 8 bugs on network team
16:47:04 <dpyzhov> other teams have about 1-2 bugs
16:47:29 <dpyzhov> Right now I assume that they will deal with bugs on their features
16:47:52 <nurla> @dpyzhov please keep in mind, that we fixed tests after centos merge
16:47:54 <dpyzhov> Do we have preliminary date for QA acceptance?
16:48:06 <nurla> i think you will get issues :)
16:48:07 <mihgen> numbers don't match
16:48:12 <mihgen> if it's 1-2 bugs on a team
16:48:18 <mihgen> and total backlog is 60
16:48:42 <dpyzhov> bugs on teams are only about python
16:49:26 <dpyzhov> still doesn't match
16:49:44 <dpyzhov> Oh, I got it
16:49:49 <dpyzhov> Missed bugs are duplicates
16:50:11 <dpyzhov> I'm trying to count them now and looks like I count them not in every place
16:50:30 <mihgen> dpyzhov: pls figure it out then, we just need to ensure that we are converging by HCF ;)
16:50:42 <mihgen> moving to the next topic?..
16:50:53 <dpyzhov> I'll update the report in 15 minutes
16:50:59 <xarses> #topic Network team status (alex_didenko)
16:51:19 <alex_didenko> Right now we're working on bugfixing and bugs related to multi-rack support and on the following BPs:
16:51:20 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/external-lbs
16:51:20 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/allow-any-vip (the most of work is done by enhancements team, so I believe they can give more details on this if needed)
16:51:20 <alex_didenko> Also we're going to start working on the following BPs shortly:
16:51:20 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/selective-default-gateway-net
16:51:20 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/dhcp-vips
16:51:20 <alex_didenko> As for external-lbs - we have some blockers for this functionality, they are reported as bugs and attached to external-lbs BP.
16:51:21 <alex_didenko> With fixes applied on my local virtual lab I was able to deploy cluster with controllers in different racks using external load balancer.
16:51:21 <alex_didenko> Note: in such case floating IPs do not work (known limitation of multirack based on static routes).
16:51:22 <alex_didenko> Everything else except floating IPs seems to work fine: VMs are running, no issues with internal network/connectivity, volumes, images (swift), etc.
16:51:22 <alex_didenko> I'm going to prepare some documentation on how to set up cluster with controllers in different racks using external LB when we address all blockers.
16:51:31 <alex_didenko> Sorry for wall of text :)
16:52:45 <mihgen> great wall of text)
16:52:50 <xarses> alex_didenko: it's great, well prepared =
16:52:52 <xarses> =)
16:52:56 <mihgen> I have a question about advanced networking
16:53:22 <mihgen> we have templates now, any work being done in a direction to make it fully available in the UI
16:53:25 <mihgen> and flexible?
16:53:38 <mihgen> API level first, of course
16:53:41 <alex_didenko> we've discussed it during tech-talk
16:54:08 <alex_didenko> and it's quite problematic - network templates are much more complex and flexible than default net config
16:54:18 <akasatkin> it is in a story, no BPs yet
16:54:23 <alex_didenko> it could be extremely tricky to try to visualize it on UI
16:54:54 <mihgen> well may be it is OK to have some of that configurable in YAML
16:55:07 <mihgen> but majority of things should be exposed to the UI I believe
16:55:28 <alex_didenko> I'm afraid that we could end up with a single input text field for template yaml :)
16:55:32 <akasatkin> it will look like a graphics editor..
16:55:57 <mihgen> well then may be we can just ask for what template user wants to choose
16:56:08 <mihgen> and then show only limited things on the UI
16:56:10 <SheenaG> mihgen: I've talked to DP about this some, but will continue that conversation
16:56:34 <SheenaG> mihgen: we agree that some subset of the functionality should probably be exposed, but providing a yaml editor is the wrong way to do it
16:56:35 <xarses> 4 min
16:56:47 <SheenaG> mihgen: the conversations haven't gone much past that yet
16:56:56 <mihgen> akasatkin: SheenaG yes please, we need to continue this effort. Current implementation with templates is still over complex for users
16:57:18 <mihgen> and once you went there, you can't do anything through UI anymore as far as I understand
16:57:31 <SheenaG> mihgen: that's right
16:57:47 <akasatkin> not anything, just interfaces to networks mapping is disabled
16:58:00 <akasatkin> but it is not good, also
16:58:10 <mihgen> well it's huge deal...
16:59:12 <SheenaG> mihgen: I'll reach out to DP again to see if we can make some progress on what to expose and how.  Right now he is working on descriptions for Networking settings in Fuel, so he's definitely heads down on the Networking usability issues.
16:59:44 <xarses> #action SheenaG to follow up with DP regarding network templates in ui
16:59:57 <xarses> thats the time we have folks
17:00:06 <xarses> #endmeeting