16:01:08 <xarses> #startmeeting fuel
16:01:08 <xarses> #chair xarses
16:01:08 <xarses> Todays Agenda:
16:01:08 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:01:08 <xarses> Who's here?
16:01:09 <openstack> Meeting started Thu Dec 17 16:01:08 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:10 <maximov> hi
16:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:13 <openstack> The meeting name has been set to 'fuel'
16:01:14 <bookwar> hi
16:01:14 <mihgen> hi
16:01:14 <sbog> hi
16:01:14 <openstack> Current chairs: xarses
16:01:14 <fzhadaev1> Hi!
16:01:15 <mwhahaha> hi
16:01:16 <rmoe> hi
16:01:19 <nurla> hi
16:01:24 <dnikishov> hello
16:01:26 <asvechnikov_> hi
16:01:49 <agordeev> hi
16:01:59 <ashtokolov> hi
16:02:02 <evgenyl> Hi!
16:02:12 <xarses> #topic Action items from last meeting
16:02:30 <xarses> dims and mattymo will follow up on https://bugs.launchpad.net/oslo.log/+bug/1514828
16:02:30 <openstack> Launchpad bug 1514828 in oslo.log "tracebacks are not logged to syslog" [Low,In progress] - Assigned to Dmitry Mescheryakov (dmitrymex)
16:02:30 <akislitsky_> hi
16:03:09 <dims> @xarses : https://review.openstack.org/#/c/258442/
16:03:43 <xarses> thanks dims
16:03:58 <xarses> bookwar will create blueprint for Fuel CI on puppet-openstack projects, this is done
16:03:59 <angdraug> hi all
16:04:04 <bookwar> here is the blueprint https://blueprints.launchpad.net/fuel/+spec/deployment-tests-for-puppet-openstack i've put some work items
16:04:06 <xarses> #link https://blueprints.launchpad.net/fuel/+spec/deployment-tests-for-puppet-openstack
16:04:14 <bookwar> i think we don't need to wait for a hardware
16:04:24 <bookwar> and can start with periodic jobs
16:04:48 <bookwar> from noop at least
16:05:04 <xarses> ok, sounds good. Lets make sure we share this with the puppet-openstack team
16:05:18 <xarses> SheenaG to follow up with DP regarding network templates in ui
16:05:18 <bookwar> degorenko: ^^
16:05:26 <SheenaG> Hey guys, sorry I'm late - DP and I are meeting today
16:05:36 <xarses> thanks SheenaG
16:05:49 <xarses> thats the end of actions
16:05:51 <degorenko> thanks for the update bookwar
16:06:06 <xarses> #topic not finished/updated 7.0 blueprints: https://launchpad.net/fuel/+milestone/7.0. https://launchpad.net/fuel/+milestone/9.0 is open. (mihgen)
16:06:17 <mihgen> folks, we have many blueprints which are not in Implemented status in 7.0.
16:06:29 <mihgen> I'm wondering should I just move them all to future, or give a few days for assignees/component leads to review them?
16:07:00 <mihgen> Also, 9.0 milestone is open. Let's move / create blueprints which we started to work on, in 9.0
16:07:28 <xarses> mihgen: we have ones open for 7.0 still?
16:07:42 <mihgen> yes; we never cleaned up those..
16:08:57 <xarses> ok, I think we should probably just push them then, I assume that we updated the ones that landed already
16:08:58 <mihgen> ok I'll move them to future early next week. But it'd be better if you guys take a look and see if there are any where we need to update status
16:09:44 <xarses> #topic fuel-nonroot status: need spec reviews, design discussion https://review.openstack.org/#/c/243340/ (dnikishov)
16:10:08 <dnikishov> as some of you may know, there was a bp on fuel using root for everything
16:10:43 <dnikishov> the bp is targeting 9.0, but it has been split into 3 smaller pieces due to the huge scope
16:11:04 <dnikishov> the items are: 1. user-specified non-root account on slave nodes; 2. non-root account on master node + services not running as root; 3. running mcollective as non-root (needs research)
16:11:39 <dnikishov> the spec for item 1 is already available https://review.openstack.org/#/c/243340/; please review it
16:12:17 <dnikishov> I'm working on the POC patches on top of current master right now, see gerrit topic https://review.openstack.org/#/q/topic:bp-fuel-nonsuperuser
16:12:45 <dnikishov> the blueprints and specs for items 2 and 3 are one their way
16:13:06 <dnikishov> however it seems reasonable to focus on item 1 for now
16:13:10 <xarses> thanks
16:13:38 <xarses> no feedback on reviews for 2+ days http://bit.ly/1RD6JLR, https://etherpad.openstack.org/p/fuel-stalled-reviews (mihgen)
16:14:23 <mihgen> As of yesterday, we had 48 patchsets which didn't have an update for more than 2 days. Which is bad. I've collected list of those patches grouped in the etherpad mentioned in the topic.
16:14:25 <xarses> #topic no feedback on reviews for 2+ days http://bit.ly/1RD6JLR, https://etherpad.openstack.org/p/fuel-stalled-reviews (mihgen)
16:14:34 <mihgen> I suggest that we assign responsible cores to each repo, and ensure that all receive feedback
16:14:46 <maximov> mihgen: +1
16:15:08 <mihgen> can you guys go ahead and set those in the etherpad?
16:15:27 <mihgen> if there is no core assigned by the end of the meeting, then we need angdraug's help
16:16:03 <mihgen> and generic question - how do we keep our response time under 2 days?
16:16:52 <mihgen> acharykov is not here unfortunately, but I'd love to know how we can speed https://bugs.launchpad.net/fuel/+bug/1497655 this up
16:16:52 <openstack> Launchpad bug 1497655 in Fuel for OpenStack "Add reviewers automatically based on MAINTAINERS data" [High,Confirmed] - Assigned to Alexander Charykov (acharykov)
16:16:57 <mihgen> which suppose to help
16:17:08 <angdraug> monester is here actually
16:17:23 <angdraug> just talked to him about this bug earlier today
16:17:43 <angdraug> he has the script ready and is now figuring out how to hook it into gerrit
16:17:46 <maximov> acharykov will join in a minute
16:17:59 <angdraug> fyi monester == acharykov
16:18:09 <mihgen> angdraug: this is the status which I have for about a month, unfortunately
16:18:20 <mihgen> can we help somehow with gerrit?
16:18:22 <monester> mihgen: this script is ready to run on our fuel-ci
16:18:35 <mihgen> monester: please run on fuel-ci then
16:18:46 <mihgen> and then meanwhile we can continue with hook
16:19:12 <monester> ok, bookwar, can you merge and apply then https://review.fuel-infra.org/#/c/12228/ ?
16:19:51 <bookwar> monester: yes, review is in progress, we apply'll the script for fuel-main only at first, and then see how it works
16:20:08 <mihgen> thank you guys
16:20:10 <monester> mihgen: is it ok?
16:20:45 <maximov> can we add action item for the next meeting to check the status?
16:20:49 <mihgen> yes, when can we make it run.. ?
16:22:11 <bookwar> mihgen: by the end of the week
16:22:17 <bookwar> fir fuel-main
16:22:17 <xarses> #action monester and bookwar will work on getting the add reviewers by MAINTAINERS data script
16:22:19 <mihgen> ok great
16:23:21 <mihgen> it's call for everyone too. We need to provide prompt feedback on patches
16:23:36 <mihgen> xarses: moving?
16:23:37 <xarses> #topic Meeting Schedule on next few weeks (xarses)
16:23:42 <xarses> I've pulled up the next few Fuel meeting days (every Thursday), and overlaid them with some of Holidays I'm aware of.
16:23:42 <xarses> Dec 24, Christmas Eve
16:23:42 <xarses> Dec 31, New Years Eve
16:23:42 <xarses> Jan 7, Russian Orthodox Christmas day // Part of New Years rest
16:23:42 <xarses> Jan 14
16:23:46 <xarses> I'd propose that we should postpone Dec 31, and Jan 7 meetings as we'd likely have no participation.
16:23:49 <xarses> What is every one's thoughts on Dec 24?
16:24:12 <maximov> russian office will be on NY party
16:24:35 <nurla> :)
16:24:39 <mihgen> what about UA, PL on 12/24?
16:25:12 <mihgen> wondering if PL & UA are working on 1/7
16:25:54 <mihgen> #link http://zib.com.ua/files/articles_photos/118507.jpg for UA
16:26:00 <mihgen> so off on 1/7
16:26:58 <mihgen> sounds like we should cancel 12/24, 31, and 1/7 which I don't really like...
16:27:26 <SheenaG> Could we move 12/24 back one day to 12/23?
16:27:40 <xarses> We'd probably not have this room
16:27:46 <SheenaG> Oh good point
16:27:47 <nurla> mihgen: you can join us)
16:27:53 <angdraug> we'd probably not have any room, they're pretty full
16:28:03 <xarses> I can look to see if we have rooms
16:28:16 <xarses> I think we have strong agreement about 12/31, and 1/7 yes?
16:28:24 <angdraug> yes
16:28:26 <bookwar> we can move to #fuel-dev once
16:28:28 <mihgen> +1 to SheenaG, even if we will have to get in #fuel-dev
16:28:32 <SheenaG> If the rooms are free, would we want to do 12/30?
16:28:34 <bookwar> for pre-holiday party..
16:28:40 <mihgen> 12/23 is actually SCF
16:28:44 <angdraug> +1 for #fuel-dev on 12/23
16:29:00 <nurla> 12/23 weekly meeting call
16:29:07 <mihgen> so we need to sync. And then we can be back on 1/14
16:29:09 <angdraug> SCF is not a reason not to have a meeting
16:29:21 <SheenaG> So, #fuel-dev on 12/23, break 12/31 and 1/7, returning to regular meeting location and time 1/14
16:29:26 <mihgen> angdraug: is IS a reason to have a meeting
16:29:44 <xarses> ok, lets put in for 12/23, I'll see if we can get a openstack-meeting room otherwise we'll do in #fuel-dev
16:30:21 <xarses> #action xarses find a meeting room from 12/23, and announce meeting schedule
16:30:32 <xarses> #topic UI Team status (vkramskikh)
16:30:42 <vkramskikh> Hi, we're working on bugfixing. This week we've reduced the number of area-ui bugs from 35 to 28: http://i.imgur.com/hngsDfQ.png
16:30:42 <vkramskikh> We still have 3 High bugs left and still plan to fix them before SCF. The total number of bugs grew slightly by the end of the week as we're focused on High bugs and don't plan to spend much time on Medium- bugs.
16:30:44 <vkramskikh> We're also spending time to help Python guys with fixing https://bugs.launchpad.net/fuel/+bug/1518993
16:30:44 <vkramskikh> After SCF we plan to finish moving Fuel UI to a separate repo with the help of vkozhukalov.
16:30:44 <openstack> Launchpad bug 1518993 in Fuel for OpenStack "Plugins metadata (keys in hash with settings) gets corrupted" [Critical,In progress] - Assigned to Vitalii Myhal (xmig)
16:30:44 <vkramskikh> Questions?
16:32:23 <xarses> thanks vkramskikh
16:32:53 <xarses> #topic Fuel-Mixed Team status (asaprykin)
16:32:58 <asaprykin> Fuel-Mixed team is working on bugs related to "OpenStack configuration" feature:
16:32:58 <asaprykin> Inbox: 0
16:33:00 <asaprykin> Patches on review: 1
16:33:01 <asaprykin> Patches merged: 14
16:33:01 <asaprykin> Also started working on fixing bugs not related to this feature.
16:33:43 <mihgen> asaprykin: is it about post-deployment changes?
16:33:52 <asaprykin> yes, correct
16:34:08 <xarses> great to hear, ave you identified what you may be working on in the next iteration?
16:34:30 <mihgen> what about all those idempotency issues.. ? do you plan to resolve them all?
16:35:21 <asaprykin> We haven't started planning process for the next iteration. AFAIK we have pool of requests that we're going to work on.
16:35:56 <asaprykin> We discussed issues with akasatkin and most of them are addressed by the patches that were merged and one is still on review.
16:36:11 <mihgen> cool
16:36:42 <asaprykin> We had to update CLI, since we did minor update in API to make it more clear for end user and solve possible inconsistent states of the cluster.
16:36:50 <asaprykin> So the last patch is about CLI only.
16:38:17 <asaprykin> Do you have any other questions?
16:38:53 <mihgen> xarses: 5 topics left...
16:38:58 <xarses> #topic Telco Team Status (fzhadaev)
16:39:03 <fzhadaev1> Fuel Telco team's main activity is fixing bugs, related to ubuntu-bootstrap feature.
16:39:03 <fzhadaev1> Here the current amount of open bugs:
16:39:03 <fzhadaev1> 1 Critical bug (fix is on review)
16:39:03 <fzhadaev1> 2 High bugs (fixes are on review)
16:39:03 <fzhadaev1> 2 Medium bugs (one is triaged, for another one fix is on review)
16:39:03 <fzhadaev1> Those who are not involved in fixing these bugs are working with bugs from 8.0 backlog (not related to feature).
16:39:03 <fzhadaev1> Do you have any questions?
16:40:22 <mihgen> plans for next milestone.. ?
16:40:50 <fzhadaev1> we have bp about ubuntu bootstrap improvements https://blueprints.launchpad.net/fuel/+spec/ubuntu-bootstrap-improvements
16:41:29 <mihgen> ok, so you plan to work on those items from blueprint..?
16:41:46 <fzhadaev1> yes, AFAIK :)
16:42:06 <mihgen> ok thx, good
16:42:27 <xarses> #topic Task-Based Deployment Status (ashtokolov)
16:42:41 <ashtokolov> Task-based deployment: Last Friday we finally merged all patches.
16:42:56 <ashtokolov> Many thanks to warpc, bgaifullin, dilyin, aglarendil and especially to ikalnitsky and holder for our merge party!
16:43:07 <ashtokolov> Now we are on testing and bug fixing track.  We’ve run task-based deployments BVT on our CI slaves.
16:43:21 <ashtokolov> As you know in case of task-based deployment we do deployment for all nodes simultaneously
16:43:40 <ashtokolov> Our testing framework uses KVMs for Fuel Master Node and for OpenStack Nodes.
16:43:43 <ashtokolov> All VMs are running on one host node so we are limited by host resources.
16:43:53 <ashtokolov> Preliminarily results:
16:44:01 <ashtokolov> Deployment part of BVT on 12 cores server: granular ~85 minutes, task-based ~48 minutes (4 runs of each type)
16:44:12 <ashtokolov> So task-based is almost two times faster than granular (minus 42% of duration)
16:44:23 <ashtokolov> Now we are testing it on 6 and 4 cores slaves. And we are going to start bare metal tests tomorrow.
16:44:34 <ashtokolov> I’ll share cases and results with all in email asap.
16:44:59 <mihgen> great improvements, this is really cool!
16:45:02 <xarses> ashtokolov: thanks, the improvement is fantastic
16:45:17 <nurla> +100500
16:45:21 <maximov> good job!
16:45:22 <xarses> #topic Bugs team status (dpyzhov) https://etherpad.openstack.org/p/fuel-bugs-status
16:45:34 <dpyzhov> Hi. We are working mostly on tricky high priority bugs. We have progress here and we are going to continue the same activity.
16:45:42 <dpyzhov> I’ve updated bugs statistics. We still have high priority bugs income. And as we know QA doesn’t start acceptance testing yet. So we are awaiting for more bugs.
16:46:13 <dpyzhov> It is kinda sad that we had passed FF long time ago and we still have no stable master. We had two broken BVT tests this week
16:46:29 <dpyzhov> And much more last week
16:46:45 <mihgen> do we have analysis on why it has been happening ..?
16:47:10 <dpyzhov> Centos 7.2 is one reason
16:47:42 <dpyzhov> another is a bug in rabbitmq container that has been hiding for a year
16:47:46 <maximov> yes. unexpected Centos upgrade to 7.2 caused regressions. so we are considering to roll it back
16:47:54 <maximov> to 7.1 version
16:48:21 <mihgen> if it's the reason, +1 for rolling it back. We are blocking QA for finding more issues in other areas
16:48:52 <maximov> ok
16:49:03 <dpyzhov> Everyone in my team has a bug and we have about 5 bugs in our queue
16:49:13 <dpyzhov> so we in the same shape as usual
16:49:26 <mihgen> Major focus should be unblock QA
16:49:32 <dpyzhov> sure
16:49:37 <maximov> dpyzhov: can you update us about swarm-blocker tag?
16:49:45 <dpyzhov> it is a next topic
16:50:03 <mihgen> so I'm for dropping any other work if there are blockers filed by QA
16:50:13 <mihgen> if that's needed, of course
16:50:31 <mihgen> let's move to another topic then) 10min left
16:50:54 <xarses> #topic swarm-blocker and swarm-fail-driver tags usage (dpyzhov)
16:51:05 <dpyzhov> We have two tags: swarm-blocker and swarm-fail-driver. And there are many bugs with these topics
16:51:28 <dpyzhov> Today we've decided to have only swarm-blocker tag for bugs that blocks at least 3 testcases
16:51:37 <dpyzhov> It is about 0.9% of swarm
16:51:54 <dpyzhov> QA will remove extra tags and we'll announce it
16:52:15 <dpyzhov> another use for swarm-blocker tag is bugs that block bvt
16:52:40 <dpyzhov> so if you see swarm-blocker tag on your bug it means that is really urgent and needs to be fixed asap
16:52:56 <mihgen> this seems to be a good idea. we had related discussion in sunnyvale, and came to similar ideas
16:53:31 <dpyzhov> I hope we'll remove extra tags tomorrow
16:53:45 <dpyzhov> Anyway there will be announce in openstack-dev
16:53:48 <salmon_> why not just mark it as critical? :)
16:54:35 <xarses> moving?
16:54:35 <mihgen> that's one of the things actually - I'd expect that all those swarm-blockers are of Critical priority
16:54:37 <dpyzhov> because we have another rules for priorities
16:55:15 <dpyzhov> mihgen: are you expecting the same rules here? set critical priority for bug that affects 1% of swarm?
16:55:52 <mihgen> thanks for working on this with nurla, please announce what you've agreed upon - and then we can review / comment
16:56:00 <dpyzhov> ok
16:56:13 <xarses> #topic Bareon new project (fork fuel_agent) (evgenyl) http://lists.openstack.org/pipermail/openstack-dev/2015-December/082397.html
16:56:19 <evgenyl> Hi.
16:56:30 <evgenyl> Will not take too much time, just a small announcement, we’ve started development of fuel_agent as a separate from Fuel project, the details are in the email on openstack-dev, if you have any question join us on #openstack-bareon channel.
16:56:34 <xarses> #action dpyzhov will announce changes in swarm-blocker tag
16:56:44 <evgenyl> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/082397.html
16:57:39 <mihgen> this is great evgenyl, I'd love to see more of this happening for other Fuel parts
16:58:01 <mihgen> we have to keep Fuel working great as set of components though
16:58:26 <mihgen> it has to be rock stable when it's built into single Fuel install
16:58:44 <evgenyl> mihgen: yes, the plan is to have integration layer between components.
16:58:54 <evgenyl> mihgen: and we know how to do it gradually.
16:59:04 <evgenyl> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/082572.html
16:59:29 <xarses> time check
16:59:30 <mihgen> great, I'll take a look
17:00:01 <xarses> thanks all
17:00:02 <xarses> #endmeeting