04:00:57 <njohnston> #startmeeting fwaas
04:00:58 <openstack> Meeting started Wed Jun 29 04:00:57 2016 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:01:00 <padkrish> hello
04:01:02 <openstack> The meeting name has been set to 'fwaas'
04:01:08 * SarathMekala says hello all
04:01:08 <yushiro> aloha~
04:01:09 <njohnston> #chair SridarK xgerman
04:01:10 <openstack> Current chairs: SridarK njohnston xgerman
04:01:30 <SridarK> I think xgerman may be travelling so may not join
04:01:48 <SridarK> #topic FWaaS v2
04:02:14 <SridarK> Lets go in order from the extensions on to the driver
04:02:48 <SridarK> i had a quick sync with shwetap - there a few more updates that she needs to pick up that she is working on
04:03:02 <SridarK> fallout from my integration testing
04:03:14 <SridarK> i have been working thru this ext - db - plugin
04:03:53 <SridarK> i am able to create rules - kind of got stuck on debugging something that turned out to be trivial once i found it
04:04:18 <SridarK> njohnston: i have some updates for the db - once i clean things up - i will pass it on
04:04:33 <njohnston> SridarK: Great, I look forward to it
04:04:56 <SridarK> we will also need a policy - rule association table
04:05:16 <SridarK> i will hack something quick - to move fwd with the testing
04:05:53 <SridarK> i am really pushing to get this done asap (hopefully by tomorrow)
04:06:02 <njohnston> SridarK: Excellent!
04:06:09 <yushiro> SridarK, great.
04:06:50 <SridarK> njohnston: i know u are busy with the L3Agent stuff - so i am not bothering u with every issue i run into - will aggregate
04:07:11 <njohnston> SridarK: OK, just let me know how I can help. :-)
04:07:17 <SridarK> njohnston: thx
04:07:20 <SridarK> will do
04:07:35 <SridarK> ok moving into the agent
04:07:48 <SridarK> padkrish: welcome back from the PTO
04:07:56 <padkrish> SridarK# Thanks
04:07:57 <padkrish> :)
04:08:03 <yushiro> padkrish, yes, welcome too.
04:08:05 <SridarK> yushiro: , padkrish: over to u guys
04:08:41 <yushiro> SridarK, OK. njohnston helped me to reach out ajo/Ihar on my patch.  Thanks, njohnston :)
04:08:55 <njohnston> yushiro: Any time!
04:09:10 <yushiro> Currently, I and padkrish focus on versioned objects.
04:09:30 <yushiro> And, L2 agent modification on neutron side.
04:09:55 <njohnston> Is the agent change this one: https://review.openstack.org/#/c/268316/ ?   If so, we should replace it with a non-abandoned one.
04:10:54 <SridarK> yushiro: i am thinking we can leverage this for L3 as well
04:11:13 <yushiro> SridarK, yes. padkrish also mentioned to me.
04:11:28 <SridarK> and once u have a plan with the versioned objects - i will ask for some help to define the plugin side of things
04:12:12 <yushiro> njohnston, ah, other patchset. I mean https://review.openstack.org/#/c/329701/
04:13:05 <yushiro> njohnston, currently I'd like to understand your patch's effect to our L2-agent side.
04:13:15 <njohnston> OK.  I wasn't sure what change is the active change as far as the FWaaS agent-side code.
04:14:00 <njohnston> yushiro: The change should be fairly minimal since you were following the pattern set by the QoS L2 plugin.  All we really did from the L2 perspective was moved some things around so that the L3 agent could also get tot hem,
04:14:23 <padkrish> njohnston# https://review.openstack.org/#/c/323971/
04:15:21 <yushiro> njohnston, I see. Your patch is to expand extension feature not only L2 but L3.
04:15:29 <njohnston> padkrish: Thanks, that's the one.
04:16:01 <njohnston> yushiro: Yes, correct, and the patch I am working on as a follow-up to that creates an L3 FWaaS plugin that utilizes the functionality
04:16:42 <njohnston> Since we've moved on to the topic of the l3 agent extension work, there is a point of concern: armax says the code may need to be moved to neutron-lib.  I dissented, but it remains unresolved.  https://review.openstack.org/#/c/329701/5/neutron/agent/l3/l3_agent_extension.py@22
04:16:55 <SarathMekala> Yushiro I had a similar observation and gave a review comment on https://review.openstack.org/#/c/268316/
04:17:02 <njohnston> I am planning on pinging armax to talk about it tomorrow
04:17:59 <SridarK> lets cover this in that topic
04:18:04 <yushiro> njohnston, OK.  I see.  Would you let me know the result?  I'm confusing whether L3 extension code should add in my WIP or not.
04:18:26 <yushiro> SarathMekala, Hi, long time no see :)  Thanks for your comment.  I'll confirm it later.
04:18:59 <SridarK> yushiro: i think for L3 Agent - we can work with the current model and then refactor once the njohnston: 's patch merges
04:19:33 <njohnston> yushiro: I think you should use the common agent_extension code from my patch, eventually.
04:19:45 <SridarK> if the L3 Agent refactor moves quickly - then we jump on that bus
04:19:59 <njohnston> yushiro: Whoever's code merges second can adapt to the one that merges first.
04:20:11 <SridarK> +1
04:20:13 <yushiro> SridarK, njohnston  Yup.  I'll pay attention about that.  Thanks :-)
04:20:37 <SridarK> yushiro: padkrish: other things on the Agent ?
04:20:52 <SridarK> that u would like to discuss
04:20:53 <yushiro> SridarK, currently, that's all from me.
04:21:07 <padkrish> SridarK# nothing from my side, will catch up more in the next day or two
04:21:17 <yushiro> padkrish, can I discuss later?
04:21:27 <padkrish> yushiro# absolutely
04:21:27 <SridarK> ok great, lets move to iptables, driver
04:21:32 <yushiro> padkrish, thanks
04:21:39 <SridarK> chandanc_: SarathMekala: pls go ahead
04:21:50 <chandanc_> We had some discussion locally
04:22:05 <chandanc_> i have updated the meeting agenda with the etherpad for the same
04:22:06 <SridarK> chandanc_: thx for opening the bug and WIP patch
04:22:32 <chandanc_> Just sent you guys some update in mail about the direction we are thinking
04:22:38 <chandanc_> sure
04:22:41 <SarathMekala> WIP etherpad https://etherpad.openstack.org/p/firewall_driver_notes
04:22:51 * njohnston saw the mail, will review it in depth tomorrow
04:23:18 <SarathMekala> will be updating it with discussion notes / issues to be looked at
04:23:24 <chandanc_> Is there any way we can post some diagram for review, I thing i am missing people in the mail
04:23:27 <SridarK> chandanc_: yes thx saw that will take a look
04:23:59 <chandanc_> ?
04:24:04 <njohnston> I forwarded it to mfranc213
04:24:08 <padkrish> chandanc_# yes, i think i was missed :)
04:24:43 <SridarK> i can add all the regular folks to that
04:24:45 <chandanc_> sure, any suggestion for posting picture will be very helpful
04:25:03 <chandanc_> yes will add you and yushiro
04:25:26 <padkrish> thanks
04:25:28 <yushiro> chandanc_, Thanks.
04:25:37 <njohnston> You could always use http://imgur.com/ to post the images.  It's not pretty but it works
04:25:53 <chandanc_> In summary, i have a better handle on the driver, but have some question
04:26:05 <SridarK> chandanc_: or for starters go with what ever is easiest for - a pdf generated from word or a google doc pointer and email
04:26:17 <chandanc_> Thanks Nate, will do that and link back to etherpad
04:26:29 <chandanc_> ok
04:26:35 <SridarK> go with what is easy for u then u can bring it up to the etherpad etc
04:27:00 <chandanc_> I will reach out for clarification as soon as i get along with the code
04:27:09 <chandanc_> sure
04:27:23 <SridarK> chandanc_: sounds good
04:27:44 <SridarK> pls free to ping mickeys for any suggestions or thoughts
04:28:02 <chandanc_> Yes will ping Mickey for clarification
04:28:20 <SarathMekala> sure
04:28:41 <chandanc_> One question though, how do I reactivate a abandoned patch ?
04:29:04 <njohnston> You have to be core or the owner of the patch I believe
04:29:22 <njohnston> If it's abandoned I think you should create a new one and then comment in the old one pointing people to the new one
04:29:23 <SridarK> chandanc_: which patch is it ?
04:29:41 <chandanc_> oh, I will ping Mickey then , the one from Mickey
04:29:45 <SridarK> chandanc_: actually go with njohnston:'s suggestion
04:29:54 <chandanc_> the one from MIckey
04:30:09 <chandanc_> ok will create a new one
04:30:52 <chandanc_> Thats all from my side for now
04:31:10 <njohnston> I added a "Team email list" section to the agenda etherpad https://etherpad.openstack.org/p/fwaas-meeting so that when we have something to mail out to the whole team we can just copy all the addresses from there.
04:31:18 <SridarK> ok sounds good - pls IRC or email if u need any help
04:31:30 <chandanc_> cool, Thanks
04:31:33 <SridarK> njohnston: roey does not work on this - so u can remove him
04:31:39 <chandanc_> sure
04:31:42 <SarathMekala> sure
04:31:52 <njohnston> SridarK: Thanks, done
04:31:55 <SridarK> thx
04:32:14 <SridarK> ok lets move on
04:32:32 <SridarK> #topic L3 Agent extension
04:32:36 <SridarK> njohnston: pls go ahead
04:33:11 <njohnston> Well, I pretty much covered it earlier.  What I said was: there is a point of concern: armax says the code may need to be moved to neutron-lib.  I dissented, but it remains unresolved.  https://review.openstack.org/#/c/329701/5/neutron/agent/l3/l3_agent_extension.py@22
04:33:53 <SridarK> njohnston: yes my concerns too - in that this will take more time
04:34:30 <njohnston> Other than that the code is coming along.  I am working on the code for the fwaas extension that will plug into that agent extension manager, which so far is a disaster, partially because I have had other things come up this week.
04:35:47 <njohnston> SridarK: Once I get things a bit further along I'd like to chat with you about where I integrate into the existing l3 codebase
04:36:09 <SridarK> njohnston: ok no worries, once i get out of my integration task  - i can work with u on that
04:36:17 <njohnston> SridarK: Great!
04:36:24 <njohnston> that is it for me
04:36:35 <SridarK> ok great thx njohnston:
04:37:11 <SridarK> #topic Vendor Driver removal
04:37:39 <SridarK> njohnston: let me take an action on that - i know most of these folks - so will work with them
04:37:59 <SridarK> #action SridarK to reach out to vendors to remove their drivers
04:38:10 <njohnston> Great.  I just recalled that we had said that would happen by N-2, and since that looms close it seems only right to give them a heads up.
04:38:21 <SridarK> njohnston: yes absolutely
04:39:28 <SridarK> if there are no other things we can go to the Open Discussion
04:40:12 <SridarK> ok
04:40:19 <SridarK> #topic Open Discussion
04:40:46 <SridarK> njohnston: PTO plans noted
04:41:14 <njohnston> The fwaas devstack plugin merged (yay!) so now on the devstack front the next thing up is https://review.openstack.org/#/c/321146 to remove other references to fwaas.  I don;t think we need to ride herd on this, we've done our part
04:41:49 <yushiro> njohnston, awesome!
04:42:01 <SridarK> njohnston: yay on that for sure - that turned out to be a bit bumpy but i think all is good now
04:42:29 <SarathMekala> +1
04:42:56 <njohnston> I also wanted to note that the #openstack-fwaas channel is logged now - http://eavesdrop.openstack.org/irclogs/%23openstack-fwaas/ - so we should all keep it in mind for facilitating group discussions
04:43:06 <SridarK> +1
04:43:14 <njohnston> mestery and others are also hanging out there, giving a really positive attitude, which is nice
04:43:28 <SridarK> agreed
04:43:43 <hoangcx> +1
04:44:26 <SridarK> I will most likely be on a plane during next weeks mtg
04:44:37 <SridarK> njohnston: i see that u are out as well
04:44:44 <njohnston> I will be at a family reunion in Michigan, yes.
04:44:46 <SridarK> would any one else like to run the mtg
04:45:14 <SridarK> i will wait to the end of the week, pls drop me a note
04:45:29 <SridarK> i think xgerman will be back - in which case he will run it
04:45:39 <SridarK> i will check with him as well
04:46:00 <njohnston> +1
04:46:56 <SridarK> I did not have anything else, any one else have things to discuss ?
04:47:06 * njohnston doesn't have anything.
04:47:17 <chandanc_> njhonston, now that we are using neutron legacy , I think we should not merge this  https://review.openstack.org/#/c/321146 correct ?
04:48:17 <njohnston> chandanc_: What https://review.openstack.org/#/c/321146 does is stop fwaas from being loaded in the gate whenever the l3 agent is loaded
04:48:54 <njohnston> for example https://review.openstack.org/#/c/321146/2/devstack-vm-gate.sh keeps it from being loaded for the neutron DVR gate tests
04:49:11 <chandanc_> oh
04:49:17 <njohnston> Now that we have disentangled our complicated inheritance model from the l3 agent I think that is fine
04:49:26 <SridarK> +1
04:50:26 <chandanc_> ok
04:50:28 <SridarK> the next few weeks are critical for us to get things moving - so would request folks to keep pushin
04:50:45 <njohnston> Do we have a clearer idea about a midcycle?
04:51:13 <SridarK> njohnston: can we hold that thought for the week after next ?
04:51:32 <njohnston> OK, but I think if the midcycle occurs in August it will be too late
04:51:49 <SridarK> if we have most of these things working or almost working - we can use the midcycle to push things thru
04:52:04 <SridarK> i was thinking later part of July
04:52:17 <SridarK> yes Aug would be too late
04:52:33 <njohnston> I will be out the last week in July, but otherwise I can accomodate any time
04:52:53 <SridarK> ok lets shoot for a date just b4 that
04:53:10 <SridarK> we could do a focussed 2 day sprint
04:53:17 <njohnston> Sounds great!
04:53:27 <SridarK> and perhaps another 2 day sprint in Aug for the remaining bits
04:53:51 <SridarK> 2 was just a notion - it can be 3 which may make more sense too
04:53:51 <yushiro> SridarK, great.
04:54:05 <SridarK> we can arrive at some consensus
04:54:51 <njohnston> sounds like a plan
04:55:19 <SridarK> ok perfect
04:55:32 <SridarK> thanks all for attending
04:55:43 <chandanc_> thanks
04:55:44 <SridarK> if nothing else we can close
04:55:49 <njohnston> Thanks everyone!
04:55:57 <SridarK> #endmeeting fwaas