04:01:11 <SridarK> #startmeeting fwaas
04:01:12 <openstack> Meeting started Wed Aug 10 04:01:11 2016 UTC and is due to finish in 60 minutes.  The chair is SridarK. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:01:15 <openstack> The meeting name has been set to 'fwaas'
04:01:19 <njohnston_> hi!
04:01:24 <SridarK> #chair xgerman njohnston_
04:01:25 <openstack> Current chairs: SridarK njohnston_ xgerman
04:01:32 <padkrish> hello
04:02:03 <SridarK> lets get started and do a quick run
04:02:40 <SridarK> We are cutting it fine on time with code freeze around the corner (Sep 2) i believe
04:03:20 <SridarK> so the next few weeks will be running tight and lets feel free to reach out to any of the team for any help or thoughts
04:03:26 <njohnston_> yep, this is week R-9 and N-3 is R-5
04:03:32 <SridarK> so we can keep things moving
04:04:08 <SridarK> njohnston_: +1 we should keep the last week as a buffer and not count on that
04:04:20 <njohnston_> absolutely.  Something always comes up.
04:04:36 <SridarK> #topic fwaas v2
04:05:20 <SridarK> been in discussions with most of u and i think we are in agreement on the priority for the first cut
04:06:11 <SridarK> we will target the first end to end with L3 as we have been discussing in past meetings
04:06:22 <SridarK> #link https://review.openstack.org/#/c/264489/
04:06:46 <SridarK> extensions - will be the first to get in - i think this is mostly ready
04:07:01 <SridarK> few minor rework is needed
04:07:15 <SridarK> but pls folks go thru and review
04:07:41 <SridarK> the next in line would be:
04:07:45 <SridarK> #link https://review.openstack.org/#/c/311159/
04:07:52 <SridarK> the db patchset
04:08:20 <SridarK> i have been helping njohnston_: while he got pulled in to the L3 extensions work
04:08:25 <njohnston_> I am working on the unit tests for that now; they have uncovered some minor issues, like some of the tables are missing primary keys etc.
04:08:39 <njohnston_> I'll be focusing on that tomorrow
04:08:51 <xgerman> Thanks
04:08:54 <SridarK> njohnston_: great - i think over the next 2 days we can iterate and fix things up
04:09:00 <njohnston_> definitely
04:09:35 <SridarK> njohnston_: i am testing some things with the policy rule associations and few other minor things around there
04:09:44 <SridarK> i think the migration will need some work too
04:09:54 <SridarK> and u quickly got the UT going
04:10:20 <SridarK> thx njohnston_: i think we should be in decent shape - we can continue to sync over tomorrow
04:10:44 <njohnston_> yes, definitely.  I'll be sure to also be very verbose with my notes in the change so it's clear what is changing
04:10:57 <njohnston_> with each PS
04:11:17 <SridarK> njohnston_: great - yes i saw that already on the PS u pushed up
04:11:19 <SridarK> today
04:11:35 <SridarK> the next patch would be the plugin
04:11:41 <SridarK> #link https://review.openstack.org/#/c/267046/
04:12:45 <SridarK> I think most things are in place, main work  is to add the UT - most of the interfaces with db/ext have been tested using devstack
04:13:31 <SridarK> and the final patch would be the L3 FWaaS agent from mfranc213:
04:13:44 <SridarK> #link https://review.openstack.org/#/c/337699/
04:13:58 <SridarK> from what i reviewed - i think this is in good shape
04:14:11 <SridarK> mainly needs UT - and mfranc213: is on that
04:14:41 <SridarK> we will need to do an integration test with the prev 3 patches
04:14:51 <yushiro> OK.
04:15:09 <SridarK> and the final piece on that is to reformulate the fw rule - iptables mapping
04:15:36 <SridarK> we will need to factor in the port in the iptable rule in place of the qr-* we had previously
04:16:00 <SridarK> chandanc: SarathMekala: I think this should be fairly straight fwd
04:16:44 <SridarK> it may be useful if mfranc213: and u all sync up
04:17:09 <SridarK> for a quick turnaround on this
04:17:14 <chandanc> I havent looked at the Iptables driver for fwaas, but given that the ports are already know in the agent side, i feel it should be simple
04:17:30 <SridarK> the initial thought is to just make this a part of the agent patch
04:17:35 <SridarK> for simplicity
04:17:42 <SridarK> chandanc: yes - i felt so too
04:17:51 <chandanc> sure will ping mfranc213: for a sync-up
04:18:34 <SridarK> i know we thought we could sync after this, but will be good to have mfranc213 in the conversation too
04:19:01 <SridarK> chandanc: perhaps early am Pacific / evening for u guys
04:19:32 <SarathMekala> sure
04:19:33 <chandanc> sure
04:19:47 <SridarK> we can do a quick sync after this too - so u have some context before discussion tomorrow
04:20:01 <chandanc> yup, we should
04:20:04 <SridarK> lets discuss offline
04:20:05 <SarathMekala> sure
04:20:33 <njohnston_> Yeah, email her to set something up - she tends to be a very early riser, so perhaps something very early EDT might work as well
04:20:33 <SridarK> so in summary that should be the first set we should get in and target for end of this week
04:20:51 <njohnston_> +100 targetting end of week
04:20:54 <SridarK> njohnston_: yes that will be good
04:21:21 <xgerman> Three days left...
04:21:33 <SridarK> so request to folks is to get some reviews out - feel free to use gerrit - get those -1's out for clarifications
04:22:19 <SridarK> once we have this base in - we can always refactor for some more cleanup
04:22:52 <SridarK> the patch dependency stuff is getting to be painful to manage
04:23:19 <SridarK> does this sound reasonable ?
04:23:29 <shwetaap> Hello, sorry I joined late, my patch got some comments from SridarK today. I will make the changes and upload the new patch tomorrow.
04:23:36 <njohnston_> once we get this foundation in, my hope is that we can implement additional parts of the functionality as self-contained patches, spanning DB, API etc all in one patch
04:23:42 <SridarK> shwetaap: sounds good
04:23:55 <njohnston_> SridarK: Yes, very reasonable to me.
04:24:05 <SridarK> njohnston_: yes could not agree more on the self contained patches
04:24:07 <njohnston_> shwetaap: Thanks!
04:24:54 <SridarK> ok lets move on to the next topic
04:25:02 <SridarK> #topic L3 Agent Extensions
04:25:07 <SridarK> njohnston_: all urs
04:25:27 <njohnston_> Well, the L3 agent extension looks good
04:25:50 <njohnston_> Ajo had an idea about generalizing the configuration so the agents would get a list of what to load from neutron server
04:26:00 <njohnston_> I think it's a great idea... for some later patch.  Not this one
04:26:14 <SridarK> njohnston_: sigh yes absolutely
04:26:19 <njohnston_> So with that out of the way, I hope to get +2s this week.
04:26:38 <njohnston_> I know I have satisfied all of carl_baldwin's points he has raised so far
04:27:14 <njohnston_> and the fullstack test - which is going to be a ridiculous piece of work - is separated so it can be deferred and kept off the critical path
04:27:33 <SridarK> njohnston_: ok great - that will be a good - i think this should merge, i know carl_baldwin want this done for quite some time now
04:27:45 <SridarK> *wanted
04:28:02 <njohnston_> The last minor issue is a jenkins failure, but I think that is unrelated... but I will look again at it
04:28:36 <njohnston_> it's only failing in the gate-grenade-dsvm-neutron-dvr-multinode and gate-grenade-dsvm-neutron-multinode tests but I think there was some swirl around them a day or two ago
04:28:52 <njohnston_> I'm Neutron bug deputy this week so I'll keep my ear to the ground
04:29:10 <njohnston_> anyway that's all for me, I pass the baton back to you SridarK
04:29:19 <SridarK> njohnston_: ok u are close to the fires :-)
04:29:32 <SridarK> thx njohnston_:
04:30:20 <SridarK> i think we are in a good shape here and njohnston_: thanks to all ur hard work on what seemed like an impossible task as we started off Newton
04:30:37 <njohnston_> I am thrilled it seems to be working out :-)
04:30:42 <SridarK> :-)
04:30:58 <SridarK> #topic FWaaS Agents
04:31:14 <SridarK> yushiro: , padkrish: over to u guys
04:31:24 <SridarK> yushiro: also thanks for joining when u are on vacation
04:31:36 <yushiro> SridarK No warrires.
04:33:19 <yushiro> SridarK, Sorry, I don't have topics today.  padkrish , how about you?
04:33:39 <padkrish> ok, i have addressed yushiro's comments on the versioned objects
04:34:04 <SridarK> padkrish: ok and u had 1 patch on neutron for defining the resources
04:34:08 <padkrish> i will wait for the DB patch to go in, then i will post my next  patch
04:34:24 <SridarK> padkrish: yes i think that should help
04:34:27 <padkrish> yes, so, i will decompose in to 3 patches
04:34:41 <padkrish> first patch on just the versioned objects that depends on the DB patch
04:34:55 <SridarK> padkrish: that would go into neutron correct ?
04:35:08 <padkrish> second patch will be defining the neutron resources, this depends on the first versioned object patch
04:35:20 <SridarK> padkrish: ok yes
04:35:23 <padkrish> SridarK# second one, that i just said goes to Neutron
04:35:55 <padkrish> and third patch is on fwaas notification driver, this depends on the second patch (neutron resources)
04:36:34 <padkrish> currectly, i have first and third patch as 1, which is creating a circular dependency and is not good :)
04:36:43 <SridarK> padkrish: can u pls post the links to the patches
04:37:08 <padkrish> SridarK# sure, it's there in the gerrit, i will post again
04:37:20 <padkrish> https://review.openstack.org/#/c/347092/1 is the neutron one
04:37:26 <SridarK> wait till tomorrow and then u can create a depends on the db patch as it should get more stable
04:37:48 <padkrish> https://review.openstack.org/#/c/342476/2 is the versioned object
04:38:00 <padkrish> SridarK# sure, sounds good
04:38:03 <SridarK> ^^^ this would be the depends on db
04:38:18 <padkrish> SridarK# yes
04:38:21 <xgerman> +1
04:38:24 <yushiro> padkrish, That's great.
04:38:24 <SridarK> so we can get some reviews going on that so we can target that quickly after the db
04:38:33 <SridarK> so u have some time on the neutron patch
04:38:39 <njohnston_> +1
04:39:07 <padkrish> SridarK# ok...
04:39:16 <SridarK> padkrish: i think njohnston_ can help with reviewers - i think ajo would one
04:39:22 <SridarK> * would be one
04:39:35 <padkrish> SridarK# ok, that would be great
04:40:23 <SridarK> i think essentially these would be our target for next week - that should get us to versioned objects and with the L3Agent ext
04:40:56 <SridarK> padkrish: anything else to discuss
04:41:09 <padkrish> SridarK# no thats about it
04:41:23 <SridarK> ok lets move on, thx padkrish: & yushiro:
04:41:37 <SridarK> #topic iptables and driver
04:41:47 <SridarK> chandanc: , SarathMekala: pls go ahead
04:42:24 <SridarK> #link https://docs.google.com/document/d/1yGsGwVNZuptPCzMMgBH4AHVkdoeWvQxsT5Wql7-jtHI/edit?usp=sharing
04:42:41 <SridarK> thanks for explaining this very clearly here
04:42:52 <SridarK> can i pls request all to take a look
04:42:56 <chandanc> The neutron patches are out, we have started working on the L2 Iptables Driver for fwaas based on the mickeys old work
04:43:31 <chandanc> We will need to sync with yushiro for integration with L2 extension
04:43:36 <SridarK> chandanc: and thx for reaching out to mickeys - hopefully u can close with him by tomorrow
04:43:48 <chandanc> Ya sure
04:44:00 <SarathMekala> as per today's discussion it looks like we need to get L3 driver done by EOW
04:44:04 <yushiro> chandanc, OK.
04:44:08 <chandanc> I think the neutron patches are more important to pushin
04:44:20 <SridarK> chandanc: do u want to quickly checkin with yushiro here
04:44:50 <SridarK> SarathMekala: yes on the L3 - i think that should be straighfwd - lets talk quickly after the mtg
04:45:00 <SridarK> chandanc: yes on the neutron
04:45:03 <SarathMekala> Yeah sure
04:45:17 <chandanc> I would probably put a comment on the patch, basically we have to agree on the driver API calls
04:45:39 <SarathMekala> and the parameters that are getting passed
04:45:43 <SridarK> i am hoping that we can reach out to neutron folks in a day or 2
04:45:44 <chandanc> I saw the driver calls are currently stubbed
04:46:49 <SridarK> yes on the driver i/f - we will need to pass in the ports (possibly along with the associated router)
04:46:51 <chandanc> The discussion with yushiro is about the fwaas driver patch, the neutron patch are already out
04:47:33 <SridarK> chandanc: yes agreed - i asked because yushiro is on PTO this week - if u want to have a quick discussion now or provide some context
04:47:41 <SridarK> when he is around
04:47:48 <SridarK> or set a time when he may be available
04:48:27 <chandanc> I will summarize my understanding in mail, i have just gone through the l2 extension i have some more reading to do
04:48:50 <chandanc> Will be sending the mail by today evening
04:49:11 <SridarK> chandanc: yes that makes sense, yushiro: if it is possible for u to take a quick look when u will be avail - that will be great
04:49:12 <yushiro> SridarK, thanks for your follow :).  chandanc , Sure.  Pls send e-mail to me.
04:49:30 <yushiro> Sure
04:49:30 <chandanc> thanks yushiro
04:49:35 <SridarK> ok great, thx
04:50:11 <yushiro> chandanc, If you send e-mail to me, please use 'gmail' instead of company address.
04:50:36 <SridarK> ok in summary, we will close on the L3 piece quickly, then there is the neutron patch and finally the L2 piece and wiring with the L2Agent
04:50:57 <yushiro> chandanc, Because I cannot confirm my company address until 16th.
04:51:14 <SridarK> chandanc: i will send u the email address
04:51:20 <chandanc> can you tell me your gmail ?
04:52:01 <yushiro> SridarK, chandanc Thank you!
04:52:03 <chandanc> Ok SridarK
04:52:36 <SridarK> ok sent
04:52:50 <SridarK> lets move on b4 we hit the hour
04:53:00 <SridarK> #topic CLI
04:53:27 <SridarK> yushiro: has a patch out
04:53:31 <SridarK> #link https://review.openstack.org/#/c/351582/
04:54:03 <SridarK> i think once we get the first set in - we should probab target this
04:54:22 <njohnston_> It looks like that patch needs unit tests, I will have more feedback on it tomorrow... but it's a great start
04:54:25 <SridarK> njohnston_: as u mentioned the cut off may be a week early
04:54:28 <xgerman> From what I gathered all new CLI work should be OSC
04:54:51 <xgerman> So let's make sure they will let that in
04:54:54 <njohnston_> except *-aas is supposed to integrate via python-neutronclient
04:54:59 <yushiro> xgerman, Sure.
04:55:01 <SridarK> and yushiro is back next week - so we should be good
04:55:08 <njohnston_> I asked in the OSC meeting, and that was the answer I got
04:55:08 <SridarK> njohnston_: oh ok
04:55:22 <njohnston_> they made python-neutronclient an OSC plugin
04:55:36 <SridarK> njohnston_: oh yes - u mentioned that earlier
04:55:58 <SridarK> i think we are in good shape there
04:56:03 <xgerman> Mmh, the LBaaS people told me a different story...
04:56:20 <yushiro> As I discussed with amotoki last week, we should start 1.create FWaaSv2 on python-neutronclient, 2.make OSC plugin for FWaaSv2.
04:56:27 <xgerman> But njohnston is likely closer to the source
04:56:34 <njohnston_> I will reconfirm
04:56:39 <njohnston_> better safe than sorry
04:56:48 <SridarK> +1
04:57:02 <xgerman> Yep.
04:57:17 <njohnston_> #action njohnston_ to reconfirm fwaas CLI to be python-neutronclient as opposed to OSC with OSC folks
04:57:18 <SridarK> ok lets get to open discussion
04:57:26 <SridarK> #topic open discussion
04:57:34 <SridarK> we are almost out of time
04:57:40 <SridarK> anything anyone ?
04:58:01 <SridarK> thanks all for really pulling together as we near the end
04:58:24 <xgerman> +1
04:58:37 <yushiro> All, please take care of 'summer heat'.  It's too hot in Japan...
04:58:48 <njohnston_> Stay cool yushiro!
04:58:55 <SridarK> yushiro: global warming :-)
04:59:20 <SarathMekala> :)
04:59:26 <SridarK> ok i think we are almost at time
04:59:42 <njohnston_> thanks everyone
04:59:46 <yushiro> njohnston_, Yeah. I always use cooler. Hahaha
04:59:50 <SridarK> thx all again and a happy and productive week, lets get those patches merging ....
04:59:56 <yushiro> Thanks!!
05:00:01 <SridarK> bye all
05:00:10 <SridarK> #endmeeting fwaas