04:00:47 <njohnston> #startmeeting fwaas
04:00:48 <openstack> Meeting started Wed Oct 19 04:00:47 2016 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:50 <SarathMekala> Hi all O/
04:00:51 <openstack> The meeting name has been set to 'fwaas'
04:00:58 <njohnston> #chair SridarK_ yushiro
04:00:59 <openstack> Current chairs: SridarK_ njohnston yushiro
04:01:04 <njohnston> #chair xgerman
04:01:05 <openstack> Current chairs: SridarK_ njohnston xgerman yushiro
04:01:22 <SridarK_> lets get started and move quickly
04:01:34 <SridarK_> #topic FWaaS v2
04:01:35 <njohnston> +1
04:01:50 <SridarK_> yushiro: welcome back hope u had a good holiday
04:02:07 <yushiro> SridarK_, Thank you so much.  Yes, everything was perfect :)
04:02:19 <SridarK_> perhaps u can kick things of with a quick update on CLI
04:03:16 <yushiro> yes
04:03:35 <yushiro> #link https://review.openstack.org/#/c/351582/
04:04:17 <yushiro> I discussed with Akihiro and decided to meet in summit with OSC team.
04:04:38 <SridarK_> yushiro: ok, so u think maybe we can move for getting this merged next week
04:04:51 <SridarK_> we can help with reviews on our side
04:05:16 <yushiro> SridarK_, I hope so.  However, I and Akihiro need to discuss about https://review.openstack.org/#/c/348097
04:05:19 <SridarK_> it may be a bit tight with the summit but u could get some good traction with the OSC team
04:05:48 <SridarK_> yushiro: ok got it
04:06:04 <yushiro> Yeah, our OSC plugin patch is looks good except some TODOs, but OSC utilities need to discuss with OSC teams.
04:06:21 <SridarK_> yushiro: ok
04:06:27 <yushiro> We got some comments from OSC team to move this utility into osc-lib.
04:06:27 <SridarK_> lets move on
04:06:34 <SridarK_> oh sorry
04:06:37 <SridarK_> pls go ahead
04:07:13 <yushiro> In summit, I know a core reviewer in OSC, I and Akihiro will discuss about that.
04:07:19 <SridarK_> ok
04:07:29 <yushiro> That's all for me.
04:07:31 <yushiro> thanks
04:07:36 <SridarK_> thx yushiro
04:07:46 <yushiro> OK, please go ahead :)
04:07:52 <SridarK_> lets get into L2 agent
04:08:08 <SridarK_> padkrish: yushiro: pls go ahead if there are updates
04:09:27 <yushiro> SridarK_, : currently, I'm busy for preparing for summit and I couldn't check deeply..   padkrish , is there some update?
04:09:40 <padkrish> SridarK_# Actually much much from me last week....just got a little done on rule/policy/group updates
04:09:41 <padkrish> i mean "not much" from me
04:10:50 <padkrish_> SridarK_# Actually not much from me last week....just got a little done on rule/policy/group updates
04:11:10 <SridarK_> padkrish: ok cool, i think we can continue to refine the methods needed for port association and also on the default fwg
04:11:46 <padkrish_> SridarK_# ok, also wanted to get some brain dump on how rule/policy updates are done for L3
04:12:05 <SridarK_> padkrish_: We will do a bit of a whiteboard discussion with default fwg at the summit and can update
04:12:13 <padkrish_> Don't believe there's any different for L2
04:12:23 <padkrish_> SridarK_# ok
04:12:35 <SridarK_> padkrish_: yes rule, policy updates are similar
04:13:11 <SridarK_> if the rule is a part of a policy that is associated with a fwg (with ports) then an update is trigerred to the agent
04:13:21 <SridarK_> will be same for L2
04:15:08 <SridarK_> #action SridarK_: to discuss default fwg with FWaaS team at the summit and update all via email
04:15:09 <padkrish_> SridarK#ok, that will have the complete dictionary, i believe....so no need to cache at the agent, right?
04:15:20 <SridarK_> padkrish_: yes
04:15:39 <padkrish_> SridarK_# sounds good..
04:15:59 <SridarK_> ok if nothing else we can move to the driver
04:16:09 <SridarK_> chandanc: SarathMekala: pls go ahead
04:16:29 <SridarK_> thx for getting things moving on the reviews out for neutron
04:16:45 <chandanc> The Conntrack patch got a review from kevinbenton, i have fixed the comments and put some explanation
04:17:11 <chandanc> the IPtables driver patch got UT fixes for some more cases
04:17:19 <SridarK_> chandanc: yes thx, try to get some IRC time with him and we can also follow up more at the summit
04:17:37 <chandanc> I am still trying to get kevinbenton to look in to the second patch
04:17:42 <chandanc> sure
04:17:54 <SridarK_> thx chandanc
04:18:06 <chandanc> getting a review of the iptables patch is critical
04:18:13 <SridarK_> yes absolutely
04:18:52 <chandanc> also we need to have some discussion on     [Challengable work] Support logging API for firewall-rule (I will update BP, spec and source code for review soon - hoangcx)
04:18:58 <chandanc> https://etherpad.openstack.org/p/fwaas-ocata
04:19:19 <chandanc> sorry i pasted the wrong one
04:19:23 <chandanc> copy paste
04:19:23 <SridarK_> chandanc: yes :-)
04:19:25 <njohnston> yes, I have noticed there has been some activity on the logging API stuff
04:19:43 <yushiro> :)
04:19:46 <chandanc> i mean there was an alternative conntrack approach
04:19:50 <SridarK_> njohnston: +1 and hoangcx and team have been pushing this for some time
04:19:54 <chandanc> let me find the link
04:20:05 <chandanc> 13. Using Netlink instead of conntrack-tools to improve performance https://bugs.launchpad.net/neutron/+bug/1630832 (hoangcx)
04:20:07 <openstack> Launchpad bug 1630832 in neutron "[RFE] FWaaS: Using Netlink instead of conntrack-tools to improve performance" [Wishlist,Confirmed]
04:20:22 <SridarK_> So we had a quick discussion with hoangcx yesterday on this on IRC
04:20:30 <njohnston> ah yes, I saw that but I don't know that much about netlink
04:20:39 <SridarK_> there is interest in pursuing for reasons of scale
04:20:39 <chandanc> this may have some impact on the ip conntrack
04:21:05 <SridarK_> this will need some attention from the drivers team as it is relevant to Sec groups as well
04:21:19 <SridarK_> hoangcx: will be pursuing this
04:21:22 <chandanc> yes, but may be initially we can go with the conntrack patch
04:21:35 <SridarK_> perhaps we can have some discussions next week
04:21:41 <SridarK_> chandanc: yes absolutlely
04:21:59 <SridarK_> i dont think any of our current direction changes
04:22:06 <chandanc> ya
04:22:23 <chandanc> Thats all for the driver update from my side
04:22:24 <njohnston> +1
04:22:58 <SarathMekala> No updates from my side.. was busy with some deliverables
04:23:16 <SridarK_> SarathMekala: ok
04:23:21 <SridarK_> #topic Neutron Stadium Compliance
04:23:27 <SridarK_> njohnston: pls go ahead
04:23:50 <njohnston> Hi!  So, as before we are tracking our compliance items in https://etherpad.openstack.org/p/fwaas-meeting
04:24:01 <njohnston> I think we have some good action on many of them
04:24:04 <SridarK_> +1
04:24:21 <njohnston> chandanc has a great patch up for multinode testing, and I have one for grenade testing, I think those will merge soon
04:24:42 <SridarK_> +1
04:24:48 <yushiro> +++1
04:24:59 <njohnston> the api reference appears to already be in flight https://review.openstack.org/#/c/363967/
04:25:04 <yushiro> great work, njohnston and chandanc :)
04:25:37 <SridarK_> On my part, i started work on the tempest tests for v2, will get a review out in a day or two
04:25:46 <njohnston> excellent!
04:26:01 <njohnston> I have been working on making myself a part of the neutron-lib effort, but It wouldn't be a bad thing for other FWaaS cores to get in on the action. :-) I am tracking the punchlist here: https://etherpad.openstack.org/p/neutron_lib_fwaas_punchlist
04:26:12 <SridarK_> njohnston: +1
04:26:20 <njohnston> a couple of n-l changes are in flight, so I think we are probably looking all right from that perspective
04:26:26 <chandanc> +1
04:26:34 <njohnston> I think the main remaining issues are documentation and tempest
04:26:45 <SridarK_> yes absolutely
04:26:59 <njohnston> oh, and I am working on fullstack, but at a little lower priority than the others
04:27:13 <SridarK_> njohnston: we could also take some time to work thru some of the documentation next week
04:27:19 <njohnston> definitely
04:27:39 <njohnston> please take a moment to review https://review.openstack.org/#/c/386773/ when you have a chance - it will boost out neutron-lib adoption percentage
04:27:47 <njohnston> s/out/our/
04:27:57 <SridarK_> will do
04:28:05 <njohnston> thanks
04:28:08 <yushiro> me too, njohnston
04:28:22 <njohnston> so I hope to have updates to the fwaas assessment as things get merged
04:28:33 <njohnston> I will make sure that is up to date
04:28:54 <SridarK_> njohnston: perfect
04:29:04 <njohnston> I think that's it on stadium compliance
04:29:23 <SridarK_> ok great, lets move on
04:29:34 <SridarK_> #topic Bugs
04:30:29 <SridarK_> anything critical that needs discussion
04:30:32 <SridarK_> ?
04:31:00 <njohnston> ZhaoBo had a couple of bugfixes
04:31:19 <njohnston> https://review.openstack.org/387398
04:31:21 <njohnston> and
04:31:28 <njohnston> https://review.openstack.org/387328
04:31:39 <yushiro> I will review them
04:31:46 <njohnston> please take a look; I tagged the bugs associated with them as newton-backport-potential
04:32:42 <SridarK_> i started looking into 387328
04:33:16 <SridarK_> yesterday - had some clarifications as this validation happens on the plugin
04:33:37 <SridarK_> but perhaps need some more cover on the update case
04:33:43 <SridarK_> let me put some comments on that
04:33:53 <njohnston> Very good
04:34:02 <SridarK_> i started looking yesterday and lost context
04:34:18 <SridarK_> those neurons are dying so fast (and i forgot) :-)
04:34:32 <njohnston> 😜
04:35:03 <SridarK_> ok lets get to open discussion if nothing else
04:35:23 <SridarK_> #topic Open Discussion
04:35:54 <njohnston> If you are going to the summit and will be there for the friday afternoon session, be sure to sign up here: https://etherpad.openstack.org/p/ocata-neutron-contributor-meetup
04:36:16 <yushiro> signed :)
04:36:28 <njohnston> Yep, just yushiro and me for now :-)
04:36:30 <SridarK_> i think those of us going are: njohnston, yushiro, mfranc213, hoangcx and SridarK_ from the FWaaS sub team
04:36:55 <yushiro> hoangcx, and annp will attend.
04:36:59 * hoangcx joined
04:37:13 <yushiro> And can we meet before Friday?
04:37:14 <njohnston> SridarK_: No shwetaap?
04:37:16 <SridarK_> and now we are 4
04:37:27 <yushiro> wow, real-time update :)
04:37:44 <njohnston> most popular table!
04:37:47 <SridarK_> yes sorry shwetaap will be there - but i have to ask how much time she will spend on FWaaS
04:37:51 <SridarK_> :-)
04:39:03 <njohnston> and the session we will all be interested in
04:39:24 <SridarK_> we can sync on email on when, where & how we can coordinate to meet even before
04:39:30 <njohnston> "Neutron: Stadium update" Friday 10/28 11:50 - 12:30
04:39:48 <njohnston> https://etherpad.openstack.org/p/ocata-nova-neutron-stadium
04:40:26 <njohnston> I would enjoy meeting before Friday, perhaps we can find a time to socialize and chat at lunch or dinner
04:40:36 <SridarK_> yes absolutely
04:40:51 <SridarK_> lets start an email amongst the attendees
04:41:09 <njohnston> +1
04:41:14 <SridarK_> we could carve out some time on each of the days to attack the documentation and other things
04:41:34 <yushiro> njohnston, SridarK_, Me too. Maybe I can book a meeting room, on Wednesday or Thursday.
04:41:37 <chandanc> SridarK_, please include us too, although we will be mute
04:41:50 <SridarK_> chandanc: oh ok surely
04:42:02 <SridarK_> we can do a webex or google hangout
04:42:06 <njohnston> chandanc: What is the best way to conference you in?  Hangouts, webex, or something else?
04:42:07 <chandanc> thanks :)
04:42:20 <chandanc> both are ok with me
04:42:25 <njohnston> ok, good
04:42:40 <SridarK_> ok we will keep the emails going across all the team members
04:42:58 <yushiro> yes.
04:43:01 <SridarK_> i really wish everyone could have made it
04:43:03 * njohnston is starting to feel the excitement
04:43:09 <SridarK_> +1
04:43:23 <njohnston> +1 hopefully we will see each other next time, chandanc and SarathMekala
04:43:36 <chandanc> i surely hope so
04:43:43 <yushiro> It'll be perfect :)
04:43:43 <SarathMekala> :) sure
04:43:58 <SridarK_> At the risk of sounding melodramatic, we have really come far from the Fri meeting at Austin
04:44:06 <njohnston> we sure have!
04:44:16 <chandanc> yes we have
04:44:29 <SridarK_> this has been an awesome team experience - really fantastic to work with all of u
04:44:32 <njohnston> We have a lot to celebrate.  I am proud of everyone here.
04:44:43 <yushiro> For me, I'll meet you since Mitaka summit.
04:44:50 <SarathMekala> +1 was a great experience
04:45:01 <chandanc> +1
04:45:32 <SridarK_> ok we can sync on email then, if nothing else we can close out
04:45:51 <SridarK_> Thanks all for attending
04:46:00 <chandanc> Thanks all
04:46:02 <njohnston> I have nothing else.  Thanks everyone!
04:46:12 <yushiro> Thanks all.
04:46:16 <njohnston> #endmeeting