14:00:05 <njohnston> #startmeeting fwaas
14:00:06 <openstack> Meeting started Tue Nov 22 14:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is njohnston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'fwaas'
14:00:22 <chandanc_> hello all
14:00:26 <yushiro> Hi
14:00:27 <njohnston> #chair yushiro SridarK xgerman
14:00:30 <openstack> Warning: Nick not in channel: SridarK
14:00:31 <openstack> Current chairs: SridarK njohnston xgerman yushiro
14:00:34 <njohnston> Hello everyone!
14:00:48 <yushiro> Hello!
14:00:54 <xgerman> Hi, love the new time!
14:01:09 <SarathMekala> hi all O/
14:01:09 <njohnston> The meeting change ahs merged, but for some reason the eavesdrop entries have not updated, so there may be some confusion this week.  I have raised the issue on the infra channel.
14:01:26 <SridarK> Hi All
14:01:38 <reedip_> hi?
14:01:38 <njohnston> N.B. the neutron team meeting is occurring in #openstack-meeting right now in case you're good at multitasking :-)
14:02:04 <SridarK> njohnston: sigh - oh yes so every other week - this will happen
14:02:09 <reedip_> Ok, I have joined the right session :)
14:02:15 <SridarK> reedip_: hi
14:02:22 <njohnston> reedip_: Yep!  Glad to have you!
14:02:33 <njohnston> SridarK: Indeed, but I am sure we can withstand it. :-)
14:02:43 <SridarK> njohnston: surely
14:02:56 <njohnston> So lets get started
14:03:11 <njohnston> #topic gate breakage
14:03:30 <njohnston> urgent topic - we broke gates for some other subprojects
14:03:56 <njohnston> #link https://review.openstack.org/400717
14:04:14 <njohnston> It was the change to the devstack plugin to allow for the tempest tests for fwaas v2 to work
14:04:32 <njohnston> it changed NETWORK_API_EXTENSIONS unconditionally, which is not good.
14:05:00 <SridarK> njohnston: sigh
14:05:08 <xgerman> :-(
14:05:27 <SridarK> njohnston: sorry just woke up and catching up on stuff
14:05:31 <njohnston> I pushed through yamamoto's revert, and he was good enough to start work on doing it the correct way, in progect-config: https://review.openstack.org/#/c/400745/
14:05:38 <reedip_> njohnston : saw yamamoto's patches for this .. didnt know it was something because of fwaas
14:05:41 <njohnston> NP SridarK, I know it is early for you :-)
14:05:53 <SridarK> so indeed we have to go to project-config
14:06:18 <SridarK> let me approve the revert
14:06:27 <njohnston> it looks like Yamamoto is setting it up so that the gate jobs consume a gate hook script
14:06:33 <njohnston> which is in the fwaas repo
14:06:47 <njohnston> and then we can populate the gate hook script with the changes to NETWORK_API_EXTENSIONS
14:06:59 <reedip_> #link https://review.openstack.org/#/c/400743/
14:07:17 <reedip_> Yamamot's gate-hook patch ^^^
14:07:20 <njohnston> Thanks reedip_, I was just searching for that link :-)
14:07:30 <reedip_> np njohnston :)
14:08:02 <njohnston> so that is the urgent news from this morning
14:08:33 <njohnston> #topic stadium
14:08:56 <njohnston> So I don't think we have the final determination yet
14:09:01 <njohnston> vpnaas, l2gw and onos have been retired
14:09:33 <njohnston> but the assessment has not merged yet
14:09:41 <njohnston> #link https://review.openstack.org/#/c/389397/ neutron stadium assessment
14:10:37 <njohnston> I believe that tempest is effectively done - as soon as we can get Yamamoto's patches merged it will be good
14:11:03 <SridarK> njohnston: yes at least for the api bit and Sarath is working the scenario
14:11:19 <yushiro> sounds good
14:11:30 <xgerman> +1
14:11:52 <njohnston> grenade testing appears to be working
14:11:59 <njohnston> So that leaves the OSC work as the main outstanding issue I believe
14:12:05 <njohnston> yushiro: can you update us on that?
14:12:36 <yushiro> njohnston: I'm fixing now from reedip_'s comment.
14:12:44 <yushiro> reedip_, thanks for your review.
14:12:48 <SridarK> yushiro: good
14:13:00 <yushiro> I'll put tomorrow.
14:13:00 <reedip_> yushiro : np , glad to help if I can :)
14:13:25 <SridarK> so lets review the action items
14:13:29 <reedip_> and I will be watching it yushiro :)
14:13:47 <SridarK> D2 (API ref)
14:14:08 <SridarK> v2 is pretty much done, v1 had some comments that were being addressed
14:14:26 <SridarK> seems like there is not much more that needs to be done on this
14:14:36 <njohnston> #link https://review.openstack.org/#/c/391338/ fwaas v2 api ref
14:14:41 <njohnston> looks like it needs a pep8 fix
14:14:48 <xgerman> Nice!
14:14:53 <yushiro> yes.
14:15:06 <SridarK> and it can merge only post assessment
14:15:11 <njohnston> work has stopped on it because armax said that it should wait for the api spec to merge
14:15:26 <njohnston> and yes the api spec would only merge at the conclusion of the assessment
14:15:31 <SridarK> so i believe we are good on this
14:15:35 <njohnston> +1
14:15:35 <SridarK> D4 (misc doc)
14:15:44 <yushiro> ++1
14:15:44 <SridarK> i believe this done
14:15:50 <njohnston> agreed
14:15:59 <reedip_> gr8 :)
14:16:22 <SridarK> there could be some minor things and we can continue to make things better
14:16:24 <SridarK> C4 (Fullstack)
14:16:41 <njohnston> this is considered not on the critical list
14:16:49 <njohnston> we will need to wait for the OSC change to be merged
14:16:54 <njohnston> and then released and g-r bumped
14:16:57 <SridarK> njohnston: i believe we need the CLI patch to merge and there is some basic things u already have a PS out
14:17:18 <SridarK> ok so nothing outstanding here
14:17:30 <njohnston> #link https://review.openstack.org/#/c/394619/ fullstack patch - super-WIP
14:17:49 <SridarK> ok we can continue this
14:17:52 <SridarK> C5 (Tempest)
14:18:21 <SridarK> we already discussed this, once yamamoto's patch is in we can renable the tempest v2 api tests
14:18:38 <SridarK> and the scenario tests are in progress
14:19:05 <SridarK> i will add more api tests as well but at least have basic CRUD coverage on all fwaas resources
14:19:14 <njohnston> +1
14:19:27 <SridarK> C6 (Upgrade)
14:19:35 <SridarK> i believe this is done
14:19:47 <njohnston> grenade tests are merged, smoke test designation has merged
14:19:50 <njohnston> so this is working
14:20:09 <SridarK> ok
14:20:11 <SridarK> C7 (Multinode CI)
14:20:17 <SridarK> this still has some failures
14:20:48 <SridarK> and we need to debug this, if i am not mistaken
14:20:52 <chandanc_> SridarK, do you have the details of the failure, i can take a look
14:21:19 <SridarK> chandanc_: if u look at any PS - u can see the failure
14:21:25 <njohnston> chandanc_: example: https://review.openstack.org/#/c/391320/
14:21:34 <njohnston> both multinode jobs fail there
14:21:59 <chandanc_> sure let me look at it
14:22:29 <SridarK> L1 (OSC) we already discussed
14:22:31 <njohnston> thanks!
14:23:00 <yushiro> :)
14:23:10 <njohnston> I think we are looking very good
14:23:15 <SridarK> njohnston: +1
14:23:20 <yushiro> +1, njohnston
14:23:24 <mfranc213> i finally managed to get here.  sorry.  am reading back through.
14:23:34 <yushiro> good team work
14:23:45 <SridarK> i think we have met the criteria that all addressable things should have Patches in flight
14:23:46 <reedip_> +1
14:23:49 <njohnston> +1 yushiro - good work by a great team!
14:24:08 <SridarK> oh yes definitely great team work
14:24:10 <SarathMekala> +1 great news SridarK
14:24:28 <mfranc213> i will take care of the pep8 on the api-ref.
14:24:34 <SridarK> mfranc213: thx
14:24:39 <yushiro> mfranc213, thanks
14:25:19 <SridarK> anything else on the assessment ?
14:25:44 <njohnston> #topic FWaaS v2
14:25:47 <SridarK> may be we can spend some time in the open slot
14:25:56 <SridarK> to close out some of the pending stuff
14:26:07 <njohnston> SridarK: sounds good
14:26:36 <njohnston> So I wanted to take a look at where we are with FWaaS v2
14:26:49 <njohnston> now that the stadium excitement seems to be calming down
14:27:10 <njohnston> #link https://review.openstack.org/348177 iptables enhancement for multiple chain coexistence
14:27:26 <njohnston> chandanc_: I saw some activity on this recently, how are things going in your opinion?
14:27:27 <SridarK> njohnston: i am still at the edge of my seat, until the final verdict :-)
14:27:52 <SridarK> chandanc_: i think u have traction with Kevin that is great
14:27:54 <chandanc_> I am working on re-factoring the code  as suggested by Kevin
14:28:14 <chandanc_> ya i got some good feedback on the direction
14:28:24 <chandanc_> i will push an update soon
14:28:41 <njohnston> excellent, I am glad kevinbenton is engaged
14:28:59 <SridarK> i think with this the neutron dependency will be covered
14:28:59 <xgerman> +1 he is great
14:29:04 <chandanc_> ya it is helpful to get his view
14:29:12 <SridarK> and irrespective of FWaaS this is a good thing to have
14:29:29 <njohnston> next up is the fwaas v2 L2 work
14:29:45 <njohnston> #link https://review.openstack.org/323971 L2 extension
14:29:57 <njohnston> yushiro: Where do we stand on that?
14:30:00 <SridarK> on the L2 Agent work, padkrish & i had some discussions
14:30:55 <SridarK> we were in discussion for some of the db related changes
14:31:18 <SridarK> padkrish may not have seen the email abt the time, but he had some question on the PS
14:31:42 <njohnston> SridarK: Are you taking about this PS?
14:31:47 <njohnston> #link https://review.openstack.org/361071 L2 driver
14:31:58 <SridarK> no 323971
14:32:05 <njohnston> ah ok
14:32:42 <njohnston> perhaps we could circle back in email?
14:32:55 <chandanc_> I have not progressed much on this, will depend on the iptables co-existence patch
14:33:02 <SridarK> njohnston: yes for sure - i think u had reverted some changes
14:33:12 <SridarK> and he was wondering why
14:33:27 <njohnston> Hmm, probably because I was being an idiot
14:33:32 <SridarK> yes we can circle back on email or on openstack-fwaas
14:33:44 <SridarK> njohnston: pls no
14:34:22 <SridarK> njohnston: i think u can look at gerrit and u will the context
14:34:30 <SridarK> anyways there is some work needed here
14:34:33 <njohnston> I will do that
14:34:41 <SridarK> padkrish also got pulled into something else
14:34:53 <SridarK> and i told him that i need to get the tempest stuff working first
14:35:03 <SridarK> but now i think we can get this jumpstarted again
14:35:15 <njohnston> +1
14:35:17 <SridarK> i think we had broad agreement on being tenant wide default
14:35:22 <njohnston> yes
14:35:25 <SridarK> so i think what we need to do is clear
14:35:53 <SridarK> and the other piece needed is the L2 driver
14:36:24 <SridarK> chandanc_: , SarathMekala: i think u guys will get on that next
14:36:32 <njohnston> yes, the L2 driver has a few cobwebs on it at this point
14:36:42 <njohnston> it'll be good to get that moving again :-)
14:36:47 <SridarK> +1
14:37:02 <SarathMekala> yes SridarK, njohnston
14:37:06 <chandanc_> yes, the current state of this patch assumes SG is disabled, but this will change with the iptables patch
14:37:14 <SridarK> chandanc_: +1
14:37:29 <xgerman> +1 peaceful coexistence
14:37:35 <SridarK> definitely the neutron change is critical, this should be fairly easy
14:37:36 <chandanc_> :) yes
14:37:38 <SridarK> xgerman: :-)
14:37:54 <SarathMekala> :)
14:38:15 <SridarK> SarathMekala: would u be able to look at Horizon after the v2 scenario
14:38:36 <SarathMekala> Sure SridarK
14:38:51 <njohnston> I have to admit, OVO and the other things we had talked about for FWaaS v2 I am not even worried about because of the shortness of Ocata
14:38:52 <xgerman> often people start own projects for dashboards e.g. fwaas-horzon
14:39:11 <xgerman> so FWaaS and Horizon people can be core
14:39:22 <SridarK> xgerman: oh ok - did not know that
14:39:33 <SridarK> i think it will be useful to have dashboard support
14:39:46 <xgerman> +1 at least set up the project
14:39:58 <SridarK> not the highest priority but defn good to have
14:40:05 <reedip_> but I guess a simple plugin would work than creating a separate project ( but its just IMHO )
14:40:17 <njohnston> #link https://blueprints.launchpad.net/horizon/+spec/fwaas-horizon original fwaas horizon work
14:40:23 <njohnston> I thought that might be helpful
14:40:28 <SridarK> reedip_: good point
14:40:35 <SarathMekala> thanks njohnston
14:40:40 <reedip_> https://review.openstack.org/400717merged !
14:40:47 <xgerman> yeah, just sharing what LBaaS and DNSaaS did
14:41:10 <SridarK> ok so we are in agreement on this
14:41:22 <SridarK> 2 other things that should be a priority
14:41:49 <SridarK> 1) continue more testing and keep adding them to the repo - this is stating the obvious and we all agree
14:42:10 <SridarK> 2) I am checking on some data plane and scale testing options
14:43:04 <SridarK> being a security feature, it will be good to validate if there are some corner case issues, for ex if a policy was changing do we have a window of vulnerability
14:43:15 <SridarK> i will try to define some scenarios
14:43:27 <chandanc_> SridarK, +1
14:43:32 <njohnston> for scale testing I will be interested to see if we can get some Rally tests going.  Not sure if we need OSC to merge before we can do that.
14:43:33 <SridarK> some of these could go in to the scenario tests
14:43:52 * njohnston looks forward to seeing fwaas metrics in browbeat
14:44:20 <SridarK> njohnston: yes on Rally as well as the dataplane - i have some folks in my org that work on these
14:44:39 <SridarK> i will get some inputs
14:44:43 <njohnston> excellent
14:45:02 <SridarK> ideally if we can focus on stability for Ocata - we will be in a good place for features next
14:45:10 <xgerman> +1
14:46:01 <njohnston> +1
14:46:13 <SridarK> #action SridarK to start an etherpad to put in some additional test requirements
14:46:38 <yushiro> I'll hurry up to be merged OSC patch ASAP!!
14:46:48 <njohnston> +1 yushiro :-)
14:46:52 <SridarK> cool
14:47:00 <reedip_> yushiro , wait , I will follow you :P
14:47:16 <SridarK> if nothing else shall we move to open discussion ?
14:47:16 <yushiro> reedip_, wow, it'll be perfect :)
14:47:25 <yushiro> SridarK, yes
14:47:28 <xgerman> :-)
14:47:38 <njohnston> #topic Open Discussion
14:48:09 <yushiro> Last week, I sent e-mail to all about API response code for fwaas v2 for API reference
14:48:23 <yushiro> However, I sent it only for SridarK.
14:48:50 <yushiro> It was my mistake, hence, I'll send e-mail to all again.
14:48:52 <SridarK> hmm
14:49:04 <SridarK> oh on the 403 issues ?
14:49:09 <mfranc213> yushiro: i don't believe i received it.  i look forward to reading it.
14:49:18 <yushiro> SridarK, Yes. 403 issues.
14:49:19 <SridarK> yes mfranc213 and i also discussed this on the phone
14:49:31 <mfranc213> SridarK: ah, yes.
14:49:52 <mfranc213> yushiro: i will read your email and change the PS accordingly.  we weren't sure how to proceed.
14:49:53 <SridarK> yushiro: yes we will need to discuss this - we were not very clear on this either -
14:50:03 <SridarK> yushiro: yes lets do an email discusion
14:50:12 <njohnston> I was wondering if anyone had a sense for who out there is using FWaaS at this point?  I am sure there are some operators running it, but I was wondering if we had a sense for who and how many?
14:50:58 <SridarK> njohnston: this seems difficult to sense
14:51:09 <xgerman> we would need to do a survey...
14:51:15 <njohnston> I agree, I was just wondering if we had any anecdotal data
14:51:39 <yushiro> mfranc213, SridarK Thanks.
14:51:50 <SridarK> every now and then some users come up with questions or bugs
14:51:52 <mfranc213> :)
14:52:12 <xgerman> yeah, you will sense by the traffic in the IRC channel and ML
14:52:58 <SridarK> xgerman: when it came to deprecation of v1 - we sensed that there were some decent number of folks who were using it
14:52:59 <xgerman> also we will see on the FWaaS Lab talk in Sydney ;-)
14:53:10 <SridarK> xgerman: +1
14:53:27 <SridarK> some questions on the tempest issue
14:53:28 <xgerman> usually V1 people complain when you deprecate
14:53:29 <njohnston> FWaaS Lab talk?  You proposing a talk xgerman?
14:53:34 <xgerman> yep
14:53:39 <yushiro> (According to 403 issues, my point is to keep on discussing/sharing information.  I think it may be better to reflect after mfranc213 's patch will be merged.)
14:53:39 <njohnston> excellent!
14:53:52 <mfranc213> +1
14:53:57 <SridarK> so with tempest breakage, now we wait on project-config changes to merge ?
14:54:07 <SridarK> and then verify
14:54:12 <njohnston> yes
14:54:33 <SridarK> once that verification is done, shall i remove the skip for v2 ?
14:54:55 <SridarK> after seeing what Jenkins says for v1
14:55:11 <yamamoto> yes
14:55:20 <SridarK> yamamoto: ok thx
14:55:33 <SridarK> i will check today and hopefully can get that in
14:55:35 <njohnston> Thanks yamamoto for your fixes to our process, apologies for any impediment we caused for the gates of others
14:56:07 <yamamoto> np.
14:56:11 <yamamoto> tomorrow is holiday in japan so i'm likely unresponsive.
14:56:25 <SridarK> yamamoto: would it be possible to hook in to some form of midonet CI with fwaas
14:56:28 <SridarK> long term
14:56:55 <SridarK> i just woke up so am not fully on top of the issues so i am be totally off mark here
14:56:59 <njohnston> 3 minutes left - any last minute topics to discuss?
14:57:11 <yamamoto> SridarK: i'm not sure what you mean by hook
14:57:12 <mfranc213> thursday is a holiday in the U.S. by the way... and many people in this country don't work friday either this week
14:57:26 <xgerman> thanks was about to say the same
14:57:27 <SridarK> chandanc_: can u start an email thread on the multinode CI issues pls
14:57:40 <chandanc_> Sure SridarK will do that
14:57:48 <SridarK> yamamoto: some mechanism for us to make sure we have not broken midonet
14:58:01 <SridarK> esp when we make some infra type changes
14:58:02 <yamamoto> SridarK: midonet 3rd party ci for relevant projects has been on our todo
14:58:46 <SridarK> yamamoto: ok - i think with some changes we broke it once earlier as well
14:59:13 <SridarK> yamamoto: anyways more long term discussion - we can pick it up later as we only have a min
14:59:34 <yamamoto> SridarK: sure
14:59:43 <SridarK> yamamoto: thx
14:59:55 <njohnston> thanks all for attending at the new time!
15:00:00 <njohnston> #endmeeting