14:02:21 <SridarK> #startmeeting fwaas
14:02:21 <openstack> Meeting started Tue Dec 20 14:02:21 2016 UTC and is due to finish in 60 minutes.  The chair is SridarK. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:26 <openstack> The meeting name has been set to 'fwaas'
14:02:49 <SridarK> today maybe light attendance with folks on PTO
14:03:23 <SarathMekala> yeah looks to be the case
14:03:33 <SridarK> lets get started and we can wrap quickly
14:04:02 <SridarK> #topic Stadium Compliance
14:04:04 <yushiro> Hi there! I'm so sorry for late.
14:04:21 <yushiro> I just came back to my home now :)
14:04:37 <xgerman> o/
14:04:46 <SridarK> #chair yushiro xgerman njohnston
14:04:48 <openstack> Current chairs: SridarK njohnston xgerman yushiro
14:04:56 <yushiro> Thanks, SridarK
14:05:00 <SridarK> hi yushiro xgerman
14:05:50 <SarathMekala> Konnichiwa yushiro :)
14:06:06 <yushiro> SarathMekala, perfect :)
14:06:06 <SridarK> We the API ref and the API definition migration to neutron-lib patches almost ready to get in
14:06:13 <SridarK> :-)
14:06:23 <SarathMekala> learnt a few words during the tokyo summit
14:07:03 <SridarK> folks do take a look and if there any nits lets sort them out - i think they are pretty much ready to go in
14:07:25 <xgerman> nice
14:07:40 <SridarK> #link https://review.openstack.org/391338
14:07:51 <SridarK> #link https://review.openstack.org/389388
14:08:40 <SarathMekala> i can spend some time on these.. will take a look
14:08:44 <SridarK> SarathMekala: thanks for the tempest scenario test
14:09:16 <SridarK> SarathMekala: now we can take a look at adding more scenarios
14:09:33 <SridarK> it is good that we have the basic stuff in
14:09:46 <SridarK> it gets easier to add more incrementally
14:09:58 <yushiro> xgerman and I executed 'recheck' into API reference patch from margaret , I found that pep8 error exists.
14:10:13 <SarathMekala> yeah SridarK.. will add more to the tests
14:10:33 <SarathMekala> infact I tried one more scenario.. but was getting unexpected results.. need to debug
14:10:35 <yushiro> I'll take a look.
14:10:41 <xgerman> yushiro I will check it out and see if I can come up with a fix
14:10:53 <yushiro> xgerman, many thanks :)
14:10:54 <SridarK> SarathMekala: xgerman: Cool thx
14:11:15 <xgerman> #action xgerman fix pep8 error in mfrancis code
14:11:49 <SridarK> SarathMekala: yes we should add a few deny scenarios as well
14:11:58 <yushiro> #action I'll help xgerman if he needs help
14:12:08 <xgerman> thx
14:12:32 <SarathMekala> SridarK, one quick question on pep8.. do you use autopep8 tool for this purpose?
14:12:52 <SarathMekala> I had a similar issue but this tool does not seem to fix the code properly
14:12:57 <SridarK> SarathMekala: i usually do tox -epep8
14:13:03 <xgerman> +1
14:13:19 <xgerman> and have a look at -epy27 and -epy35
14:13:29 <xgerman> (hope we have those)
14:13:35 <SridarK> xgerman: yes
14:13:40 <SridarK> for the UT
14:13:57 <SarathMekala> oh.. thanks.. will try it out
14:14:25 <SridarK> yushiro: on the OSC patch - i have to look at ur latest revision
14:14:33 <yushiro> SridarK, Thanks.
14:14:48 <yushiro> SridarK, I've already sent e-mail to any core-reviewer to review my patch.
14:14:50 <SridarK> but we are pretty much good on this
14:14:54 <SridarK> #link https://review.openstack.org/351582
14:15:02 <SridarK> others can take a look also
14:15:32 <yushiro> Yes, reviewing is necessary to OSC patch in order to do tempest test or something.
14:16:00 <SridarK> We can skip over fullstack
14:16:24 <yushiro> You can practice as follows.  1. checkout my patch,  2. sudo python setup.py install  3. execute 'openstack' command on your devstack...
14:16:59 <yushiro> SridarK, OK.  I see.
14:17:07 <SridarK> yushiro: ok thx
14:17:27 <SridarK> any thing else any one would like to discuss on Stadium compliance
14:18:05 <SridarK> #topic FWaaS v2
14:18:35 <SridarK> chandanc_: lets start with the neutron iptables enhancement
14:18:50 <SridarK> #link https://review.openstack.org/348177
14:18:59 <SridarK> chandanc_: pls go ahead
14:19:13 <chandanc_> SridarK, I have pushed a new patch, this should close more UT issues, but stiill some UTs are failing
14:19:22 <SridarK> chandanc_: ok
14:19:26 <chandanc_> I think i am ready for the code review
14:19:36 <mfranc213> thank you SarathMekala regarding 391338
14:19:46 <mfranc213> (sorry late)
14:19:51 <SridarK> mfranc213: hi
14:19:59 <chandanc_> otheres acan start having a look at the code
14:20:05 <SridarK> chandanc_: +1
14:20:22 <xgerman> k
14:20:23 <SridarK> chandanc_: and see if u can get closure on any remaining UT issues
14:20:41 <chandanc_> yes i am working on that
14:21:07 <yushiro> chandanc_, good start!
14:21:15 <SridarK> next week most likely most folks will be off - but we can have it in good shape to get some traction this week and try to close out early Jan
14:21:16 <SridarK> chandanc_: thx
14:21:28 <chandanc_> Thanks, please have a look at the code and let me know
14:21:34 <SridarK> +1
14:21:58 <SridarK> we can skip over the L2 driver with the dependency to the change above
14:22:07 <chandanc_> yes
14:22:56 <SridarK> On the L2 Agent changes, been in discussion with padkrish - we are debugging an issue with the db query on the plugin when a new port is added
14:23:32 <SridarK> we are trying to get some closure this week
14:23:39 <SridarK> so this piece can be ready
14:23:51 <SridarK> yushiro: will sync with u also on this
14:23:55 <yushiro> SridarK, quick question.  are you going to use l2 agnet exntesion framework like handle_port()
14:24:09 <SridarK> yushiro: yes no change in that
14:24:49 <yushiro> SridarK, OK.  I can work until 28th, so I really need some task for other members :)  review or update or ...
14:25:06 <SridarK> yushiro: ok sounds good
14:25:18 <SridarK> we will try to see if we can sync end of the week
14:25:36 <yushiro> chandanc_, mfranc213 SarathMekala  If you'd like to ask me something, please let me know !!
14:25:42 <SridarK> and next week most of us are out so we can restart in Jan
14:25:49 <yushiro> about your patch or something.
14:25:50 <mfranc213> yushiro: thank you!
14:25:59 <xgerman> SridarK +1
14:26:58 <SridarK> The other thing on fwaas v2, SarathMekala pls start looking thru some workflows for Horizon
14:27:28 <SarathMekala> yes SridarK.. I am brushing up on my horizon skills
14:27:46 <SridarK> we can try to push for that in Jan before we end O cycle
14:27:47 <SarathMekala> should have something ready by January
14:27:52 <SridarK> perfect
14:28:15 <SridarK> anything else do discuss on v2 ?
14:28:55 <SridarK> we can hopefully end O with basic L2 done, some Horizon support and more testing
14:29:43 <SridarK> #topic performance improvement for v1
14:29:52 <SridarK> tuhv: pls go ahead
14:29:55 <tuhv> Hi,
14:30:09 <tuhv> Actually, there is no change in this patch this week
14:30:23 <tuhv> I am waiting others for reviews
14:30:46 <xgerman> tuhv you have some sugestions how we can test it?
14:30:47 <tuhv> A good news is, privsep is considered to be adopted in Neutron
14:30:49 <SridarK> tuhv: and i have done a quick pass on review - don't see any issues, need to do a  closer look
14:31:13 <tuhv> About test,
14:31:26 <hoangcx> Thanks chandanc_ for reviewing the solution in deeply
14:31:34 <xgerman> yep, code looks sane but would like to take it for a spin before +2
14:31:45 <tuhv> I create 10.000 conntrack entries specified by destination_port
14:31:45 <chandanc_> hoangcx, you are welcome :)
14:32:13 <tuhv> then deleting it, with old code, and my patch
14:32:28 <yushiro> tuhv, I'll take a look even if I can review not so deeply comment.
14:32:40 <tuhv> The performance comparasion is in goo.gl link in my commit message
14:32:58 <xgerman> yeah, I saw that… will try to install it on some devstack and ick the tires
14:33:22 <tuhv> Thank you, xgerman
14:33:36 <hoangcx> xgerman, really appreciate
14:34:31 <tuhv> Actually, I should upload my scripts to test this. I will update tomorrow
14:34:32 <SridarK> tuhv: if u have some scripts for any of the setup - pls share a pointer on a etherpad link - if it can make it easier to replicate the test
14:34:44 <SridarK> tuhv: :-) u read my mind
14:34:57 <SridarK> tuhv: that will be perfect
14:34:59 <tuhv> Sridark, that's my fault
14:35:07 <yushiro> tuhv, hoangcx sounds good.
14:35:09 <SridarK> tuhv: no issues at all
14:35:19 <tuhv> Sridark, thank you
14:35:57 <SridarK> #topic Open Discussion
14:36:31 <xgerman> https://review.openstack.org/#/c/412257/ the commit message confused but ti looks legit
14:36:31 <SridarK> One thing we will need to keep an eye on is some of the multinode CI failures
14:36:42 <xgerman> +1
14:36:48 <SridarK> seems like a race condition
14:36:59 <SridarK> njohnston: was looking into it
14:37:58 <SridarK> we can keep an eye and triage further
14:38:12 <xgerman> yeah, debugging those is tricky
14:38:19 <SridarK> xgerman: sigh yes
14:38:22 <yushiro> folks,  please send me or share e-mail to some tasks or review.
14:38:37 <SridarK> thankfully they are still non-voting
14:38:42 <xgerman> sigh
14:39:17 <SridarK> yushiro: +1
14:39:19 <yushiro> I'd like to help fwaas work as long as possible I can in this year(2016).
14:39:44 <SridarK> yushiro: and i hope it will continue in to 2017 also :-)
14:40:00 <yushiro> SridarK, Hahaha.  Of course I can :)
14:40:41 <SridarK> I had nothing else, also pls send an email if anything needs looking into as we hit the Holiday season
14:40:51 <hoangcx> Small thing: I have just updated meeting time on the etherpad with latest status
14:41:00 <xgerman> you can also ping me on the channel if you need a review
14:41:02 <hoangcx> https://etherpad.openstack.org/p/fwaas-meeting
14:41:13 <yushiro> hoangcx, xgerman thanks.
14:41:32 <SridarK> hoangcx: thx
14:41:37 <SridarK> xgerman: thx
14:41:57 <SridarK> I was thinking we can cancel the meeting for next 2 weeks
14:42:04 <xgerman> +2
14:42:04 <yushiro> Again, please share e-mail about your task or TODO before your holidays :) (X'mas and New year's day)
14:42:09 <xgerman> most teams are doing that
14:42:26 <SridarK> sounds good
14:42:27 <hoangcx> +1
14:42:32 <yushiro> xgerman, SridarK Yes, 2 weeks will be canceled.
14:42:53 <SridarK> but folks yes lets email each other if we need some traction on reviews or ping on IRC
14:43:03 <yushiro> Yeah.
14:43:11 <SridarK> i will be sure to check email periodically
14:43:21 <SarathMekala> sure SridarK, yushiro
14:43:34 <xgerman> we can always try to set up a trello to manage our project more visual ;-)
14:43:47 <SridarK> Wishing all of u a very Happy Holiday Season and best wishes for the new year
14:43:56 <xgerman> +1
14:44:00 <SarathMekala> +1
14:44:04 <yushiro> You too, SridarK and all :)
14:44:07 <SridarK> for fwaas this was a good year to come this far
14:44:08 <hoangcx> +1
14:44:11 <chandanc_> Best wishes for New Year to all
14:44:14 <SridarK> and thanks to all of u
14:44:14 <mfranc213> +1
14:44:25 <mfranc213> thank you everyone.
14:44:33 <yushiro> Thanks!!!
14:44:44 <tuhv> Thank you, best wishes,
14:44:49 <SridarK> ok lets close out then for 2016
14:44:58 <yushiro> I really appreciate for all members.
14:45:16 <SridarK> yushiro: +1
14:45:19 <SridarK> #endmeeting