14:00:56 <xgerman_> #startmeeting fwaas
14:00:57 <openstack> Meeting started Tue Aug 15 14:00:56 2017 UTC and is due to finish in 60 minutes. The chair is xgerman_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:58 <reedip_> so whose chairing?
14:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:59 <reedip_> k
14:01:00 <openstack> The meeting name has been set to 'fwaas'
14:01:15 <xgerman_> #chair SridarK yushiro
14:01:16 <openstack> Warning: Nick not in channel: yushiro
14:01:17 <openstack> Current chairs: SridarK xgerman_ yushiro
14:01:20 <SridarK> xgerman_: u are running today ?
14:01:28 <xgerman_> sure, I can run
14:01:42 <SridarK> sorry i have been out on PTO and just got back late last night - so bit out of context
14:01:52 <xgerman_> #topic Announcements
14:01:58 <SridarK> thx xgerman_
14:02:03 <xgerman_> FWaaS has been released for Pike
14:02:20 <xgerman_> I saw the branch’s being created, etc.
14:02:40 <xgerman_> Thx to Armando
14:02:54 <reedip_> yeah ... :)
14:03:30 <SridarK> yes indeed
14:03:47 <xgerman_> PTG in DEnver
14:03:51 <xgerman_> #link https://etherpad.openstack.org/p/neutron-queens-ptg
14:03:57 <reedip_> not coming....
14:04:00 <SridarK> so on this topic - do we need to do anything for release - i thought it just happens as part of neutron
14:04:16 <reedip_> plz share the etherpad link and the webcast if there would be a VTG :)
14:04:18 <xgerman_> no, everyhting happens automatic
14:04:20 <SridarK> just to be sure in case something is needed from us as a team
14:04:25 <SridarK> xgerman_: ok perfect
14:04:56 <SridarK> i will be able to make the PTG
14:04:56 <xgerman_> so for the PTG the etherpad has an FWaaS section which is currently empty - we ought to change that
14:05:09 <SridarK> reedip_: yes for sure we can figure out something
14:05:16 <xgerman_> +1
14:05:32 <reedip_> xgerman_ : which etherpad ?
14:05:43 <xgerman_> #link https://etherpad.openstack.org/p/neutron-queens-ptg
14:06:07 <SridarK> xgerman_: i think our first order of business is to get L2 support in
14:06:24 <xgerman_> yep
14:07:03 <reedip_> Lets put the items in the etherpad, so that we dont miss things... what do you think >
14:07:11 <xgerman_> +1
14:07:22 <xgerman_> That’s why I was bringing it up ;-)
14:07:49 <reedip_> :)
14:07:54 <SridarK> yes started that
14:08:09 <xgerman_> Awesome!
14:08:13 <reedip_> Yeah, me too adding :P
14:08:54 <SridarK> i think we should focus on putting the wraps on L2 support early in the cycle
14:09:04 <xgerman_> are we good on stadium compliance or is that amother thing we should talk about at the PTG?
14:09:09 <SridarK> so that gives us some time on testing
14:09:14 <xgerman_> +1
14:09:31 <reedip_> xgerman_ need to test the Project status
14:09:38 <xgerman_> ok
14:09:40 <SridarK> xgerman_: i think fullstack as reedip_ has added is one part of stadium complicance that is missing
14:10:10 <reedip_> xgerman_ : do we have the project report from Ocata ? Or the last time when we executed the report for stadium compliance?
14:10:51 <SridarK> reedip_: hmm i think this was tracked on Gerrit at some point in a review
14:11:00 <reedip_> doing that
14:11:06 <xgerman_> mmh, not sure — there also is a post moretem each release we need to fill out
14:11:21 <SridarK> but i do recall that we had covered most of the requirements
14:11:44 <reedip_> xgerman_ postmortem is filled by armando iirc
14:11:46 <SridarK> xgerman_: yes this was sort of a post mortem tracking
14:11:55 <SridarK> reedip_: yes exactly
14:12:01 <SridarK> we can track that down
14:12:10 <xgerman_> juts making sure we don’t skip process ;-)
14:12:18 <SridarK> fullstack i know defn was missing
14:13:08 <SridarK> Ok i think we have very few missing pieces in terms of code for L2 Support
14:13:18 <SridarK> possibly we are mostly done
14:13:18 <xgerman_> +1
14:13:21 <xgerman_> yes
14:13:24 <SridarK> we just need to do some testing
14:13:46 <SridarK> i think yushiro is on PTO this week
14:14:06 <SridarK> looks like chandanc is not online either
14:14:20 <SridarK> oh today is a local holiday
14:14:24 <xgerman_> yeah, it’s pretty quiet this week
14:14:46 <reedip_> Its also a holiday in India :)
14:15:04 <xgerman_> :-)
14:15:32 <xgerman_> Lastly, we all specs should be submitted for Queens from now on
14:15:48 <xgerman_> new specs I mean - old ones are carried forward
14:15:57 <reedip_> we have the one from bbzhao
14:16:11 <xgerman_> yep, I think he needs to move that to Queens
14:16:15 <SridarK> reedip_: u had some thoughts on integration with TaaS and SFC - we should pursue those
14:16:22 <xgerman_> +1
14:16:22 <reedip_> I added you guys in the reviewer .. If he is not able to update it, I will update it so that we can get a move on it
14:16:30 <SridarK> reedip_: +1
14:17:02 <reedip_> SridarK: For Common Classifier Framework, we need to go through the latest updates of the neutron-classifier repo
14:17:26 <SridarK> reedip_: ok perfect - we can see if we can connect with folks at the PTG as well
14:17:32 <xgerman_> +1
14:17:37 <reedip_> and identify the various Protocols we would support ( though I think the ones we do support are from the iptables protocols mentioned in the neutron-lib)
14:17:55 <reedip_> xgerman_ , SridarK : Already added to the etherpad for you guys :)
14:18:02 <xgerman_> ;-)
14:19:10 <SridarK> great
14:19:38 <xgerman_> I also think we are close with Horizon
14:19:54 <SridarK> we shoud discuss that
14:20:04 <xgerman_> #topic Horizon
14:21:29 <xgerman_> #link https://review.openstack.org/#/c/475840/
14:21:58 <xgerman_> Looking through the patches It seems our gate is broken?
14:22:11 <SridarK> thx to amotoki for the reviews
14:22:13 <amotoki> as my horizon core hat, I am really afraid it is still not mature....
14:22:24 <SridarK> i think SarathMekala is out today
14:22:41 <SridarK> amotoki: i will message him about ur concerns
14:22:43 <amotoki> I hope fwaas team tests it in your local env
14:22:52 <SridarK> amotoki: yes for sure
14:22:58 <xgerman_> yes
14:23:08 <amotoki> I only do static reviews... for testing v1 support
14:23:17 <SridarK> i just got back from PTO and i will do the testing as well
14:24:40 <amotoki> final release for intermediary release is the week of Aug 21 https://releases.openstack.org/pike/schedule.html
14:25:11 <SridarK> we essentially will have to close things in the next few days
14:25:43 <amotoki> one thing
14:25:46 <amotoki> until then we need to test it against stable/pike horizon, so I proposed https://review.openstack.org/#/c/493444/
14:26:44 <amotoki> I believe it can be merged as-is
14:26:51 <xgerman_> yes
14:27:21 <amotoki> I will check the review later this week again
14:27:41 <SridarK> amotoki: thx done
14:27:52 <amotoki> thanks
14:28:21 <SridarK> ok i will reach out to SarathMekala
14:29:16 <reedip_> jfyi xgerman_ For postmortem could just find this : https://review.openstack.org/#/c/425990/ .
14:29:26 <xgerman_> thx
14:30:02 <amotoki> reedip_: is it related to the current topic?
14:30:15 <xgerman_> last topic
14:30:49 <amotoki> let's move on
14:31:04 <xgerman_> #topic Gate errors
14:31:37 <xgerman_> I see more -1 than usual and recheck doesn’t fix it
14:31:53 <xgerman_> so I am wondering if anybody ahs an idea or we need to investigate
14:32:16 <xgerman_> e.g. https://review.openstack.org/#/c/493666/
14:33:23 <SridarK> xgerman_: sorry i am just catching up on things
14:33:30 <amotoki> have you checked http://grafana.openstack.org/dashboard/db/neutron-fwaas-failure-rates ?
14:34:05 <xgerman_> I +2/+A some obvious stuff and it all failed
14:34:58 <xgerman_> amotoki - thanks, that’s a great resource
14:35:22 * xgerman_ bookmarked
14:35:28 <amotoki> it is one of items in the stadium assessment :)
14:35:45 <amotoki> but I see an error message for functional failure rate :(
14:36:16 <amotoki> some might need to be updated
14:36:35 <xgerman_> yes, that’s my assessment as well
14:36:50 <xgerman_> volunteers?
14:37:30 <amotoki> I can update grafana definitions if nobody wants to do it
14:37:41 <xgerman_> thanks
14:37:53 <reedip_> I can help if required
14:38:08 <xgerman_> @action amotoki, reedip_ Update grafana definitions
14:38:30 <xgerman_> #action amotoki, reedip_ Update grafana definitions
14:38:41 <xgerman_> sorry, too much Slack
14:38:45 <reedip_> :P
14:38:53 <amotoki> FYI: grafana defs are here http://git.openstack.org/cgit/openstack-infra/project-config/tree/grafana
14:38:59 <xgerman_> ok, we also should fix our tests
14:39:24 <amotoki> does anybody see error patterns?
14:39:49 <xgerman_> I think we need to dig
14:40:35 <xgerman_> I will see what I can do today… will report in channel so it can be picked up if I can’t get it working today
14:41:02 <reedip_> amotoki : I would check it out tomorrow morning . If you do find anything, let me know :). I would do the same once I start investigating
14:41:22 <amotoki> reedip_: on grafana or job failure?
14:41:45 <reedip_> grafana, I guess ?
14:42:09 <xgerman_> ok, I will look at the job failures
14:42:20 <amotoki> another info: http://status.openstack.org/openstack-health/#/g/project/openstack~2Fneutron-fwaas
14:42:32 <amotoki> periodic-neutron-fwaas-py35-with-neutron-lib-master always fails
14:43:33 <xgerman_> mmh, my main goal is to get things in a shape we can merge again
14:43:44 <xgerman_> but we also need to look into this job failure
14:44:09 <amotoki> note that the last link is about periodic job, so we usually do not check it
14:44:27 <xgerman_> yes, periodic is one of those out-of-mind
14:44:49 <xgerman_> but we should either fix it or remove the job
14:46:45 <amotoki> perhaps py35 and/or master neutron-lib triggers the failure ...
14:46:56 <xgerman_> yeah
14:47:18 <xgerman_> we need to look into it — hard to tell from the outset
14:47:25 <xgerman_> moving on
14:47:36 <xgerman_> @Open Discussion
14:47:46 <amotoki> #topic?
14:47:48 <xgerman_> #topic Open Discussion
14:47:55 <xgerman_> yes
14:47:56 <TuanVu> Hi guys, thank you for checking
14:47:56 <TuanVu> https://review.openstack.org/#/c/443385
14:47:56 <TuanVu> Hopefully this patch set could be merged soon
14:47:56 <reedip_> too much slack :P
14:48:04 <xgerman_> +
14:48:05 <xgerman_> 1
14:48:57 <xgerman_> TuanVu thanks for the patch
14:49:15 <reedip_> let us know the schedule for FWaaS discussion in PTG, so that people who can virutally join in, can do so :)
14:49:16 <TuanVu> Thank you, xgerman_ :)
14:49:16 <amotoki> TuanVu: is it worth having a release note?
14:49:37 <xgerman_> it fixes a bug so I am on the fence with that
14:49:47 <amotoki> if it is a big problem it is worth having it. if minor, not
14:50:21 <TuanVu> Hi amotoki, hmm ... let me think ...
14:50:23 <xgerman_> in any case we should get better with release notes
14:50:43 <xgerman_> #action cores make sure we have proper renos
14:50:53 <SridarK> +1
14:51:08 <TuanVu> Ok, then I'll add release note
14:51:16 <xgerman_> thx
14:51:22 <TuanVu> :)
14:51:30 <amotoki> fyi, i recently updated neutron relnote how https://docs.openstack.org/releasenotes/neutron/
14:51:42 <hoangcx_> amotoki: I think it is a big problem but not sure it needs release note or not.
14:51:59 <hoangcx_> amotoki: Because it does not affect to API or user visibility
14:51:59 <TuanVu> Thank you, amotoki
14:52:26 <SridarK> reedip_: yes will do that - we can try to figure out a decent time. As it is the PTG is a bit informal - so audio quality can be a challenge
14:52:40 <reedip_> No issues
14:53:12 <SridarK> we can also follow up with virtual session post PTG (and possibly one pre PTG - so we can nail down the priorities)
14:53:16 <amotoki> TuanVu: hoangcx_: if the current behavior is surprising enough and it does not match user expectation, I believe it is worth having a relnote :)
14:53:20 <reedip_> That also works
14:53:26 <xgerman_> SrfidarK +1
14:53:40 <amotoki> nice idea
14:54:04 <SridarK> ok lets plan for that once yushiro is back from PTO
14:54:37 <xgerman_> +1
14:55:02 <hoangcx_> amotoki: Got it. I usually see release note when a change affects to user experience
14:55:45 <TuanVu> Ok, I got it
14:56:07 <TuanVu> Thank you, hoangcx_ and amotoki
14:57:03 <xgerman_> T-3
14:57:19 <xgerman_> anything else?
14:57:29 <reedip_> none from my side
14:57:38 <SridarK> same here
14:57:48 <xgerman_> #endmeeting