14:01:03 <yushiro> #startmeeting fwaas
14:01:04 <openstack> Meeting started Tue Aug 29 14:01:03 2017 UTC and is due to finish in 60 minutes. The chair is yushiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:07 <openstack> The meeting name has been set to 'fwaas'
14:01:07 <xgerman_> o/
14:01:21 <yushiro> #chair SridarK yushiro xgerman_
14:01:22 <openstack> Current chairs: SridarK xgerman_ yushiro
14:01:24 <SridarK> Hi All
14:01:40 <yushiro> SridarK, Hi. Today is ur turn :)
14:01:48 <SridarK> yushiro: yes thx
14:01:54 <SarathMekala> hi all O/
14:01:57 <SridarK> shall we get started
14:02:00 <chandanc> Hello All
14:02:13 <SridarK> #topic Pike
14:02:32 <xgerman_> Pike is released
14:02:37 <SridarK> yes
14:02:44 <xgerman_> we should change the toic to Queens ;-)
14:03:00 <SridarK> i just wanted to say that we came very close to wrapping up L2 and Horizon
14:03:02 <yushiro> aha
14:03:17 <xgerman_> SridarK =+
14:03:27 <SridarK> and we have good momentum but unfortunately we just missed the boat
14:03:31 <SridarK> :-)
14:03:39 <SridarK> or rather :-(
14:03:52 <SridarK> #topic Queens
14:04:24 <SridarK> target for Queens - is to wrap up L2 support and Horizon among other things
14:04:45 <SridarK> other things --> we will prioritize that list in PTG
14:05:14 <HoloIRCUser5> Guys sorry, I am driving so will be checking the messages for now (Reedip)
14:05:34 <yushiro> SridarK, yes
14:05:44 <HoloIRCUser5> Also let us know the possibility of a virtual PTG for those who won't join in(??)
14:05:56 <SridarK> we have captured some thoughts in the etherpad
14:06:12 <SridarK> HoloIRCUser5: (reedip) most definitely lets plan for that
14:06:45 <SridarK> if nothing else we can move to features
14:06:56 <SridarK> that we know about
14:07:09 <SridarK> #topic L2 Support
14:07:31 <SridarK> yushiro: pls go ahead starting with agent changes
14:07:44 <yushiro> SridarK, sure.
14:08:06 <yushiro> #link https://review.openstack.org/#/c/323971/
14:08:50 <yushiro> Now, I'm fixing UT. On the other hand, I need to decide a constraint to become 'ACTIVE' for firewall group.
14:10:41 <SridarK> yushiro: yes this is a bit more tricky
14:10:48 <yushiro> Currently, in L2, fw_group becomes 'ACTIVE' when it has 'ports' and firewall_policy(ingress or egress) and rules.
14:10:53 <yushiro> Please refer https://review.openstack.org/#/c/323971/49/neutron_fwaas/services/firewall/agents/l2/fwaas_v2.py@165
14:11:25 <yushiro> However, in L3, it becomes 'ACTIVE' when firewall group has 'ports'.
14:12:11 <yushiro> I think 'ACTIVE' means some rules are applied and firewall_group is working.
14:12:41 <xgerman_> yep
14:12:41 <SridarK> yushiro: would a simplistic model - like if there is atleast 1 VM port associated it is ACTIVE
14:12:44 <HoloIRCUser5> Active should mean that the firewall is working, so I guess this can just be something mentioned in the release notes
14:12:59 <HoloIRCUser5> And it would be an expected behavior
14:13:07 <SridarK> but if there is no VM port - it is INACTIVE
14:13:14 <SridarK> this is consistent with L3
14:13:23 <SridarK> but not make that much sense with L2
14:13:25 <xgerman_> yes — that makes sense
14:13:36 <yushiro> SridarK, +1 Yeah, it should be aligned with same constraint b/w L2 and L3.
14:13:43 <SridarK> we could start with this
14:13:48 <xgerman_> especially when we think about 3rd party which might have to apply stuff which takes time
14:14:02 <yushiro> xgerman_, SridarK HoloIRCUser5 OK, I'll change the constraint to become 'ACTIVE'.
14:14:02 <SridarK> yes
14:14:19 <SridarK> but i think this will need some revisit
14:14:48 <yushiro> SridarK, +1 yeah, but I agree with your opinion.
14:15:28 <yushiro> That's all for me. chandanc, anythink else for https://review.openstack.org/#/c/447251 ?
14:15:44 <chandanc> nothing as of now
14:16:02 <SridarK> With multiple ports - we may need to revise some thoughts on that - this has been on mind for sometime - will put down some notes and we can discuss during PTG as well
14:16:23 <yushiro> chandanc, I got some comment from neutron guy about ovs firewall driver in neutron has been fixed some bugs.
14:16:43 <chandanc> oh, what bugs are fixed
14:16:47 <yushiro> chandanc, We need to consider how to maintain.
14:17:17 <yushiro> chandanc, Sorry I didn't hear in detail. Let me check more with neutron guy.
14:17:25 <chandanc> ok sure
14:18:19 <yushiro> HoloIRCUser5, BTW, did you execute my latest l2 patch? Was it succeeded in deploying devstack?
14:18:51 <HoloIRCUser5> No, not yet, will check it tomorrow morning once
14:18:56 <yushiro> OK.
14:19:06 <yushiro> SridarK, That's all. Please going on :)
14:19:55 <SridarK> chandanc: from the driver perspective - are there any things that u need to wrap up ?
14:20:40 <SridarK> chandanc: I think u had some UTs to add
14:20:47 <chandanc> SridarK: i have not done any more tests, but curretly all the points raised in the review are already in
14:21:26 <chandanc> I can check the OVS driver on neutron
14:21:51 <SridarK> chandanc: ok good - we do kick off some integration tests once we things in place
14:21:59 <chandanc> sure SridarK
14:22:33 <SridarK> reedip1: now the roads are safer :-)
14:22:52 <reedip1> No, I am waiting for my missus at the dance centre :p
14:22:56 <xgerman_> unless you have a self driving car?
14:23:00 <yushiro> chandanc, I'll help about it and let's decide for maintenance
14:23:17 <chandanc> sure yushiro
14:23:37 <SridarK> reedip1: ah welcome to the next stage in life - which involves a lots of waiting ... ;-)
14:24:04 <SridarK> sorry for the diversion :-)
14:24:15 <yushiro> np :)
14:24:25 <SridarK> reedip1: good u have the devstack things in line too ?
14:24:31 <reedip1> That's why I am here on the IRC
14:24:37 <SridarK> :-)
14:24:40 <xgerman_> :-)
14:25:07 <reedip1> I am still fixed upon the full stack for now . Can't seem to get around it
14:25:23 <SridarK> reedip1: ok
14:27:06 <SridarK> I had some notes somewhere on a basic testplan - i will put that into an etherpad - we can refine that as a team and ensure that we test and document
14:27:30 <SridarK> #action SridarK to kick off an intial test plan for L2 support
14:27:47 <reedip1> Ok sure... Let s also include the migration for v1 to v2
14:28:04 <reedip1> It can serve as the items for queens
14:28:15 <SridarK> and during the PTG we can clarify where neutron is with ovs transition - if there are some things we need to address
14:28:28 <SridarK> reedip1: yes great point - lets get that in as well
14:28:53 <SridarK> ok if nothing more lets move to next topic
14:29:04 <SridarK> #topic Horizon
14:29:13 <xgerman_> +1 but I thinke we should get V2 working before we worry about migration…
14:29:26 <SridarK> xgerman_: +1
14:29:28 <reedip1> xgerman yep
14:29:38 <SridarK> SarathMekala: pls go ahead
14:29:56 <SridarK> i think we are really close with some great help from amotoki
14:30:00 <SarathMekala> I would like to thank all for pitching in during the last round
14:30:06 <xgerman_> +100
14:30:19 <amotoki> ++
14:30:21 <SridarK> yes indeed
14:30:38 <yushiro> No problem :)
14:30:42 <SarathMekala> :)
14:30:48 <amotoki> I am not sure what are the remaiing blocking issues
14:30:52 <SridarK> we are really close except for some minor things that need to be addressed
14:31:00 <amotoki> (except UT failures)
14:31:21 <SarathMekala> there are some review comments from 17-25 patches that need to be looked into and addressed
14:31:34 <SarathMekala> and fix UT
14:31:56 <yushiro> amotoki, I think we cannot create firewall policy with rules ( specified rule is not reflected )
14:31:57 <amotoki> how about the issues reported in the etherpad?
14:31:59 <SarathMekala> yushiro, seems to have added a comment on rules not getting fetched
14:32:17 <yushiro> SarathMekala, yes, I added a comment to https://etherpad.openstack.org/p/fwaas-v2-dashboard
14:32:28 <amotoki> IIRC most or all comments from 17-25 patches have been addressed
14:32:39 <SarathMekala> amotoki, yes.. I will clean it up and make it more trackable
14:32:58 <yushiro> Please refer #fwp-6
14:33:45 <SarathMekala> yushiro, sure
14:33:50 <SridarK> i had some minor issues on PS25 - i will check if there were fixed
14:34:14 <SridarK> I have them on the etherpad - but all major issues were fixed
14:34:31 <yushiro> SarathMekala, any critical issue ?
14:34:46 <yushiro> except creating firewall policy with rule
14:34:50 <SarathMekala> as of now I dont think so
14:34:56 <amotoki> I think we can test and report the dashboard patch. One question is how we can move things forward.
14:35:20 <SarathMekala> yes
14:35:28 <amotoki> SarathMekala: you continue to say 'ignore UT failures'. do you have any blocking thing to address UT failures
14:35:31 <SridarK> SarathMekala: pls look at the etherpad on top for PS25 - to be sure
14:36:10 <SarathMekala> amotoki, I will fix the UT now..
14:36:18 <amotoki> I think it is time to make UT passed for all patch sets.
14:36:25 <amotoki> *every patch set
14:36:58 <SarathMekala> yushiro, do you have any progress on the UT or should I take over?
14:37:07 <SridarK> +1 we can then do more manual tests also
14:37:43 <SarathMekala> right.. I will concentrate of fixing the UTs by Friday
14:37:55 <yushiro> amotoki, +1. SarathMekala I'm fixing UT too. OK, I'll send you my patch file (draft)
14:38:00 <SarathMekala> I will be travelling this weekend and will be back on Tuesday
14:38:23 <SarathMekala> yushiro, sure..
14:38:29 <yushiro> SarathMekala, OK, so could you send me your patch file?
14:38:49 <SarathMekala> you mean on Friday?
14:39:05 <yushiro> SarathMekala, Yes. I think you should enjoy your weekend travel :)
14:39:17 <SarathMekala> :)
14:39:38 <SarathMekala> sure yushiro, I will try to fix them as much as possible.. you can pickup from there
14:40:16 <SridarK> sounds good - i think we will be in good shape by Fri
14:40:33 <yushiro> SarathMekala, OK. If I can fix UT as soon as possible, I'll update PS and tell you.
14:40:40 <SarathMekala> sure yushiro
14:40:42 <SridarK> we can follow up with more manual tests and we have a chance to merge next week
14:41:15 <SarathMekala> SridarK, yes.. I will clean up the etherpad so that we can have a better visibility on the status
14:41:23 <SridarK> many thx SarathMekala and to amotoki and yushiro for jumping in
14:41:33 <yushiro> NP :)
14:41:40 <amotoki> you're welcome
14:41:41 <SarathMekala> I have one more question
14:41:47 <yushiro> So, I'll update test case for manual in https://etherpad.openstack.org/p/fwaas-v2-dashboard
14:42:03 <SarathMekala> amotoki, how do we test installing dashboard via devstack
14:42:24 <SarathMekala> currently I am installing it the "pip install -e ." way
14:43:03 <amotoki> SarathMekala: do you mention the instructions described at the bottom of https://etherpad.openstack.org/p/fwaas-v2-dashboard by 'pip install -e .' way ?
14:43:19 <SarathMekala> yes
14:43:34 <SarathMekala> I am checking out fwaas-dashboard and installing it onto my devstack
14:43:52 <amotoki> for devstack plugin instruction, i update the devstack doc in your review
14:44:00 <amotoki> see devstack/README.rst
14:44:12 <amotoki> didn't you check it?
14:44:21 <SarathMekala> ok.. I did not try it
14:45:05 <SarathMekala> has anyone tested this method?
14:45:16 <amotoki> It mostly does the same thing as 'pip install -e .' way does.
14:45:39 <yushiro> SarathMekala, not yet but will install after finished this meeting.
14:46:01 <SarathMekala> ok
14:46:22 <SarathMekala> To summarize:
14:46:28 <SarathMekala> #action clean up etherpad
14:46:36 <SarathMekala> #action fix UT
14:46:46 <SarathMekala> #action fix rules issue
14:47:02 <SarathMekala> #action address etherpad issues
14:47:04 <SarathMekala> :)
14:47:18 <amotoki> sounds a good list :)
14:47:20 <amotoki> then call for testing again :)
14:47:29 <reedip1> :)
14:47:32 <SarathMekala> :)
14:48:16 <SarathMekala> SridarK, thats it from my side
14:48:16 <amotoki> we are now in queens, so we can merge it once we agree it covers the basic scenarios
14:48:24 <amotoki> and fix other issues in follow-up patches
14:48:34 <SarathMekala> amotoki, +1
14:48:37 <yushiro> amotoki, +++++++1
14:48:45 <SridarK> Sounds good - i think lets target to be done by next week
14:48:52 <yushiro> let's merge ASAP :)
14:49:24 <SarathMekala> SridarK, right
14:49:31 <SridarK> Ok i think we have a plan in place - lets move on
14:49:40 <SridarK> #topic Open Discussion
14:50:02 <SridarK> doude: i saw u join - things u would like to bring up ?
14:50:15 <doude> Hi all
14:50:34 <reedip1> O
14:50:35 <doude> I had not time to make progress during last weeks on my patch
14:50:48 <doude> but I plan to work on it next week
14:50:59 <reedip1> The pluggable back end righ5
14:51:08 <SridarK> doude: no worries - i think we can have more traction for Queens
14:51:10 <doude> yes
14:51:15 <yushiro> doude, OK.
14:51:22 <reedip1> Too much conflicts
14:51:22 <doude> I'll start on a big rebase work :)
14:51:27 <doude> yes
14:51:28 <SridarK> doude: will u be at the PTG ?
14:51:36 <doude> no
14:51:39 <SridarK> ok
14:51:42 <reedip1> I tried to fix it but too much changes :p
14:51:48 <doude> probably at the summit not yet decided
14:51:54 <SridarK> ok
14:52:48 <doude> reedip1: I'll try to do that
14:52:50 <doude> thx
14:52:57 <reedip1> Ok
14:53:13 <doude> I've got a question, probably you already discussed it
14:53:14 <reedip1> I can also pick it up if u want help
14:53:29 <doude> what's the deprecation plan for the v1 API?
14:53:33 <SridarK> reedip1: on the virtual PTG - shall we plan to meet virtually sometime mid next week to set priorities before the PTG
14:53:39 <doude> ok reedip1
14:54:01 <SridarK> doude: i think we are on way and possibly by R
14:54:34 <SridarK> what do others feel abt meeting virtually before
14:54:40 <doude> ok so for the moment keep it as is
14:55:03 <yushiro> yes
14:55:14 <SridarK> I am not sure how good any audio feed during the actual PTG will be to be effective
14:55:23 <SridarK> and the timing may be odd too
14:55:50 <yushiro> ( 5 minutes left )
14:55:59 <xgerman_> yes — maybe we should just do some pre-PTG and then push that at the real one
14:56:33 <SridarK> xgerman_: yes exactly at least we have feedback from the entire team on what things they view as important
14:57:37 <xgerman_> +!
14:58:24 <xgerman_> also Sydney is a pretty slim agenda…
14:58:48 <SridarK> xgerman_: yes
14:59:00 <yushiro> xgerman_, yes, short term.
14:59:20 <xgerman_> I have some budget to cover the flight and meals… so I am on the fence right now…
14:59:38 <SridarK> ok maybe i will ask in an email if folks want to conect before PTG next week. Or we can discuss in next weeks mtg also.
15:00:05 <xgerman_> e-mail might be best… PTG is in two weeks
15:00:05 <SridarK> ok i think time to wrap up
15:00:10 <SridarK> thanks all for joining
15:00:17 <SridarK> #endmeeting fwaas