14:00:44 <SridarK> #startmeeting fwaas
14:00:45 <openstack> Meeting started Thu Mar  8 14:00:44 2018 UTC and is due to finish in 60 minutes.  The chair is SridarK. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:49 <openstack> The meeting name has been set to 'fwaas'
14:00:58 <SridarK> #chair xgerman_ yushiro
14:00:59 <openstack> Current chairs: SridarK xgerman_ yushiro
14:01:08 <xgerman_> o/
14:01:17 <doude> Hi o/
14:01:50 <SridarK> yushiro: xgerman_: whose turn today ?
14:02:06 <xgerman_> I am not keeping track… so no idea…
14:02:11 <SridarK> :-)
14:02:13 <yushiro> I think xgerman_ :)
14:02:21 <xgerman_> ok
14:02:23 <SridarK> ok
14:02:36 <SridarK> maybe primarily PTG debrief
14:02:38 <xgerman_> #topic PTG
14:03:01 <xgerman_> #link https://etherpad.openstack.org/p/fwaas-rocky-planning
14:03:12 <SridarK> xgerman_: yushiro: thanks for the meeting in spite of the all the confusion at PTG due to weather
14:03:27 <annp> Hi
14:03:50 <yushiro> No warries.  Good meeting in snowpenstack :)
14:04:10 <annp> :-)
14:04:19 <xgerman_> yep — also RedHat seemed to be the biggest OoenStack contributor those days
14:04:40 <xgerman_> they had a whole bus to take their people to their exclusive party
14:04:40 <SridarK> yushiro: :-) i think snowpenstack has caught on
14:04:54 <xgerman_> +1
14:04:57 <SridarK> oh wow
14:05:21 <annp> Wow
14:05:25 <yushiro> wow
14:05:32 <yushiro> hi chandanc
14:05:36 <chandanc> Hello yushiro
14:05:49 <SridarK> And was the overall turnout quite good ?
14:05:58 <xgerman_> yeah, they sold out
14:06:20 <SridarK> and at the conference itself ?
14:06:58 <yushiro> annp, chandanc Now topic is "PTG*
14:07:05 <xgerman_> the conference center was pretty widespread but at the hotel it was packed
14:07:10 <xgerman_> #link https://wiki.openstack.org/wiki/PTG/Rocky/Etherpads
14:07:12 <chandanc> thanks yushiro
14:07:26 <annp> Thanks yushiro
14:07:53 <xgerman_> there was a session on upgrades, security etc. — I went to API and k8s
14:08:07 <SridarK> ok we only had 3 of our folks in London attend - and they seemed to also feel it was well attended
14:08:39 <ndefigueiredo> Hi folks
14:09:02 <yushiro> Hi ndefigueiredo
14:09:26 <SridarK> How did the discussions with CCG go - the early part of the mtg the audio was very bad
14:09:32 <annp> Hello ndefigueiredo
14:10:09 <yushiro> SridarK, CCF ?
14:10:25 <SridarK> Common Classifier
14:10:29 <xgerman_> ok
14:10:49 <SridarK> What is the state of the code in ur view ? Have they got to a point where others can consume ?
14:11:09 <xgerman_> I think they said this cycle they like to have it in QoS
14:11:17 <SridarK> ah good
14:11:20 <yushiro> +1
14:11:41 <xgerman_> so we could wait for that and then start or if we have the resources attempt in parallel
14:12:11 <SridarK> ok sounds good - we can be the next adopter
14:12:29 <xgerman_> +1
14:12:44 <annp> +1
14:12:58 <SridarK> Also with ndefigueiredo 's proposal of stateless ACL - it will become more useful
14:13:10 <SridarK> so other features can use the classifier
14:13:10 <xgerman_> +1
14:13:28 <yushiro> yep
14:13:56 <SridarK> ok good i could not get a sense from the mtg as to how we should plan for this cycle
14:14:47 <xgerman_> yeah, I think it will mostly be stabilizing and testing
14:14:56 <yushiro> +1
14:15:00 <SridarK> I think we can initiate a spec a bit later in the cycle and plan an implementation next cycle possibly or start later in this cycle
14:15:03 <annp> ++1
14:17:16 <ndefigueiredo> agreed, ACLs would be a natural consumer of CCF. Just to give a brief update from my side, I arrived to discover a huge backlog of work but I have started the internal discussions and should be able to submit the RFE soon and then follow with a spec..
14:17:33 <xgerman_> that would be good!
14:17:34 <SridarK> ndefigueiredo: ok great
14:17:41 <yushiro> great!!
14:18:03 <SridarK> ndefigueiredo: perhaps u could start a google doc if u dont mind and we can discuss there too
14:18:36 <yushiro> SridarK, ndefigueiredo +1  It's better to sync up more earlier.
14:18:43 <xgerman_> +1
14:19:13 <SridarK> ndefigueiredo: for the reference implementation - we will need to scope out both ovs (l2) and iptables (L3) on the driver side
14:19:35 <SridarK> and i guess mainly the conntrack interactions
14:20:04 <chandanc> SridarK: +1
14:20:41 <xgerman_> +1
14:20:45 <ndefigueiredo> SridarK: yes, I will create a document for discussion this week.
14:20:54 <annp> +1
14:20:57 <SridarK> ndefigueiredo: thx perfect
14:21:00 <yushiro> +1
14:21:01 <xgerman_> +!
14:21:43 <xgerman_> #topic Bug
14:21:58 <SridarK> u can post a link into the etherpad #link https://etherpad.openstack.org/p/fwaas-rocky-planning pointed to above
14:22:22 <xgerman_> #link https://bugs.launchpad.net/neutron/+bug/1753507
14:22:23 <openstack> Launchpad bug 1753507 in neutron "FWaaS V2: Upgrade Pike->Queen causes error" [Critical,Fix released] - Assigned to chandan dutta chowdhury (chandanc)
14:22:41 <xgerman_> Thanks chandanc for jumping on that so quickly
14:22:47 <yushiro> Thanks chandanc
14:22:51 <SridarK> chandanc: thx for the quick analysis
14:22:56 <annp> Tha k
14:23:02 <xgerman_> I saw this mentioned in our channel by jdavis
14:23:10 <chandanc> Sorry guys the lsat update , i made the mistake
14:23:16 <chandanc> have update patch
14:23:16 <SridarK> xgerman_: yes thx for catching that quickly
14:23:20 <xgerman_> but I am not sure how we cab reach him ;)
14:23:51 <SridarK> yes it will be good to verify - so we know for sure
14:23:54 <yushiro> Aha.  it's OK chandanc and thanks.
14:24:10 <chandanc> thanks for help yushiro
14:24:54 <SridarK> it is odd that it happened on upgrade to Queens, so according to our theory then this new traffic should have also started (or the cleanup only happened) after moving to Queens
14:24:54 <xgerman_> +1
14:25:31 <yushiro> Yes.
14:25:52 <yushiro> So, do't we need to backport?
14:25:57 <chandanc> SridarK: initially i thought the unknow protocol might be unusual, but then i saw the multicast traffic is marked as unknown
14:26:07 <yushiro> I mean that for stable/pike.
14:26:12 <SridarK> yushiro: +1 i think we should
14:26:21 <yushiro> SridarK, OK, thanks.
14:26:22 <xgerman_> +1
14:26:27 <annp> +1
14:26:29 <yushiro> So, chandanc
14:26:32 <chandanc> vrrp in routers can produce that
14:26:40 <SridarK> chandanc: hmm yes
14:26:52 <SridarK> so that should be common
14:27:03 <yushiro> chandanc, It's better to revert this patch and re-push(with fixed).
14:27:29 <SridarK> yushiro: +1 i think that may be cleaner
14:27:41 <chandanc> yushiro: i think it is better to add comment on the nedd one if needed
14:28:14 <chandanc> i am worried about the impact already
14:28:35 <SridarK> chandanc: backports may be a bit awkward - i think that is yushiro 's point
14:28:46 <chandanc> oh
14:29:08 <yushiro> SridarK, yes.
14:29:12 <chandanc> if that is going to help backport, i am +1 for it
14:29:27 <yushiro> Taking backport into consideration, it's better to summarize 1 patch.
14:29:30 <xgerman_> yes, much easier to bacjport one patch then two
14:29:36 <chandanc> i will need help with the revert though
14:29:45 <yushiro> chandanc, OK, I'll do it.
14:30:12 <xgerman_> ok
14:30:16 <yushiro> chandanc, Reverting is easy to push on gerrit UI.  You can push 'Revert' button for specified patch :)
14:30:30 <xgerman_> (there is a button on gerrit I remember)
14:30:31 <chandanc> oh
14:30:45 <yushiro> #action yushiro will revert https://review.openstack.org/#/c/550140/
14:30:54 <xgerman_> ok
14:30:56 <chandanc> yushiro: then i should rebse my urrent pathc ?
14:31:18 <SridarK> chandanc: also u can update the bug with some info to avoid any confusion
14:31:32 <chandanc> SridarK: ok
14:31:36 <yushiro> +1
14:31:45 <xgerman_> +1
14:32:04 <xgerman_> #topic FWaaS Dashboard
14:32:21 <xgerman_> I don’t recall if we managed to release for Q
14:33:31 <xgerman_> also
14:33:34 <xgerman_> #link https://review.openstack.org/#/c/522081/
14:33:57 <xgerman_> that was the one we planned to merge for Q — so likely now R-1
14:34:57 <openstackgerrit> Yushiro FURUKAWA proposed openstack/neutron-fwaas master: Revert "Skip unknown protocols while deleting conntrack"  https://review.openstack.org/550851
14:35:16 <xgerman_> ^^ sweet
14:35:19 <yushiro> :)
14:35:58 <yushiro> xgerman_, Yeah, it should R-1 for dashboard.
14:36:04 <chandanc> Thanks yushiro
14:36:11 <yushiro> chandanc, NP
14:36:24 <annp_> thanks yushiro
14:37:42 <xgerman_> any other dashboard things we should discuss?
14:38:34 <yushiro> Today I don't see Sarath...
14:38:59 <chandanc> Sarath is on leave this week
14:39:00 <xgerman_> ok, moving on
14:39:06 <yushiro> chandanc, OK
14:39:13 <xgerman_> so we will catch him next week ;-)
14:39:15 <SridarK> chandanc: perhaps u can update Sarath
14:39:31 <chandanc> SridarK: will do
14:39:39 <xgerman_> thanks
14:39:47 <xgerman_> #topic Service Driver Refactor
14:39:52 <xgerman_> doude: ?
14:40:30 <doude> I refreshed my patch this morning
14:40:35 <doude> on master
14:40:46 <doude> still not have any news from the neutron drivers team
14:41:04 <doude> last 2 weekly meeting was canceled
14:41:11 <SridarK> doude: i think we need to get it on the agenda for next mtg
14:41:15 <doude> there is one tonigh
14:41:26 <doude> I'll try to attend
14:41:31 <doude> mtg?
14:41:48 <xgerman_> feel free to send the bat signal if you need us to jump in ;-)
14:41:56 <SridarK> :-)
14:41:58 <doude> ok :)
14:42:11 <yushiro> yes, doude please refer http://eavesdrop.openstack.org/#Neutron_drivers_Meeting
14:43:33 <doude> yes tonight at 11pm for me
14:43:37 <xgerman_> ouch
14:43:39 <doude> Paris tz
14:43:47 <SridarK> doude: i think 22:00 UTC
14:43:54 <SridarK> but next week is earlier
14:44:02 <doude> yes
14:44:12 <SridarK> so maybe u can bring it up next week
14:44:25 <doude> normally I could attend it tonight
14:44:29 <SridarK> It will be 14:00 UTC
14:44:30 <doude> I'll try
14:44:40 <xgerman_> sounds good
14:44:48 <doude> yes on Friday next week
14:45:23 <SridarK> doude: i have to be out for sometime - but i think i should be back - i will linger there too
14:45:46 <xgerman_> +1
14:46:05 <xgerman_> #topic Open Discussion
14:46:11 <xgerman_> #link http://lists.openstack.org/pipermail/openstack-dev/2017-September/122135.html
14:46:29 <doude> ok thant SridarK
14:47:05 <SridarK> doude: no worries - and if it is late for u we will get it next week
14:47:15 <xgerman_> so they pulled os-testr and stestr has a different syntax — I am hoping neutron is handling that for us…
14:47:21 <doude> ok
14:48:00 <xgerman_> this has been an issue on the LBaaS side for the last few days
14:48:15 <SridarK> xgerman_: ok thx for the update on this
14:49:21 <xgerman_> njohnston: resurrected #link https://review.openstack.org/#/c/394619/
14:49:37 <SridarK> +1
14:50:08 <xgerman_> we need to touch base to see if he is working on it and how we can help
14:50:15 <SridarK> we can get some traction on fullstack
14:50:33 <xgerman_> +!
14:51:25 <xgerman_> #link https://releases.openstack.org/rocky/schedule.html
14:51:38 <xgerman_> R-1 is 4/16
14:52:33 <SridarK> this week - we can all review the etherpad and have some planning - we can discuss next mtg
14:52:40 <xgerman_> +1
14:53:38 <annp_> +1
14:56:17 <xgerman_> if nothing else we can close early ;-)
14:56:28 <yushiro> OK, thanks all!
14:56:33 <xgerman_> +1
14:56:42 <xgerman_> #endmeeting