14:01:18 <yushiro> #startmeeting fwaas
14:01:19 <openstack> Meeting started Thu Aug  9 14:01:18 2018 UTC and is due to finish in 60 minutes.  The chair is yushiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:22 <openstack> The meeting name has been set to 'fwaas'
14:01:36 <yushiro> #chair SridarK xgerman_
14:01:37 <openstack> Current chairs: SridarK xgerman_ yushiro
14:01:56 <yushiro> I'm sorry SridarK xgerman_ .  Who is today's turn? I just forgot :p
14:02:36 <yushiro> my turn ?
14:02:41 <xgerman_> I think with logging yushiro should take the turn. On the other hand I am gone the next two weeks
14:02:51 <SridarK> no worries
14:02:55 <yushiro> xgerman_, Sure. Thanks.
14:02:57 <SridarK> yushiro: pls go ahead
14:03:02 <yushiro> EYS!
14:03:06 <yushiro> s/EYS/YES
14:03:12 <yushiro> OK, let's start
14:03:17 <yushiro> #topi announcements
14:03:24 <yushiro> #topic announcements
14:04:20 <yushiro> Today (9th) is the deadline for release.  Miguel told us about that.
14:04:25 <mlavalle> o/
14:04:37 <annp> hi mlavalle
14:04:45 <yushiro> mlavalle, Hi o/
14:04:51 <njohnston> o/
14:04:59 <SridarK> mlavalle: njohnston: hi
14:05:03 <amotoki> seems time for o/
14:05:12 <SridarK> amotoki: hi
14:05:17 <hoangcx_> Indeed o/
14:05:21 <amotoki> :)
14:05:32 <mlavalle> LOL
14:06:25 <mlavalle> so I see 3 patches in flight
14:06:45 <longkb> hi mlavalle :D
14:06:53 <SridarK> mlavalle: :-) this is a tight race and very near the finish line
14:07:10 <yushiro> mlavalle, Yes. But it just started so..
14:07:30 <SridarK> a prayer to the gate gods
14:07:33 <amotoki> #link https://review.openstack.org/#/q/topic:bug/1720727+(status:open+OR+status:merged)
14:08:06 <mlavalle> so we need the 3 patches in flight here?
14:08:42 <yushiro> mlavalle, You're right.  We need these patches.
14:09:02 <mlavalle> ok, here's what I propose amotoki......
14:09:53 <mlavalle> since it is getting late for you, why don't you push a release patch with what we have already merged and mark it wip
14:10:11 <mlavalle> I will track down these 3 patches in flight during my day time
14:10:31 <mlavalle> and if / when they land, I will amend the patch
14:10:38 <mlavalle> does that work?
14:10:47 <amotoki> okay, I am preparing a release patch. let you know it when i push it
14:10:59 <amotoki> yes, it works fine
14:11:19 <yushiro> +1 mlavalle and amotoki  Thank you so much
14:11:24 <mlavalle> amotoki: note that in  Neutron https://review.openstack.org/#/c/589573 landed
14:11:25 <amotoki> for the neutronclient patch, it is not covered to FFE. it will be a part of early Stein of neutronclient
14:11:44 <amotoki> mlavalle: yeah, I know that.
14:12:10 <yushiro> amotoki, OK, I see about client patch.
14:12:12 <annp> amotoki, mlavalle: thanks a lot.
14:12:24 <mlavalle> SridarK: my other request is that during the day, you stay reachable here, in case unexpected things arise and you and I need to talk
14:12:40 <SridarK> mlavalle: will do
14:13:00 <xgerman_> I am around, too, if you need votes
14:13:03 <yushiro> I will...
14:13:18 <mlavalle> xgerman_: great!
14:13:41 <mlavalle> to make things easier for me, I am using this query: https://review.openstack.org/#/q/status:open+project:openstack/neutron-fwaas+branch:master+topic:bug/1720727
14:13:49 <mlavalle> These are the 3 patches, right?
14:14:03 <yushiro> mlavalle, Correct!
14:14:20 * mlavalle has a small brain that cannot handle lists with more than 3 items ;-)
14:14:54 <SridarK> :-)
14:14:59 <annp> mlavalle :-)
14:15:02 <yushiro> haha :)
14:15:08 <amotoki> it looks simple as we can check whether the number of patches is empty or not :) heh
14:15:23 <SridarK> What is a list ? :-)
14:15:42 <mlavalle> ok, this looks like a plan for the day in the US
14:15:57 <SridarK> hopefully these will merge soon
14:16:45 <mlavalle> yushiro, annp, hoangcx_, longkb, SridarK: thanks for your efforts! hopefully we will wrestle this thing into submission today
14:17:17 <mlavalle> and thanks to amotoki for his patience :-)
14:17:39 <longkb> mlavalle: sure :D
14:17:56 <amotoki> no worries. we are the community for a same goal :)
14:17:56 <annp> mlavalle: thanks. :)
14:18:00 <yushiro> mlavalle, amotoki You too.  Super appreciated at any time anywhere :)
14:18:21 <annp> amotoki, +100
14:18:58 <xgerman_> +1
14:19:28 <SridarK> +1
14:20:44 <yushiro> OK, I hope their flight are safety and a little earlier.
14:21:09 <mlavalle> ok guys, running to pay attention to something else
14:21:23 <SridarK> mlavalle: thx for the support as always
14:21:24 <mlavalle> have a good night / day
14:21:36 <yushiro> Thanks mlavalle
14:22:19 <yushiro> OK, let's continue
14:22:41 <yushiro> #topic Rocky
14:23:08 <yushiro> Almost finished !
14:23:17 <amotoki> yushiro: could you share the link of the meeting agenda etherpad?
14:23:27 <yushiro> amotoki, OK
14:23:34 <yushiro> #link https://etherpad.openstack.org/p/fwaas-meeting
14:23:37 <SridarK> So one request with the lot of changes going in
14:23:39 <amotoki> thanks
14:23:52 <yushiro> SridarK, yes.
14:23:59 <SridarK> to have some sanity testing done with the RC
14:24:19 <SridarK> to make sure our basic functionality works including the datapath
14:24:30 <yushiro> SridarK, +1
14:24:31 <SridarK> just in case there is some regression
14:25:26 <yushiro> #agree it is really important point.
14:26:45 <yushiro> SridarK, Currently, our repository refers a master branch of neutron for zuul job(sphinx-docs, lower-constraints)
14:27:18 <yushiro> After released neutron-rc1,  is it better to revert to use pip package of neutron?
14:27:19 <SridarK> yushiro: yes i know u had to do this with amotoki
14:27:51 <amotoki> It is okay with either.
14:28:03 <yushiro> For testing perspective, I think it's better.
14:28:12 <amotoki> if you use pip package of neutron, you are not affected by a sudden master change in neutorn
14:28:35 <amotoki> if you consume master neutron, you don't need to wait milestone/rc releases
14:28:55 <amotoki> they are pros and cons, so it is up to the team
14:29:10 <yushiro> amotoki, yes.  I'd like to discuss with you, SridarK and xgerman_ about that.
14:29:40 <SridarK> amotoki: are there implications once the release happens ?
14:30:17 <amotoki> SridarK: could you elaborate a bit more? I didn't get you
14:31:01 <SridarK> amotoki: sorry i would think we want to be associated with the pip package on release
14:31:44 <hoangcx_> SridarK: AFAIK, neutron and fwaas released together. So, we don;t need to care about it
14:31:53 <SridarK> hoangcx_: ok got it
14:32:01 <hoangcx_> SridarK: That is the reason amotoki said either way is OK
14:32:08 <amotoki> hoangcx_: correct
14:32:19 <SridarK> ok thx just want to be sure
14:32:45 <amotoki> yeah, that's the point which usually confuses us
14:33:08 <hoangcx_> I vote for the master based :p
14:33:17 <SridarK> no thx for clarifying
14:33:57 <yushiro> What about neutron-lib ?
14:34:13 <amotoki> there is one tricky point when we use neutron master.
14:34:41 <amotoki> tox jobs (like py27/py35 and so on) works as-is in the gate
14:34:49 <yushiro> Yes
14:34:59 <amotoki> but you need to install neutron master manaully after creating tox env
14:35:06 <amotoki> to pass py27/py35 tests
14:35:18 <hoangcx_> yushiro: AFAIK, neutron-lib is considered as library. So we can't do with master
14:35:39 <yushiro> hoangcx_, OK.
14:35:44 <amotoki> hoangcx_: yes, this case is considered as corner case
14:36:30 <amotoki> neutron-lbi exposes an interfaces
14:36:43 <amotoki> in this case, we depends on internal behaviors of neutron which is not exposed as an interface, so we needed to use neutron master.
14:36:56 <reedip|afk> o/
14:37:02 <amotoki> so it sometimes happens
14:37:44 <yushiro> OK, I see.
14:38:39 <hoangcx_> LOL
14:38:54 <longkb> :))
14:38:59 <SridarK> he he :-)
14:38:59 <yushiro> I think he is typing with magic arm :)
14:39:07 <amotoki> he might type with voice :)
14:39:18 <yushiro> haha
14:40:07 <yushiro> OK, so, I think it's better to keep on using master branch of neutron.
14:40:10 <amotoki> returning to the topic, we don't need to care lower bound of neutron pypi
14:40:27 <amotoki> as neutron and fwaas are released together.
14:40:36 <yushiro> Ok
14:41:05 <amotoki> what was the problem in the docs job?
14:41:37 <hoangcx_> amotoki: the docs job encountered tricky issue
14:41:57 <yushiro> amotoki, Even if we referred master neutron, apidoc doesn't refer master but old version of neutron.
14:42:13 <hoangcx_> amotoki: I tried to ask in #openstack-infra for help but no luck
14:42:58 <hoangcx_> http://eavesdrop.openstack.org/irclogs/%23openstack-infra/%23openstack-infra.2018-08-08.log.html#t2018-08-08T01:15:01
14:42:59 <amotoki> ah... docs and releasenotes jobs are different from other jobs
14:43:10 <amotoki> they might not honor required-projects
14:43:22 <amotoki> we need to check openstack-zuul-jobs (and/or zuul-jobs) carefully
14:43:34 <yushiro> maybe it still refers pip package...
14:43:49 <amotoki> yeah, perhaps so
14:44:03 <yushiro> Thanks hoangcx_ for your research :)
14:44:48 <amotoki> so perhaps do we need to drop required-project for the docs job and revert some workaround after RC1 cut?
14:45:41 <hoangcx_> amotoki: yes. That will be my task
14:45:54 <hoangcx_> amotoki: because I proposed it :p
14:45:54 <amotoki> thnx for clarfication
14:46:12 <yushiro> Regarding docs job, we should drop required-project.
14:46:40 <hoangcx_> yushiro: no worries, I will do it
14:46:43 <yushiro> Ah, sorry.  yes, it's OK.
14:46:46 <yushiro> hoangcx_, thanks
14:47:51 <yushiro> Good discussion.  THanks
14:48:32 <yushiro> today, let me skip specs topics and talk about horizon first
14:48:35 <yushiro> #topic Horizon support
14:48:44 <yushiro> amotoki, Thanks for pushing some patches.
14:49:35 <amotoki> I just push maintenance patches :)
14:50:11 <amotoki> neutron-fwaas-dashboard rocky was released yesterday and the stable branch was cut
14:50:23 <yushiro> I'll definitely check them.
14:50:50 <SridarK> We need to add work items for Stein - i think we have a few things that need to be covered
14:51:26 <yushiro> SridarK, +1 horizon is also work item :)
14:51:35 <amotoki> logging support might be a feature gap which should go to horizon repo.
14:52:08 <hoangcx_> Do we have plan to meet in person for next PTG?
14:53:33 <yushiro> Currently, I don't have any plan but want to talk with amotoki and horizon team about that.
14:54:06 <yushiro> oh, 5 minutes left.
14:54:18 <yushiro> #topic Open Discussion
14:54:37 <yushiro> Today, I'd like to talk about fwaas roadmap for Stein.
14:54:44 <yushiro> s/talk/discuss
14:55:11 <amotoki> i have one thing to raise
14:55:58 <yushiro> amotoki, go a head
14:56:03 <amotoki> as of now, neutron server fails to start when we enable both neutron fwaas and vpnaas.
14:56:17 <yushiro> oh
14:56:24 <amotoki> service provider configurations fail to be loaded.
14:56:39 <amotoki> it would be nice if someone can look into the detail.
14:57:12 <yushiro> amotoki, o/  Is there bug-report?
14:57:16 <amotoki> at least neutron log says FIREWALL_V2 cannot be found, but vpnaas devstack might override the service provider.
14:57:20 <amotoki> yushiro: not yet
14:57:47 <amotoki> I just noticed it when preparing horizon for  translation check
14:57:50 <hoangcx_> amotoki: with latest neutron and enable fwaas_v2,vpnaas together?
14:57:55 <SridarK> yushiro: i just added a section to the meeting etherpad for stein topics
14:57:56 <njohnston> implementing fwaas as an agent extension was supposed to avoid that issue
14:58:06 <SridarK> njohnston: +1
14:58:23 <njohnston> I wonder how vpnaas's binding into the neutron agent is implemented
14:58:23 <annp> njohnston, ++
14:58:23 <SridarK> i am not sure if such an effort happend with vpnaas
14:58:26 <yushiro> SridarK, +100
14:58:48 <yushiro> hoangcx_, Do you know about that?
14:58:48 <hoangcx_> njohnston: the same for vpnaas, I am the one who implemented that
14:58:51 <amotoki> hoangcx_: yes, for example local.conf http://paste.openstack.org/show/727445/
14:59:15 <SridarK> hoangcx_: ah ok
14:59:34 <njohnston> hoangcx_: excellent!  good to have the original author. :-)
15:00:17 <hoangcx_> amotoki: I will try with that tomorrow
15:00:24 <amotoki> hoangcx_: thanks
15:00:30 <yushiro> Oh, it's time.
15:00:39 <yushiro> #endmeeting