15:01:29 <n0ano> #startmeeting gantt
15:01:30 <openstack> Meeting started Tue Apr  8 15:01:29 2014 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:34 <openstack> The meeting name has been set to 'gantt'
15:01:44 <bauzas_> o/
15:01:44 <n0ano> anyone here to talk about the scheduler?
15:01:49 <mspreitz> o/
15:01:59 <bauzas_> On my phone with limited access
15:02:03 * johnthetubaguy is lurking
15:02:35 <n0ano> we'll try and make it quick today (as I jinx things)
15:02:45 <n0ano> #topic forklift effort
15:03:02 <n0ano> main item is reviewing the BP proposal
15:03:10 <n0ano> #link https://review.openstack.org/#/c/82133/
15:03:14 <bauzas_> Indeed
15:03:30 <bauzas_> johnthetubaguy helped me
15:03:31 <n0ano> I think this is getting close, so if people could take a look at it that would be great
15:04:28 <n0ano> bauzas_, you've been mainly driving this, do you need anything specific?
15:04:54 <bauzas_> We are trying to identify the scope of the change
15:05:00 <johnthetubaguy> would be good to see if people agree with whats suggested
15:05:17 <bauzas_> +1
15:05:45 <n0ano> OK, we're all in violent agreement, let's see what the review comments come up with
15:06:01 <bauzas_> johnthetubaguy: I have some remarks about your patchset
15:06:09 <bauzas_> Will do in the patch
15:06:17 <johnthetubaguy> cool, what you thinking? generally?
15:07:06 <bauzas_> there are a few details to spend time on, but the most of it is good to me
15:08:05 <bauzas_> T
15:08:18 <doron> T?
15:08:26 <bauzas_> Oops
15:08:39 <n0ano> bauzas_, blame your mobile :-)
15:08:46 <doron> lol
15:08:49 <bauzas_> O:-)
15:09:39 <n0ano> OK, let's move on
15:09:43 <bauzas_> Sure
15:09:50 <n0ano> #topic Atlanta scheduler sessions
15:09:53 * doron wondering about the BP
15:10:05 <bauzas_> will propose a new patchset
15:10:09 <doron> thanks
15:10:13 <n0ano> in addition to the ones we mentioned last week I saw a new one:
15:10:24 <n0ano> #link http://summit.openstack.org/cfp/details/45
15:10:48 <bauzas_> This one was already raised last week :-)
15:10:51 <n0ano> title - Reservation and Scheduling resources in OS
15:10:58 <mspreitz> Yes, we should revisit the API discussion for holistic scheduling
15:11:15 <bauzas_> Yup
15:11:20 <n0ano> bauzas_, my bad, I didn't remember it and wondered if anyone knew anything about it.
15:11:37 <bauzas_> that's originating from the Climate incubation request
15:12:13 <bauzas_> where TC told us to see what bits of Climate can be shared and how
15:12:15 <mspreitz> and it runs into the larger discussion that has been rumbling along
15:12:50 <n0ano> OK, I wanted to be sure everyone knew about all the sessions so we can get critical mass for the discussions
15:12:51 <bauzas_> well, it tends to be discussed for Juno target
15:13:05 <bauzas_> +1
15:13:20 <doron> n0ano: is there a pad with all proposals like we had in HK summit?
15:13:34 <bauzas_> Not yet
15:13:37 <doron> IIRC we also aggregated several BOFs.
15:13:41 <bauzas_> Until they get validated
15:13:54 <doron> right, I guess to early now.
15:13:56 <n0ano> doron, there is a list of proposed sessions at http://summit.openstack.org/
15:14:29 <doron> n0ano: I'm aware of it. I was thinking of scheduler related sessions and bofs
15:14:31 <mspreitz> will we do Nova unconference sessions again?  I liked them
15:14:37 <bauzas_> don't know the eta for validating
15:14:38 <doron> +1
15:15:14 <n0ano> doron, we don't have a separate gantt track per se, just keep an eye on scheduler related topics
15:15:26 <doron> n0ano: will do, thanks,.
15:15:48 <n0ano> mspreitz, I'm sure there will be an unconference, I find that attendance at those can be a little spotty
15:15:59 <bauzas_> n0ano: worth it to put in ethetpad so we keep track ?
15:16:25 <n0ano> bauzas_, way too organized but a good idea, let me put one up
15:16:50 <n0ano> #action n0ano to setup etherpad with scheduler related Atlanta sessions
15:17:17 <n0ano> odd, why didn't #action do anything - oh well, I know what I'm doing
15:17:17 <doron> n0ano: thanks. this will help me focus...
15:17:27 <bauzas_> Do we have a wiki placeholder ?
15:17:37 <doron> maybe bauzas_ propose a new patch set as #action?
15:17:51 <bauzas_> n0ano: It created an action
15:17:56 <n0ano> bauzas_, what do you mean, it's easy to create a wiki page, what did you have in mind
15:17:59 <bauzas_> +1
15:18:24 <bauzas_> We need to keep track of the etherpad utl
15:18:25 <bauzas_> url
15:18:46 <n0ano> given that it's easy to update wiki
15:19:05 <n0ano> scratch that, fat finger
15:19:10 <doron> just fyi guys, in HK we had- https://etherpad.openstack.org/p/IceHouse-Nova-Scheduler-Sessions
15:19:14 <bauzas_> :-)
15:19:37 <doron> (still alive btw)
15:19:46 <n0ano> doron, tnx, I think I'll use that as a tempate for Juno
15:19:59 <doron> n0ano: sure. just checking my memory....
15:20:30 <n0ano> bauzas_, I think we need to create an offical gantt top level wiki page, with links to appropriate stuff, let me think about it.
15:20:52 <bauzas_> Place me an action
15:21:05 <bauzas_> I already did that for Climate
15:21:12 <n0ano> bauzas_, you want to do the wiki?  - NP
15:21:24 <n0ano> #action bauzas_ to create top level gant wiki page
15:21:38 <bauzas_> I I'll take Climate wiki as pattern
15:21:55 * n0ano is a great believer in creative plagiarism
15:22:11 <doron> :)
15:22:29 <n0ano> OK, moving on
15:22:34 <doron> AKA The fine arts of copy-paste...
15:22:34 <n0ano> #topic opens
15:22:54 <n0ano> anyone have anything new for today?
15:23:01 <toan-tran> I have a question on Instace Group API
15:23:16 <n0ano> toan-tran, go for it
15:23:17 <toan-tran> there's a good progress in the blueprint
15:23:26 <toan-tran> https://blueprints.launchpad.net/nova/+spec/instance-group-api-extension
15:23:42 <toan-tran> some parts are delayed to Juno
15:23:47 <bauzas_> Does it need a nova-specs ?
15:24:06 <toan-tran> bauzas_: not mentioned
15:24:13 <toan-tran> in the dashpad
15:24:16 <mspreitz> BTW, I am interested in making a heat resource-type for that.
15:24:23 <bauzas_> Worth asking johnthetubaguy
15:24:33 <toan-tran> I wonder if we have discussion on it at the session
15:24:44 <toan-tran> there will be Nova API 3.0 and Gantt API
15:25:16 <bauzas_> mmm
15:25:30 <toan-tran> it cross my mind when we discussed the anti-affinity in the mailing list
15:25:31 <toan-tran> http://lists.openstack.org/pipermail/openstack-dev/2014-April/032190.html
15:25:34 <n0ano> toan-tran, you can always propose a session, if it doesn't get approved we can think about bringing the issue up somewhere else
15:25:43 <bauzas_> +1
15:26:05 <toan-tran> n0ano: I'm afraid I have to leave on Friday :(
15:26:06 <bauzas_> or discuss it within the Gantt API session
15:26:19 <toan-tran> so I cannot propose any session
15:26:20 <toan-tran> :(
15:26:31 <n0ano> bauzas_, that was my idea for `womewhere else'
15:26:47 <bauzas_> mmm
15:26:49 <toan-tran> I think that would be better to insert it into nova api 3 or gantt
15:27:47 <toan-tran> bauzas_: what do you think, does it fit to gantt?
15:28:08 <n0ano> toan-tran, your call, I'd proposal a session and ask theirry to move it if it gets scheduled for Fri
15:28:34 <n0ano> s/theirry/thierry
15:28:50 <bauzas> Sorry got disconnected
15:28:50 <toan-tran> n0ano: thanks, that'd be great, will do that
15:29:37 <n0ano> bauzas, toan-tran last question was what do you think, does it fit to gantt?
15:30:17 <n0ano> seems appropriate to me
15:30:32 <bauzas> Imho yes
15:30:47 <doron> +1
15:31:02 <bauzas> provided that's a pure placement request
15:31:22 <toan-tran> bauzas: yes it is :) mostly affinity & anti-affinity
15:31:32 <doron> affinity is usually about it...
15:31:52 <mspreitz> wait
15:32:00 <mspreitz> we do more than that in our placement work
15:32:11 <mspreitz> but I'm lost, how did we get onto placement?
15:33:09 <toan-tran> mspreitz: the instance group API provides the interface to create instance group :)
15:33:35 <toan-tran> mspreitz: but then the scene behid it is always group dpeloyment
15:33:43 <mspreitz> I envision evolution there of the breadth and depth of policy that can be associated with a group
15:34:02 <mspreitz> We have some policy types that take parameters
15:34:26 <mspreitz> #link https://wiki.openstack.org/wiki/Heat/PolicyExtension
15:36:10 <bauzas> My concern is about the timeline
15:36:24 <mspreitz> I would not expect everything at once
15:36:37 <mspreitz> I expect, hope for, evolution
15:36:43 <n0ano> well, sounds to me that this will be ripe for a separate session to talk this things over
15:36:47 <bauzas> Gantt Api is not planned to be here by Juno
15:37:12 <bauzas> we need to split out first
15:37:23 <mspreitz> yes.  Split is prior to other work
15:37:24 <n0ano> bauzas, indeed, not as a separate API yet, for Juno it'll just be a copy of the current Nova API
15:37:50 <bauzas> hard work
15:38:05 <n0ano> that's why they pay us the big bucks :-)
15:38:07 <toan-tran> Can anybody  raise debo_dutta ? He should be the right guy to say about it :)
15:38:32 <bauzas> the best would be to port client interface to Pecan
15:38:33 <mspreitz> I have been sending some email, with no response
15:38:46 * mspreitz wonders what Pecan is
15:39:01 * n0ano mspreitz +1
15:39:12 <toan-tran> mspreitz: +1
15:39:28 <bauzas> Not something to eat :-)
15:40:01 <doron> :)
15:40:05 <bauzas> A wsgi controller
15:40:24 <bauzas> For defining Rest interfaces
15:41:30 <n0ano> given we've come up with what, 2 APIs so far, do we really need something like Pecan then?
15:41:54 <bauzas> https://review.openstack.org/#/c/71011/
15:42:14 <doron> ok. Guys I need to drop off. Will look for the meeting notes. cya soon...
15:42:44 <bauzas> Anyway, too early to be discussed
15:42:55 <n0ano> bauzas, NP
15:43:14 <bauzas> but porting the existing Nova Api is much more work than creating a new one
15:43:30 <n0ano> bit of administrivia, I'm out next week (internal company conference), bauzas can you run the meeting?
15:43:54 <bauzas> Sure
15:44:21 <n0ano> #action bauzas to chair meeting on 4/15
15:44:36 <n0ano> OK, unless there are any last minute opens?
15:45:11 <n0ano> then I'll thank everyone, talk to you later
15:45:15 <n0ano> #endmeeting