15:00:17 <bauzas> #startmeeting gantt
15:00:18 <openstack> Meeting started Tue Apr 22 15:00:17 2014 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <openstack> The meeting name has been set to 'gantt'
15:00:26 <bauzas> hi all
15:00:35 <PaulMurray> hi
15:00:36 <tianst> hi
15:00:39 <jay-lau-513> hi
15:00:57 <mspreitz> o/
15:01:07 <bauzas> nice to see people there :)
15:01:27 <bauzas> waiting one more min and then we start
15:01:29 <PaulMurray> finally worked out the time zone
15:01:35 <YorikSar> bauzas: Hi :)
15:01:49 <bauzas> YorikSar: hi ! j
15:02:29 <bauzas> #topic Open action items
15:02:56 <bauzas> #link http://eavesdrop.openstack.org/meetings/gantt/2014/gantt.2014-04-15-15.00.html
15:03:16 <bauzas> quite simple, there were 3 actions from one single person last week :)
15:03:32 <bauzas> luckily, I know him
15:04:03 <bauzas> so, all, you can look at https://wiki.openstack.org/wiki/Gantt
15:04:16 <bauzas> #link https://wiki.openstack.org/wiki/Gantt#Developer_Summit_Sessions
15:04:29 <bauzas> here is the etherpad link for proposals
15:04:44 <bauzas> I went thru all the open subjects
15:04:49 <bauzas> maybe I missed some
15:05:04 <bauzas> so feel free to add/amend the etherpad if so
15:06:01 <bauzas> the best would be that mikal and johnthetubaguy would take note of this page
15:06:04 <jay-lau-513> Not sure if http://summit.openstack.org/cfp/details/262 can be put to gantt?
15:06:28 <bauzas> jay-lau-513: good question
15:06:32 <jay-lau-513> http://summit.openstack.org/cfp/details/262 is for dynamic scheduling
15:06:58 <bauzas> jay-lau-513: I think that some gantt people would love joining the discussion
15:07:11 <bauzas> jay-lau-513: even if it's not purely related to gantt
15:07:35 <jay-lau-513> Great, the dynamic scheduler can work for nova, cinder even neutron etc
15:07:38 <bauzas> jay-lau-513: IMHO, this service should be linked someway to gantt
15:07:41 <mspreitz> 262 is related to 400
15:07:45 <jay-lau-513> but we can first start from nova for this
15:07:54 <mspreitz> I see Gantt as preparing for both
15:08:03 <bauzas> mspreitz: +1
15:08:26 <bauzas> the problem is see here is the chicken-and-egg one
15:08:44 <bauzas> as gantt is currently not yet delivered, it can't be leveraged for this purpose
15:09:01 <bauzas> but possibly it should help
15:09:38 <mspreitz> I do not see a circle of dependency
15:09:46 <mspreitz> 262 and 400 depend on Gantt, not the other way around
15:10:34 <bauzas> well, let's discuss about this topic later in the meeting
15:10:51 <jay-lau-513> mspreitz yes,  262 is for dynamic schdulig and seems 400 is still for  holistic static placement
15:11:08 <bauzas> I also had an action for linking Gantt wiki with Nova one
15:11:19 <bauzas> that's done :
15:11:33 <bauzas> #link https://wiki.openstack.org/wiki/Nova#Active_Sub-teams:
15:12:14 <bauzas> the last action I had, about creating a 2nd blueprint for the sched forklif
15:12:34 <bauzas> #link https://blueprints.launchpad.net/nova/+spec/isolate-scheduler-db
15:12:47 <bauzas> the nova-specs patch has to be sent
15:13:31 <bauzas> let's move quickly to the next topic
15:13:42 <bauzas> so, we'll have time for discussions :)
15:13:55 <bauzas> #topic Status on forklift efforts
15:14:18 <bauzas> #link https://review.openstack.org/#/c/82133/
15:14:42 <bauzas> if people have time for reviewing it, that would be great
15:15:18 <bauzas> I made a dependency on https://review.openstack.org/#/c/86988/4
15:15:43 <bauzas> any comments yet ?
15:16:10 <bauzas> I take it for a no :)
15:16:30 <bauzas> as said, I also began working on another blueprint
15:16:44 <bauzas> https://blueprints.launchpad.net/nova/+spec/isolate-scheduler-db
15:17:11 <bauzas> the idea is to have the scheduler only accessing compute_nodes db table
15:17:28 <YorikSar> bauzas: I guess that should be related to no-db-scheduler
15:17:47 <bauzas> YorikSar: that's a separate blueprint
15:17:51 <bauzas> IMHO
15:18:28 <bauzas> YorikSar: at the moment, scheduler is not only accessing compute_nodes, but also aggregates, services etc.
15:18:40 <YorikSar> bauzas: Sure. I see.
15:18:52 <bauzas> YorikSar: so there is need to modify the calls
15:19:34 <bauzas> YorikSar: for baby-stepping, I was planning to only refactor the changes and isolate all the calls into the next scheduler client lib
15:19:48 <bauzas> YorikSar: but that needs to be debated
15:19:55 <bauzas> both in terms what and how :)
15:20:39 <bauzas> YorikSar: correct me if I'm wrong, but no-db sched is planning to rewrite accesses to compute_nodes table ?
15:20:47 <bauzas> YorikSar: only
15:21:17 <YorikSar> bauzas: Yes. It isolates only nodes/services/hoststates.
15:21:37 <bauzas> YorikSar: I saw your patches
15:21:55 <bauzas> YorikSar: I would love discussing it in the next second topic
15:22:25 <bauzas> YorikSar: because we need to see when you plan to deliver it
15:22:29 <YorikSar> bauzas: Looking forward to it :)
15:23:08 <bauzas> ok, any other comments about the forklift ?
15:23:57 <bauzas> fyi, as the sched-lib blueprint is close to be accepted, I'll publish a first patch for implementing it, next week
15:24:15 <bauzas> ok, next topic
15:24:25 <bauzas> #topic Juno summit design sessions
15:24:31 <bauzas> again, the etherpad
15:24:39 <bauzas> #link https://etherpad.openstack.org/p/Gantt-summit-sessions
15:25:18 <bauzas> so, jay-lau-513, do you prefer I remove mention to 262 ?
15:25:53 <jay-lau-513> bauzas, you mean remove 262 from gantt session?
15:26:05 <bauzas> jay-lau-513: from the etherpad, at least :)
15:26:24 <bauzas> we still have to discuss with mikal to see how many sessions we will have
15:26:35 <bauzas> and if there is need to group some proposals
15:27:00 <jay-lau-513> bauzas, ok, but does gantt will handle dynamic schduling in the future?
15:27:12 <bauzas> maybe russellb is knowing how many sessions we will have for scheduler ?
15:27:53 <bauzas> jay-lau-513: maybe that could be discussed during http://summit.openstack.org/cfp/details/140
15:28:08 <bauzas> jay-lau-513: I mean, Gantt scope should be considered therer
15:28:10 <bauzas> there
15:28:22 <jay-lau-513> bauzas: OK, no problem
15:28:52 <bauzas> jay-lau-513: so, do we keep track of your proposal as gantt related subject ?
15:29:11 <jay-lau-513> I think that we can merge it to 140
15:29:21 <jay-lau-513> bauzas: make sense?
15:29:52 <bauzas> jay-lau-513: when do you plan to implement 262?
15:30:17 <mspreitz> My estimation is that scheduling will get few slots, 142, 2562, 400 will get merged into 140
15:30:17 <jay-lau-513> bauzas: You mean implement code or just spec :-)
15:30:34 <bauzas> jay-lau-513: I mean implementation
15:30:34 <mspreitz> s/2562/262/
15:30:39 <jay-lau-513> mspreitz: Agree
15:31:02 <jay-lau-513> bauzas: In Juno if approved, but not sure in which sprint.
15:31:17 <bauzas> jay-lau-513: that sounds a big baby here :)
15:31:29 <jay-lau-513> bauzas: I also discussed with someone, many of them prefer a new project for this :)
15:31:43 <bauzas> jay-lau-513: who's someone ? :D
15:31:58 <jay-lau-513> bauzas: let me check my email
15:31:58 <bauzas> jay-lau-513: ok, I see
15:32:04 <bauzas> jay-lau-513: no worries
15:32:18 <bauzas> jay-lau-513: I remember the discussion in the ML
15:32:38 <bauzas> jay-lau-513: but as mspreitz said, it could possibly need Gantt
15:32:46 <bauzas> for implementation
15:33:25 <bauzas> jay-lau-513: ok, let's amend the etherpad for merging 140 and 262, and let's discuss it in the etherpad
15:33:28 <jay-lau-513> bauzas: Exactly, gantt is th ebase
15:33:31 <jay-lau-513> the base
15:33:42 <jay-lau-513> bauzas: OJK
15:33:45 <jay-lau-513> ok
15:34:00 <jay-lau-513> bauzas: http://markmail.org/message/5zotly4qktaf34ei
15:34:14 <bauzas> #action bauzas to merge http://summit.openstack.org/cfp/details/262 into http://summit.openstack.org/cfp/details/140 in the etherpad
15:34:54 * bauzas loves to see his name
15:35:12 <bauzas> ok, any other sessions to mention?
15:35:15 <mspreitz> I have been thinking about 99
15:35:25 <mspreitz> that email just cited mixes 99 and 262
15:35:36 <mspreitz> I was willing to accept 99 as a separete, small scope thing
15:35:42 <mspreitz> but that email links to bigger ideas
15:35:54 <bauzas> sounds lik
15:36:03 <mspreitz> I agree that 99 can be seen as part of bigger things
15:36:04 <bauzas> mspreitz: sounds like 99 is the first step for 262
15:36:13 <mspreitz> Exactly, let's do 99 as a baby step first
15:36:43 <bauzas> will also amend the etherpad if so
15:36:44 <jay-lau-513> bauzas mspreitz yes, 99 is the first step for many projects ;)
15:37:53 <bauzas> well, the no-db sched effort would love discussing about 99, I bet :)
15:38:02 <bauzas> maybe I'm wrong, YorikSar ?
15:38:03 <bauzas> :)
15:38:12 <bauzas> http://summit.openstack.org/cfp/details/99
15:38:47 <YorikSar> bauzas: I won't come to summit but someone will definitelly come to discuss further directions in that.
15:38:47 <jay-lau-513> the nova spec for 99 is here https://review.openstack.org/#/c/88983/
15:39:27 <bauzas> YorikSar: well, the idea of persisting hints would impact no-db sched efforts I suppose
15:39:43 <bauzas> so, indeed, that would be worth discussing it at summit time
15:40:24 <bauzas> jay-lau-513: I added myself to the reviewers for the spec
15:40:30 <YorikSar> bauzas: I'm not sure about that. no-db part is about host states, not about resources themselves.
15:40:32 <jay-lau-513> bauzas: yes, I think 99 does deserve a small session though it is straigforward, but it has some interation with other blueprints
15:40:43 <jay-lau-513> bauzas: great :)
15:40:48 <bauzas> jay-lau-513: will try to take time to review it
15:41:03 <bauzas> anyway, that's a good transition for...
15:41:08 <jaypipes> so many Jays... my IRC is just lighting up. :)
15:41:15 <bauzas> #topic no-db scheduler
15:41:36 <bauzas> YorikSar: you're up
15:41:37 <bauzas> :)
15:41:49 <jay-lau-513> jaypipes sorry for the confuse :-)
15:41:54 <bauzas> YorikSar: glad to see you took the blueprint
15:41:55 <YorikSar> I've picked up Alexey's work in Nova.
15:42:16 <YorikSar> Currently it looks like technical part works.
15:42:26 <bauzas> YorikSar: could you please summarize a bit on what you're doing?
15:42:32 <YorikSar> (at least Jenkins is not complaining)
15:42:37 <bauzas> YorikSar: I saw some patches
15:42:37 <mspreitz> jay-lau-513: should that change be linked to bp?
15:43:02 <bauzas> YorikSar: do you need reviewing help ?
15:43:04 <jay-lau-513> mspreitz which change?
15:43:07 <YorikSar> https://review.openstack.org/#/q/topic:bp/no-db-scheduler,n,z - this patch series
15:43:27 <YorikSar> I'd appreciate anyone besides bots to take a look at it.
15:43:51 <bauzas> #link https://review.openstack.org/#/q/topic:bp/no-db-scheduler,n,z
15:43:59 <bauzas> (for minutes)
15:44:02 <YorikSar> I still have 2 -2's because I need to write blueprint to nova-specs and get it approved (again)
15:44:26 <jay-lau-513> YorikSar I will add myself as reviewer
15:44:29 <YorikSar> bauzas: thanks. I forget about those all the time
15:44:31 <bauzas> YorikSar: ok, let us know when you're done with the spec, so we can review it
15:44:53 <bauzas> YorikSar: that's already in my review list
15:45:05 <YorikSar> I asked our Rally team to stress-test that code to see if there're more errors to be fixed.
15:45:22 <bauzas> YorikSar: cool
15:45:39 <YorikSar> jay-lau-513, bauzas: Thanks, I'm looking forward to your -1's (with comments) :)
15:45:55 <bauzas> YorikSar: you know how I love reviewing your code ;)
15:46:18 <YorikSar> bauzas: It's Alexey's code with couple of bugs fixed by me
15:46:43 <YorikSar> bauzas: So you'll have to try to love reviewing his code too ;)
15:46:50 <bauzas> YorikSar: ;)
15:47:14 <YorikSar> I guess we can add an action item for me to publish spec.
15:47:49 <bauzas> #action YorikSar to publish nova-spec for no-db scheduling blueprint
15:47:57 <bauzas> there it is
15:48:03 <YorikSar> bauzas: cool
15:48:11 <bauzas> thanks for your support :)
15:48:41 <bauzas> YorikSar: is that basically ready for reviewing or do you plan further bugfixing ?
15:49:06 <bauzas> YorikSar: as you mentioned, Jenkins is happy but still :)
15:49:31 <YorikSar> bauzas: It's ready. Except for Memcached part that laks both unittests and real-world testing.
15:49:42 <YorikSar> I'll mark that one as WIP
15:50:07 <bauzas> YorikSar: cool thanks
15:50:14 <YorikSar> Oh, I can't :(
15:50:28 <bauzas> YorikSar: ok, no worries, just put a comment then
15:50:33 <YorikSar> I'll -1 it :)
15:50:39 <bauzas> sure thanks
15:50:48 <bauzas> can we move to open discussion ?
15:50:53 <YorikSar> sure
15:50:56 <bauzas> #topic opens
15:51:09 <bauzas> there, 10 mins to go
15:51:17 <bauzas> any subject to raise?
15:51:21 <bauzas> any miss I made ?
15:51:34 <bauzas> any complain to do ?
15:52:01 <YorikSar> How often are we going to have these meetings?
15:52:42 <jay-lau-513> Does the meeing time always UTC 15:00 every Tuesday?
15:52:43 <bauzas> every Tuesday
15:52:49 <bauzas> jay-lau-513: indeed
15:53:15 <jay-lau-513> bauzas: ok
15:53:37 <bauzas> https://wiki.openstack.org/wiki/Meetings/Scheduler
15:53:39 <YorikSar> Great. It's hard to remember when to expect every-other-week meetings. Good to have a weekly one :)
15:54:12 <bauzas> well, I think we'll only have one left before summit
15:54:40 <bauzas> maybe on May 6th, but that's close to summit dates
15:55:25 <bauzas> ok, any other things to discuss ?
15:55:54 <bauzas> PaulMurray: I had no time for reviewing yet (Monday was off in France), but I'll do it for your patches on extended RT
15:56:16 <bauzas> PaulMurray: I saw some new patchsets
15:57:01 <bauzas> PaulMurray: s/extended/extensible/
15:57:49 <bauzas> ok, thanks all for your presence
15:58:08 <bauzas> let's discuss next week
15:58:16 <bauzas> thanks
15:58:18 <bauzas> #endmeeting