15:00:39 <bauzas> #startmeeting gantt
15:00:41 <openstack> Meeting started Tue Sep 16 15:00:39 2014 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <openstack> The meeting name has been set to 'gantt'
15:00:47 <n0ano> o/
15:00:53 <bauzas> n0ano: oops
15:00:58 <bauzas> #chair n0ano
15:00:59 <openstack> Current chairs: bauzas n0ano
15:01:05 <bauzas> \o
15:01:08 <n0ano> NP, you can run it\
15:01:24 <bauzas> n0ano: well, I'm not sure we will have people here
15:01:32 <PaulMurray> hi
15:01:38 <bauzas> awesome
15:01:57 <n0ano> I just didn't think there was much to discuss this week and I don't like meetings for meetings sake but if there's people who want to talk that's fine
15:02:16 <bauzas> n0ano: yeah I know
15:02:22 <PaulMurray> n0ano, did jay do his write-up?
15:02:34 <bauzas> jaypipes is not here yet
15:02:41 <n0ano> haven't seen it yet, I pinged him yesterday and haven't heard back yet
15:02:49 <bauzas> PaulMurray: and I don't think he did had time
15:03:24 <PaulMurray> bauzas, I know the feeling - its been a hard week for me - will lighten up and looking forward to contributing a bit more
15:03:34 <bauzas> PaulMurray: no worries
15:03:52 <n0ano> PaulMurray, theres ~1000 bugs we can all look at :-)
15:03:56 <bauzas> PaulMurray: as Nova is in FF, all the patches are just for working on Kilo
15:04:27 <bauzas> PaulMurray: that said, as the level of changes is really high, these extra weeks are worth it
15:04:34 <bauzas> ok, let's start
15:04:39 <bauzas> #topic Gantt status
15:04:54 <bauzas> so, we all were on previous meeting
15:05:26 <bauzas> if someone lurking here and wants to know what's the plan, let's ping here
15:06:07 <bauzas> ok, assuming everybody is aware that we decided to work on objectify the dicts
15:06:21 <bauzas> and provide claims on Scheduler too
15:06:59 <bauzas> so, most of my week is currently busy on https://review.openstack.org/#/c/119807/
15:07:12 <PaulMurray> bauzas, is any objects work going to get through in FF?
15:07:33 <bauzas> PaulMurray: all the patches will have to be merged by Kilo
15:07:45 <bauzas> PaulMurray: unless it's a critical bug
15:07:59 <bauzas> PaulMurray: I'm not sure we can land any patch by Juno now
15:08:13 <n0ano> +1
15:08:14 <bauzas> PaulMurray: I know you worked on the ComputeNode object
15:08:19 <PaulMurray> bauzas, that's what I thought - just checking
15:08:47 <n0ano> all part of developement will be faster once we split out gantt
15:08:51 <bauzas> PaulMurray: yep, understood. I'm just saying that ComputeNode object is far from being ready for being used
15:09:19 <bauzas> by saying that, I mean that this object is missing some fields and has a nested object too
15:09:44 <PaulMurray> bauzas, you had started a patch on CN - do you want me to take it over
15:09:51 <bauzas> so, as I said, I'm working on removing the nested Service object, and will have to work on adding the missing fields, like the pci_devices fields IIRC
15:10:14 <bauzas> PaulMurray: any help is welcomed, in particular as you worked on the CN object yet
15:10:32 <bauzas> PaulMurray: the above patch ^ is about removing the Service object dependency
15:11:06 <bauzas> PaulMurray: most of the work is already done except unittests modifications, I wanted to see if Tempest was happy or not
15:11:46 <bauzas> PaulMurray: your help will probably be good if you could resume my previous work on the missing fields
15:12:09 <PaulMurray> bauzas, ok , will do
15:12:09 <bauzas> https://review.openstack.org/97837 - Add missing fields to ComputeNode object
15:12:37 <bauzas> ^here I tried to look at what was missing in the CN object
15:12:44 <bauzas> of course, it needs a huge rebase
15:13:19 <bauzas> as you understand both, these tasks are preliminary but mandatory for using the CN object
15:13:53 <PaulMurray> bauzas, I'll do it - I'll split it to a patch for each field
15:14:03 <bauzas> once the CN object being fixed (hoping in early Kilo), we will be able to modify the update_resource_stats() method and pass an Object instead of a stats dict
15:14:11 <bauzas> PaulMurray: +1
15:14:12 <PaulMurray> bauzas, the supported instances is done wrong in ironic and needs special attention
15:14:23 <bauzas> PaulMurray: could you just rebase on my above patch too ?
15:14:35 <bauzas> PaulMurray: because I'm changing the CN object alot
15:14:49 <bauzas> PaulMurray: that Service dependency was pretty strong
15:15:10 <bauzas> PaulMurray: and it was impossible to cut it without modifying all implicated methods
15:15:23 <PaulMurray> bauzas, ok - meaybe we can talk tomorrow morning about how to coordinate that
15:15:29 <bauzas> strong +1 here
15:15:31 <PaulMurray> bauzas, don't want to send n0ano to sleep
15:15:39 <bauzas> :)
15:15:45 <n0ano> huh, what, did you say something :-)
15:15:58 <bauzas> eh, I hope that n0ano is enough caffeinated
15:16:09 <n0ano> working on my second cup, I'm good
15:16:15 <bauzas> awesome
15:16:29 <bauzas> so, that's basically the plan
15:16:44 <bauzas> I'm really worried about the required level of changes needed for having the CN object usable
15:17:01 <bauzas> that means we absolutely need to get these changes by Kilo-1
15:17:19 <bauzas> if we want to work on the next steps
15:17:48 <bauzas> wrt all the talks about the Kilo process, I'm really concerned about the timeframe and the support we'll get for Kilo
15:17:55 <bauzas> in particular if slots are implemented
15:18:29 <n0ano> I'm not a believer in slots, I think that's just a coarse way to slow down progress but we'll see
15:18:48 <bauzas> n0ano: maybe you know my opinion...
15:18:59 <bauzas> n0ano: yeah, I'm -2 on slots
15:19:19 <bauzas> but that's not the place here for discussing that :)
15:19:50 <n0ano> good news is I have people who want to work on gantt so we have some development resources available, we just need well defined, specific tasks for them.
15:19:51 <bauzas> #action PaulMurray and bauzas to coordinate on ComputeNode modifications needed for the split
15:20:24 <bauzas> n0ano: based on my previous experience with Juno, we will perhaps need more involvement than just committers
15:20:39 <bauzas> n0ano: but any help is good to take
15:20:54 <bauzas> n0ano: long story short, we don't need committers, we need reviewers
15:21:15 <n0ano> I think we have a silent majority of people who want gantt so we have more support than you think, core reviewers unfortunately will be an issue
15:21:29 <bauzas> n0ano: that's my thought
15:21:39 <bauzas> n0ano: we don't have a contributors issue
15:22:28 <bauzas> n0ano: and if we have slots in Kilo, we will only have core support for a certain amount of time
15:22:35 <bauzas> anyway
15:22:47 <bauzas> any other things to discuss about the split ?
15:23:06 <bauzas> can I move forward and raise the open topic ?
15:23:32 <bauzas> silent majority, any question to ask ?
15:23:34 <n0ano> go for it
15:23:53 <bauzas> #topic Open discussion
15:23:59 <bauzas> so
15:24:17 <bauzas> just wanted to make sure everybody is aware of what will happen for the Summit ?
15:24:28 <bauzas> ie. the new Summit agenda ?
15:24:44 <bauzas> by Summit, I mean "Design Summit" of course
15:24:48 <PaulMurray> what will happen?
15:24:51 <n0ano> I thought we were still debating that
15:25:12 <bauzas> n0ano: I think the main consensus has been reached, hence my discussion
15:25:24 <n0ano> then what's your take on it
15:26:26 <bauzas> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/045844.html
15:26:29 <bauzas> PaulMurray: ^
15:26:51 <PaulMurray> thanks
15:26:52 <bauzas> n0ano: I want to make sure everybody can review the proposals for Day 2 and 3
15:27:02 <bauzas> so basically let me summarize
15:27:14 <bauzas> Day 1 will be for cross-projects discussion
15:27:21 <bauzas> => Gantt can claim for a call here
15:27:35 <PaulMurray> +1
15:27:41 <n0ano> indeed
15:27:53 <bauzas> Day 2 and Day 3 will be about project important discussions
15:28:18 <bauzas> https://etherpad.openstack.org/p/kilo-nova-summit-topics is the etherpad for tracking these topics
15:28:23 <bauzas> for Nova I mean
15:28:47 <bauzas> so, while we could discuss on Gantt for the day 1, we will only discuss about the sched split in Day 2 and Day 3
15:28:59 <bauzas> ie. what should be the scheduler in the next future
15:29:23 <bauzas> PaulMurray: feel free to review the above etherpad and leave comments if so
15:29:30 <PaulMurray> ok
15:29:38 <n0ano> a little cart before the horse, we really need to work out the split before we get concerned about future uses
15:29:54 <bauzas> PaulMurray: I just put the motto "scheduler split" and I'm happy to see debates about it there
15:30:04 <bauzas> n0ano: agreed
15:30:25 <bauzas> n0ano: that said, I think we need to at least restate our concern
15:30:37 <n0ano> +1
15:30:56 <bauzas> n0ano: I'm still wondering how Cinder or Neutron are scheduling
15:31:01 <n0ano> this also keeps the scheduler issues at the front of everyone's mind
15:31:15 <bauzas> n0ano: any guidance from these folks would be good here
15:31:29 <n0ano> cinder basically re-implemented the nova scheduler, I talked to the Cinder PTL, he is completely on board with gantt
15:31:49 <bauzas> n0ano: here comes Neutron...
15:32:04 <n0ano> (the cinder PTL is lives 30 miles away from me, we had coffee together one morngin)
15:32:14 <bauzas> n0ano: that said, a very quick glance on the Cinder code didn't showed me same classes or the same RT model
15:32:42 * bauzas wishes having Teleportals like in Star-Trek
15:32:46 <n0ano> they did their re-implementation a long time ago, the two schedulers have divered
15:32:55 <bauzas> n0ano: that's my understanding
15:32:56 <n0ano> s/divered/diverged
15:33:10 <bauzas> n0ano: so that's not an easy backport
15:33:24 <n0ano> but their goals are close enough that a single scheduler should work
15:33:26 <bauzas> at least, we need to know their concepts
15:33:40 <bauzas> anyway
15:33:48 <bauzas> back to the Summit discussion
15:33:55 <bauzas> Day 4 is still obscure to me
15:33:56 <n0ano> I believe nova sched is a superset of cinder, converging should be do able, but anyway
15:34:26 <PaulMurray> this sounds like the theme of day 1
15:34:44 <PaulMurray> understanding projects' needs
15:35:01 <bauzas> Day 4 seems to be a non-formal mode of discussions
15:35:22 <bauzas> ie. no time, just a big meetup
15:35:24 <n0ano> day 4 sounds as if it's like minded people get together
15:35:33 <bauzas> yeah, like BoFs or pods
15:35:56 <n0ano> e.g. just the gantt people on day 4, everyone argues things on day 2&3
15:36:14 <bauzas> I was seeing this as a possible use of pods
15:36:19 <bauzas> day 4 is just a big pod
15:36:37 <PaulMurray> looks like day 1-3 = discussion, day 4 = decide actions
15:36:41 <n0ano> seems like we'll be stuffing a `lot` of discussions in days 2&3
15:36:42 <bauzas> ie. people can come in and leave
15:37:00 <bauzas> n0ano: I agree
15:37:06 <bauzas> PaulMurray: I don't think so
15:37:13 <PaulMurray> bauzas, no?
15:37:39 <bauzas> PaulMurray: I'm seeing day 2 and day 3 as the same kind of talks we had from the previous summits (ie. a 60-min topic debated)
15:37:49 <bauzas> PaulMurray: where actions can be taken
15:38:01 <bauzas> PaulMurray: while day 4 is just a pure brainmind
15:38:20 <bauzas> PaulMurray: ie. something for discussing what's coming in on a non-formal mode
15:38:53 <PaulMurray> bauzas, I guess it depends on the topic
15:38:55 <bauzas> so, about what can be related to Gantt, I think it's covered by the etherpad for day 2-3
15:39:10 <bauzas> that said, I can't see any info about day 1
15:39:18 <PaulMurray> bauzas, I was thinking about the api versioning topic last time
15:39:23 <bauzas> so, if we want to talk about Gantt in day 1, we need to make sure we'll be able to
15:41:11 <bauzas> ok, I think I'm done on my side
15:41:22 <bauzas> any other things to discuss ?
15:41:44 <n0ano> I'm good
15:41:59 <bauzas> k
15:42:06 <bauzas> closing the call then
15:42:08 <bauzas> see you all
15:42:14 <PaulMurray> bye
15:42:14 <n0ano> tnx everyone
15:42:19 <bauzas> PaulMurray: feel free to ping me tomorrow
15:42:23 <bauzas> #endmeeting