15:00:14 <n0ano> #startmeeting gantt
15:00:15 <openstack> Meeting started Tue Sep 30 15:00:14 2014 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <openstack> The meeting name has been set to 'gantt'
15:00:27 <n0ano> anyone here to talk about the scheduler?
15:00:44 <PaulMurray> hello
15:01:06 <bauzas> \o
15:01:56 <n0ano> let's get started then...
15:02:02 <n0ano> #topic forklift status
15:02:11 <mspreitz> hi
15:02:22 <n0ano> bauzas, I see you `almost` got your patch in, one final change?
15:03:20 <edleafe> o/
15:03:53 <n0ano> bauzas, you on mute :-)
15:03:56 <bauzas> n0ano: oops
15:04:07 <bauzas> n0ano: sorry, trying to do 15 things once
15:04:29 <bauzas> n0ano: so, yup, my patch is ready to be reviewed
15:04:44 <bauzas> #info https://review.openstack.org/119807 is ready to be revieweds
15:05:15 <bauzas> there are 2 minor nits I need to add, and I'm really concerned about the size of the change
15:05:46 <bauzas> but it would be nice if ppl could just review what's already there, before I'm splitting
15:05:54 <n0ano> what about https://review.openstack.org/#/c/110043/
15:06:25 <bauzas> n0ano: that one was formerly part of isolate-scheduler-db, I decorrelated it
15:06:55 <bauzas> n0ano: because it was not using ERT or anything else, just a quickwin
15:07:18 <n0ano> OK, so 119807 is the critical one, right?
15:07:47 <bauzas> 119807 is required for using correctly the ComputeNode object
15:07:57 <bauzas> so yep, that's a dep
15:08:35 <n0ano> #action all to review https://review.openstack.org/119807
15:08:49 <bauzas> once this patch will get merged, plus the one from PaulMurray, I will make use of ComputeNode for passing info to the sched instead of a json dict
15:09:17 <PaulMurray> bauzas, I just pushed one patch for computenode and will keep going
15:09:24 <n0ano> PaulMurray, do you have the link to your patch, I'd like to get it into the minutes
15:09:30 <bauzas> PaulMurray: oh nice, any link ?
15:09:38 <PaulMurray> https://review.openstack.org/#/c/125091/
15:09:53 <bauzas> PaulMurray: I haven't yet checked my watched changes
15:10:07 <PaulMurray> bauzas, btw - I haven't run tests on it yet cos I can't make tests work right now
15:10:23 <bauzas> PaulMurray: ok, let me know if you need help then
15:10:30 <PaulMurray> bauzas, anyone else have problems with pip?
15:10:47 <bauzas> PaulMurray: what are your problems ?
15:10:56 <bauzas> PaulMurray: pip needs to be 1.4.1
15:11:13 <n0ano> PaulMurray, when I do I just reinstall linux and start from scratch, I've gotten really hung up on pip dependencies in the past
15:11:20 <PaulMurray> bauzas, don't worry, I will sort it, just complaining to anyone who will listen ;)
15:11:33 <bauzas> PaulMurray: gimme a ping on #nova if you need
15:11:45 <PaulMurray> bauzas, ok
15:11:48 <bauzas> PaulMurray: I can help you to sort it out
15:12:05 <bauzas> there are magic combinations to have for our dev env
15:12:14 <n0ano> PaulMurray, BTW, your patch has a workflow x from you, will you be sorting that out soon?
15:13:04 <PaulMurray> n0ano, I did that because I haven't tried it yet, so still going over it
15:13:41 <n0ano> I normally ignore things with x's but I'll look at this one now.
15:13:53 <bauzas> PaulMurray: I can take your patch and run it on my local env
15:14:18 <bauzas> n0ano: the common word for workflow x is -W ;)
15:14:37 <n0ano> bauzas, good to know :-)
15:14:48 <bauzas> n0ano: and +W for asking to be merged
15:15:05 <bauzas> -W or WIP btw.
15:15:21 <PaulMurray> pip --version
15:15:28 <PaulMurray> ha ha - oops
15:16:34 <bauzas> I guess we're done with that topic ?
15:16:59 <n0ano> I was going to say, looks like the current patches are well in progress, no issues there...
15:17:11 <n0ano> #topic kilo opening up
15:17:22 <bauzas> n0ano: I'm not expecting a +W before splitting code :)
15:17:43 <n0ano> So kilo should open, hopefully this week, are we ready to re-submit our BP for splitting out gantt?
15:18:09 <bauzas> n0ano: that would need probably some preliminary work
15:18:19 <bauzas> n0ano: not that much, just one or 2 days
15:18:29 <bauzas> n0ano: because I need to publish the new bps
15:18:49 <n0ano> let me know if I can help, the sooner we get the BP proposed for kilo the better
15:18:59 <bauzas> n0ano: sure thanks
15:19:07 <n0ano> in that vein...
15:19:11 <n0ano> jaypipes, are you there?
15:20:02 <jaypipes> n0ano: yes...
15:20:23 <n0ano> hoping to get your thoughts on resource tracker, will you be able to write that up soon?
15:21:39 <jaypipes> n0ano: I've done a lot of writing in the last 6 days or so. will try to do some more on the RT.
15:22:10 <n0ano> NP, we're looking forward to it.
15:22:56 <n0ano> I think we're good on kilo, we should get our BP posted shortly after it opens
15:23:09 <n0ano> #topic opens
15:23:12 <bauzas> jaypipes: don't overload yourself, we just need to think about how to claim resources using the existing objects
15:23:47 <n0ano> so, anything new for today?
15:23:59 <bauzas> jaypipes: as we already discussed, we just need to identify either the actual objects or some nested ones (like ComputeNodeUsage) having a .claim() method
15:25:14 <bauzas> n0ano: not from me
15:25:37 <mspreitz> not from me
15:25:44 <n0ano> I'm hearing a lot of crickets
15:26:00 <n0ano> in that case I'll thank everyone and we'll talk again next week.
15:26:05 <n0ano> #endmeeting