15:00:20 <n0ano> #startmeeting gantt
15:00:20 <openstack> Meeting started Tue Jan  6 15:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:23 <openstack> The meeting name has been set to 'gantt'
15:00:25 <bauzas> \o
15:00:31 <n0ano> anyone here to talk about the scheduler?
15:00:40 <PaulMurray> \o
15:00:43 <edleafe> o/
15:01:11 <alex_xu> \o
15:01:12 <jaypipes> o/
15:01:22 <alex_xu> welcome back everyone :)
15:01:33 <n0ano> let's begin
15:01:37 <jaypipes> thx, you too alex_xu
15:01:41 <n0ano> #topic status of cleanup work
15:01:49 * bauzas still thinks about his vacations... :(
15:01:55 * alex_xu is not leave
15:02:19 <n0ano> as we left things, we're in pretty good shape, that table at:
15:02:22 <n0ano> https://wiki.openstack.org/wiki/Gantt/kilo
15:02:41 <bauzas> so we'll need 2 exceptions
15:03:11 <n0ano> shows almost all the specs are approved expcet for the resoure object model & DB access for scheduler filters
15:03:21 <n0ano> bauzas, indeed
15:03:33 <bauzas> right
15:03:44 <n0ano> unfortunately, the exception process isn't defined yet, I assume we'll do that at the nova meeting this week
15:03:45 <bauzas> we need to wait formal clarification about the process then
15:03:49 <bauzas> +1
15:04:04 <edleafe> Now that everyone's back, feedback on https://review.openstack.org/#/c/138444/ would help while we iron out the exception process
15:04:18 <n0ano> we'll certain push for our 2 exceptions, I don't think we'll have a problem
15:04:32 <bauzas> edleafe: I'm not forgetting you ;)
15:04:48 <bauzas> edleafe: that said, I have lots of comments to do, starting by the commit msg
15:04:57 <bauzas> :)
15:05:07 <jaypipes> edleafe: I already left my major comment about that...
15:05:46 * bauzas readed too fast "I already lifted my major"...
15:05:48 <edleafe> jaypipes: but I re-wrote it after, remember?
15:05:54 <jaypipes> btw, guys, I have most of the resource-objects coding done. just been waiting on a patch from ndipanov/sahid to land around numa limit topology objects.
15:06:15 <jaypipes> edleafe: ah, sorry ed
15:06:25 <edleafe> jaypipes: I didn
15:06:34 <n0ano> jaypipes, coding before the spec is approved, a little gutsy isn't that?
15:06:41 <edleafe> jaypipes: I didn't ignore your comments. :)
15:07:02 <jaypipes> n0ano: nope. it was essential to show people the PoC code for the blueprint during the spec review process.
15:07:11 <bauzas> n0ano: jaypipes likes to live in a dangerous way :)
15:07:15 <jaypipes> n0ano: also ironed out a few things in the spec while coding.
15:07:40 <n0ano> WFM, I just hope the spec review doesn't require a major rewrite
15:07:51 <bauzas> we all hope this
15:08:28 <PaulMurray> What's WFM - world food markets?
15:08:34 <jaypipes> n0ano: hey, what's one more when there's been like 12 already? ;P
15:08:35 <n0ano> jaypipes, so the spec hasn't been updated since mid-Dec, do you plan an update this week?
15:08:46 <lxsli> PaulMurray: works for me
15:08:50 <n0ano> PaulMurray, WFM = works for me
15:09:07 * PaulMurray is just not down with the kids
15:09:20 * n0ano refuses to act his age
15:09:27 <bauzas> eh
15:09:55 * bauzas gladly assuming his age
15:10:13 <bauzas> provided I'm not shaving my beard...
15:10:17 <n0ano> anyway, jaypipes spec update?
15:10:21 <bauzas> anyway, we're diverting, are we ?
15:11:08 <n0ano> hmm, jaypipes must be away, so instead...
15:11:19 <n0ano> edleafe, need any help on your spec other than reviews?
15:11:44 <PaulMurray> edleafe, I will review later today
15:11:55 <bauzas> edleafe: count me in too
15:12:08 <n0ano> edleafe, I should be able to add a voice
15:12:26 * n0ano is pulled in too many directions
15:12:28 <edleafe> n0ano: No, reviews would be a good start
15:13:14 <n0ano> all - if we can get a handfull of reviews before this Thurs that will probably help the exception request - no pressure here :-)
15:13:48 <bauzas> eh :)
15:14:25 <jaypipes> n0ano: eh, sorry, three discussions going at once.
15:14:54 <n0ano> jaypipes, I figured, just curious about when the resource objest spec will be updated
15:15:35 <jaypipes> n0ano: it needs reviewed, not updated. :)
15:15:55 <jaypipes> n0ano: it was the code that is waiting on sahid.
15:16:33 <n0ano> jaypipes, that's even better, I was afraid it needed to change, reviews we can do
15:17:34 <n0ano> #action all to review https://review.openstack.org/#/c/127609/ & https://review.openstack.org/#/c/138444/
15:18:05 * bauzas wonders if he can +1 himself
15:18:18 <n0ano> not sure my action worked but we all know what I meant
15:18:39 <edleafe> bauzas: sounds naughty
15:18:41 <n0ano> I think that's enough on the specs for now
15:18:46 <n0ano> #topic opens
15:19:02 <n0ano> anything else anyone wants to discuss
15:19:07 <PaulMurray> n0ano, two things
15:19:18 <n0ano> PaulMurray, thing 1?
15:19:22 <PaulMurray> n0ano, first - I am doing the compute node object in RT
15:19:44 <bauzas> PaulMurray: feel free to CC me on your patches
15:19:54 <bauzas> PaulMurray: I may have missed some
15:20:01 <PaulMurray> n0ano, started last day before xmas and picked back up yesterday - may come for ideas as I go
15:20:07 <PaulMurray> bauzas, nothing pushed up yet
15:20:13 <bauzas> oh ok
15:20:13 <PaulMurray> bauzas, nearly
15:20:20 <PaulMurray> n0ano, thing 2
15:20:25 <n0ano> PaulMurray, ping us at will, we'll be glad to help
15:20:54 <PaulMurray> n0ano, is it too early to consider what we want to talk about at the mid-cycle
15:20:55 <PaulMurray> ?
15:21:03 <PaulMurray> and who's going
15:21:11 <bauzas> well, at least do we know who's going ?
15:21:14 <bauzas> oh
15:21:21 <PaulMurray> I am
15:21:21 <bauzas> so, I'm in
15:21:27 <edleafe> I'll be there
15:21:38 <jaypipes> I'll be there as well.
15:21:40 <lxsli> o/
15:21:42 <n0ano> PaulMurray, good question, I think a little early on what to talk about, let's see what happens with our exceptions and then progress
15:21:51 <n0ano> I expect to be there
15:21:53 <bauzas> n0ano: violent agreemen,t
15:22:15 <PaulMurray> n0ano, something to think about as we go though
15:22:23 <n0ano> PaulMurray, +1
15:22:50 <bauzas> agreed
15:22:55 <n0ano> I'll add it to the agenda, we can start talking about subject next week and finalize shortly before the mid-cycle
15:23:11 <bauzas> well, we probably need to wait for the midcycle etherpad
15:23:23 <bauzas> because it's not even discussed at the Nova level
15:23:33 <bauzas> so we need to see which topics will come up
15:23:51 <bauzas> we just need to make sure we can have proper timing for discussing related topics
15:23:56 <bauzas> but I'm not that worried
15:24:18 <n0ano> bauzas, we can think/discuss about scheduler issues before hand, nothing concrete until things like the etherpad are up
15:24:42 <bauzas> honestly, I think we'll reasonably discuss about our progress during midcycle
15:24:55 <bauzas> most of the specs have been approved
15:25:11 <PaulMurray> I think we are pretty clear on what we are doing now, and the mid cycle is really for getting the end of the cycle lined up
15:25:14 <bauzas> but I don't think we'll discuss about the split itself
15:25:24 <bauzas> PaulMurray: +1
15:25:28 <PaulMurray> but I would welcome the chance for side discussions on forward looking things
15:25:32 <n0ano> assuming we are making good progress on implementing the tasks we can start to think about the split in L and beyond
15:26:29 <n0ano> anything else for today?
15:26:39 <bauzas> not from my side
15:26:48 <PaulMurray> I'm done
15:26:53 <edleafe> me too
15:26:54 * bauzas just saw that Ironic midcycle will be 5 min away from home, hurrah
15:27:15 <alex_xu> nothing from me
15:27:35 <n0ano> then, just to re-iterate, review everyone and we'll talk again next week
15:27:45 <n0ano> #endmeeting