15:00:04 <n0ano> #startmeeting gantt
15:00:05 <openstack> Meeting started Tue Feb 24 15:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <openstack> The meeting name has been set to 'gantt'
15:00:17 <n0ano> anyone here to talk about the scheduler?
15:00:42 <edleafe> \o
15:00:57 <lxsli> o/
15:01:15 <n0ano> edleafe, are you a lefty too or are you just being ironic?
15:01:16 <PaulMurray> \o/
15:01:34 <edleafe> I'm ambidextrous, actually
15:01:42 <n0ano> even better
15:01:58 <edleafe> write with right hand, mouse with left
15:02:23 <n0ano> my mother claims I started life as a lefty and then bowed to peer pressure and switched, before I remember things
15:02:51 <eliqiao> lefty is smarter then righty :)
15:03:03 <eliqiao> s/then/than :)
15:03:06 <n0ano> eliqiao, arguable :-)\
15:03:11 <n0ano> anyway, let's get started
15:03:18 <n0ano> #topic Remove direct nova DB/API access by Scheduler Filters
15:03:18 <edleafe> Only left-handed people are in their right minds!
15:03:41 <n0ano> edleafe, I see you're finally getting all +'s on the spec, anything to talk about it?
15:03:42 <edleafe> ok, so bauzas finally added his +1 to the spec
15:03:55 <bauzas> \o
15:03:55 <edleafe> so I ran it by ndipanov and johnthetubaguy
15:03:58 * bauzas waves late
15:04:02 <edleafe> got a +2 from John
15:04:10 <n0ano> edleafe, saw that, good news
15:04:10 <edleafe> nick is still reviewing
15:05:02 <n0ano> I think it should be approved (finally) shortly so, unless you have anything, we can move on
15:05:22 <edleafe> Once that spec is approved, the WIP code can be changed to actual reviewable code
15:05:25 <ndipanov> edleafe, fwiw I don't have +2 on that repo
15:05:39 <edleafe> patch series starting at https://review.openstack.org/#/c/149430
15:05:55 <ndipanov> edleafe, but am unlikely to protest the spec now... as for the code... :D
15:06:02 <n0ano> ndipanov, you're not core for Nova?
15:06:03 <edleafe> ndipanov: I assume you're just being thorough :)
15:06:10 <ndipanov> I am on nova
15:06:12 <ndipanov> not on nova specs
15:06:22 <ndipanov> that is the job of nova-drivers
15:06:26 <bauzas> nova-drivers are only +2'ing specs
15:06:33 <edleafe> ndipanov: ah, I thought you were core for specs, too
15:06:35 <ndipanov> first among equals
15:06:52 <edleafe> guess I'm going to have to bug dansmith
15:07:03 <ndipanov> edleafe, yeah
15:07:05 * n0ano thinks the beaurocracy is getting a little large
15:07:17 <edleafe> n0ano: getting? :)
15:07:19 <bauzas> n0ano: ssssht
15:07:20 <ndipanov> thou I think if he sees +1s from me and jay you'd have to bug him a bit less
15:07:46 <n0ano> if need be we can bring it up at the nova meeting this week, let's hope we don't have to wait until then
15:07:52 <edleafe> ndipanov: but it's fun to bug Dan!
15:07:56 <ndipanov> n0ano, yathink?
15:08:05 <ndipanov> edleafe, that it is
15:08:11 <ndipanov> :)
15:08:18 <n0ano> OK, let's move on
15:08:25 <n0ano> #topic Status on cleanup work
15:08:45 <n0ano> bauzas, I believe your patches are under control, need any help:?
15:09:42 <bauzas> n0ano: bp/detach-services is taking the most of my time
15:09:54 <bauzas> n0ano: but I'm rushing to provide bp/isolate-sched-db
15:10:08 <bauzas> n0ano: bp/detach-service deserves reviews
15:10:22 <bauzas> n0ano: and bp/isolate-sched-db is WIP
15:10:36 <bauzas> (once I'll fix all the demands on bp/detach-service)
15:11:03 <bauzas> n0ano: bp/requestspec-object is planned to be done on Liberty
15:11:10 <n0ano> #action review patches for https://blueprints.launchpad.net/nova/+spec/detach-service-from-computenode
15:11:11 <bauzas> because FF is Mar 3rd
15:11:30 <edleafe> March 5, no?
15:11:38 <alex_xu> bauzas: 5?
15:11:44 <bauzas> edleafe: not exactly
15:12:04 <bauzas> branches are done on Thursdays but code has to be merged on Tuesdays in general
15:12:05 <PaulMurray> johnthetubaguy, said 5th to me
15:12:37 <bauzas> that's a matter of trusting Zuul for merging all patches close to a FF
15:12:40 <johnthetubaguy> https://wiki.openstack.org/wiki/Kilo_Release_Schedule
15:12:50 <johnthetubaguy> says 5th March for Feature Proposal Freeze
15:13:07 <bauzas> I'm usually targeting Tuesdays for deliveries, even if branching is done by Thursdays
15:13:37 <bauzas> anyway, you got the idea
15:13:37 <PaulMurray> bauzas, nothing has to be merged - just uyp for review
15:13:45 <PaulMurray> s/uyp/up
15:13:59 <n0ano> bottom line, early next week
15:14:10 <bauzas> yuy
15:14:33 <bauzas> eh, hold on
15:14:40 <johnthetubaguy> bauzas: there is no branching or tagging for FeatureProposalFreeze, but thats true for FeatureFreeze
15:14:57 <PaulMurray> bauzas, FF is 19th
15:14:59 <bauzas> johnthetubaguy: right, I confounded FPF and FF
15:15:20 <bauzas> so yeah, let's plan to rush on the patches by mid-next week
15:16:04 <lxsli> Time for an update from PaulMurray ?
15:16:14 <n0ano> sure, go for it
15:16:28 <bauzas> btw. I'm taking the opportunity here to ask people to amend https://etherpad.openstack.org/p/kilo-nova-priorities-tracking and set the correct statuses on their ownerships for Launchpad BPs
15:16:34 <ndipanov> hey n0ano - I have one patch I hacked to bring up (sorry not following along fully) is it appropriate now
15:16:41 <ndipanov> after paul that is
15:17:01 <n0ano> ndipanov, sure, no fast rules here, but PaulMurray has the floor for now
15:17:09 <PaulMurray> there are a few patches for review here: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/make-resource-tracker-use-objects,n,z
15:17:44 <PaulMurray> I have one ready for review that starts a (small) series on changing compute node to object
15:18:07 <PaulMurray> lxsli, has some migration object patches that could do with rebase and work
15:18:32 <lxsli> those are in a chain, starting with Jay's numa patch going through sahid's
15:18:51 <PaulMurray> thanks - just havin trouble typing that
15:18:55 <n0ano> PaulMurray, lxsli do you need help with that rebase/work or are reviews sufficient?
15:18:59 <bauzas> lxsli: but jaypipes seems to have problems with his own patch
15:19:13 <lxsli> yes getting hay's patch merged is prio #1
15:19:21 <bauzas> lxsli: so I guess it's impacting your chain, right ?
15:19:45 <lxsli> he mentioned some issue in nova room, sahid said he'd look at that
15:19:54 <bauzas> lxsli: yeah, I understand it but Jenkins seems to be a badass by sending continously red tomatoes
15:20:07 <lxsli> I'm working on rebasing sahid's patch to master atm so he has an easier time rebasing it onto jay's patch when it's ready
15:20:11 <bauzas> lxsli: cool
15:20:26 <lxsli> I have quite some IRC lag atm so apologies for typos
15:20:53 <n0ano> lxsli, NP, the typos are minor so far
15:21:02 <PaulMurray> as https://review.openstack.org/#/c/148904/ is sitting ready it would be good to get it through - it moves a couple of methods around so it tends to get hit by rebases
15:21:41 <PaulMurray> there are two more follow-ons fro that then compute node will be done
15:22:25 <PaulMurray> My aim is to get rid of references to conductor api with everything going through objects so online updates can work
15:22:53 <PaulMurray> Not worry so much about making all the code perfect as it will get changed soon anyway with changes comming to RT
15:22:58 <PaulMurray> and scheduler etc.
15:23:23 <n0ano> PaulMurray, I agree not to worry, we'll just change in future as needed
15:24:10 <PaulMurray> But of course, my code will be perfrect.... :)
15:24:14 <bauzas> PaulMurray: seen some patches from Hans Lindgren ?
15:24:24 <bauzas> PaulMurray: lemme find those
15:24:30 <n0ano> PaulMurray, so, in general, sounds like you're making good progress, anything else?
15:25:05 <PaulMurray> n0ano, actually - been on vacation - so progress will be better than was
15:25:10 <bauzas> PaulMurray: https://review.openstack.org/#/c/149224/
15:25:38 <n0ano> vacation - I've heard of that, I should try one sometime :-)
15:25:48 <bauzas> n0ano: take a French resident passport
15:25:50 <lxsli> bauzas: that is abandoned
15:25:59 <bauzas> lxsli: orly ?
15:26:06 <PaulMurray> bauzas, that's out of date by the look of it - should be abandoned.
15:26:07 <lxsli> are there others which are active?
15:26:07 <bauzas> lxsli: indeed, I missed that point
15:26:27 <PaulMurray> lxsli, oh -your right - is abandoned
15:26:48 <bauzas> lxsli: https://review.openstack.org/#/c/133663/ also
15:26:51 <lxsli> bauzas: because it was covered by one of your patches no less :)
15:27:02 <bauzas> lxsli: right
15:27:25 <bauzas> lxsli: I probably made 15 patches in my series, so I'm sometimes loosing memory
15:27:47 <PaulMurray> bauzas, thanks - I had better keep an eye out for things comming from left field
15:28:02 <n0ano> OK, let's move on a bit...
15:28:03 <bauzas> PaulMurray: I have severe delays in reviewing
15:28:07 <n0ano> ndipanov, you wanted to say something?
15:28:27 <ndipanov> ah yes
15:28:54 <ndipanov> so I was working on the bug
15:29:20 <ndipanov> where we don't consider the right flavor for migrating with NUMA
15:29:31 <ndipanov> https://bugs.launchpad.net/nova/+bug/1370390
15:29:32 <openstack> Launchpad bug 1370390 in OpenStack Compute (nova) "Resize instace will not change the NUMA topology of a running instance to the one from the new flavor" [Medium,In progress] - Assigned to Nikola Đipanov (ndipanov)
15:29:42 <ndipanov> and came up with this https://review.openstack.org/#/c/158245/
15:29:57 <ndipanov> which kinda steps into request_spec teritory
15:30:13 <ndipanov> but is only relevant inside the filter code
15:30:13 <bauzas> ndipanov: right, I quickly reviewed your patch
15:30:35 <ndipanov> I mean I CAN fix the bug without it
15:30:51 <bauzas> ndipanov: anyway, I think that we need to rework on the RequestSpec BP, because there was some good comments on the implementation
15:30:53 <ndipanov> but this would be a nice cheap win for moving all the filters to use flavor objects
15:31:14 <ndipanov> bauzas, this really makes no assumptions about that other than it will be an object at one point
15:31:23 <ndipanov> that will expose this one method
15:31:46 <ndipanov> the reason I need this one method that tells me if the flavor is changing
15:32:37 <ndipanov> is that we can tell when we don't need to recalculate stuff
15:32:51 <ndipanov> like I said - not critical to go this route
15:32:59 <bauzas> ndipanov: right, the problem is that we're dehydrating the Flavor object when sending it to the wire
15:33:16 <bauzas> ndipanov: we should just pass to the Scheduler what we already have
15:33:25 <ndipanov> yeah that's not a problem for me for now but agreed
15:33:28 <ndipanov> it should all be objects
15:33:34 <bauzas> ndipanov: cool that you found a workaround
15:33:47 <ndipanov> so basically
15:34:05 <ndipanov> I'd like a review and ack that this is not insane from sched folks and dansmith if possible
15:34:20 <ndipanov> but not sure if I can put up the whole series this week since I am a bit swamped
15:34:46 <ndipanov> if not - ah well, but I think moving to flavor objects in the scheduler with this is an easy win unless I missed an angle
15:35:01 <n0ano> ndipanov, so you're asking for a review of your patch 158245, right?
15:35:12 <ndipanov> well more like -
15:35:27 <ndipanov> try to see the approach
15:35:35 <ndipanov> and tell me if it;s OK to land it for a bugfix
15:35:43 <ndipanov> and get some refactoring early and cheap
15:36:10 <bauzas> ndipanov: ack, will give you my voice
15:36:21 <ndipanov> next patch in that series moves all use of flavor in filters to objects
15:36:28 <n0ano> at this point I am hesitant about refactoring at this late stage in Kilo, even if it's easy
15:36:29 <ndipanov> but still failing tests so not posted
15:36:38 <ndipanov> n0ano, that is reasonable
15:36:43 * PaulMurray has to drop off now - sorry
15:36:51 <bauzas> ndipanov: +1
15:36:58 <n0ano> PaulMurray, NP, just read the logs
15:37:04 <ndipanov> but we;re still not that late from priorities pov
15:37:07 <ndipanov> so think about it
15:37:26 <n0ano> ndipanov, OK, we'll check it out
15:37:50 <n0ano> moving on...
15:37:55 <n0ano> #topic opens
15:38:01 <n0ano> anything new for today?
15:38:57 <n0ano> hearing crickets...
15:39:02 <bauzas> I got one
15:39:08 <n0ano> bauzas, go ahead
15:39:34 <bauzas> basically, restating what I said in the crowd
15:39:35 <bauzas> (16:16:28) bauzas: btw. I'm taking the opportunity here to ask people to amend https://etherpad.openstack.org/p/kilo-nova-priorities-tracking and set the correct statuses on their ownerships for Launchpad BPs
15:40:24 <bauzas> ie. NeedsCodeReview, Slow Progress or In Progress
15:41:20 <n0ano> bauzas, +1
15:41:44 <n0ano> anything else?
15:42:06 <bauzas> nothing really much
15:42:28 <n0ano> OK, so, as always, lots of reviews needed, everyone sharpen your pens and we'll talk next week.
15:42:33 <n0ano> tnx for attending
15:42:40 <n0ano> #endmeeting