20:01:28 <markwash> #startmeeting Glance
20:01:28 <openstack> Meeting started Thu Apr 25 20:01:28 2013 UTC.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:32 <openstack> The meeting name has been set to 'glance'
20:01:49 <markwash> We've got a lot of blueprints to talk about today!
20:02:14 <markwash> I posted a new standing agenda here https://wiki.openstack.org/wiki/Meetings/Glance
20:02:27 <markwash> but we probably will only get into the new blueprints part
20:02:46 <markwash> I want to leave time for open discussion at the end though, so please yell at me if we go over 50 minutes
20:02:48 <markwash> sigh
20:03:00 <markwash> #topic new blueprints
20:03:32 <markwash> The summit was great, and we had a lot of fruitful discussions
20:03:42 <markwash> thanks, session leaders!
20:04:16 <markwash> I've co-opted the the glance meeting agenda etherpad to try to streamline things today
20:04:29 <markwash> #link https://etherpad.openstack.org/glance-meeting-agenda
20:05:14 <markwash> just curious, do we have ameade nikhil jbresnah present?
20:05:20 <jbresnah> nod
20:05:21 <jbresnah> wave
20:05:38 <ameade> here
20:05:43 <ameade> phew
20:05:51 <markwash> iccha is traveling, correct?
20:05:55 <nikhil> ack
20:06:00 <jbresnah> yeah, i believe she is
20:06:00 <nikhil> yes markwash
20:06:08 <nikhil> actually on vacay
20:06:14 <markwash> :-)
20:06:34 <rosmaita> no one is on vacation from openstack!
20:06:45 <rosmaita> it's like 2 am where she is though
20:06:50 <markwash> :-)
20:06:59 <markwash> openstack will find you wherever you are
20:07:15 <markwash> So looking at the etherpad, anyone have thoughts on moving forward on quotas?
20:07:15 <nikhil> true
20:07:39 <rosmaita> (not me)
20:07:52 <jbresnah> ummm
20:08:02 <jbresnah> is the idea to manage it via keystone?
20:08:12 <markwash> not as far as I am concerned
20:08:26 <nikhil> markwash: is that your top priority?
20:08:54 <jbresnah> is that effort mostly about enforcement then?
20:08:56 <markwash> not really, the list is ordered more by summit session than anything else
20:08:56 <nikhil> i'm a little curious about folks assigned to the existing blueprints as such
20:09:04 <ameade> what was happening with the whole centralized quota thing? how would that even work?
20:09:17 <markwash> did anybody other than me go to the centralize quota session?
20:09:23 <jbresnah> i was there
20:09:24 <nikhil> i was there
20:09:45 <jbresnah> having keystone manage the information seemed broken to me
20:09:55 <markwash> I'm not sure I got a clear impression of it, but it sounds like 1) there are issues with the proposed implementation
20:09:56 <jbresnah> like... working around the procedure to create a new service
20:09:56 <nikhil> and then we sync-ed up later in the common lobby/hall
20:10:08 <markwash> and 2) even if there weren't, it would take a while to get it rolling
20:10:11 <flaper87> I don't think that's a good idea, FWIW
20:10:13 <ameade> not everyone uses keystone
20:10:17 <ameade> lets just do it in glance?
20:10:29 <flaper87> ameade: +!
20:10:31 <flaper87> ameade: +1
20:10:39 <markwash> I'm at +1 for that
20:10:51 <rosmaita> how badly do we need quotas?
20:10:51 <nikhil> markwash: ameade do we need to create an action item to sync with folks who are working on it in keystone?
20:11:07 <jbresnah> i dunno, i like the idea of having it shared across all projects
20:11:11 <rosmaita> i really think a multi-component solution would be better
20:11:14 <nikhil> (agree to non-centralized)
20:11:25 <rosmaita> (what jbresnah said)
20:11:40 <jbresnah> so many things will be needed every where
20:11:46 <rosmaita> no i mean multi-component in the sense of something that multiple components can use, not just glance
20:11:47 <flaper87> I think the quotas thing should start moving but perhaps we should try to sync with other projects as well. I mean, there's some code duplicated between nova and cinder
20:11:59 <flaper87> we should contribute back to oslo and use that
20:12:15 <ameade> flaper87: +1
20:12:28 <ameade> i would like a general solution, but not a centralized one
20:12:44 <flaper87> I was going to take care of that in the next few weeks since I'm trying to reduce duplicated code throughout openstack
20:12:48 <markwash> rosmaita: jbresnah: I"m all for centralizing the UX of managing quotas, but I never want to have to make a call across a region to determine a users quota limit
20:13:04 <nikhil> i feel there is a discussion going on somewhere else where folks are pushing towards the other idea
20:13:08 <rosmaita> well, a centralized solution is needed if you are worried about totla bandwith usage in the cloud for example
20:13:28 <rosmaita> is anyone worried about that?
20:13:29 <markwash> nikhil: I feel that you are right
20:13:38 <jbresnah> ameade: I see
20:13:47 <jbresnah> you are looking for a shared code base but not a shared service?
20:13:59 <ameade> rosmaita: good point, drats, this is a can of worms!
20:14:20 <rosmaita> so I agree with the action item to find out more info before working on this in glance
20:14:22 <nikhil> that's a really good idea (not sure how fast it might move in oslo though)
20:14:38 <jbresnah> well the other thing here, is who should do the enforcement?
20:14:45 <nikhil> guessing the best route would be to develop a good solution and then make it generic
20:14:48 <jbresnah> i am sure there are good OS level things to do this
20:15:01 <jbresnah> one person in one of the sessions was strongly against trying to do it in python
20:15:13 <markwash> interesting
20:15:16 <nikhil> think there are a lot of them
20:15:21 <jbresnah> if it is at the host level having limits across sevices is easier (i think)
20:15:28 <ameade> jbresnah: josh harlow was against ratelimiting in python
20:15:32 <nikhil> my guess is it's kind of a tie
20:15:55 <markwash> #action research approaches to centralize quota management, limit storage, enforcement, and usage monitoring
20:15:56 <jbresnah> ameade: was it for streaming limits only?
20:16:06 <jbresnah> or limiting rate of request/connection also?
20:16:15 <markwash> okay, let's table this for a bit, looks like we don't have a stong consensus
20:16:20 <jbresnah> nod
20:16:21 <nikhil> markwash: nice!
20:16:22 <ameade> +1
20:16:24 <flaper87> +1
20:16:24 <rosmaita> +1
20:16:28 <jbresnah> i can look into that action item also
20:16:32 <esheffield> +!
20:16:33 <jbresnah> +1
20:16:52 <markwash> Okay, protected properties (again from the etherpad)
20:17:07 <markwash> I think this is pretty uncontroversial?
20:17:17 <nikhil> +1
20:17:24 <markwash> iccha and smclaren and mikal were possible assignees
20:17:26 <rosmaita> +1
20:17:39 <nikhil> yes
20:17:58 <markwash> #action markwash talk to iccha and smclaren and mikal about who will lead api-v2-property-protection
20:18:03 <markwash> moving on
20:18:10 <nikhil> markwash: one sec
20:18:18 <nikhil> can we get the etherpad in the bp
20:18:38 <nikhil> looks like folks are out of sync (at least from what i sense here)
20:18:41 <markwash> who in the what now?
20:18:53 <ameade> yeah lets update teh blueprints to have all the info
20:19:05 <flaper87> +1
20:19:07 <nikhil> the link to the etherpad which has details about this protected properties implementation proposal
20:19:14 <markwash> ah
20:19:20 <markwash> do you have that link? I don't recall it?
20:19:22 <nikhil> be in the bp *
20:19:27 <nikhil> one min
20:19:48 <markwash> #action nikhil to update api-v2-property-protection blueprint with link to etherpad discussion/proposal
20:19:55 <markwash> anything else before we move on?
20:20:09 <nikhil> https://etherpad.openstack.org/public-glance-protected-props
20:20:11 <nikhil> ok
20:20:18 <markwash> thanks!
20:20:19 <markwash> Upload/Download Workflow: https://blueprints.launchpad.net/glance/+spec/upload-download-workflow
20:20:41 <markwash> this was discussed during the summit, I'm proposing we split it up into two blueprints
20:20:56 <markwash> but I'm not sure that I captured all the details we need to cover
20:21:41 <markwash> rosmaita: any thoughts here?
20:21:45 <flaper87> mhh, my understanding is that users will be able to download the image directly from swift
20:21:49 <flaper87> am i right ?
20:22:16 <markwash> flaper87: in some deployments yes, in others perhaps not
20:22:25 <rosmaita> (what mark said)
20:22:40 <markwash> I think the idea is that direct download and copy-to would have potentially different policies
20:22:42 <flaper87> and I guess the direct download won't happen using glance's client, right?
20:22:44 <jbresnah> so the idea is that you put an image some place and then register it with glance?
20:22:55 <markwash> jbresnah: that's a little different
20:22:58 <jbresnah> 'some place' being something outside of the scope of glance?
20:23:04 <markwash> the idea is that you put an image someplace, and then glance downloads it from there
20:23:11 <markwash> async
20:23:16 <ameade> oh this is copy from?
20:23:30 <ameade> oh i see now
20:23:37 <markwash> ameade: that's what I'm proposing, that "import" is really just "copy-from"
20:23:42 <markwash> and "export" is just "copy-to"
20:23:55 <markwash> though I'm not married to any particular verbal scheme here
20:24:01 <jbresnah> ok
20:24:13 <rosmaita> so are copy-from and copy-to already implemented?
20:24:17 <jbresnah> so 'conversion/verification' do not apply here?
20:24:22 <rosmaita> or are you talking conceptually?
20:24:26 <markwash> copy-from exists in v1
20:24:32 <ameade> what is this bp proposing?
20:24:40 <ameade> it seems to be a lot
20:24:46 <nikhil> generic workflow
20:24:59 <rosmaita> markwash: what is your proposal for splitting?
20:24:59 <markwash> jbresnah: I think copy-from may have some room for conversion / verification support
20:25:05 <nikhil> it a conceptual ameade
20:25:18 <ameade> got it, so it would have a bunch of dep bps
20:25:37 <markwash> rosmaita: two blueprints, one for adding copy-from like behavior to v2, another for adding copy-to like behavior to v2
20:25:48 <rosmaita> that makes sense to me!
20:26:04 <nikhil> prolly could be an action item here ameade (get all the stuff implemented noted down and add bp for things to be created) good point
20:26:12 <jbresnah> can we spell out use cases for this?
20:26:24 <jbresnah> i am having some trouble getting my head around what it is trying to do
20:26:26 <flaper87> jbresnah: you beat me
20:26:29 <markwash> sure
20:26:32 <ameade> yeah, i dunno why we need copy to if we have copy from
20:26:33 <jbresnah> and i have some interest in surrounding areas
20:26:45 <nikhil> upload/download
20:27:01 <markwash> well, in the usual case, you can just directly upload the image bits on creation
20:27:21 <markwash> but in the "import" case, the implication is that the bits you upload are not necessarily the bits that get stored
20:27:27 <markwash> b/c of possible conversion, etc.
20:27:31 <ameade> (almost halfway through meeting time btw)
20:28:11 <ameade> wanna add the usecases to the bp?
20:28:17 <ameade> that could be an action item
20:28:18 <markwash> perhaps a few of us should take this offline and repackage it to better explain to others?
20:28:25 <nikhil> +1
20:28:28 <flaper87> +1
20:28:31 <jbresnah> +1
20:28:33 <rosmaita> +1
20:28:44 <esheffield> +1
20:28:44 <markwash> rosmaita, how about you and me?
20:28:46 <nikhil> let's have a team speak channel for glance?
20:28:53 <nikhil> may be i went a bit too optimistic on that
20:29:25 <markwash> #action rosmaita & markwash to clarify upload/download workflow bp
20:29:26 <rosmaita> sure
20:29:48 <markwash> How about rate limits? Summit discussion was mostly "nope" as I understood it
20:30:08 <rosmaita> agreed, nope
20:30:10 <jbresnah> i think that one will fall out of the quota reseach
20:30:21 <markwash> jbresnah: I agree they're related
20:30:27 <flaper87> +!
20:30:29 <flaper87> +1
20:30:31 <markwash> :-)
20:31:08 <markwash> so, can I mark it superseded by quotas, but say consensus is leading towards not implementing it in glance?
20:31:41 <ameade> yeah the lazy consensus at the summit was we dont have to worry about it in glance
20:31:43 <flaper87> I'd say superseded by quotas, period :P
20:31:46 <markwash> it == https://blueprints.launchpad.net/glance/+spec/transfer-rate-limiting
20:31:51 <rosmaita> right, it seems better done  by something else so glance never sees the requests in the first place
20:32:25 <markwash> kk, now on to image workers https://blueprints.launchpad.net/glance/+spec/async-glance-workers
20:32:32 <markwash> which is sort of a new one, sort of an old one
20:33:01 <nikhil> like!
20:33:17 <rosmaita> +1
20:33:21 <ameade> gotta be done somehow
20:33:22 <ameade> lol
20:33:47 <markwash> this would dovetail into the upload/download workflow to give us a chance at image conversion
20:33:59 <rosmaita> +1
20:34:01 <flaper87> I like the idea
20:34:01 <nikhil> markwash: is there a strong focus on queue based async?
20:34:08 <jbresnah> it seems to be the same line of thinking as upload/download...
20:34:14 <markwash> and also possibly https://blueprints.launchpad.net/glance/+spec/iso-image-metadata
20:34:14 <jbresnah> i have not processed this one yet
20:34:45 <markwash> nikhil: I'm not sure. . I think its a good idea in some possible implementations
20:34:57 <markwash> nikhil: but I could also see a devstack-focused one that doesn't bother with a queue
20:35:05 <jbresnah> i know i may sound like a broken record on this but i feel glance needs to get its story strat on replica management before it should do conversion
20:35:33 <ameade> +1
20:35:37 <jbresnah> for example: is a qcow2 image that was converted from a raw image a replica?
20:35:47 <nikhil> markwash: cool, was just gunna ask about metadata sync and exceptions on the queue based proposal
20:35:56 <markwash> if the answer is "no" does that make things simpler?
20:36:08 <jbresnah> does a user look to glance to: find me all ubuntu11.11 base images?
20:36:09 <jbresnah> ummm
20:36:25 <jbresnah> it might, but then it makes me ask 'why is glance doing conversion'
20:36:38 <flaper87> I think the async-workers bp can be related to conversion but it isn't. It's useful for other operations as well.
20:36:45 <jbresnah> at some level glance is a discovery service for images
20:36:45 <markwash> jbresnah: sorry, didn't mean for that to come off as jerk-ish :-)
20:36:52 <jbresnah> it didnt
20:37:00 <jbresnah> (didn't even entry my mind that way)
20:37:04 <markwash> phew
20:37:22 <jbresnah> if glance is just tracking image blobs
20:37:34 <jbresnah> then the formats would not be replicas at all
20:37:49 <jbresnah> but if it is just doing blobs, why is it in the business of conversion
20:37:56 <flaper87> TBH, I'd also like glance to be more "image aware" and be capable of introspecting images (extracting metadata and useful info from them)
20:38:00 <jbresnah> i have no objection either way, i just think it should be well defined
20:38:08 <flaper87> but that maybe could be discussed in another meeting
20:38:19 <markwash> I was definitely in the "just blobs" mindset
20:38:21 <jbresnah> we need to have a strong typing on the service or feature creap happens
20:38:29 <nikhil> 12 mins to go
20:38:51 <jbresnah> just blobs works, but then why does glance convert?
20:38:52 <markwash> but then there would still be a justification for conversion, in that a given deployer knows that he can't actually run qcow2 internally
20:39:02 <markwash> for example
20:39:32 <jbresnah> so, is the idea is to have a image conversion service under the glance umbrella?
20:39:38 <markwash> maybe there is more discussion here that should follow on or be a part of the upload/download workflow?
20:39:41 <flaper87> I'm not sure about having conversions in Glance, TBH
20:39:51 <markwash> jbresnah: not quite
20:40:09 <ameade> does glance deal with bits or not?
20:40:13 <ameade> we just need to define that
20:40:20 <ameade> then we can go headstrong into whatever
20:40:34 <jbresnah> yeah, i think glance's role could be more clearly defined
20:40:47 <markwash> so, action item is to refine the pitch for conversion?
20:40:48 <flaper87> as for now, I like to think it doesn't
20:40:50 <jbresnah> and if it was, i think i would be siginificantly less of a PITA :-(
20:40:58 <nikhil> is glance == metadata + image data?
20:41:24 <jbresnah> perhaps a specific meeting to discuss glance's hats?
20:41:25 <esheffield> or glance == metadata + image directory
20:41:34 <rosmaita> i think that glance should allow users to upload images in wome enumeration of formats and should make sure that when the image is used, it's in a format that the cloud the glance is in can use
20:41:39 <flaper87> jbresnah: +1
20:41:48 <nikhil> there is yes and no there either way esheffield
20:41:51 <nikhil> ?
20:42:18 <markwash> quick, somebody #action something! :-)
20:42:51 <nikhil> you might have done that markwash
20:42:53 <nikhil> !
20:43:02 <nikhil> on "something" :)
20:43:09 <jbresnah> heh
20:43:23 <markwash> #action markwash schedule meeting to further discuss image conversion and glance's role with image data
20:43:31 <nikhil> awesome
20:43:32 <ameade> +1
20:43:33 <flaper87> +1
20:43:36 <jbresnah> +1
20:43:41 <esheffield> +1
20:43:41 <markwash> okay, we aren't going to get through all of the ones on the list today, but that's def okay
20:44:04 <markwash> I'd like to skip out of the summit session bps down to the "Other new Blueprints" section of https://etherpad.openstack.org/glance-meeting-agenda
20:44:36 <markwash> and, going out of order, flaper87 had some discussion points around functional testing
20:44:54 <nikhil> wow, that domain model will need a lot of work
20:45:04 <nikhil> guessing
20:45:24 <markwash> flaper87: functional test bp notes?
20:46:34 <flaper87> well, not many. THere are a couple of things I think we should improve there: 1) Reduce the number of tests that need an up&running glance service (perhaps converting some to unittests)
20:46:53 <markwash> +1
20:46:54 <flaper87> jbresnah: has been doing an amazing job on improving fuinctional tests performance
20:46:58 <markwash> +1000
20:47:12 <jbresnah> really i jsut did the impl, markwash did the hard part
20:47:17 <ameade> yeah shoutout to jbresnah
20:47:30 <jbresnah> redirects to markwash
20:47:44 <markwash> well, and also the fix to port selection has landed
20:47:48 <nikhil> o/
20:47:56 <flaper87> oh another one
20:47:58 <markwash> I'm curious if folks are still seing a lot of ECONNREFUSED jenkins blowouts
20:48:08 <flaper87> 2) We should stop using glance-control for functional tests
20:48:10 <flaper87> T_T
20:48:11 <jbresnah> yeah i would like to know that too
20:48:17 <jbresnah> ECONN
20:48:30 <ameade> one thing i wanted to mention with regard to reviews, which has been better lately but still, is requiring unit tests and not just functional
20:48:34 <markwash> ah yes, I forgot alla bout glance-control over night
20:49:09 <jbresnah> ameade: what do you mean?
20:49:11 <flaper87> markwash: I haven't sent the email because it's holiday here and my gf took advantage of that :P
20:49:30 <flaper87> I'll send it later
20:49:30 <markwash> :-)
20:49:33 <markwash> cool
20:49:33 <nikhil> :)
20:49:43 <markwash> #action flaper87 send that glance-control email
20:49:54 <ameade> jbresnah: i just mean that in the past i've seen functional test coverage be good enough for a patch and that shouldnt be
20:50:05 <ameade> not a big deal since i havent noticed lately
20:50:06 <nikhil> more than 50 mins now
20:50:08 <nikhil> markwash: ^^
20:50:12 <flaper87> about ECONN, I haven't seen it lately
20:50:16 <jbresnah> oh i see
20:50:17 <jbresnah> yeah
20:50:18 <markwash> ameade: that is a really good point
20:50:26 <jbresnah> +1
20:50:36 <markwash> there are a few items on open discussion
20:50:41 <markwash> #topic open discussion
20:50:52 <nikhil> i have one question
20:50:56 <markwash> go for it
20:51:37 <nikhil> scott was assign to public glance and wondering if he's working on it?
20:51:46 <nikhil> assigned*
20:51:55 <markwash> nikhil: good point, we need to follow up with him
20:52:08 <nikhil> thanks, action item?
20:52:23 <markwash> #action markwash follow up with smoser on public glance bp
20:52:26 <flaper87> I'd like to know if we plan to support legacy commands. They've been deprecated since folsom, AFAIK and some of them have given users some issues
20:52:31 <nikhil> perfect!
20:52:49 <flaper87> I think we should drop them based on the fact that new commands have been around for 2 releases
20:52:54 <flaper87> and we should support those
20:53:00 <nikhil> +1
20:53:00 <ameade> flaper87: +1
20:53:07 <nikhil> flaper87: ^^
20:53:14 * jbresnah agrees
20:53:21 <markwash> its not an issue to drop support for them?
20:53:40 <ameade> markwash: well we version glance-client dont we?
20:53:46 <flaper87> they're all covered by the new commands
20:53:52 <flaper87> so, a big NOTE in the change log
20:54:00 <flaper87> and release notes should be enough
20:54:02 <flaper87> IMHO
20:54:07 <markwash> this would be a major version change I think
20:54:10 <flaper87> plus, they won't see them anymore :P
20:54:14 <jbresnah> user legacy scripts could be scripting around the old calls
20:54:20 <ameade> markwash: yes definitely
20:54:23 <jbresnah> but they have been deprecated for some time
20:54:37 <ameade> we dont do "releases" for clients do we?
20:54:37 <markwash> #action bcwaldon consider dropping legacy shell commands in glance client and let us know why or why not
20:54:41 <jbresnah> and setting a cultural understanding that deprecation means it is probably a good thing
20:55:01 <markwash> bcwaldon really still owns this for now, I haven't taken the time to get up to speed
20:55:20 <nikhil> releases for glance client too? (good point ameade)
20:55:38 <markwash> jbresnah: did you want to try to schedule a meeting for talking about the transfer service?
20:55:59 <jbresnah> i do
20:56:06 <jbresnah> but i thnk i will send email about it
20:56:08 <flaper87> I also wanted to let folks now that I submitted 2 patches for review related to the new registry's api. I'd love to have some feedback from you and make sure we agree with what have been written there
20:56:19 <markwash> cool
20:56:24 <jbresnah> i want to have a few more thoughts clear and available for pre-meeting consumption
20:56:31 <markwash> and in general I'd like to remind folks that
20:56:34 <flaper87> Registry's V2 https://review.openstack.org/#/c/27359/
20:56:41 <markwash> #info glance review and bug squashing day tomorrow!
20:56:49 <flaper87> ww000000000000000000000000000000000ttttttttttttttttt
20:56:54 * jbresnah is looking forward to it!
20:57:03 <ameade> heck yeah
20:57:10 <flaper87> In an hour it will be tomorrow for me
20:57:11 <ameade> some hard core coding and reviewing action
20:57:21 <jbresnah> flaper87: i was looking over that review and i think i need some interactive help understanding some things
20:57:22 <rosmaita> let the squashing begin!
20:57:29 <markwash> also, its probably obvious that this meeting format is still a little under-construction
20:57:33 <jbresnah> flaper87: perhaps later today if not too late for you?
20:57:33 <rosmaita> flaper87: where are you located physically?
20:57:41 <flaper87> rosmaita: Italy
20:57:49 <flaper87> jbresnah: it's never late :P
20:57:51 <markwash> anybody got quick feedback? also you can email me longer feedback as well
20:57:52 <flaper87> jbresnah: sounds great!
20:58:06 <jbresnah> markwash: i am really happy about these meetings FYI
20:58:16 <nikhil> markwash: like on the meetings!
20:58:17 <ameade> markwash: i think they are going well
20:58:18 * flaper87 is happy too
20:58:20 <jbresnah> markwash: it is making it so much easier for me to get involved in things
20:58:23 <ameade> we just have so much to discuss atm
20:58:23 <rosmaita> +1
20:58:24 <jbresnah> nod
20:58:42 <markwash> okay cool. . feel free to share ideas for improvment though. I'm just improvising at this point :-)
20:58:55 <ameade> well good job so far markwash
20:59:00 <nikhil> free food
20:59:00 <flaper87> +1
20:59:04 <jbresnah> nod
20:59:10 <markwash> lets's close it there, we can discuss the bps we missed next week or offline during the week
20:59:14 <rosmaita> flaper87: ciao!
20:59:15 <markwash> nikhil: lol!
20:59:19 <ameade> kk
20:59:24 <flaper87> rosmaita: ciao :D
20:59:28 <markwash> #endmeeting