14:01:40 <markwash> #startmeeting glance
14:01:41 <openstack> Meeting started Thu Jun 20 14:01:40 2013 UTC.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:44 <openstack> The meeting name has been set to 'glance'
14:01:48 <zhiyan1> hi markwash, shall we talk about cinder-store in the meeting?
14:02:16 <markwash> zhiyan1: perhaps, but lets put it off for a moment, I want to ask about the progress of some other blueprints
14:02:49 <zhiyan1> sure
14:02:50 <rosmaita> \o
14:02:57 <esheffield> good [morning | afternoon | evening] everyone! \0/
14:04:00 <markwash> today I'd like to go through our h-2 targeted blueprints and make sure we're up to date on the targeting and the implementation status
14:04:12 <markwash> anybody got items for discussion for after that?
14:04:18 <ameade_> here
14:04:35 <markwash> #link https://blueprints.launchpad.net/glance/havana
14:04:44 <zhiyan1> markwash: yes, cinder-stroe
14:04:57 <mclaren> markwash:hey markwash, a couple mins on protected props?
14:05:11 <markwash> zhiyan1: mclaren: for sure
14:05:50 <mclaren> thanks!
14:06:02 <zhiyan1> thank~
14:06:02 <markwash> nikhil: bp:clone-image-across-regions, should that be targeted at h3?
14:06:04 <markwash> #link https://blueprints.launchpad.net/glance/+spec/clone-image-across-regions
14:06:20 <rosmaita> what's the h3 date?
14:06:20 <markwash> I guess it is blocked on async and import stuff, based on our dependency planning
14:06:27 <markwash> sure ask a hard question
14:06:34 <nikhil> markwash: yeah
14:06:47 <markwash> rosmaita: 2013-09-05
14:06:54 <markwash> nikhil: thanks!
14:07:27 <nikhil> markwash: would like to sync up about aysn stuff sometime today/tomorrow if you've some time
14:07:31 <nikhil> ?
14:07:41 <markwash> nikhil: definitely
14:07:46 <nikhil> thanks
14:07:48 <markwash> nikhil: I have some ideas, but I'm a little bit stuck
14:07:54 <markwash> I'll touch on that again
14:08:02 <nikhil> ah k, hope to help
14:08:13 <markwash> iccha: rosmaita: upload-download-workflow
14:08:23 <markwash> #link https://blueprints.launchpad.net/glance/+spec/upload-download-workflow
14:08:38 <rosmaita> i'm working on a rewrite
14:08:46 <rosmaita> got some good API feedback here
14:08:57 <rosmaita> will have done before next mtg for comments
14:09:11 <zhiyan1> markwash: just kindly remind for cinder-stroe be, i target it H2, but there 2 things: 1. i need make sure multiple-location support will be addressed on h2, since cinder-store base on it. 2. after h2 release, when cinder/brick (and others) ready, i will enhance cinder-store also..
14:09:34 <markwash> rosmaita: should I be targeting the new-upload-workflow and new-download-workflow bps instead?
14:09:56 <rosmaita> probably
14:10:07 <rosmaita> guess those are the actual bps
14:10:27 <markwash> rosmaita: does that look like h3 stuff? or h2 (july 18) ?
14:10:52 <rosmaita> TBH, probably h3
14:11:05 <markwash> rosmaita: cool, no worries
14:11:12 <rosmaita> k
14:11:30 <markwash> bp:add-sheepdog-support
14:11:40 <markwash> #link https://blueprints.launchpad.net/glance/+spec/add-sheepdog-support
14:12:03 <zhiyan1> seems the change closely get ready...
14:12:09 <markwash> this is implemented, but we can't get jenkins tests to pass :-(
14:12:17 <zhiyan1> yes, saw
14:12:33 <markwash> basically, there is some weird indeterminacy where a tiny bit more slowness in the api initialization breaks one of the tests
14:12:35 <markwash> very weird
14:12:40 <zhiyan1> check log details and ask infra-team if needed?
14:12:57 <markwash> zhiyan1: perhaps, but I was able to randomly get the failure to happen on my laptop
14:13:14 <zhiyan1> oops, very weird, -1
14:13:30 <markwash> and there was almost nothing I could do to debug it, because adding debugging to the test slowed things down, which resolved the race condition differently
14:13:49 <markwash> so it was basically a quantum measurement problem :-(
14:13:50 <zhiyan1> interesting
14:14:12 <markwash> anyway, if anyone has thoughts on that, its a hard problem but any solution would be amazin
14:14:15 <markwash> g
14:14:55 <markwash> #link https://blueprints.launchpad.net/glance/+spec/multiple-image-locations
14:15:01 <markwash> we're missing jbresnah
14:15:21 <markwash> I know he has a bunch of stuff up for review, I've given it a bit of a look
14:15:24 <zhiyan1> seems collie has concurrent issue? not sure...
14:15:58 <markwash> zhiyan1: maybe, but I think the collie stuff is actually fine. . it prints a silly error because collie isn't available, but the exception is handled and everything is "normal"
14:16:01 <zhiyan1> yes, i think if that PATCH handler patch ready, then cinder-store can work
14:16:24 <zhiyan1> :( but not normal..
14:16:29 <markwash> #action markwash and zhiyan1 to square up with jbresnah on what next steps are needed to get multiple locations through as soon as possible
14:16:52 <zhiyan1> thanks!
14:17:13 <markwash> moving on to protected properties
14:17:14 <markwash> #link https://blueprints.launchpad.net/glance/+spec/api-v2-property-protection
14:17:30 <mclaren> thanks Mark
14:17:32 <markwash> iccha: mclaren: notes here? should this be targeted at h-2 or h-3 at this point?
14:18:01 <mclaren> hmm, I don't see h-2 to be honest.
14:18:04 <ameade_> have we settled on the API?
14:18:22 <zhiyan1> btw, markwash, as i planned for multiple-location support for nova (https://blueprints.launchpad.net/nova/+spec/image-multiple-location), i have a draft version here: https://review.openstack.org/#/c/33409/2
14:18:25 <mclaren> I think we're a bit wedged, probably largly my fault
14:18:37 <rosmaita> iccha is in trainig today
14:18:38 <mclaren> I proposed something simpler, would love feedback on that
14:19:03 <mclaren> if possible -- the "Reduced billing specific functionality" at the end of the ether pad
14:19:09 <ameade_> gosh where is the TL;DR for this etherpad
14:19:11 <rosmaita> mclaren: that was the proposal to add a new "billing" prop to the non-additional properties?
14:19:13 <mclaren> https://etherpad.openstack.org/public-glance-protected-props
14:19:20 <mclaren> right
14:19:34 <rosmaita> that won't work for our use cases, unfortunately
14:19:42 <mclaren> ok, np
14:19:45 <rosmaita> unless we add like 30 properties!
14:19:55 <mclaren> thanks for taking a look.
14:20:10 <rosmaita> i've been on vacation, will work with iccha on this early next week
14:20:20 <rosmaita> and you too mclaren
14:20:20 <markwash> rosmaita: do you agree with h3 for this one?
14:20:36 <markwash> or is it an earlier target for you guys?
14:20:51 <rosmaita> let's say h3 and we'll try to deliver earlier
14:21:03 <markwash> okiedokie
14:21:18 <rosmaita> h2 is what we're really looking at, but may be too optimistic
14:22:07 <markwash> rosmaita: let's keep it h2 for now
14:22:12 <markwash> we can revisit a bit later
14:22:22 <rosmaita> ok
14:22:52 <markwash> :-( I refreshed my blueprint page and now my listing is in a different order
14:22:58 <markwash> hope I don't miss any of the bps!
14:23:10 <markwash> next one up, registry-db-driver
14:23:17 <markwash> hmm, but we don't have flaper87 today
14:23:34 <markwash> #action markwash, flaper87 talk about next steps with bp:registry-db-driver
14:24:10 <markwash> Do we have kiran or romil?
14:24:52 <markwash> moving on for now to glance-cinder-driver
14:25:25 <markwash> zhiyan1: you've got a nice looking code review up, and talks about cinder brick are proceeding well for its possible use in h3
14:25:27 <zhiyan1> markwash: use multiple-location and use  'buyer-beware' mode is ready IMO
14:25:59 <markwash> zhiyan1: does it make sense to hold off on merging until we have a minimal multiple location functionality setup?
14:26:14 <markwash> zhiyan1: this goes back to the previous action item of you and I talking to jbresnah about next steps
14:26:17 <zhiyan1> for https://review.openstack.org/#/c/32864/2 ?
14:26:22 <markwash> zhiyan1: eys
14:26:25 <markwash> yes
14:26:28 <zhiyan1> for h2, right?
14:26:31 <markwash> right
14:26:35 <zhiyan1> great.
14:27:15 <zhiyan1> i'd co-work with you and jbresnah, to get multiple-location landing. then to check/merge #32864....for h2
14:27:15 <markwash> zhiyan1: help me figure out the *minimum* needed in multiple locations api functionality in order to merge that, and I think we'll be good :-)
14:27:22 <markwash> zhiyan1: perfect
14:27:37 <zhiyan1> ok, i'd like
14:27:54 <markwash> I think the only bp left to discuss for h2 is async-glance-workers
14:27:59 <zhiyan1> just make sure i can meger this version for cinder-store implementation on H2....
14:28:07 <markwash> #link https://blueprints.launchpad.net/glance/+spec/async-glance-workers
14:28:30 <markwash> nikhil:  you and I are already planning to talk to try to get me unstuck here
14:28:50 <nikhil> markwash: ya, sure
14:28:55 <markwash> okay cool
14:29:08 <markwash> let's leave it at h2 since its a blocker for other bps
14:29:30 <nikhil> +1
14:29:31 <markwash> nikhil:  you'll have some time later today to discuss?
14:29:46 <nikhil> markwash: in between some meetings ;)
14:29:48 <nikhil> :)
14:29:57 <nikhil> 0:)
14:29:59 <markwash> nikhil: cool, today or tomorrow then
14:30:00 <markwash> :-)
14:30:04 <nikhil> thanks
14:30:15 <markwash> anyone else have h2 blueprint notes?
14:30:46 <zhiyan1> markwash: do you think there's some value about my iscsi-store change ?
14:31:06 <zhiyan1> do you remember that :)
14:31:42 <markwash> zhiyan1: I do remember it somewhat. . is that something brick would be doing more generically (i.e. for more types of volume devices?)
14:31:45 <zhiyan1> https://blueprints.launchpad.net/glance/+spec/iscsi-backend-store
14:32:26 <zhiyan1> maybe, ok just hold it....will think about it when I have time...
14:32:30 <markwash> kk
14:32:34 <markwash> #topic Open Discussion
14:33:23 <esheffield> a general "exposing glance" question
14:34:03 <esheffield> basically what api version(s) will be exposed? from our end I think we're only concerned with v2
14:34:32 <markwash> esheffield: that makes sense. . I think it has to be deployer configurable though
14:34:38 <esheffield> but more specifically, should that really be v2.1 only?
14:34:39 <markwash> I think we have sufficient settings for that
14:34:56 <esheffield> ok
14:35:02 <markwash> esheffield: I assume that there are several installations that currently expose v1 to direct use
14:35:14 <mclaren> "exposing glance" == publically available api?
14:35:19 <esheffield> yes
14:35:43 <mclaren> oh, well some of the slower moving companies are probably interested in v1!
14:36:01 <zhiyan1> +1, mclaren
14:36:28 <mclaren> but as mark says its configurable so no probem I think
14:36:31 <zhiyan1> not sure, v2 does not fit "publically" api?
14:36:56 <rosmaita> whether you expose v1 or v2 will depend on your situation
14:37:01 <esheffield> how about v2.1 vs 2.0? I remember some discussion in a prior meeting that 2.0 usage probably shouldn't be encouraged because of the patch behavior not corresponding to the final patch spec
14:37:30 <zhiyan1> enable_v1_api/enable_v2_api options?
14:37:38 <markwash> esheffield: I think v2.0 is basically inaccessible at this point, except in the sense that v2.1 is backwards compatible with v2.0
14:38:07 <markwash> maybe you can ask for v2.0, but you're gonna get v2.1
14:38:19 <esheffield> hmm, ok then - does 2.1 accept either forms of patch?
14:38:24 <markwash> esheffield: yes
14:38:40 <markwash> those rfc jerks ;-)
14:38:45 <esheffield> lol
14:39:09 <markwash> they literally changed the draft to match the internal python structure I was deserializing the previous form to
14:39:19 <markwash> which I guess made the change easy. . but
14:39:36 <markwash> I suppose that's what I get for using draft rfcs :-)
14:39:53 <markwash> on the topic of testing, I'd like to plug my etherpad again https://etherpad.openstack.org/glance-improving-test-cycle-times
14:39:58 <markwash> #link https://etherpad.openstack.org/glance-improving-test-cycle-times
14:40:03 <zhiyan1> sorry, is there a link to show the v2.1 api spec?
14:40:39 <markwash> zhiyan1: not sure if there is a v2.0 vs v2.1 doc anywhere
14:40:55 <markwash> but v2.1 is basically just adding in image membership management and a slightly different JSON-PATCH format
14:41:14 <zhiyan1> sorry, is v2.1 in current code base?i just think they are v1.1. and v2
14:41:15 <markwash> all that merged in grizzly
14:41:25 <markwash> current is v1.1 and v2.1
14:41:25 <zhiyan1> ok, got it
14:41:37 <zhiyan1> got it, thanks. that's already 2.1 :)
14:41:45 <markwash> I've been working on testing stuff while I've been stuck on async
14:41:45 <rosmaita> so folsom == v2 and grizzly == v2.1 ?
14:42:00 <markwash> rosmaita: yeah I think that's accurate, though v2 was probably not useable until grizzly
14:42:16 <markwash> rosmaita: I believe the store was hardwired as filesystem
14:42:34 <rosmaita> bummer
14:42:50 <rosmaita> so is havana still v2.1 ?
14:43:19 <markwash> rosmaita: so far
14:43:27 <rosmaita> ok, i will shut up now
14:43:38 <markwash> rosmaita: I guess multiple locations might warrant a miinor version bump
14:43:51 <markwash> rosmaita: especially if we start adding more fields to locations
14:44:30 <markwash> for testing, my goal is to make glance tests run in about a minute
14:44:44 <markwash> but with slightly improved coverage
14:44:51 <ameade_> all tests?
14:44:56 <ameade_> even 'functional'
14:44:59 <markwash> ameade_: yup
14:45:03 <ameade_> wooo
14:45:11 <markwash> well, a large part of that document is "we don't need this type of functional test all the time"
14:45:42 <markwash> ameade_: the goal is a breakdown of about 30s unit, 30s integration, 10s functional
14:46:01 <zhiyan1> markwash, folks, i'd like listen your comments/input/thoughts about my change to allow nova consume multiple-location of an image (https://blueprints.launchpad.net/nova/+spec/image-multiple-location), i have a draft implementation here: https://review.openstack.org/#/c/33409/2
14:46:21 <zhiyan1> base on that, in the near future, nova can 'link' image from a backend store but not always download it for local cache.
14:46:27 <markwash> the functional level, instead of being broadly assertive as it is now, would evolve to be mostly a "does it all wire up correctly" check, and the correctness would be asserted at the integration level
14:47:44 <markwash> zhiyan1: thanks! taking a look now
14:47:50 <zhiyan1> thanks!
14:48:05 <zhiyan1> i talked that in last weekly meeting this room
14:48:26 <markwash> zhiyan1: ah, sorry. . I was very distracted by some day job stuff last week
14:48:41 <zhiyan1> never mind :) that's ok
14:48:52 <zhiyan1> baby step :)
14:49:25 <markwash> anybody else? we can end early. . .
14:50:42 <markwash> #endmeeting