20:00:52 <markwash> #startmeeting glance
20:00:53 <zhiyan> hey jbresnah_!
20:00:53 <openstack> Meeting started Thu Sep 19 20:00:52 2013 UTC and is due to finish in 60 minutes.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:57 <openstack> The meeting name has been set to 'glance'
20:01:02 <markwash> I'll go try a little highlighting in #openstack-glance
20:01:53 <markwash> 3 is a quorum, I'm pretty sure :-)
20:02:00 <rosmaita> four
20:02:11 <markwash> rosmaita: hi!
20:02:26 <rosmaita> howdy!
20:02:50 <esheffield> o/
20:02:52 <markwash> I've been out for most of the past week, so I'm feeling a bit out of touch
20:03:09 <zhiyan> markwash: any topic in today's agenda?
20:03:12 <markwash> but i've been looking through the rc1 bugs and it looks like we made some decent progress
20:03:27 <markwash> zhiyan: yes, I would like to do the following
20:03:37 <markwash> 1) action items for resolving all current RC1 bugs
20:03:54 <markwash> 2) action items for reviewing tasks
20:04:11 <markwash> as we slowly approach unfreezing glance
20:04:20 <markwash> 3) and action items for glanceclient
20:04:43 <markwash> other topics?
20:04:53 <jbresnah_> i have some
20:05:07 <zhiyan> markwash: yes, talk about design summit topic?
20:05:12 <jbresnah> flavio couldnt make it but he emailed me a couple of bugs he wanted to talk about
20:05:20 <jbresnah> they might be covered in the above
20:05:31 <jbresnah> and also i want to tell everyone that i am leaving red hat
20:05:39 <zhiyan> jbresnah: :)
20:05:43 <jbresnah> and what that will be like for me on glance etc
20:06:14 <markwash> jbresnah: OK, let's make sure to work that in
20:06:36 <markwash> zhiyan: sounds good, lets talk design summit topics as well
20:06:48 <markwash> jbresnah: are you still going to be working on openstack stuff?
20:07:01 <jbresnah> yes, but less so
20:07:13 <zhiyan> markwash: cool. http://summit.openstack.org
20:07:15 <jbresnah> :-(
20:07:30 <jbresnah> i will still be a good glance citizen in terms of reviews
20:07:35 <jbresnah> but probably less development
20:08:12 <markwash> I see. . well we'll be sad to see your coding contributions decrease :-(
20:08:20 <jbresnah> nod
20:08:28 <markwash> with all the great fixes and features you've added in havana, for example
20:08:30 <jbresnah> was a tough call, but i will still be around
20:08:37 <jbresnah> thanks!
20:09:10 <zhiyan> jbresnah: have a good career to you!
20:09:35 <jbresnah> zhiyan: this is not goodbye!
20:10:02 <zhiyan> jbresnah: :) of cause. (you know we talked this)
20:10:21 <markwash> all right. . well. . I guess we should take a quick look at rc 1 bugs
20:10:24 <markwash> #topic rc1 bugs
20:10:33 <jbresnah> do you have a link to the list of them?
20:10:35 <zhiyan> https://launchpad.net/glance/+milestone/havana-rc1
20:10:38 <markwash> #link https://launchpad.net/glance/+milestone/havana-rc1
20:10:39 <markwash> haha
20:10:40 <markwash> twice
20:10:42 <nikhil> o/
20:11:28 <markwash> 7 In progress, 1 new, 5 committed
20:11:45 <jbresnah> oh, this one is not real: https://bugs.launchpad.net/glance/+bug/1220919
20:11:45 <markwash> and I think the highest priority In Progress bugs have at least a single +2
20:12:06 <jbresnah> i jsut set it to invalid
20:12:07 <markwash> ah, okay, thanks. . I was going to ask
20:12:38 <markwash> I removed the milestone then too
20:13:04 <jbresnah> 1213241 should be all set
20:13:09 <jbresnah> just needs review
20:13:10 <markwash> of note, it appears that the blocking jenkins issue was fixed in https://bugs.launchpad.net/glance/+bug/1213241
20:13:24 <jbresnah> flwang and zhiyan helped me through the last issue
20:13:25 <jbresnah> yeah
20:13:31 <markwash> #action more core reviews of https://bugs.launchpad.net/glance/+bug/1213241
20:13:48 <markwash> flwang: zhiyan: thanks so much for that! I had been looking but was completely lost
20:14:12 <zhiyan> markwash: welcome :)
20:14:29 <markwash> https://bugs.launchpad.net/bugs/1223516 needs another core look as well
20:14:41 <markwash> #action more core reviews of https://bugs.launchpad.net/bugs/1223516
20:15:00 <markwash> we have the same story with https://bugs.launchpad.net/bugs/1218712
20:15:14 <markwash> that last one is metadata encryption for multiple locations
20:15:28 <markwash> zhiyan: I gave my +2 this morning as I was trying to catch up on reviews
20:15:54 <zhiyan> markwash: saw, thanks.
20:16:04 <jbresnah> i'll get through some reviews this afternoon
20:16:21 <zhiyan> markwash: for #1213241, i think jbresnah's patch is good enough to get merge IMO.
20:16:30 <zhiyan> jbresnah: thank you.
20:16:57 <markwash> I guess "more reviews" is the main message for those rc1 bugs
20:17:09 <jbresnah> nod
20:17:10 <markwash> with one standout: https://bugs.launchpad.net/bugs/1224449
20:17:55 <zhiyan> markwash: humm, this one seems ttx has some different sounds, iirc,,
20:18:09 <markwash> that one depends on a change to requirements
20:18:13 <markwash> which has been blocked somewhat
20:18:31 <zhiyan> markwash: nod
20:18:58 <markwash> okay, it looks like ttx is okay with that requirements change at this point
20:19:03 <zhiyan> markwash: ok, seems you like copy OrderedDict from package directly ...
20:19:08 <markwash> I think we really need to fix that bug
20:19:16 <markwash> I'd much prefer that we get the change in to requirements
20:19:44 <markwash> but i we cant, I think copying in OrderedDict would work as a Havana fix
20:19:50 <markwash> s/i we/if we/
20:20:09 <zhiyan> markwash: and it obviously is a obviously solution..
20:21:07 <markwash> anyone here have strongish objections to just copying the implementation of OrderedDict into Glance if that's what it takes to fix this bug?
20:21:31 <markwash> on the assumption that we would remove it asap for the Icehouse and future releases
20:21:33 <jbresnah> sorry i am not familar with the bug yet
20:21:38 <jbresnah> copy from oslo?
20:21:48 <zhiyan> jbresnah: from https://pypi.python.org/pypi/ordereddict/1.1
20:21:55 <markwash> it would involve copying from a project on pypi
20:22:12 <markwash> I don't think the licensing is an issue at all, we can just preserve the original license
20:22:17 <markwash> but its kinda nasty
20:22:19 <jbresnah> | License :: OSI Approved :: MIT License
20:22:23 <jbresnah> those are ok for a copy?
20:22:32 <markwash> jbresnah: hmm, I guess maybe I should double check
20:23:27 <zhiyan> markwash: is there have not any chance to allow us change requirement.txt at this stage??
20:23:28 <jbresnah> i am ok with the copy
20:24:56 <markwash> zhiyan: its looking more and more likely we can still change requirements at this stage, but I just want to make sure people are okay with "holding their noses" while we copy and paste, if that is what is required
20:25:48 <zhiyan> markwash: i'm ok with the copy too. thanks for explaining markwash.
20:25:53 <markwash> okay great
20:26:05 <markwash> I hope we don't have to take that option, but I don't think we can ship with that bug
20:26:22 <markwash> since it will make property protection ordering non deterministic
20:26:32 <jbresnah> yeah
20:26:34 <zhiyan> markwash: nod
20:26:45 <markwash> which would mean that you might match things in the wrong order. . breaks things the same as if your iptables rules were evaluated in a random order
20:27:05 <markwash> jbresnah: did flavio have any other bug notes for us?
20:27:11 <zhiyan> markwash: it's a critical bug obviously
20:27:19 <jbresnah> yeah but first  a quick question on this one: https://review.openstack.org/#/c/45942/
20:27:32 <jbresnah> i am wondering if we lose context
20:27:42 <jbresnah> we trap exceptions, create messages and then raise
20:27:51 <markwash> hmm, I wonder about that too now
20:27:55 <jbresnah> with things like ValueError, will we lose the context for that exception?
20:28:08 <jbresnah> StorageFull etc are probably not a problem
20:28:25 <jbresnah> i hate to stall it out on that
20:29:06 <markwash> based on a simple on the spot test, I don't think we lose context when we use a "raise" statement with no argument
20:29:36 <jbresnah> oh, i mean something else
20:29:37 <markwash> http://paste.openstack.org/show/47282/
20:29:48 <jbresnah> like, at this point in the code we know what a ValueError is caused by
20:29:54 <jbresnah> but do we up the stack?
20:30:06 <jbresnah> sure, we may have the wholestack trace
20:30:11 <jbresnah> and can introspect that
20:30:20 <jbresnah> but can we create sane error messages
20:30:24 <jbresnah> that go to a user
20:30:27 <jbresnah> does that make sense?
20:30:28 <markwash> I think we do still "know" further up the stack
20:30:51 <jbresnah> even for Exception and ValueError?
20:30:56 <markwash> b/c we're not really changing the behavior here at all
20:31:04 <markwash> if it raises before you layer in notifications, it still raises
20:31:34 <markwash> I think the argument could be made that those exceptions are too general for this interface, but it seems like the semantics (too general though they may be) are intact after layering in notification
20:31:48 <jbresnah> hmmm
20:32:02 <jbresnah> look at the msg = for ValueError
20:32:07 <markwash> how about we take it up in the review though. . I'm okay with a -1 :-)
20:32:13 <jbresnah> sure sounds good
20:32:19 <jbresnah> i will just 0 it tho
20:32:34 <jbresnah> ok, so flavio was concerned with these 2
20:32:41 <markwash> I mean, I'm okay with a -2 as well :-) I'd just be a little sad
20:32:51 <jbresnah> heh
20:33:01 <jbresnah> no, this is -1 worthy nitpick at best
20:33:02 <jbresnah> https://bugzilla.redhat.com/show_bug.cgi?id=1004398
20:33:20 <jbresnah> i added comments to that after flavio brought it to my attention but it would be good for others to weigh in too
20:33:56 <jbresnah> https://bugs.launchpad.net/glance/+bug/1226078
20:34:04 <jbresnah> that one seems like something we should deal with
20:34:54 <jbresnah> i do not fully understand the problem yet
20:35:00 <jbresnah> but it is a potentially big security problem
20:35:19 <markwash> okay interesting. . yeah both of those look signficant
20:35:37 <markwash> for the first one, I'm wondering if its a glanceclient bug only? or is it both glanceclient and glance?
20:35:56 <jbresnah> i think it is a glance bug
20:36:07 <jbresnah> glance allows a client to set a bogus size value
20:36:18 <jbresnah> but really all those values are just advisory
20:36:24 <jbresnah> nothing is really vetted
20:36:34 <zhiyan> jbresnah: for glance server side, you meaning v1 or v2 api ?
20:36:36 <jbresnah> i dont see it getting fixed for H
20:36:46 <jbresnah> zhiyan: i think either?
20:36:51 <jbresnah> zhiyan: but i am not certain
20:37:29 <esheffield> I agree it seems more like a glance bug than glanceclient
20:37:37 <zhiyan> jbresnah: iirc, v1 has checking code for that..compare http content-length with store driver returned size ..
20:37:51 <zhiyan> esheffield: i think so markwash.
20:37:52 <esheffield> esp with v2 where the client is more ignorant of the options, relying on the schema more
20:38:02 <markwash> hmm okay
20:39:27 <markwash> okay, I marked that first bug as triaged/confirmed
20:39:31 <jbresnah> zhiyan: even when --location is used?
20:39:50 <jbresnah> we should have a discussion on that bug
20:39:54 <jbresnah> i posted some of my thoughts
20:40:01 <zhiyan> jbresnah: yes, seems defect related with that situation, need check code deeply
20:40:06 <markwash> re the second, security-related bug
20:40:12 <markwash> I'm confused
20:40:23 <markwash> it seems like that bug is just documenting the thing we don't like about v1 memberships
20:40:30 <jbresnah> also with add location
20:40:31 <jbresnah> how do verify size?
20:40:31 <jbresnah> checksum?
20:40:31 <jbresnah> that it is actually  a replica
20:40:51 <jbresnah> the second bug?
20:41:08 <jbresnah> well i do not really understand the problem yet
20:41:21 <jbresnah> maybe we should talk it over with flavio when he is around
20:41:26 <markwash> okay, sounds good
20:41:51 <markwash> #action jbresnah, flaper87, markwash discuss https://bugs.launchpad.net/glance/+bug/1226078
20:41:55 <markwash> okay
20:41:59 <jbresnah> but i wold like to hear your understanding of too mark
20:42:02 <jbresnah> at some point anyway
20:42:08 <markwash> any other bugs of note for rc1?
20:42:23 <jbresnah> not from me
20:42:48 <markwash> #topic glanceclient
20:43:06 <markwash> esheffield: I saw your recent message to the list and have the review open in my browser
20:44:01 <esheffield> yes - there were a couple of minor comments that I took care of this morning
20:44:34 <markwash> that looks like the main outstanding item for v2 support
20:44:47 <esheffield> I think so
20:45:06 <markwash> and it has some options for managing caching of schemas, so it seems
20:45:27 <jbresnah> esheffield: i am excited about that one landing btw
20:45:52 <markwash> okay, well I just wanted to check in there. I expect to do another full pass on python-glanceclient reviews soon
20:46:11 <esheffield> great, thanks!
20:46:12 <zhiyan> jbresnah: esheffield: I believe other folks from other team will be also
20:46:25 <markwash> does anyone have other notes for glanceclient work in the next week or so?
20:46:41 <jbresnah> i dont
20:46:47 <zhiyan> zhiyan: i have not
20:46:52 <zhiyan> oh, markwash ^
20:46:55 <jbresnah> i do have a general question as a reviewer when there is a minute
20:47:12 <markwash> #topic asynchronous tasks
20:47:20 <markwash> whoops
20:47:26 <markwash> jbresnah: go ahead with your question
20:47:46 <jbresnah> what can i approve/not approve?
20:48:05 <markwash> I don't think there are really any restrictions at this time
20:48:17 <jbresnah> ok cool
20:48:24 <markwash> we should avoid breaking backwards compatibility unless we're planning a major point release
20:48:29 <markwash> which we are getting close to
20:48:31 <jbresnah> i am worried i will approve something in a freeze
20:48:38 <markwash> no freeze for the client
20:48:44 <jbresnah> oh i mean in general
20:48:46 <jbresnah> glance too
20:48:49 <markwash> oh
20:49:03 <markwash> yeah, glance is still frozen, so only approve bugs targeted to rc1
20:49:19 <markwash> but feel free if you see something important to draw some attention to it so we can approve it if needed
20:49:32 <markwash> that gives some good context for async tasks
20:49:51 <markwash> we decided to try to land async tasks very early in Icehouse, which should open in about a week
20:50:01 <markwash> so there is still good reason to be doing reviews there
20:50:07 <jbresnah> yeah, ok
20:50:20 <markwash> as I mentioned, I was out last week, and I'd like to do a deep dive on async tasks as I catch back up
20:50:23 <jbresnah> so only things referencing these bugs: https://launchpad.net/glance/+milestone/havana-rc1
20:50:28 <markwash> jbresnah: right
20:50:36 <markwash> nikhil: can you update me on the status of async tasks?
20:50:58 <nikhil> markwash: here
20:51:00 <nikhil> :)
20:51:18 <nikhil> so, we created another wip/temp repo which has all the changes asyn workers need
20:51:58 <nikhil> to make reviewers' and
20:52:17 <nikhil> everyone who is working on it - their job easier to maintin the patch
20:52:32 <markwash> sounds good. . I think you emailed me the link, can you share it here though too?
20:52:38 <nikhil> it has impl for a generic class which acts like interface
20:52:42 <nikhil> sure
20:53:00 <nikhil> and it has filesys-filesys importer almost complete
20:53:19 <nikhil> meaning there is some error on the domain proxy for a functional test which I'm resolving this week!
20:53:50 <nikhil> https://review.openstack.org/#/c/46117/
20:54:07 <nikhil> markwash: the plan was to make it robust and acceptable
20:54:16 <nikhil> and then we can break it down and send it in?
20:54:30 <markwash> #action markwash (and others!) perform early reviews with an eye towards landing https://review.openstack.org/#/c/46117/ early in Icehouse
20:54:31 <nikhil> I meant to ask if that is okay
20:54:40 <nikhil> thanks markwash !!
20:54:49 <markwash> nikhil: I think that's fine, we can talk about how to break it up best in the review notes as well
20:54:56 <markwash> but anything that makes it easier to work on for you guys is good
20:55:04 <zhiyan> nikhil: seems it mixed all related changes in #46177, right?
20:55:30 <markwash> we have only 5 minutes left
20:55:42 <markwash> and wanted to touch on design summit talks as well
20:55:43 <nikhil> markwash: thanks
20:55:45 <nikhil> zhiyan: yes
20:56:05 <nikhil> that patch has all the changes which importer and tasks api would need
20:56:17 <jbresnah> i have design summit topics, but it will have to be by proxy
20:56:27 <zhiyan> nikhil: is it just for testing ? i mean do you still maintain other separated patchs?
20:56:42 <nikhil> zhiyan: the current patches are not up to date
20:56:47 <nikhil> as they were causing issues
20:57:02 <nikhil> maintaining the earlier / depency patched by fei
20:57:08 <nikhil> patches**
20:57:11 <zhiyan> nikhil: so #46177 is latest code right?
20:57:18 <nikhil> yes
20:57:25 <zhiyan> nikhil: ok, got it.
20:57:31 <zhiyan> nikhil: thanks
20:57:57 <markwash> #topic design summit topics
20:57:59 <nikhil> zhiyan: the MP to be reviewed is https://review.openstack.org/#/c/46117/
20:58:08 <nikhil> oops
20:58:16 <zhiyan> markwash: jbresnah yes do you think we'd better talk about design seesion topic?
20:58:27 <markwash> yeah, with the little time we have left
20:58:31 <zhiyan> markwash: seems we have not one proposal in the list
20:58:40 <jbresnah> zhiyan: should we throw them out here or is the web site for submission available yet?
20:58:49 <nikhil> I've one but would not be able to make it to the summit
20:59:08 * markwash has forgotten where we are on that front, since we didn't have a project meeting this week
20:59:38 <zhiyan> markwash: when you cut them up? i mean from summit.openstack.org?
20:59:52 <markwash> I've got one or two ideas I've been kicking around that I'd like to discuss at the summit as well
20:59:59 <zhiyan> markwash: do you think we can just put something we want, and review together later?
21:00:14 <markwash> oh yeah, looks like its opened up
21:00:19 <markwash> you guys can submit whatever you feel like there
21:00:28 <jbresnah> zhiyan: i like that idea
21:00:36 <jbresnah> cool
21:00:45 <zhiyan> oh, seems time up..
21:00:50 <markwash> yeah, I think we're out of time
21:00:52 <zhiyan> markwash: will ping you later
21:00:56 <zhiyan> off line
21:00:58 <markwash> thanks everybody
21:01:01 <jbresnah> thanks!
21:01:08 <zhiyan> thanks !
21:01:14 <markwash> #action submit your summit topics at http://summit.openstack.org !
21:01:21 <markwash> #endmeeting