20:01:04 <markwash> #startmeeting glance
20:01:05 <openstack> Meeting started Thu Oct 17 20:01:04 2013 UTC and is due to finish in 60 minutes.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:08 <openstack> The meeting name has been set to 'glance'
20:01:14 <markwash> who do we have here today? give a o/
20:01:39 <ameade_> hey
20:01:46 <nikhil> o/
20:01:47 <ameade_> sorry folks are talking irl
20:01:57 <markwash> ameade_: buncha irl jerks
20:02:05 <vkolosov> Hi
20:02:05 <iccha_> o/
20:02:36 <Guest95732> o/
20:02:44 <rosmaita> \o
20:02:52 <markwash> welcome all!
20:02:52 <hemanth> o/
20:03:08 <esheffield> o/
20:03:14 <markwash> We've got a full agenda for today, thanks to all the helpful suggestions from folks
20:03:20 <markwash> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:03:23 <zhiyan> hi
20:03:41 <buzztroll> wave
20:03:51 <markwash> it doesn't say so, but we'll try to have an Open Discussion time at the end for at least 5 minutes
20:04:01 <markwash> in case folks didn't have a chance to suggest stuff on the etherpad agenda
20:04:27 <markwash> #topic project status meeting update
20:04:40 <markwash> Just taking the opportunity to pass info down from the weekly openstack project meeting
20:05:01 <markwash> this week was fairly uneventful for glance, but as you all know, rc2's and rc3's are out for all the projects
20:05:16 <markwash> since glance seems pretty stable post rc2, we're full steam ahead on new code
20:05:22 <iccha_> woohoo!
20:05:35 <markwash> (because we have no reason to believe we need to worry about backporting bug fixes needing to be especially easy)
20:06:04 <markwash> there is also some install documentation in a wiki that glance folks might want to check out and see if they can contribute to
20:06:13 <markwash> #link https://wiki.openstack.org/wiki/HavanaDocTesting
20:06:26 <markwash> thanks again to everyone for their efforts with rc2
20:06:32 <markwash> it really went well from my perspective
20:06:44 <markwash> (we got everything merged before the crud hit the fan with jenkins gating)
20:07:06 <markwash> any questions about the project meeting?
20:07:44 <markwash> cool
20:08:02 <markwash> #topic Release Notes
20:08:10 <markwash> Glance release notes for havana have been published
20:08:20 <markwash> #link https://wiki.openstack.org/wiki/ReleaseNotes/Havana#OpenStack_Image_Service_.28Glance.29
20:08:49 <markwash> I think we could still fill out some more info there for "known issues" i.e. bugs that we're carrying over that are significant
20:08:55 <markwash> and also possibly upgrade notes
20:09:11 <markwash> anyone interested in helping out with that effort?
20:09:25 <iccha_> would upgrade notes be like new config values and stuff?
20:09:32 <iccha_> and migrations?
20:09:39 <markwash> that could make sense
20:09:41 <iccha_> what goes in upgrade notes?
20:09:45 <markwash> good question :-)
20:10:00 <markwash> that same page has the release notes for other projects, we can take their lead a bit
20:10:42 <markwash> yeah, it looks like new config is definitely appropriate
20:10:50 <iccha_> ah gotcha, I can try taking a stab at it
20:10:59 <markwash> iccha_: can i #action you for that?
20:11:07 <iccha_> yes sir markwash
20:11:23 <markwash> #action iccha_ to consider and add upgrade information to glance havana release notes
20:11:31 <markwash> anybody else?
20:11:37 <markwash> erm, or questions?
20:12:17 <markwash> cool
20:12:18 <buzztroll> sorry, i want to be more active on that but i dont see having time for it in the short term :-(
20:12:23 <markwash> no worries
20:12:26 <markwash> we do as we can
20:12:33 <markwash> #topic design summit
20:12:49 <markwash> there have been a fair number of submissions for talks at the design summit
20:12:55 <markwash> #link http://summit.openstack.org/cfp/topic/15
20:13:10 <buzztroll> forbidden
20:13:13 <zhiyan> markwash: Forbidden
20:13:13 <markwash> doh
20:13:24 <markwash> #link http://summit.openstack.org/
20:13:32 <markwash> that's a bit more general, but I think you can sort by topic
20:13:42 <zhiyan> click 'Topic' column to orderby
20:13:53 <buzztroll> i added one yesterday
20:14:04 <zhiyan> buzztroll: saw, need proxy?
20:14:15 <buzztroll> zhiyan: i do
20:14:27 <buzztroll> zhiyan: it is a pretty clear effort i think
20:14:28 <markwash> i think the person who suggested this item is wondering if we should announce a cutoff date for the submissions?
20:14:38 <buzztroll> zhiyan: i actually made a prototype for it at one point
20:14:57 <buzztroll> markwash: which one?
20:14:59 <zhiyan> markwash: yes, to review them i mean
20:15:09 <markwash> buzztroll: sorry, not the design summit topic, but the agenda item
20:15:12 <buzztroll> ah
20:15:13 <markwash> topic looks good to me
20:15:13 <buzztroll> ok
20:15:58 <markwash> zhiyan: I think the time is running down on that. . its a task for me. . IIUC I could review and approve/reject everything by next meeting, and then folks could get a chance for some more general feedback
20:16:18 <markwash> zhiyan: does having everything reviewed and set up by next meeting for feedback sound good to you?
20:16:33 <zhiyan> markwash: sure, just remember that
20:16:35 <zhiyan> :)
20:16:40 <markwash> lol yes
20:16:54 <markwash> #action markwash announce a cutoff for design summit submissions on the ML
20:17:06 <markwash> #action markwash review design summit submissions for next meeting
20:17:18 <markwash> any other thoughts folks want to share about the summit at this time?
20:17:42 <markwash> cool
20:17:54 <markwash> #topic releasing glanceclient
20:18:23 * markwash searches for a good link
20:18:34 <iccha_> we seem to have major functionaility for glanceclient to talk to glance v2 api in
20:18:43 <markwash> couple of significant bug fixes have gone in here https://review.openstack.org/#/q/status:merged+project:openstack/python-glanceclient,n,z
20:18:46 <markwash> erm
20:18:48 <markwash> #link https://review.openstack.org/#/q/status:merged+project:openstack/python-glanceclient,n,z
20:19:15 <markwash> I'd like to do a minor release very soon to grab those fixes
20:19:29 <markwash> in particular I'm worried that the ones russ did are probably really important otherwise why would he bother?
20:19:41 <iccha_> what version is gc currently on?
20:20:08 <markwash> 0.11.0
20:20:20 <markwash> as for a major release
20:20:26 <markwash> there is something I've been stewing on for a while in private
20:20:38 <markwash> I really don't care for the fact that we use our own SSL stuff
20:20:49 <markwash> and I think we should switch to using requests
20:21:09 <iccha_> could you elaborate markwash ?
20:21:11 <buzztroll> on first read that makes a lot of sense to me
20:21:27 <markwash> bcwaldon was churning on both those items, but couldn't come up with a really satisfactory answer, because our custom SSL stuff is there to optionally disable ssl compression
20:21:27 <buzztroll> i havent thought about it before
20:21:40 <markwash> the idea is that disabling compression makes uploads of already compressed images much faster
20:22:05 <markwash> which makes sense, but python just doesn't support it very well yet in terms of common libraries
20:22:25 <markwash> anyway, I think we should revisit the major release in a week or two
20:22:37 <markwash> any objections to a minor release in the next few days?
20:23:01 <buzztroll> in my opinion the transfering of images in terms of efficiency in glance is quite imperfect right now anyway
20:23:26 <markwash> buzztroll: yeah true
20:23:26 <buzztroll> so leaning towards more supportable code and away from efficiency seems ok to me
20:23:34 <esheffield> +!
20:23:39 <markwash> I need to pressure bcwaldon to submit the review if he ahsn't already
20:23:45 <esheffield> er, +1 :-)
20:23:47 <buzztroll> because it is already a neglected category, why have tiny bandaides?
20:23:53 <markwash> yeah
20:24:08 <buzztroll> just my 2 cents there
20:24:14 <markwash> k
20:24:24 <buzztroll> no objection at all to a minor release
20:24:27 <nikhil> buzztroll: :)
20:24:27 <buzztroll> to answer your question
20:24:30 <buzztroll> sounds good
20:24:32 <markwash> #action markwash try-release a minor version of glance client in the next few days
20:24:48 <markwash> #action bcwaldon submit requests review
20:24:52 <iccha_> sounds good
20:24:55 <markwash> okay, moving on
20:25:15 <markwash> #topic bugs
20:25:24 <markwash> some nice folks suggested bugs for us to consider in the meeting
20:25:45 <markwash> first one
20:25:46 <markwash> #link https://bugs.launchpad.net/glance/+bug/1176978
20:26:13 <markwash> the issue is about how our deleted indexes make it so you cannot reuse an image id
20:26:30 <markwash> for most users this has no significance, because they cannot specify the image id on create anyway (by policy)
20:26:36 <buzztroll> ugh
20:26:50 <markwash> I think folks sensibly think its pretty silly to reuse a uuid
20:26:56 <ameade_> yeah
20:26:58 <buzztroll> i think i am on record as not liking the idea of reusing IDs
20:27:02 <buzztroll> yeah
20:27:04 <markwash> however, I think there are some rare operational situations where it makes sense
20:27:11 <ameade_> seems like glance-replicator needs it or something?
20:27:18 <markwash> and i guess we'd just be saving folks the trouble of doing the mysql themselves
20:27:33 <buzztroll> i fear it would move the problem around
20:27:45 <markwash> also I think fixing the underlying db issue would help with some performance areas as well
20:28:14 <markwash> I'm not sure we will have a fast answer in this meeting
20:28:20 <zhiyan> markwash: do you think it is make sense if we support recover a pending-delete status image back to active ?
20:28:28 <buzztroll> markwash: probably not
20:28:44 <buzztroll> markwash: i am trying not to run off on tangents and derails the meeting with this topic
20:28:54 * buzztroll behaves
20:28:57 <markwash> zhiyan: that makes sense, but I'm not sure its necessarily a substitute for what folks are trying to do
20:29:14 <markwash> anyway, i'd love to see folks post their thoughts on the bug if they haven't already
20:29:23 <buzztroll> markwash: cool will do
20:29:35 <markwash> I suspect fixing the db would just pick a winner in this debate anyway
20:29:40 <markwash> anyway
20:29:42 <markwash> next one!
20:29:52 <markwash> #link https://bugs.launchpad.net/glance/+bug/1197344
20:29:55 <nikhil> zhiyan: that would mean adding a re-use option in the CRUD methodology
20:30:00 <ameade_> just marked it as invalid :P
20:30:12 <iccha_> would multiple locations help?
20:30:38 <markwash> basic issue: v2 doesn't show deleted images
20:30:51 * markwash backs up. .
20:30:53 <buzztroll> and it should?
20:30:53 <ameade_> markwash: yeah neither does v1....that used to be a rax thing
20:30:58 <markwash> sorry didn't mean to jump ahead
20:31:08 * markwash revs forward again!
20:31:12 <iccha_> lol
20:31:20 <markwash> I don't really think it should
20:32:05 <markwash> looks like this issue is covered for now
20:32:08 <ameade_> v1 doesn't show deleted images
20:32:10 <iccha_> so we can move on since its marked invalid
20:32:14 <ameade_> so invalid :P
20:32:14 <markwash> +1
20:32:26 <markwash> #link https://bugs.launchpad.net/glance/+bug/967832
20:32:47 <iccha_> glance verifying tenants with keystone has been a topic repeatedly brought up
20:33:01 <markwash> basic issue: if I delete a keystone project, all the images for that project still exist
20:33:21 <markwash> iccha_: I think this bug is related but a little bit different
20:33:36 <iccha_> yeah i was speaking off a similar conversation
20:33:49 <ameade_> i think if we do need this addressed it should probably be handled outside of glance?
20:33:53 <ameade_> that's my gut feeling
20:33:59 <iccha_> and our stance has always been that we want separation of concern
20:34:07 <markwash> yeah, I think that is a fair point
20:34:11 <nikhil> we need superglance
20:34:16 <markwash> in any case its certainly not something we can just solve by ourselves
20:34:25 <markwash> we need either a separate project taht does this cleanup
20:34:37 <markwash> or we need some standard way of consuming openstack notifications to delete things
20:34:42 <markwash> either approach would work
20:34:55 <nikhil> that makes sense
20:35:26 <zhiyan> markwash: i'm thinking again glance-worker ...
20:35:27 <markwash> so I think we really want some TC guidance on this. . I'd really like the TC to adopt/suggest a path forward on this across the board
20:35:28 <nikhil> how can we ensure glance as a stand alone service if it's married to openstack then or that is not one of the goals?
20:35:44 <markwash> nikhil: I think we're married to keystone at least
20:35:47 <markwash> probably nova too
20:35:50 <markwash> (must be Utah)
20:35:57 <nikhil> gotcha
20:35:59 <nikhil> lol
20:36:10 * markwash turns off Sister Wives to focus
20:36:37 <markwash> so maybe we can bring this up during an early TC meeting
20:36:45 <nikhil> no advetisements of TV shows here :P
20:36:49 <iccha_> there is no way for glance to proactively know when things are deleted from keystone.
20:36:52 <iccha_> +1 markwash
20:37:36 <markwash> okay, sounds good. . how do we make sure we don't forget?
20:37:43 <markwash> I don't know when the first TC meeting is
20:38:13 <iccha_> have a separate etherpad for tc -glance communication notes? markwash or keep this etherpad
20:38:14 <markwash> I'll just carry it over on the agenda etherpad
20:38:28 <iccha_> ya one etherpad is better than two
20:38:52 <markwash> cool
20:38:55 <markwash> moving on!
20:39:02 <markwash> #topic reviews
20:39:08 <markwash> I saw one review I just wanted to bring up here briefly
20:39:17 <markwash> https://review.openstack.org/#/c/46715/
20:39:26 <markwash> someone is helpfully contributing unit test coverage
20:39:36 <markwash> several folks have been, actually, adding in use of mock
20:39:42 <markwash> which IMO is much nicer than mox
20:39:42 <ameade_> i would prefer the context manager over decorator
20:39:49 <ameade_> for mock.patch
20:40:01 <ameade_> but i don't have a strong opinion
20:40:06 <nikhil> +1 ameade_
20:40:09 <iccha_> i think there was universal propagation for mock vs mox
20:40:17 <buzztroll> i thought we decided a bit ago that everything would be mock instead of mox from now on?
20:40:20 <markwash> ameade_: thanks, I'm just not that familiar with it so your opinion is very helpful for context!
20:40:29 <nikhil> though nesting is trick with context manager
20:40:40 <markwash> buzztroll: yes. I think we're all good with mock
20:40:54 <markwash> my question is just mock.patch
20:41:10 <markwash> mostly the thing I don't like is that the order of the decorators is the reverse of the order of the extra arguments passed to the test function
20:41:12 <ameade_> nikhil: true story....i think we should just be consistent with one way
20:41:16 <markwash> due to how decorators work
20:41:21 <ameade_> yeah decorators are wack
20:41:41 <vkolosov> Guys, it was my commit. :)
20:41:51 <markwash> okay well I'm not super worried about this patch, I dont think it will kill us even if we don't love mock.patch :-)
20:41:55 <markwash> vkolosov: hi!
20:42:29 <markwash> vkolosov: any thoughts then based on this conversation? keep in mind I'm thrilled for the extra test coverage
20:42:30 <vkolosov> I used decorators to avoid multiple nesting
20:42:36 <vkolosov> That's all. :)
20:42:57 <markwash> hmm, yeah all that tabbing could be worse
20:43:09 <nikhil> it's hard to read/review though with decorators
20:43:16 <vkolosov> I noticed that many unittests actually are not UNIT test
20:43:30 <markwash> vkolosov: yeah :-( they sure aren't
20:43:32 <ameade_> haha no doubt
20:43:33 <vkolosov> So I tried to make them more like "unit"
20:43:49 <nikhil> learn't hard way that tabbing (or not tabbing) could result into a useless tests
20:43:50 <vkolosov> And used a lot of mock decorators
20:43:51 <markwash> vkolosov: we're all on the same page there, but its been slow going, trying to keep sufficient coverage
20:44:20 <ameade_> nikhil, markwash: if we have to nest too deep it's a code smell, i like everything being in the test function...but i really dont wanna dwell on this
20:44:21 <markwash> well, it may be the case that mock.patch is the least problematic way of doing this
20:44:26 <nikhil> vkolosov: :) good point (agree about unit tests)
20:44:41 <nikhil> ameade_: haha true! :)
20:44:43 <markwash> okay, well folks chime in on the review, I'm removing my -1
20:45:00 <ameade_> sounds good, thanks for your efforts vkolosov
20:45:05 <nikhil> +1
20:45:06 <markwash> if nobody has any other concerns I'll probably +2 as is in a few days
20:45:12 <vkolosov> And it would be good to see some other opinions on the review.
20:45:29 <markwash> vkolosov: thanks again
20:45:40 <vkolosov> :)
20:45:55 <vkolosov> I plan to work more on this way.
20:46:01 <markwash> #topic glance async workers checkin
20:46:17 <nikhil> hey
20:46:20 <markwash> despite missing all the meetings this week, we've got some progress with initial branches merging!
20:46:31 <markwash> s/missing/me missing/
20:46:33 <nikhil> thanks markwash and buzztroll!
20:46:58 <markwash> nikhil: it looks like you've got some more review notices there for us to look into in the next few days
20:47:08 <markwash> (there == in the agenda)
20:47:13 <nikhil> yeah,
20:47:38 <nikhil> I'm sure we can review and merge them without other patches needing design approval
20:47:46 <markwash> okay cool
20:47:46 <nikhil> wanted to bring it to everyone's notice
20:47:54 <markwash> I'll give it some more attention then
20:47:58 <nikhil> thanks
20:48:12 <markwash> nikhil: any other notices wrt async stuff?
20:48:28 <nikhil> I feel like we should add more tests around tasks
20:48:35 <zhiyan> nikhil: do you think it's ok for executor part?
20:48:38 <nikhil> even though with images we might have missed a few
20:49:00 <nikhil> and by tasks - I meant db api and REST api
20:49:27 <nikhil> without diving into async part yet - as it is not in images section of the code
20:50:08 <nikhil> markwash: something venkat_ and I felt the pain of fixing stuff
20:50:25 <nikhil> and had to rely on test_tasks_lifecycle for most things
20:50:29 <markwash> ah
20:50:39 <markwash> yeah, more unit testing could be good there. .
20:50:54 <markwash> do you need any help with that, or just refocusing some priorities for you guys?
20:51:02 <nikhil> thanks!
20:51:20 <nikhil> markwash: just trying to focus on the review section in case some one notices it
20:51:23 <markwash> gotch
20:51:28 <nikhil> I saw one review - do not know who posted it
20:51:29 <markwash> s/$/a/
20:51:51 <nikhil> saying this is like images so we should merge it (feel like that would be fast but painful in the future)
20:51:59 <nikhil> something to look out for in this huge patch
20:52:03 <markwash> okay cool
20:52:04 <nikhil> let me check the patch
20:53:15 <markwash> if there's nothing else on async, we can talk about the next/last item
20:53:15 <nikhil> well, ignore me for now (might be remembering a irc comment if not the review comment)
20:53:20 <markwash> ah okay
20:53:29 <markwash> #topic gnome OPW project ideas
20:53:45 <markwash> #link https://wiki.openstack.org/wiki/OutreachProgramForWomen/Ideas
20:53:49 <buzztroll> i wonder if any of the design summit proposals would be good for that?
20:54:01 <nikhil> :)
20:54:08 <markwash> buzztroll: oh neat
20:54:09 <iccha_> if we have any small project in glance we would like an intern to work on we can add it to the ideas page
20:54:20 <ameade_> rewrite the unit tests
20:54:22 <markwash> there may be a few things like that
20:54:22 <ameade_> heh
20:54:24 <iccha_> the internship is from dec- mid - march mid i think
20:54:38 <iccha_> i dont think they ll pick glance if the project is to rewrtie tests
20:54:41 <markwash> buzztroll: do you think moving storage out could be good for that?
20:54:50 <buzztroll> it could be yeah
20:54:57 <buzztroll> there are some nuances
20:55:04 <nikhil> +1 from me
20:55:05 <buzztroll> like backward compat
20:55:07 <markwash> nikhil: and do you think stevedore (which i know you've been looking at) could be a good fit for external storage modules?
20:55:19 <buzztroll> i used it in nova
20:55:26 <buzztroll> and i ahve a prototype with it actually
20:55:29 <buzztroll> if i can find it
20:55:32 <markwash> ah cool
20:55:38 <buzztroll> it seems to be the blessed OS way now, right?
20:55:40 <nikhil> markwash: I feel like stevedore can fit in great for multi-backend approach
20:55:54 <markwash> I'm glad to know you guys have already covered this ground. . sounds very reasonable
20:55:55 <buzztroll> it just hurts the legacy way to load a little
20:56:01 <buzztroll> will take a shoe horn there
20:56:15 <markwash> well we should also keep an eye out for other opportunities here
20:56:20 <buzztroll> or a decree from our benevolent PTL 'backward compat be dammed!'
20:56:21 <markwash> because the OPW seems like a great program
20:56:26 <buzztroll> yeah
20:56:30 <markwash> I'm personally pretty bad at thinking of tasks like that
20:56:33 <buzztroll> it all depends on the itern that you get
20:56:36 <iccha_> +1
20:56:38 <buzztroll> i have done GSoC in the past
20:56:42 <buzztroll> which i think is similar
20:56:44 <iccha_> some of them are not very technical
20:56:48 <buzztroll> and i was a mixed bag
20:56:52 <markwash> take a simple well defined task and I'll figure out how to complicate it to the point that I can't explain how I want it done anymore, so I just do it myself :-)
20:56:57 <iccha_> but want to forray into technology
20:57:08 <nikhil> buzztroll: even gsoc is not technical?
20:57:19 <iccha_> last time i tried making the intern do some pythonclient features
20:57:28 <markwash> oh crap, running out of time
20:57:31 <buzztroll> hmmm gsoc is technical
20:57:38 <markwash> #topic open discussion
20:57:39 <buzztroll> maybe i do not understand the program, ill read up on it more
20:57:44 <markwash> firehoses open!
20:57:47 <ameade_> how do you win the bid if you aren't technical
20:58:18 <nikhil> software engineering to me seems more process oriented that technology oriented
20:58:42 <nikhil> -2 mins?
20:58:52 <markwash> yeah
20:59:07 <markwash> -1 !
20:59:21 <iccha_> flwang had a baby bot
20:59:25 <iccha_> *boy
20:59:28 <nikhil> :D
20:59:36 <nikhil> that was on purpose I bet
20:59:41 <markwash> heh I was thinking, I didn't know flwang was a robot :-)
21:00:04 <nikhil> since the b'day was 10.01 at 00.01 in 2013 right?
21:00:05 <markwash> congrats flwang!
21:00:23 <markwash> okay, out of time. . lets make way
21:00:29 <ameade_> peace out
21:00:30 <iccha_> see ya folks!
21:00:30 <markwash> (also I need lunch I guess0
21:00:35 <markwash> thanks errbody
21:00:39 <markwash> #endmeeting