20:02:05 <markwash> #startmeeting glance
20:02:06 <openstack> Meeting started Thu Feb 20 20:02:05 2014 UTC and is due to finish in 60 minutes.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:08 <marun> mdhami: thanks!
20:02:09 <openstack> The meeting name has been set to 'glance'
20:02:15 <mdhami> bye
20:02:17 <nikhil__> o/
20:02:22 <markwash> o/ !
20:02:23 <arnaud___> o/
20:02:28 <markwash> greetings glance folks
20:02:30 <hemanth_> o/
20:02:39 <markwash> #link agenda https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:02:41 <iccha_> hey
20:03:10 <markwash> since we're getting close to icehouse-3 closing I wanted to do another review/unblocking focused one
20:03:33 <markwash> but first a few quick items
20:03:42 <markwash> #topic artifacts api status checkin
20:04:13 <markwash> hmm
20:04:25 <markwash> not sure we have anyone present for that item
20:04:31 <gokrokve> Hi
20:04:35 <markwash> there he is!
20:04:46 <gokrokve> Sorry for the delay.
20:04:48 <markwash> gokrokve: any status update to report?
20:05:01 <gokrokve> We are working on the API part.
20:05:28 <gokrokve> We did not do much as we were busy with Murano incubation preparation. I promise to start working actively on it.
20:05:54 <gokrokve> There was a discussion on a whiteboard for some specific use cases to be covered in artifacts repo.
20:06:12 <markwash> I've been exchanging some emails of design discussion with jbernard and ativelkov
20:06:19 <markwash> mostly related to instance templates
20:06:20 <gokrokve> It is related to keeping dependencies between artifacts.
20:07:03 <markwash> gokrokve: yes, I think there are a lot of use cases we should be keeping in mind as folks are designing the pai
20:07:07 <markwash> s/pai/api
20:07:13 <gokrokve> There is a use case from kfox1111.
20:07:51 <markwash> #link https://blueprints.launchpad.net/glance/+spec/artifact-repository-api
20:08:01 <markwash> okay, seems there is not much more for public consumption yet
20:08:09 <arnaud___> gokrokve: I think more important than the relation betweens artifacts is the relation of the things that are inside the artifact
20:08:10 <markwash> but let's see if we can push in that direction in the next week or two
20:08:14 <gokrokve> The question do we want to have these dependencies static (i.e. with referencing them by id) or dynamic (reference by name and version or just by name)
20:08:24 <gokrokve> I think we will discuss this via e-mail in details
20:09:02 <gokrokve> arnaud___: Agree. But this is only one use case. It is better to discuss all possible use cases to choose proper design.
20:09:24 <gokrokve> Alex promised to write an e-mail about that.
20:09:41 <markwash> is that email still in progress or did I miss it?
20:09:50 <arnaud___> gokrokve: I have several use cases that I want to make sure to be covered by artifacts (ovf, versions of images, images on different stores)
20:09:53 <gokrokve> Its not sent yet I believe.
20:10:31 <gokrokve> arnaud___: Please share them on a white board or attach an etherpad.
20:10:40 <markwash> is there some place we should start aggregating these use case suggestions?
20:10:42 <arnaud___> sounds good
20:10:52 <arnaud___> could you share the link here
20:11:07 <markwash> link to bp and whiteboard is given above
20:11:10 <arnaud___> (sorry missed it)
20:11:13 <markwash> #link https://blueprints.launchpad.net/glance/+spec/artifact-repository-api
20:11:22 <gokrokve> Etherpad will work fine for use cases aggregation.
20:12:04 <markwash> all right, so we want that etherpad, alex's email, and continued progress on publicly shared design info
20:12:28 <markwash> sounds good
20:12:36 <markwash> #topic blueprint triage
20:12:53 <markwash> I have been a little out of review form for the past week or so, becuase I've been spending my time on this
20:13:05 <markwash> #link https://wiki.openstack.org/wiki/Glance/Drivers
20:13:25 <markwash> if you have a lot of blueprints you might have noticed a lot of notifications from launchpad with my comments
20:14:03 <markwash> anyway, the basic idea is this
20:14:16 <markwash> I've written a tool that is helping me keep track of blueprints that are triaged or new or need more information
20:14:32 <markwash> so far I've gone down from 80+ unreviewed blueprints to only 20
20:14:53 <iccha_> its a pretty nifty tool markwash
20:15:01 <markwash> I guess if anyone is more interested in this, just let me know, or check out the code yourself
20:15:08 <markwash> #link https://github.com/markwash/hoke
20:15:15 <markwash> moving on :-)
20:15:22 <markwash> #topic icehouse-3 bugs
20:15:35 <markwash> first one "Don't enable all stores by default" flaper87|afk
20:15:52 <markwash> #link https://bugs.launchpad.net/glance/+bug/1255556
20:16:01 <markwash> seems flaper87|afk is not here, probably timezone issues
20:16:32 <markwash> anyway, the takeaway from this one is that I talked to dean troyer and we figured out the problem is that the devstack changes need to be backported to stable/havana
20:16:51 <markwash> anyone can do that to unblock the review, but I'll action flaper87|afk
20:17:17 <markwash> #action flaper87 backport devstack changes to stable/havana for https://bugs.launchpad.net/glance/+bug/1255556
20:17:34 <markwash> next up: "image status set to killed even if has been deleted"
20:17:42 <markwash> #link https://bugs.launchpad.net/glance/+bug/1236868
20:18:10 <markwash> zhiyan: I think the blocker here is some confusion between us perhaps?
20:18:17 <markwash> review here:
20:18:24 <markwash> #link https://review.openstack.org/#/c/50457/10
20:18:56 <zhiyan> markwash: oh, i think you are proposing a new fix approach right?
20:19:19 <markwash> zhiyan: yes, it seemed to me that a slightly smaller change would give a more desirable result
20:19:31 <zhiyan> markwash: which are using db level check to prevent race condition issue right?
20:19:34 <markwash> zhiyan: can we meet to discuss it my tomorrow morning, your later tonight?
20:20:10 <zhiyan> markwash: maybe your tomorrow morning?
20:20:13 <markwash> yeah
20:20:32 <zhiyan> markwash: actually i think that approach is cool to me/us
20:21:13 <markwash> is it? I'm worried that I"m just confused about the problem
20:21:45 <markwash> zhiyan: but if it makes sense to you and it doesn't seem like I'm just confused, if you would just switch to -1 on that review it would probably send the right message
20:22:02 <zhiyan> markwash: i believe those two ways are all can work
20:22:19 <markwash> okay, just want to make sure we get unstuck
20:22:26 <markwash> if you want I'm definitely available to discuss it tomorrow morning
20:22:46 <zhiyan> markwash: ok, the reason to me is that current change is correct
20:23:00 <zhiyan> markwash: but seems you r proposing a new approach
20:23:14 <zhiyan> markwash: but i'm ok to switch -1 if you like
20:23:33 <zhiyan> markwash: if you like to go with that way
20:23:37 <markwash> zhiyan: okay let's try to follow up
20:23:53 <markwash> next up
20:24:10 <markwash> notifiier traps and recodes exceptions
20:24:11 <markwash> #link https://bugs.launchpad.net/glance/+bug/1223516
20:24:31 <markwash> this bug is just a notice for reviewers
20:24:43 <markwash> it looks like zhiyan is already taking good care of it but of course it will need more than one core reviewer
20:25:12 <markwash> any concerns about this one, zhiyan, or is it just nits at this point?
20:25:53 <markwash> review link https://review.openstack.org/#/c/73530/
20:25:57 <zhiyan> markwash: there will have a new ps
20:26:05 <markwash> gotcha okay
20:26:22 <markwash> next one up
20:26:31 <zhiyan> to try to reorganize the exception handling stracutre within image_data.py
20:26:42 * markwash nods
20:26:56 <markwash> "Log image_id with all BadStoreURI error messages"
20:27:02 <markwash> #link https://bugs.launchpad.net/glance/+bug/1243704
20:27:23 <markwash> venkatesh is not around it seems
20:27:50 <markwash> my question on this bug: is there still a strong push for addressing this concern? or can we bump it from the list?
20:28:15 <markwash> ah, nm
20:28:22 <markwash> looks like he will be pushing a new patchset soon
20:28:30 <markwash> okay that's all the bugs that are fit to print
20:28:34 <markwash> let's look at blockers on blueprints
20:28:38 <markwash> #topic icehouse-3 blueprints
20:29:02 <markwash> i18n message improvements
20:29:03 <markwash> #link https://blueprints.launchpad.net/glance/+spec/i18n-messages
20:29:15 <markwash> flwang: I have two questions for you on this one
20:29:22 <markwash> flwang: well one question and one request
20:29:41 <markwash> flwang: first, there is one patch up for review, how much more do you think is needed to land this in icehouse?
20:29:48 * markwash hopes flwang is here. . .
20:30:24 <markwash> my request was for a little bit of explanation of how it all works
20:30:29 <markwash> I will follow up with flwang
20:30:41 <markwash> #action markwash follow up with flwang about https://blueprints.launchpad.net/glance/+spec/i18n-messages
20:30:50 <zhiyan> iirc, flwang just told us in last meeting, #71398 should be the last one...
20:30:56 <markwash> oh okay
20:30:59 <markwash> forgetful me
20:31:11 <markwash> zhiyan: thanks
20:31:15 <markwash> next up
20:31:18 <markwash> #link https://blueprints.launchpad.net/glance/+spec/split-image-size
20:31:23 <markwash> can anyone confirm that this one is done?
20:31:30 <zhiyan> np at all. (maybe i'm forgetful)
20:32:26 <zhiyan> and btw, seems i18n change #71398 has a some question like to know arnaud___'s input
20:32:53 <arnaud___> yes zhiyan I wanted to pm flwang yesterday but he wasn't there
20:33:05 <arnaud___> I will follow up with him today
20:33:13 <arnaud___> tomorrow for you :)
20:33:31 <zhiyan> thanks arnaud___, just raise this btw, since you are here now you know
20:34:02 <markwash> arnaud___: okay perhaps I can lurk during that conversation
20:34:12 <arnaud___> yes sounds good
20:34:13 <markwash> the feature seems good I just want to make sure I understand the various moving parts
20:34:19 <arnaud___> tbh, I need more info
20:34:35 <markwash> at first I was very confused about how _('foo') could be localized differently for logs vs api responses
20:34:43 <arnaud___> to understand what is potentially harmful and what is not
20:34:54 <zhiyan> arnaud___: me too, so maybe non-pm is better
20:34:55 <zhiyan> anyway
20:35:01 <arnaud___> ok sounds good
20:35:26 <arnaud___> as soon as flwang is available we can discuss this
20:35:29 <markwash> arnaud___: yes if you can try to ping me and zhiyan when you get a hold of flwang that would be graet
20:35:36 <arnaud___> yes! sounds good
20:35:44 <zhiyan> thanks. next pls
20:35:50 <markwash> BTW, for next blueprint, I've asked flaper87|afk on the whiteboard if its done
20:36:13 <markwash> next up: status property on image locations
20:36:17 <markwash> #link https://blueprints.launchpad.net/glance/+spec/image-location-status
20:36:30 <markwash> I think there are 3 patchsets that need to land still
20:36:36 <zhiyan> pls folks give some review
20:36:44 <markwash> yeah, that
20:36:56 <arnaud___> I will look at it more today zhiyan
20:37:00 <zhiyan> and arnaud___'s comments had been addressed, thanks btw
20:37:00 <markwash> zhiyan: sorry, I have spent way to much time doing blueprint review :-)
20:37:27 <zhiyan> thanks markwash. and any potential reviewers
20:37:35 <zhiyan> np at all
20:37:37 <markwash> zhiyan: can you quickly summarize the domain and api changes?
20:37:53 <zhiyan> ok
20:38:04 <zhiyan> api changes has two part
20:38:12 <zhiyan> db api and restful api
20:38:43 <zhiyan> i add a new db api to allow upper layer request delete a single image location with a target status
20:39:24 <zhiyan> and in restful api controller, i ask glance only return "active" location entries back to client
20:40:27 <markwash> this will make it possible for scrubber to just look for 'pending_delete' locations ?
20:40:55 <zhiyan> yes
20:41:09 <markwash> okay cool
20:41:14 <markwash> thanks
20:41:16 <zhiyan> the main domain's change is in store level
20:41:20 <markwash> taht should help me get started on the review
20:41:22 <markwash> next up!
20:41:37 <markwash> #link https://blueprints.launchpad.net/glance/+spec/community-level-v2-image-sharing
20:41:44 <zhiyan> to extract image (location) delete functions to a new common file
20:41:45 <zhiyan> ok
20:41:53 <markwash> oh, and I accidentally skipped the discussion about the "community" name
20:41:55 <markwash> maybe we can do it now?
20:41:59 <markwash> iccha_: ^^
20:42:26 <iccha_> yes
20:42:40 <iccha_> so there has been some discussion about the name community
20:42:49 <iccha_> it is basically a visibility filter name
20:43:05 <iccha_> to indicate that the image is available to everyone but doesnt appear in their image list
20:43:28 <iccha_> a lot of terminology has been thrown around - community, broadcast, open, published
20:43:41 <iccha_> wanted to know if anyone had any strong opinions thoughts or any other suggestions
20:44:22 <arnaud___> I still feel like community doesn't describe well what this filter does
20:44:26 <arnaud___> :)
20:44:57 <markwash> I guess we really want something that means "shared with all"
20:45:01 <iccha_> rosmaita: ^
20:45:51 <arnaud___> back to my initial concern, markwash: it is not exactly shared with all
20:45:59 <markwash> oh
20:46:02 <zhiyan> may i know when we finish this feature, who has the permissions to share that things?
20:46:04 <arnaud___> it is "public" but need to be accepted
20:46:22 <iccha_> the owner gets to make their image available to all zhiyan
20:46:40 <iccha_> it is still available , 'accepting' it only makes it appear in their image list
20:47:00 <markwash> arnaud___: hmm, I'm a little confused, becuase I think that restriction is present in normal p2p shared images as well
20:47:37 <rosmaita> zhiyan: image owner can make the image "community"
20:47:50 <arnaud___> yes but since glance doesn't have group sharing, it is not like something you share and you know that only you have access to it
20:48:11 <zhiyan> ok, seems it share the image to other tenants directly, but don't need them accept, right?
20:48:39 <rosmaita> zhiyan: makes the image available for any tenant to boot an instance from
20:48:52 <iccha_> yes zhiyan
20:48:57 <rosmaita> zhiyan: they only need to "accept" if they want it to appear in their image-list
20:49:03 <zhiyan> tbh it sounds like that old security issue, which we resolved. what's the different/limitation there? to prevent "anti-spam"?
20:49:10 <arnaud___> the owner "publishes" it, and the tenants "subscribe" to it by accepting it
20:49:12 <zhiyan> am i misunderstanding?
20:49:55 <rosmaita> zhiyan: you are right, the "accept" bit is just to prevent spam
20:50:24 <markwash> well, maybe we can review the code while coming up with some more alternative suggestions for the name, and ensure we have the name resolved at or before next weeks meeting?
20:50:46 <markwash> I can see the problem with "community"
20:51:01 <rosmaita> well, it's like the open source commnunity
20:51:05 <rosmaita> you don't have to be a member
20:51:07 <markwash> but I'm not very excited about the alternatives yet
20:51:09 <rosmaita> but you can be if you want to
20:51:36 <markwash> is_public2
20:51:47 <markwash> haha
20:51:48 <iccha_> hehe
20:51:49 <rosmaita> -2000 !
20:51:51 <markwash> sorry
20:51:54 <arnaud___> lol
20:52:07 <rosmaita> is_sorta_public
20:52:18 <markwash> okay, let's keep working on this name and pick our least unfavorite in a finite amount of time
20:52:43 <markwash> last but not least
20:52:50 <markwash> async / import
20:53:10 <markwash> nikhil__: looks like you've been busy
20:53:21 <nikhil__> hey
20:53:30 <nikhil__> I added some comments to the agenda
20:53:31 <markwash> and have posted some review links for us in the agenda
20:53:35 <markwash> yes, thank you for that!
20:53:48 <markwash> I like the shape of the first change in the list, I haven't looked much at the others yet, but will
20:54:00 <nikhil__> oh, great
20:54:35 <nikhil__> markwash: have communicated with Flavio on the intentions this MP is going
20:54:47 <nikhil__> he mentioned that he would like to be more involved
20:54:54 <markwash> okay cool
22:06:59 <davidlenwell> the bot seems like its back
22:07:16 <openstack> davidlenwell: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
22:07:28 <davidlenwell> #endmeeting