20:07:00 <markwash> #startmeeting glance
20:07:00 <openstack> Meeting started Thu May  1 20:07:00 2014 UTC and is due to finish in 60 minutes.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:07:03 <openstack> The meeting name has been set to 'glance'
20:07:09 <markwash> Greetings glancelings
20:07:22 <mclaren> hi markwash
20:07:30 <ativelkov> hi
20:07:34 <rosmaita> hello
20:07:40 <arnaud___> hi
20:07:45 <zhiyan> hi
20:08:26 <markwash> Great, looks like we've got some folks here. Sorry again that I am late
20:08:30 <markwash> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:08:36 <markwash> meeting agenda ^^
20:08:37 <nikhil___> o/
20:09:09 <eddie_> o/
20:09:12 <markwash> I have a few items there, main thing is to talk about artifacts design stuff
20:09:43 <markwash> So let's run through the quicker items I have first
20:09:59 <markwash> First things first
20:10:08 <markwash> #topic Design summit
20:10:11 <markwash> the schedule is posted
20:10:17 <markwash> maybe somebody has the link handy?
20:10:43 <markwash> my browser remembers!
20:10:44 <markwash> #link http://junodesignsummit.sched.org/overview/type/glance
20:11:10 <markwash> I didn't hear back from anybody about conflicts so I assume we're good with that general layout
20:11:17 <markwash> I think descriptions might still get updated
20:11:23 <mclaren> o/
20:11:47 <markwash> any thoughts anyone would like to share about the summit layout and the way I munged sessions together?
20:12:01 <mclaren> I've something kinda related?
20:12:06 <markwash> go for it mclaren
20:12:29 <mclaren> On the backend storage thing I mentioned at the last glance mini-summit
20:12:31 <nikhil___> markwash: are we doing something on Friday? did not see any unconference slots, so was wondering if Friday was being planned for the same?
20:12:42 <mclaren> we've put in a blueprint here: https://etherpad.openstack.org/p/Swift_trusted_services
20:13:06 <mclaren> and we've actually implemented the approach in that blueprint (different to what I proposed at the mini summit)
20:13:14 <mclaren> the patches are listed at the end of the etherpad
20:13:19 <mclaren> my question is
20:13:33 <mclaren> I'm way too late to the party to get an official slot
20:13:52 <mclaren> is this something we could have an unconference session for perhaps?
20:14:16 <rosmaita> i would like to see that
20:14:42 <markwash> mclaren: its not too too late but I think there would need to be something like a vote or broader consensus
20:15:09 <markwash> we'd have to figure out what was going to get bumped or merged
20:15:24 <markwash> nikhil___: we'll come back to your question in one sec
20:15:26 <mclaren> absolutely, not trying to be pushy :-)
20:15:59 <nikhil___> mclaren: +1 from me if it works out :)
20:16:02 <ameade> o/
20:16:54 <markwash> I'm not seeing exactly where it would fit in
20:17:16 <mclaren> yeah its tricky, its kinda cross-project too
20:17:28 <markwash> mclaren: I don't suppose anyone has any suggestions about how to rearrange the schedule? or if someone who has a whole slot wants to share?
20:17:53 <markwash> that's a bit sad
20:18:03 <rosmaita> is there any way we can just meet in the dev lounge on friday?
20:18:09 <mclaren> if its not possible don't worry, I realise I'm super late
20:18:12 <rosmaita> have our own unconference session for glance
20:18:20 <markwash> well, I think there will be a glance project pod
20:18:25 <arnaud___> also, to have people not too much confused: the title of the session might hide more than 1 submitted session
20:18:38 <markwash> and I think there might be a cross-project pod in some locations?
20:18:57 <mclaren> yeah some kind of informal gathering might be our best option at this point
20:18:58 <arnaud___> for example: Glance Store and future features contains: Flavio's and Fei's
20:19:06 <markwash> arnaud___: good point
20:19:36 <markwash> nikhil___ and rosmaita: regarding friday, I have to leave Atlanta friday morning to make it to DC for a wedding
20:19:57 <rosmaita> ok
20:20:03 <markwash> so I will not be able to attend any such sessions. However I would encourage you to still have them in my absence
20:20:11 <mclaren> it may be tangentially related to the glance store rejig that flavio is considering
20:20:13 <arnaud___> yep or have a lunch
20:20:20 <markwash> so that later I can come running through kicking over sandcastles
20:20:23 <markwash> not
20:21:01 <markwash> :-)
20:21:22 <mclaren> ok, I'll send mail around to try and get folks together in some way, eg unconferance -- thanks
20:21:41 <markwash> let's briefly talk etherpads
20:22:05 <markwash> If you have a session or part of a session, you're probably going to want to have an etherpad and some blueprint / design docs that people can review before the session
20:22:26 <markwash> so lets get those etherpads started now
20:22:59 <markwash> and if its a topic that has already been discussed a lot and has some existing etherpads, give a careful look to determine if you need to clean up those old etherpads rather than just re-using them for the summit
20:23:07 <markwash> clarity matters for participants so keep it in mind
20:23:21 <ameade> can those be linked into the sched descriptions or should they be emailed to the list?
20:23:23 <markwash> ideally we'd have the etherpads ready by next week to include links in the summit wiki
20:23:37 <markwash> ameade: usually we just put them on a summit-wide wiki
20:23:57 <markwash> but it doesn't hurt to link them anywhere, and I'm happy to update summit descriptions for that or other purposes
20:24:03 <markwash> let me just #action these real fast
20:24:14 <ativelkov> what should be the structure of the pad? session agenda + brief on proposed topics?
20:24:17 <markwash> #action write your summit etherpads and make sure they're clear
20:24:40 <markwash> #action notify markwash if you have any changes you want made to summit descriptions that show up in sched.org
20:25:00 <markwash> ativelkov: yes, basically the goal of the session should be laid out in an agenda-like format
20:25:18 <markwash> and we will add notes as we go through the discussion
20:25:38 <markwash> the sessions are very much discussions with broad participation, rather than just talks led by someone
20:25:49 <markwash> so an etherpad can help herd all the cats in the right directions
20:25:58 <markwash> so to speak
20:26:06 <nikhil___> wolves, you mean ;)
20:26:22 <markwash> hehe
20:26:57 <markwash> okay, any other thoughts on design summit? I'm through with my requests
20:27:39 <nikhil___> any informal events all glance folks going to?
20:27:52 <nikhil___> meant, specifically
20:28:32 <nikhil___> if Friday lunch/gathering covers it please ignore
20:28:35 <markwash> I'm not really aware of anything like that yet
20:28:56 <markwash> okay, let's move on I guess
20:29:03 <markwash> #topic juno mini glance summit
20:29:11 <markwash> I have no updates yet but I'm still thinking about this
20:29:26 <markwash> probably I'll ask ttx next chance I get for some tips about possible foundation support
20:29:43 <mclaren> I, well HP, could possibly offer support
20:30:07 <markwash> mclaren: cool, good to know
20:30:18 <ativelkov> Any ideas on possible date and location?
20:30:22 <markwash> my plan is to give the foundation right of first refusal
20:30:30 <mclaren> an administrator for sure, maybe $, but would probably have to be based in Ireland (always a catch!), I'm guessing US mainland is preferred option?
20:30:56 <markwash> mclaren: I hear hp has some offices in california ;-)
20:31:08 <zhiyan> it will be cool if team could provide a remote access way
20:31:15 <mclaren> really? :-)
20:31:37 <mclaren> what I meant is I just checked with the local office rather than corporate if that makes sense?
20:31:39 <markwash> okay, I'll just carry this item forward to next week
20:31:41 <markwash> or the next actual week
20:31:54 <markwash> that we have a meeting
20:32:13 <arnaud___> vmware could also possibly host the event in the bay area
20:32:30 <markwash> we'll probably have to have a call for sponsors
20:32:41 <markwash> but again, foundation first
20:33:16 <markwash> okay let's move on to the main event!
20:33:32 <markwash> #topic artifacts design
20:33:53 <markwash> how are folks doing with their review? mostly done?
20:34:23 <markwash> I saw some notes on the ML
20:34:29 <markwash> (again that doc is here: https://docs.google.com/document/d/1tOTsIytVWtXGUaT2Ia4V5PWq4CiTfZPDn6rpRm5In7U/edit?usp=sharing)
20:34:30 <ativelkov> There are a number of comments in the document
20:35:10 <ativelkov> Adrian Otto has provided some help in polishing the text
20:35:23 <markwash> I have to admit at this point I have not found the time to review the document closely. I've been unfortunately very busy and distracted
20:35:50 <arnaud___> I started to read it yesterday night... will finish by the end of the week
20:36:52 <markwash> my only immediate reaction is that there might be some things about images that don't need to carry forward to images
20:37:03 <markwash> but I'd like to make that critique more specific, obviously :-)
20:37:37 <arnaud___> there is one point that I would like to discuss
20:37:54 <arnaud___> the set of artifacts that glance contains by default
20:38:15 <arnaud___> I mean that Glance natively supports
20:38:20 <ativelkov> arnaud___: you mean the types of artifacts?
20:38:23 <arnaud___> yes
20:38:54 <arnaud___> the way I see it, is kinda the same as the stores where we have file/http by default
20:39:12 <arnaud___> type: image/bulk data artifact
20:40:20 <arnaud___> is it the way you see it too ativelkov? or you expect let's say heat artifact to be natively "first class" artifact
20:40:35 <arnaud___> because you are talking of a plugin mechanism to add new artifacts
20:40:52 <arnaud___> so I would like to know if heat for example comes through this plugin mechanism
20:40:56 <arnaud___> or is there natively
20:41:01 <arnaud___> you see what I mean?
20:41:08 <ativelkov> Well, I would have everything done as plugins, even the images - just for unification
20:41:27 <ameade> +1
20:41:42 <ativelkov> The images plugin will be the part of the core code, while everything else may stay in some special repository
20:42:06 <arnaud___> ok, so the separation would be a different repository
20:42:19 <arnaud___> I see
20:42:23 <ativelkov> And we need to define the process of "incubating" the plugins, i.e. accepting them as "officially supported", reviewed etc
20:42:44 <arnaud___> yep
20:42:51 <arnaud___> do you discuss that in the doc?
20:42:56 <arnaud___> maybe the part that I didn't read :)
20:43:29 <ativelkov> Nope. This was discussed last wek and I din't have time to update the doc
20:43:38 <arnaud___> ok!
20:44:29 <markwash> arnaud___: did you have a chance to catch randall burt about sharing the session leadership at the summit
20:44:40 <arnaud___> no
20:44:46 <arnaud___> I talked to ativelkov only
20:45:23 <markwash> I'll see if I can reach out to him
20:45:34 <arnaud___> sounds good
20:45:36 <markwash> (actually I think this might have already been an item for me and I just forgot, sorry!)
20:46:00 <arnaud___> also, I think it would be nice to come with a strategy to validate the parts we agree and we can start implementing
20:46:01 <markwash> okay, so it sounds like people either completely love the artifacts design, or are perhaps waiting a bit for the summit to get a chance to review
20:46:23 <ativelkov> What is missing are the actual API specs
20:46:44 <markwash> arnaud___: +1
20:46:58 <ativelkov> I'll to try to have a draft of them at apiary before the summit starts
20:47:10 <markwash> "hit the ground running" is a theme we should be aiming for post-summit
20:47:21 <rosmaita> +1
20:47:24 <arnaud___> yep
20:48:50 <ativelkov> BTW, folks, are you aware of project called "graffiti"?
20:49:01 <ativelkov> https://wiki.openstack.org/wiki/Graffiti
20:49:07 <arnaud___> I know there is a session about it at the summit
20:49:42 <arnaud___> Tuesday, May 13 • 2:00pm - 2:40pm
20:50:12 <ativelkov> It seems like they are moving in the same direction
20:50:33 <markwash> link to summit session?
20:50:45 <arnaud___> http://junodesignsummit.sched.org/event/555561439e8187a25985473ea53cc078
20:52:00 <markwash> okay, looks like we've exercised about as much as we can
20:52:12 <markwash> so I think we can just encourage more people to read through the docs and comments
20:52:16 <markwash> sound good?
20:52:38 <ativelkov> +1
20:52:45 <markwash> great
20:52:48 <markwash> #topic open discussion
20:52:59 <markwash> should we have a meeting next week or take the week off?
20:54:07 <ameade> maybe next week we could go through the sessions to make sure preparation has been done and links to ehterpads posted and such?
20:54:21 <arnaud___> +1 ameade
20:54:42 <ativelkov> Agree. Also, may be we'll get some more feedback on artifacts
20:55:44 <markwash> okay sounds good
20:57:11 <markwash> okay looks like we're done
20:57:13 <markwash> thanks folks
20:57:26 <markwash> see you next week for round two of summit + artifacts
20:57:31 <markwash> #endmeeting