14:11:32 <nikhil__> #startmeeting glance
14:11:34 <openstack> Meeting started Thu May 22 14:11:32 2014 UTC and is due to finish in 60 minutes.  The chair is nikhil__. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:11:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:11:37 <openstack> The meeting name has been set to 'glance'
14:11:45 <nikhil__> roll call
14:11:48 <nikhil__> o/
14:11:51 <flaper87> o/
14:11:53 <hemanth_> 0/ yes sir
14:11:54 <TravT> o/
14:11:54 <ewindisch> o/
14:11:58 <rosmaita> o/
14:11:59 <gokrokve> Georgy Okrokvertskhov (Mirantis)
14:11:59 <jokke_> o/
14:12:03 <d0ugal> o/
14:12:03 <ameade> o/
14:12:39 <hemanth_> haha, what now?
14:12:47 <hemanth_> do we have an agenda?
14:12:47 <nikhil__> was getting a link
14:12:48 <nikhil__> https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:13:17 <nikhil__> seems like 3 items
14:13:53 <nikhil__> guessing question #1 was answered
14:14:02 <nikhil__> unless someone here has more info
14:15:32 <jokke_> sorry, don't know and mclaren does not seem to be here
14:15:51 <nikhil__> cool
14:16:15 <nikhil__> we can leave that as is and catch up next meeting
14:16:44 <nikhil__> moving to next item, anyone from tuskar here?
14:16:51 <tzumainn> hi!  both d0ugal and I are here
14:16:59 <d0ugal> Hi :)
14:17:21 <tzumainn> we're extremely interested in the prospect of using glance to store HOT templates
14:17:45 <tzumainn> and were wondering - is there an optimal way to keep up-to-date with development progress, perhaps test things out, help if needed, etc. . . ?
14:18:09 <flaper87> I think the best way is helping out and watching glance on gerrit
14:18:20 <flaper87> It would be really useful to get your feedback on thsoe reviews
14:18:24 <flaper87> and the original proposal
14:18:51 <flaper87> A rough plan came out of that session but I haven't seen it written anywhere
14:19:14 <flaper87> so, it'd be nice to help planning things for juno and start coding on it
14:19:21 <flaper87> I don't believe there's LOT of work there
14:19:29 <flaper87> and it seems to be pretty isolated from the rest
14:19:32 <flaper87> how does that sound?
14:19:49 <tzumainn> that sounds good - is there a primary developer focusing on the development?
14:19:56 <gokrokve> Where is a spec review repo fro glance? I believe Alex will have to add specs for artifact repository.
14:20:34 <nikhil__> anyone has the google doc link handy?
14:20:35 <rosmaita> gokrokve: i don't think the spec repos is ready yet, will know more tomorrow
14:20:50 <tzumainn> https://docs.google.com/document/d/1tOTsIytVWtXGUaT2Ia4V5PWq4CiTfZPDn6rpRm5In7U
14:20:59 <gokrokve> rosmaita: Ok. As soon as we have it we will post artifact repository specs.
14:21:34 <TravT> Regarding that document... I think that the general consensus was to simplify it.  I don't think the outcome of the session has been captured in it.
14:22:23 <tzumainn> okay, so it sounds like you guys are starting up a spec repository like tripleo, and then we can expect a spec for the artifact repository there?
14:23:00 <gokrokve> TravT: Yes. The was a consensus to implement simplified version first. Alex has to create specs for the features which will be implemented in Juno release.
14:23:15 <d0ugal> https://review.openstack.org/#/q/status:open+%28project:openstack/glance-specs%29,n,z
14:25:51 <nikhil__> seems like all the information needs to be put in a single place
14:26:05 <nikhil__> any volunteers for it?
14:26:41 <nikhil__> (possibly work on the doc to simplify it and get notes from summit in there)
14:28:00 <nikhil__> Okay then, we can let people catch up outside of the meeting. Possibly discussing in the next meeting, if needed.
14:28:55 <nikhil__> jokke_: seems like you'r tagged for the next item ;)
14:29:16 <jokke_> Yeah
14:29:36 <jokke_> I walked through quite a bunch of old bugs during the summit week
14:30:19 <jokke_> and I was thinking would it help if we would agree a tag that can be used to flag those old/inactive/incomplete/fixed bugs for closure to clean the list up
14:30:50 <jokke_> so person like me could go and flag the bug and those bugs would be easily found for review
14:31:46 <jokke_> and closure
14:31:57 <nikhil__> +1 from me
14:32:25 <nikhil__> (do we can want to put that on vote here? and let mark see the results to take a decision?)
14:33:36 <jokke_> that's fine by me, but I think we should get some name for that tag as well so we could distribute the info (and make sure that there is no 25 different tags like "toBeClosed" "for_closure" etc.) :)
14:33:52 <nikhil__> yeah
14:34:50 <nikhil__> okay, let's put that as action
14:34:55 <jokke_> I would propose "inactive" as I think the spam bugs are ok for anyone to just mark invalid
14:34:58 <nikhil__> jokke_: do you mind owning that?
14:35:18 <nikhil__> jokke_: it would be good to see what other projects use just to confirm
14:35:51 <jokke_> I can look around and see if other projects uses some mechanism for identifying these
14:35:59 <nikhil__> sounds good
14:37:04 <nikhil__> #action jokke_ get some info from other openstack projects about additional tag for inactive bugs
14:37:36 <nikhil__> last item on agenda before open discussion
14:37:50 <jokke_> I'll put my findings/proposal to the meeting agenda regardless if I'm going to attend or not
14:37:59 <nikhil__> Graffiti developers?
14:38:01 <jokke_> for next week
14:38:04 <nikhil__> jokke_: thanks
14:38:08 <TravT> Graffiti - here
14:38:17 <TravT> We demo'd our Graffiti project POC around metadata "tagging" of various resource types (images, volumes, flavors, etc).  We received very positive feedback and numerous people proposed that we build the Graffiti metadata repository API concepts in Glance. Mark was very interested as well and we had a number of in person discussions.
14:38:32 <TravT> So, we have been digging into that to see what it might mean and are putting together a base proposal, which we'll send out on the mailing list soon for discussion.
14:39:26 <TravT> We also learned quite a bit during our POC, so we're working through those learnings as well.
14:39:38 <TravT> So, this is just a heads up on that.
14:39:45 <nikhil__> that sounds good
14:39:52 <jokke_> TravT: do you know if that demo was recorded? Sounds interesting
14:40:04 <TravT> Unfortunately, it wasn't...
14:40:08 <TravT> Was pretty disappointed
14:40:09 <jokke_> :(
14:40:18 <TravT> but, I was thinking that today I could create new quick demo
14:40:39 <TravT> I mean I could create a quick updated video.
14:40:58 <TravT> I'll send that out, too.
14:41:39 <jokke_> TravT: sounds good
14:42:13 <nikhil__> TravT: great, if you intend to discuss more in next meeting(s), we should tag that as an action item
14:42:30 <TravT> Yes, go ahead
14:42:39 <TravT> we'll want to discuss more, I'm sure.
14:43:24 <nikhil__> #action TravT to work on a demo video for Graffiti
14:43:49 <nikhil__> let's put the meeting for open discussion
14:44:49 <jokke_> One thing I noticed today, reading the wiki ... our feature support matrix is pretty damn outdated ... is there plans to update that or ditch it?
14:45:35 <nikhil__> jokke_: do you have the link handy?
14:45:42 <jokke_> in a sec
14:45:54 <jokke_> https://wiki.openstack.org/wiki/GlanceFeatureMatrix
14:46:10 <nikhil__> seems like we should get that updated
14:46:25 <jokke_> Either updated or removed
14:47:08 <nikhil__> volunteers?
14:47:53 <jokke_> I'm not familiar enough, unfortunately, to do it
14:47:58 <nikhil__> #action decide the fate of feature support matrix
14:48:09 <nikhil__> no worries, thanks for bringing that up
14:48:50 <nikhil__> unless someone has something else, we can have short meeting today
14:49:28 <jokke_> One more question, is there any central place where we who couldn't attend to the summit could read about the outcome of the sessions?
14:50:03 <nikhil__> all the sessions should have a corres. etherpad
14:50:36 <nikhil__> link to it is generally placed in the description of the same
14:50:45 <cpallares> jokke_: https://wiki.openstack.org/wiki/Summit/Juno/Etherpads#Glance
14:50:46 <jokke_> ok, is there a way to browse those etherpads/links to them somewhere?
14:50:58 <jokke_> cool thanks cpallares !!
14:51:02 <nikhil__> thanks cpallares
14:51:20 <nikhil__> #link https://wiki.openstack.org/wiki/GlanceFeatureMatrix
14:51:27 <nikhil__> #link https://wiki.openstack.org/wiki/Summit/Juno/Etherpads#Glance
14:53:21 <nikhil__> thanks for the meeting folks, let's adjourn
14:53:26 <jokke_> thnx
14:53:32 <nikhil__> #endmeeting