20:00:07 <markwash> #startmeeting glance
20:00:08 <openstack> Meeting started Thu May 29 20:00:07 2014 UTC and is due to finish in 60 minutes. The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:13 <openstack> The meeting name has been set to 'glance'
20:00:14 <markwash> howdy everybody
20:00:19 <nikhil__> o/
20:00:20 <arnaud> o/
20:00:22 <ativelkov> o/
20:00:46 <eddie_> o/
20:00:50 <nikhil__> markwash: we'd a meeting last week and the minutes are in the etherpad
20:00:53 <rosmaita> o/
20:01:05 <markwash> great, thanks guys for running that
20:01:06 <nikhil__> https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:01:08 <markwash> sorry I couldn't be around
20:01:10 <nikhil__> np
20:01:22 <markwash> I accidentally scheduled my return trip from Atlanta (well east coast) during that time
20:01:34 <nikhil__> nothing major, just had some action items and questions for you. Hopefully, we can cover that today.
20:02:14 <nikhil__> *action items for different people, questions for you
20:02:16 <markwash> yes lets do, but first I'm going to pull rank and add a few quick items to the top of the agenda
20:02:37 <markwash> First off, the buzz in the project meetings lately
20:02:41 <nikhil__> np, just trying to bring it up for people who might hold me responsible ;)
20:02:58 <markwash> which you can see here http://eavesdrop.openstack.org/meetings/project/2014/
20:03:25 <markwash> and here http://eavesdrop.openstack.org/meetings/ptl_sync/2014/
20:03:44 <markwash> the big topics lately have been the specs repo
20:03:47 <markwash> and juno 1
20:03:56 <markwash> so Juno-1 ends pretty soon actually
20:04:04 <markwash> June 12
20:04:29 <markwash> and we're going to be transitioning to glance-specs as the entry point for feature proposals as opposed to Launchpad
20:04:40 <markwash> launchpad will still be used for tracking milestones and release candidates
20:04:50 <arnaud> #link https://github.com/openstack/glance-specs
20:05:12 <markwash> to summarize, there will be automatic scripts which push approved entries in glance-specs to Launchpad, and which kick out of Launchpad anything that is not in glance specs
20:05:39 <markwash> We'll turn those scripts on soon, once we've prioritized everything in Juno-1 that belongs in Juno-1 (the scripts will ignore prioritized and approved bps)
20:06:42 <markwash> For J2 and beyond I'd like to see everything come through glance-specs
20:06:50 <markwash> questions about this setup? I went a little fast :-)
20:07:12 <ativelkov> Is there any doc on how to use glance-specs?
20:07:45 <arnaud> the repo contains instructions
20:07:52 <arnaud> https://github.com/openstack/glance-specs/blob/master/README.rst
20:08:07 <arnaud> and you use the template https://github.com/openstack/glance-specs/blob/master/specs/template.rst
20:08:14 <arnaud> to build your spec
20:08:27 <arnaud> highly inspired by nova-specs
20:08:56 <arnaud> the specs should be created in the juno/ folder
20:09:23 <eddie_> how about after a spec has been approved and development is happening?
20:09:32 <markwash> Just to be clear, we're not doing this to throw up a process barrier. Using glance-specs should make it a lot easier to notice and properly review new proposals that come in. Launchpad as the entry point was kind of a disaster
20:09:57 <eddie_> will there be an annotation we should put in commit messages to link back to the spec like how we do with "bp blah" that links back to launchpad?
20:10:31 <arnaud> no, because when you start the coding part, the BP will also be in launchpad
20:10:42 <eddie_> ah, ok
20:11:21 <arnaud> and, as you can see in the template, we ask people to use the same identifier in LP and the spec
20:11:42 <arnaud> my-bp.spec launchpad/my-bp
20:11:45 <markwash> just found a quick example in nova: https://review.openstack.org/#/c/94047/
20:12:11 <arnaud> the reference to the spec is contained in Launchpad
20:12:32 <markwash> next item up is some a summary of the Graffiti discussions I've been having
20:12:37 <markwash> any more questions about specs?
20:13:15 <ativelkov> If we submit dependent specs, will this lead to the creation of dependent BPs?
20:14:34 <markwash> hmm I actually do not know how that is handled
20:14:56 <arnaud> markwash, this should be part of the script (maybe it is not yet)
20:15:21 <arnaud> ativelkov, we will check that
20:15:25 <markwash> #action markwash ask ttx about dependency handling for specs & blueprints
20:15:36 <markwash> #topic graffitti
20:15:52 <markwash> hint: I do not know how to spell graffiti
20:16:04 <markwash> Many of you probably saw the Graffiti talk at the summit
20:16:20 <markwash> And here is some more info about it:
20:16:22 <markwash> #link https://www.youtube.com/watch?v=Dhrthnq1bnw&feature=youtu.be
20:16:50 <markwash> Basically, it is a project to make it easier to discover the appropriate tags and metadata to use on various cloud resources
20:17:07 <markwash> and it needs some backend storage of metadata schemas and tag descriptions
20:17:29 <markwash> So I've been helping the guys craft their proposal for adding this backend stuff to Glance
20:17:49 <markwash> Expect to see this proposal on the ML soon
20:18:08 <ativelkov> As far as I understood, they wanted to use Graffiti as a backend for custom metadata properties for the artifacts
20:18:34 <arnaud> markwash, that's what I was going to ask: there is a dependency to artifact right?
20:18:45 <markwash> I don't think there is a hard dependency on the artifacts
20:18:57 <markwash> actually a lot of the initial use cases are about explaining things like flavor and volume extra-specs
20:19:28 <markwash> but I think its relevant to the Catalog mission because we want to support a good UX around tags and metadata in the artifact repository
20:20:20 <markwash> ativelkov: there was some talk about that use case but I think they're not going in that direction at this time
20:20:56 <ativelkov> I see
20:20:59 <markwash> ativelkov: rather, think of it as a place to store schemas about user-metadata. . its a bit silly because we typically think of user-metadata as not having any runtime implications, however, that's not quite accurate in the cloud today
20:21:43 <markwash> ativelkov: I think in the future a lot of the Graffiti horizon components would consume directly from artifact type schemas
20:22:00 <markwash> but anyway, I just wanted to let you guys know my involvement and that these discussion are going on
20:22:05 <markwash> and give you a bit of a heads up
20:22:35 <markwash> just want to make sure everyone is aware and has the opportunity to participate in shaping how these use cases are met
20:23:13 <markwash> looks like next up is a discussion of bug tagging
20:23:23 <markwash> any other thoughts for now about Graffitti?
20:24:08 <markwash> #topic bug tagging
20:24:28 <markwash> looks like jokke is not here, nikhil__ notes about this topic?
20:25:40 <markwash> eek, did I netsplit?
20:25:43 <nikhil__> markwash: will need to dig through the logs, don't have it top of my head
20:25:46 <markwash> ah phew
20:26:16 <nikhil__> ah
20:26:22 <markwash> it looks like the proposal is to use a "propose-close" tag to indicate bugs that are no longer valid, but we want a little more review before closing them completely
20:26:23 <arnaud> btw, just to let you know guys, we are planning organizing a bug day soon
20:26:33 <arnaud> I am going to send an email to the ML soon
20:26:52 <markwash> it also looks like folks generally concurred with the proposal to use this tag
20:26:55 <markwash> does that sound accurate?
20:27:25 <nikhil__> no one opposed that idea
20:27:37 <markwash> well it sounds fine to me :-)
20:28:17 <markwash> #agreed use "propose-close" tag to indicate bugs that probably should be closed but need a little more review
20:28:46 <nikhil__> markwash: should launchpad not have a duplicate status for a bug?
20:29:10 <markwash> nikhil__: I think it should… I've used it before
20:29:35 <nikhil__> eddie_: and I ran into this bug yesterday and could not mark it duplicate
20:29:57 <nikhil__> seems the option vanished somehow
20:30:31 <markwash> hmm, that's odd
20:30:49 <nikhil__> yep, don't see it now in any of the bugs I'm checking
20:31:20 <markwash> hmm, I see it over to the right side of the screen
20:31:52 <markwash> can you use 'bug url'/+duplicate ?
20:32:02 <markwash> anyway, don't want to get too far into the weeds on launchpad just now
20:32:22 <markwash> #topic multiple containers for swift store
20:32:27 <arnaud> "Mark as duplicate" I see it too
20:32:34 <nikhil__> no, on the question above
20:33:05 <markwash> hmm, weird, might be a permissions issue
20:33:16 <eddie_> oh, duh, I see it now
20:33:40 <eddie_> not where I expected to find it
20:34:10 <markwash> Anybody here to discuss the agenda item about multiple containers in the swift store?
20:34:34 <nikhil__> rosmaita: ^
20:35:02 <rosmaita> hi
20:35:42 <rosmaita> the outline is in the etherpad
20:36:05 <markwash> rosmaita: this sounds related to some previous work
20:36:12 <markwash> about password management
20:36:17 <nikhil__> is flaper87 here as well (may be good for awareness on the glace.store code) ?
20:37:20 <rosmaita> i guess my main question is, how much do we have to worry about other projects that rely on how glance is currently configured?
20:37:45 <markwash> are you worried about other projects talking directly to the swift store?
20:38:06 <rosmaita> yes, that's it
20:38:22 <rosmaita> i guess glance.store would mediate
20:38:27 <markwash> well, I suppose as long as the configuration change is optional (which I suppose it has to be anyway) there shouldn't need to be much of a problem
20:38:28 <rosmaita> when it's available?
20:38:29 <notmyname> if you have a glance-specific prefix for containers in swift, would that help?
20:39:02 <notmyname> there's nothing to stop someone from messing with glance data in swift today, is there?
20:39:22 <rosmaita> notmyname: no, there's not, but that's not what i'm worried about
20:39:38 <rosmaita> want people who know how to find the data to still be able to find it
20:40:30 <markwash> I'm not sure we have a good index to see what may be accessing the store directly
20:40:45 <markwash> err -> s/the store/the container/
20:40:56 <flaper87> o/
20:41:02 * flaper87 tries to catch up
20:41:45 <markwash> rosmaita: if we made sure that the swift store in glance.store worked properly before adding a multi-container option, we could ask any other applications talking to the container directly to adopt glance.store. . would that help your concerns?
20:41:49 <flaper87> mmh, not sure I understand what the problem is
20:42:05 <rosmaita> markwash: yes
20:42:36 <markwash> AFAICT, the problem is that if we suddenly start storing images differently in swift containers, then certain out of tree enhancements might suddenly break
20:42:47 <nikhil__> yeah
20:42:50 <rosmaita> exactly
20:43:17 <markwash> I think we just need to be as good as we can about notification and having alternatives available for people who would be in that spot
20:43:20 <rosmaita> so i guess we need to notify other projects on the ML ?
20:43:22 <flaper87> right, but glance.store won't change the way we store images in swift.
20:43:45 <flaper87> at least that's not part of the plan
20:43:48 <flaper87> rosmaita: +!
20:43:49 <flaper87> +1
20:44:02 <markwash> flaper87: right. . I think rosmaita is proposing that we do change it as a feature in glance.store at some point
20:44:10 <rosmaita> flaper87: how close is the swift part of glance.store to getting done?
20:44:33 <rosmaita> (you told me at the summit but i forgot)
20:44:39 <markwash> as I recall flaper87 needs somebody to help untangle the ungainly multi-swift store code
20:44:56 <flaper87> rosmaita: I... haven't done it yet. it'd take a day or two, TBH. It's not a lot of work. I just don't know that code so I was hoping someone already familiar with it to take over
20:45:07 <nikhil__> multi tenant is a mystery by itself
20:45:14 <flaper87> nikhil__: yeah
20:45:23 <flaper87> I'll stab that code asap
20:45:26 <markwash> rosmaita: can we resolve to make a functional glance.store a prereq of such a feature, along with ML notifications? there are a few more things to get to today
20:45:36 <flaper87> I started doing changes in glance (I submitted a patch today)
20:45:42 <markwash> flaper87: yay
20:45:43 <rosmaita> sure, i just wanted a preliminary discussion
20:46:18 <markwash> #agreed we need a functional glance.store prior to adding multiple container support (which is different from multi-tenant) to the swift store
20:46:47 <markwash> for the rest of today we need to talk about glance tasks and also the mid-cycle meetup
20:46:49 * flaper87 agrees with that
20:46:51 <markwash> can we do the meetup first?
20:47:05 <markwash> s/meetup first/meetup discussion first/
20:47:09 <markwash> heh
20:47:10 <nikhil__> the other day, I tried to figure if some input could be provided however based on how that is structured, it seems some more work needs to be done to be able to use it
20:47:14 <nikhil__> markwash: sure
20:47:23 <markwash> okay thanks!
20:47:27 <markwash> #topic mid cycle meetup
20:47:51 <markwash> I've been lagging on the planning part of the meetup and I was hoping some folks could step up and take charge of this
20:48:17 <arnaud> markwash, did you get a chance to talk to the OpenStack people?
20:48:52 <markwash> yes
20:48:58 <markwash> they don't have any real input to provide
20:49:00 <markwash> so we're on our own
20:49:06 <arnaud> I see
20:49:25 <nikhil__> markwash: what did the survery results yield?
20:49:43 <markwash> I actually did not see the results of the survey, is ashwini around to share?
20:49:45 <arnaud> VMware can host the event, the problem being that most of the people are in Virginia :) so that might not be the best way to go
20:49:54 <ash__> i am here
20:50:24 <ash__> rackspace folks will be okay with any locations
20:50:37 <markwash> ash__: did it seem like west coast would suit enough folks?
20:50:57 <markwash> I liked your idea of colocating with the nova summit (even though its a little hard on my schedule personally!)
20:50:57 <ash__> and I actually did not send out the survey, I prepared it but was waiting on Mark to waive the flag for sending it :)
20:51:10 <markwash> ash__: I think I sent it out to the ML
20:51:17 <ash__> nova one is in portland
20:51:19 <markwash> I might have messed up though
20:51:29 <nikhil__> markwash: got your email
20:51:42 <ash__> oh okay.. then I missed seeing it but it does not send me auto notifications so will check results now
20:52:16 <markwash> so is there a group who has reasonably flexible support and can step up to plan the meetup?
20:52:32 <arnaud> just want to confirm: what are the aspects of the sponsorship? a place to have the meetings and the food right?
20:52:35 <arnaud> is there something else?
20:53:12 <ash__> for the folks that responded so far, preference is east coast..8 replies so far
20:53:30 <ash__> place and food mostly
20:53:57 <arnaud> if we go east coast, vmware can sponsor the food (I guess)
20:54:03 <ash__> the travel and logging is individual responsibility (i.e. respective company responsibilty)
20:54:17 <ash__> arnaud: you and I can coordinate on it later?
20:54:22 <arnaud> yeah
20:54:31 <ash__> markwash: me and arnaud can run with it
20:54:39 <arnaud> I remember stuart
20:54:44 <arnaud> suggested HP could do something as well
20:54:52 <markwash> if you guys can mention your plans to gokrokve, TravT, and mclaren that would be great
20:54:57 <markwash> not sure if I'm missing someone else who was interested
20:55:00 <ash__> sure he has sent me some contact for the same i will follow uo
20:55:02 <ash__> up
20:55:06 <nikhil__> (btw, I just need >3 mins to syncup)
20:55:27 <markwash> okay thanks guys! now a brieve syncup on tasks
20:55:31 <markwash> #topic glance tasks syncup
20:55:35 <markwash> go nikhil__ go! :-)
20:55:46 <nikhil__> added a brief update/plan on the etherpad
20:56:16 <nikhil__> much stuff was agreed on during the summit however, things tend to go a little off during implementation
20:56:39 <nikhil__> so, of all the points my questions is the last one
20:56:55 <arnaud> nikhil__, can I go ahead and rebase my taskflow patch on top of yours?
20:57:08 <nikhil__> am about to update the MP with new PS once all the tests pass (along with a icky race condition test)
20:57:35 <nikhil__> arnaud: let's discuss that offline, if that's okay (may not be enough time now)
20:57:45 <arnaud> yes
20:58:16 <nikhil__> if some core-ish reviewers can ask some concerns/+1s/-1s would really help
20:58:21 <markwash> :-)
20:58:31 <markwash> I'm not sure I quite follow the question unfortunately
20:58:33 <nikhil__> just want to ensure that whatever is upthere can be landed in near future
20:59:14 <nikhil__> markwash: oh, so we'd just decided that we should use store module in glance to do filesystem based store operations
20:59:26 <nikhil__> however, I'd just prefer that change to be completely different MP
20:59:45 <markwash> I suppose as long as it follows soon that is not a problem
20:59:53 <nikhil__> that way we can let the taskflow patch progress be not blocked as well
21:00:06 <nikhil__> yeah, I can proposed that in a day or so
21:00:10 <markwash> arnaud: if you're okay with this I'm okay with it
21:00:37 <arnaud> yes sounds good
21:00:48 <markwash> okay nikhil__ sounds like you get your way :-)
21:00:48 <nikhil__> great, thanks guys
21:00:52 <nikhil__> :)
21:01:03 <markwash> we're out of time, thanks everybody
21:01:09 * markwash has to run to the airport
21:01:13 <rosmaita> bye
21:01:16 <arnaud> thanks
21:01:16 <markwash> #endmeeting