14:00:15 <markwash> #startmeeting glance
14:00:16 <markwash> o/
14:00:16 <openstack> Meeting started Thu Jun 19 14:00:15 2014 UTC and is due to finish in 60 minutes.  The chair is markwash. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <openstack> The meeting name has been set to 'glance'
14:00:20 <hemanth_> o/
14:00:21 <ativelkov> o/
14:00:22 <jokke_> o/
14:00:25 <TravT> o/
14:00:43 <nikhil___> o/
14:00:45 <brianr> o/
14:00:54 <zhiyan> o/
14:01:22 <markwash> I have one item for today, then I guess we can just go into open discussion
14:01:23 <arnaud> o/
14:01:54 <markwash> reminder agenda is here: https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:16 <markwash> #topic addressing the integration requirements gap
14:02:45 <markwash> we need to provide the TC with simple plan to address some of our tempest testing gaps
14:03:07 <markwash> principle among them is a lack of testing "realistic" image data
14:03:17 <markwash> I was a bit hasty with the timeline for this item
14:03:48 <markwash> we need an assignee and plan soon
14:04:03 <markwash> but the timeline for actually adding more testing should probably be targeting juno-2
14:04:07 <nikhil___> I've no clue about the testing done there atm however, can pick it up if none is available
14:04:33 <markwash> so I'm looking for some volunteers
14:04:35 <nikhil___> if someone can point me to the right place to look into
14:04:38 <markwash> nikhil___: heh I'm in the same boat
14:04:43 <hemanth_> hemanth_: I have no clue what it takes to address the testing gap, but I can work with nikhil___
14:04:51 <hemanth_> I'm talking to myself!
14:04:56 <markwash> haha
14:04:57 <jokke_> me neither, but I'm willing to help
14:05:32 <nikhil___> great, we've 3 now hope we can move things forward
14:05:41 <markwash> okay, based on this what I'm going to do is go digging into to tempest to find the place that needs modification
14:05:50 <markwash> and I'm going to put nikhil___ down as the assignee
14:05:54 <nikhil___> and guessing blitz__ would like to work on as well so 4 ..
14:06:09 <markwash> and I'll document at least in an email what the gap is and where I think we need to modify tempest
14:06:11 <nikhil___> markwash: works
14:06:29 <zhiyan> markwash: if you ok pls CC me
14:06:39 <markwash> #action markwash document changes needed for tempest testing gaps
14:06:42 <markwash> zhiyan: sure thing
14:06:45 <nikhil___> markwash: can work with you today if needed and if it would help ..
14:06:49 <zhiyan> markwash: thanks
14:07:19 <markwash> #topic mission statement
14:07:41 <markwash> I'm planning on submitting another patchset to the openstack/governance glance mission statement review tomorrow
14:07:55 <markwash> hopefully we find something that can be adopted by the TC next tuesday
14:08:23 <markwash> (just wanted to give that little update)
14:08:36 <markwash> #topic open discussion
14:08:49 <jokke_> markwash: in the lline with the second mission statement that were out for review?
14:09:38 <markwash> jokke_: yes, I'm talking about a new version of the change that is out in review right now
14:09:51 <markwash> https://review.openstack.org/#/c/98002/
14:09:54 <jokke_> k
14:10:59 <zhiyan> i have a quick one like to get folks help
14:11:06 <markwash> the agenda is a bit light today, but this could be a good opportunity for folks to ask each other questions
14:11:17 <markwash> since we have a good portion of the group here
14:11:20 <markwash> zhiyan: go for it
14:11:47 <zhiyan> basicly, i just like folks help my location-status change stuff
14:12:24 <zhiyan> jokke_: thanks for the review btw
14:12:58 <jokke_> zhiyan: still working on it ... it's not fast to digest ;)
14:13:00 <zhiyan> the db table change has already been landed in I early (iiuc), rest of it is ready for you review
14:13:10 <wayne__> in investigating where to add the new metadata-schema tables i noticed there is an abandoned blue-print for moving towards alembic pending community direction...is that still the case?
14:14:08 <zhiyan> the start point of it is here: https://review.openstack.org/#/c/67115/
14:14:29 <markwash> wayne__: I think that we were expecting to just pick that up through oslo I guess? if it is necessary for consistency with the rest of openstack
14:15:03 <wayne__> we used alembic in the graffiti poc...would it make any sense to use alembic just for the metadata-schema tables?
14:15:28 <wayne__> or should i add a new sqlalchemy-migrate version?
14:15:58 <markwash> wayne__: probably porting that to sqlalchemy-migrate is going to be the way to go
14:16:15 <wayne__> ok
14:16:33 <nikhil___> markwash: wayne__ : just fyi, we tried to use alembic for another project and it turned out to be a nightmare to switch to it atm
14:16:40 <ativelkov> what about API? Any plans on moving to pecan?
14:16:52 <nikhil___> it def is a good tool however, a bit too early to make the swicth
14:16:57 <wayne__> i see
14:17:14 <markwash> ativelkov: we could never quite muster up the test confidence to authorize a big switch like that (to pecan)
14:17:40 <markwash> but I was hoping that the graffiti stuff could stay in pecan but still be brought into the glance codebase
14:17:52 <markwash> any luck on running pecan beside our current wsgi homebrew?
14:18:00 <markwash> wayne__: ^^ (were you looking into that?)
14:18:00 <TravT> markwash: lakshmi on our  team was started looking into that
14:18:17 <markwash> ah okay cool
14:18:18 <lakshmiS> Pecan seems to run in its own process
14:18:38 <ativelkov> Cause I have the same question on artifacts - if we want this thing to co-exist in v2 branch, we probably have to have a single engine
14:19:38 <markwash> how much does pecan buy us, vs what wsme buys us?
14:19:46 <markwash> and is it possible to use wsme in our current engine?
14:20:05 <nikhil___> using the same port (9292) would be a big factor into using the same process, right?
14:20:42 <lakshmiS> nikhil___ thats right
14:21:17 <ativelkov> Port is part of the endpoint in keystone. We probably do not want to have more then one "glance" endpoint in service catalog
14:21:33 <lakshmiS> wsme could be used separately from pecan. It will gives us marshalling/unmarshalling of json.
14:21:42 <markwash> lakshmiS, ativelkov: this is definitely a tough integration step. I think we really want to find the solution that lets us make the fewest ripples
14:21:56 <markwash> I'll also take a look at the pecan wsme stuff this week and see if I can come up with any ideas
14:22:08 <nikhil___> ah, that's interesting
14:22:20 <markwash> I mean, I'm a little terrified of the idea of porting v2 to pecan/wsme, but maybe its not so hard?
14:22:27 <TravT> We are hoping to at least use the WSME marshalling.
14:22:29 <markwash> if that's what we have to do
14:22:30 <ativelkov> As for me I would prefer to use the current engine for now. Migrating to pecan may be done later, when (if) we start doing v3
14:22:55 <markwash> ativelkov: ah okay
14:23:20 <zhiyan> if we can't do it in a underlayer (like wsgi level), v3 is good to me
14:23:24 <markwash> it sounds like we need a clear plan of action on the api framework issue
14:23:42 <zhiyan> +1
14:24:27 <ativelkov> BTW, do we have any long-term (or mid-term) roadmap?
14:24:48 <markwash> ativelkov: does there seem to be any advantage to you to using wsme in our current engine
14:25:01 <TravT> wsme lets you create an object model and then not hand code marshalling.  I think that's what you were going to be trying out within current Glance framework next, rigth lakshmiS?
14:25:05 <markwash> ativelkov: outside of our specs documents and the general artifact plans, no I don't think so
14:25:27 <lakshmiS> TravT yes
14:27:08 <markwash> #action markwash lakshmiS ativelkov: investigate wsme/pecan options living alongside the current engine for next weeks discussion
14:27:15 <markwash> ^^ is that okay with you guys?
14:27:21 <lakshmiS> sounds good
14:27:26 <ativelkov> Works for me
14:27:31 <markwash> great, thanks
14:27:36 <jokke_> markwash: https://review.openstack.org/#/c/98750/ (Fake Keystone) could you open that your comment about performance concerns a bit? Would be nice to get the thoughts of the group as well! (If/when the framework topic is done for now)
14:28:29 <markwash> jokke_: I think I maybe didn't mean to say "performance"
14:28:58 <markwash> s/performance/behavior/ seems like what I must have meant
14:28:59 <markwash> sorry
14:29:49 <markwash> okay, I think we can just move more discussion to #openstack-glance
14:29:52 <markwash> thanks everybody
14:30:04 <markwash> #endmeeting