14:10:19 <rosmaita> #startmeeting glance
14:10:20 <openstack> Meeting started Thu Jul 17 14:10:19 2014 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:10:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:10:23 <openstack> The meeting name has been set to 'glance'
14:10:36 <rosmaita> roll call!
14:10:41 <TravT> o/
14:10:43 <arnaud__> haha o/
14:10:46 <nikhil___> o/
14:10:46 <ativelkov> o/
14:10:47 <lakshmiS> hi
14:10:51 <zhiyan> o/
14:11:14 <rosmaita> #topic bugfixing days
14:11:36 <rosmaita> sorry i wasn't available the past 2 days, any comments on how things went?
14:11:45 <arnaud__> (the agenda is not up to date)
14:12:14 <zhiyan> we fixed some bugs, now we have 260 bugs there
14:12:36 <arnaud__> some triage has been done as well
14:12:43 <zhiyan> but we tagged some bugs, they probably can be closed safely
14:12:48 <arnaud__> and tagging of bugs
14:12:54 <nikhil___> and reviews
14:13:01 <nikhil___> which actually merged L=:)
14:13:41 <rosmaita> sounds good, thanks for all your work (to everyone who participated)
14:14:26 <rosmaita> i think we need to discuss mid-cycle meetup, but that may take some time, anyone got something they'd like to discuss first?
14:14:38 <zhiyan> my concerns is that , seems there are some frozen "in-progress" items there, most of them have higher importance
14:14:42 <arnaud__> I think we need to focus on reviews now, because our review queue is getting bigger and bigger
14:14:52 <zhiyan> indeed
14:15:00 <d0ugal> o/
14:15:38 <rosmaita> at some point, we had a review day, do we need to do that again?
14:15:46 <nikhil___> +1
14:16:01 <zhiyan> so probably we can send a mail to raise a asking, and take and fix them as needed
14:16:12 <nikhil___> ad-hoc review requests many times lead to semi-pending MPs
14:16:13 <zhiyan> +1 for review day
14:16:26 <rosmaita> #action get markwash to schedule a review day
14:16:56 <boris-42> hi guys=)
14:17:48 <rosmaita> d0ugal, boris-42: hi
14:18:01 <rosmaita> anything else before mid-cycle agenda discussion?
14:18:27 <d0ugal> Hi! not from me :)
14:19:24 <rosmaita> #topic mid-cycle meet-up
14:19:41 <rosmaita> #link https://etherpad.openstack.org/p/glance-juno-mid-cycle-meeting
14:20:05 <rosmaita> arnaud has added directions to the etherpad
14:20:22 <arnaud__> still figuring out for remote people
14:20:39 <arnaud__> I will give an update on that asap
14:20:56 <rosmaita> zhiyan: you attended last meetup remotely, do you have any suggestions?
14:21:34 <zhiyan> rosmaita: arnaud__ if it could, i think make a test before is necessary
14:21:39 <zhiyan> to verify it works well
14:21:58 <arnaud__> yes
14:22:49 <arnaud__> I think being in a company and not an hotel, should make things a bit easier this time
14:23:00 <rosmaita> +1
14:23:25 <zhiyan> ping me when you want to test it, i can access it remotely as a verification/
14:23:35 <arnaud__> will do
14:23:38 <rosmaita> so it looks like we have 9 topics now
14:23:40 <arnaud__> today or tomorrow
14:23:41 <zhiyan> cool
14:23:44 <TravT> how do you typically organize the agenda?  do you just vote at the beginning of the first day?
14:23:57 <zhiyan> thanks arnaud__
14:23:59 <TravT> timing wise, that is.
14:24:01 <arnaud__> np!
14:24:13 <rosmaita> last time, markwash just assigned times
14:24:34 <rosmaita> but looking at the topics, some will require more time than others
14:24:51 <arnaud__> it also seems we will be very busy
14:25:09 <rosmaita> and i personally am in favor of maybe revisiting some topics at the end after we've had time to think and discuss
14:25:25 <rosmaita> arnaud__: do you think there is too much on the agenda now?
14:25:27 <nikhil___> should we have an individual etherpads for each topic (possible re-using old ones) ?
14:25:46 <arnaud__> +1 nikhil___
14:25:55 <rosmaita> nikhil___: +1
14:26:02 <mclaren> can the v1/v2 performance one be removed? zhiyan pushed up a couple of fixes
14:26:11 <nikhil___> :)
14:26:14 <arnaud__> good point
14:26:21 <nikhil___> boris-42: any inputs on that?
14:26:42 <boris-42> nikhil___ where?)
14:26:44 <boris-42> nikhil___ reading
14:26:46 <nikhil___> rosmaita: arnaud__ : may be then each topic leader would create one or do you all need a volunteer?
14:26:50 <rosmaita> looks like it already got removed!
14:27:05 <rosmaita> so 8 topics
14:27:09 <zhiyan> ify, those only covered "image-list" case, but others probably could be handled case by case.
14:27:12 <boris-42> nikhil___ guys btw sorry for interrupting but
14:27:21 <boris-42> what about profiling stuff?)
14:27:31 <boris-42> it can really reduce a lot of time
14:27:37 <arnaud__> actually
14:27:39 <arnaud__> I was thinking
14:27:49 <boris-42> and it's quite ready
14:27:50 <arnaud__> what about a demo of the profiling stuff with glance?
14:27:51 <arnaud__> :)
14:27:59 <boris-42> arnaud__ in any time
14:28:05 <rosmaita> +1
14:28:07 <boris-42> arnaud__ we can make hangout call
14:28:08 <nikhil___> +1
14:28:17 <boris-42> arnaud__ and I'll share my screen
14:28:18 <arnaud__> ok sounds boris-42
14:28:24 <boris-42> arnaud__ could we pick some date?
14:28:27 <rosmaita> would it make sense to do it as part of glance diagnostics, or own session?
14:28:36 <mclaren> would it help if folks updated their items with a time estimate of what they'll need? Eg some folks may only need 1/2 a session
14:28:51 <boris-42> rosmaita I think it's enough to make hangout call=)
14:28:57 <boris-42> rosmaita and not spend time of summit for this
14:29:30 <mclaren> wow that was quick :-)
14:29:32 <rosmaita> boris-42: that sounds good, maybe we should do it during glance meeting in 2 weeks?
14:29:43 <boris-42> rosmaita maybe faster?
14:29:49 <boris-42> mclaren cause patches are ready for merge
14:29:53 <boris-42> rosmaita ^
14:30:21 <rosmaita> boris-42: when would you like to do it?
14:30:32 <boris-42> rosmaita it depends on you guys
14:30:49 <arnaud__> I have added an "Estimated time" section in the ether pad, if you are leader on a section please add how much time you think you need
14:31:04 <TravT> nikhil___: you put time estimate of 1 session.  Can we put in minutes?
14:31:08 <arnaud__> s/on a section/of a topic
14:31:28 <mclaren> 1 session = 40 minutes?
14:31:51 <arnaud__> I think we should try to put in minutes
14:32:05 <nikhil___> TravT: discussions usually tend to go a little over time
14:32:08 <nikhil___> arnaud__: ^
14:32:33 <nikhil___> arnaud__: is the schedule not split into equal sized sessions?
14:32:57 <arnaud__> initially it should
14:33:01 <nikhil___> based on arrangements for lunch and other such breaks?
14:33:15 <arnaud__> but I think we have sessions that need more and sessions that need less than 1hour...
14:33:37 <arnaud__> first, does 9AM-6PM sounds reasonable?
14:34:09 <mclaren> 9-5?
14:34:10 <nikhil___> TravT: ok, put the session time even more explicitly :)
14:34:34 <arnaud__> ok let's go with 5:30
14:34:37 <arnaud__> then
14:34:39 <mclaren> ok :-)
14:35:10 <rosmaita> does that "schedule" look ok?
14:35:18 <rosmaita> do we need morning break?
14:35:35 <arnaud__> I think we will need 10/15min breaks
14:35:50 <arnaud__> in the middle of morning especially
14:35:51 <arnaud__> :)
14:36:10 <nikhil___> and evening too else the brain would be fried with too many ideas :)
14:36:19 <arnaud__> 10-10:10
14:36:25 <rosmaita> well, the evening is wide-open
14:36:26 <mclaren> and jetlag :-)
14:36:41 <nikhil___> oh, yeah. that
14:38:22 <rosmaita> ok, so we could do 2 30 min sessions before first break, or is that unrealistic?
14:38:24 <zhiyan> rosmaita: do we have a open-discuss section in this meeting ?
14:38:25 <arnaud__> I will talk to markwash later today and see if we need a wiki page like we had last time
14:38:46 <rosmaita> zhiyan: +1
14:38:52 <mclaren> do we have more time than sessions?
14:39:08 <rosmaita> mclaren: depends on how we schedule!
14:39:31 <rosmaita> i guess the key thing is: does anyone have a topic that is NOT on the agenda?
14:41:09 <rosmaita> ok, hearing none, let's stick with what's on the agenda
14:41:18 <rosmaita> not all the topics have leaders yet
14:41:46 <mclaren> ok. I think last time we did some ad hoc stuff aswell, which worked quite well. (remember the ideas on post-it notes?)
14:41:59 <TravT> I don't see anything specific to the artifacts work by ativelkov
14:42:19 <rosmaita> mclaren: +1
14:42:34 <ativelkov> The "Artifacts and Metadata service" seems related
14:42:38 <TravT> there's something called Artifacts and Metadata service, but it looks different.
14:42:42 <arnaud__> +1 mclaren
14:42:55 <mclaren> will markwash be there? I'd nominate him for the image transfer one...
14:43:03 <nikhil___> +1
14:43:04 <ativelkov> It is probably about implementing the existing feature requests with artifact plugins
14:43:18 <arnaud__> mclaren, yep he is coming
14:43:19 <rosmaita> TravT: i was thinking the "Artifacts and Metadata Service" would cover artifacts, who proposed it?
14:43:35 <TravT> rosmaita: i don't know.
14:43:49 <TravT> it talks about Grafiti, though.
14:43:49 <rosmaita> ativelkov: ?
14:44:36 <ativelkov> not me.
14:44:38 <rosmaita> ativelkov: do you want to lead that discussion (and make sure artifacts work gets discussed)?
14:44:42 <ativelkov> I will
14:44:50 <rosmaita> cool, feel free to rewrite the description
14:44:55 <ativelkov> If the initial author of this description does not object
14:44:59 <mclaren> I nominated markwash for the Transfer one -- unless someone here wants it
14:45:07 <TravT> maybe we need a field "requestor"
14:45:17 <TravT> so we know who put it up there?
14:45:19 <rosmaita> TravT: +1
14:45:22 <mclaren> I'm sure he'll thank me :-)
14:45:49 <rosmaita> #action remember to put "requestor" field on agenda next time
14:46:17 <TravT> ativelkov: i would like to ensure we can discuss on what the relationship is between the artifact service and the metadata catalog we are working on.
14:46:38 <ativelkov> TravT: right. We do not want any overlaps
14:47:14 <arnaud__> I think also, it would be nice to have a session, we select a couple of bugs and we discuss them
14:47:15 <rosmaita> nikhil___ : did you want to do transfer sevice? i think you proposed it
14:47:46 <arnaud__> (if we have enough time)
14:48:00 <nikhil___> rosmaita: well, it's going to be a cross project discussion
14:48:17 <rosmaita> arnaud__: how about we use glance drivers meeting tomorrow to work with markwash to make an agenda, put out announce on mailing list, and people can comment/revise before wednesday?
14:48:33 <arnaud__> that's what I was thinking
14:48:34 <arnaud__> sure
14:48:38 <nikhil___> if mark does not prefer taking it, I can. Had left it for thim or inputs from John B.'s work which Mark would be more familiar with
14:49:12 <mclaren> nikhil___: John B's work?
14:49:21 <nikhil___> rosmaita: arnaud__ : we "may" need a tiny session for discussing testing moved out of glance
14:49:24 <rosmaita> #action arnaud, rosmaita, markwash to create agenda with times tomorrow, will post for comments/revisions
14:49:44 <nikhil___> mclaren: https://github.com/stackforge/staccato/commits/master
14:49:47 <rosmaita> #action include time for post-it notes, open discussion, and testing
14:49:51 <mclaren> thanks
14:50:33 <rosmaita> (i don't think i am using #action correctly)
14:50:50 <rosmaita> anything else about minisummit?
14:51:24 <nikhil___> rosmaita: adding the testing item to agenda
14:51:39 <nikhil___> seems like there is a cross project discussion going on in ML
14:54:26 <TravT> there were some rest api discussions on ML.  if there was a conclusion, getting a summary would be good.
14:56:54 <TravT> rosmaita: are we in open discussion?
14:58:38 <arnaud____> netsplit?
14:58:52 <rosmaita_> guess so, what did i miss?
14:59:05 <TravT> well, i asked if we are in open discussion?
14:59:15 <arnaud____> 1min left, I think we are TravT
14:59:19 <TravT> we had a question on files for the schemas.
14:59:33 <rosmaita_> #topic open discussion
14:59:39 <TravT> basically, are we supposed to create a single file per table in the schema files?
14:59:49 <TravT> or is it okay to lump them together?
15:00:10 <rosmaita_> you mean the json schemas?
15:00:25 <wayne_> migrate_repo versions
15:00:25 <TravT> the sql alchemy migrate files
15:00:37 <TravT> like : �    001_add_images_table.py
15:01:14 <TravT> looks like we are out of time today, though.
15:01:28 <rosmaita_> TravT: maybe send to ML ?
15:01:36 <TravT> ok.
15:01:42 <TravT> it is also in code review
15:01:59 <rosmaita_> boris-42: could you send proposal for google hangout time for demo?
15:02:08 <rosmaita_> we are over time
15:02:11 <rosmaita_> #endmeeting
15:02:12 <boris-42> rosmaita_ in meeting by I will
15:02:16 <arnaud____> TravT, I think it should be per table
15:02:39 <openstack> cknight: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
15:03:00 <rosmaita> #endmeeting