20:00:21 <arnaud> #startmeeting glance
20:00:22 <openstack> Meeting started Thu Aug  7 20:00:21 2014 UTC and is due to finish in 60 minutes.  The chair is arnaud. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:26 <openstack> The meeting name has been set to 'glance'
20:00:42 <zhiyan> o/
20:00:46 <arnaud> o/
20:01:00 <rosmaita> o/
20:01:00 <arnaud> nikhil___,
20:01:22 <rosmaita> light agenda today: https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:01:25 <nikhil___> o/
20:01:26 <ativelkov> o/
20:01:38 <arnaud> yep
20:01:46 <arnaud> let's wait for TravT to show up
20:01:59 <arnaud> to discuss the metadefs
20:02:38 <jcook> o/
20:02:50 <arnaud> so Mark is on vacation
20:03:06 <arnaud> for the next 2/3 weeks
20:03:51 <arnaud> wayne_, do you know if Travis is going to show up?
20:03:57 <lakshmiS> he is joining
20:04:10 <arnaud> sounds good
20:04:39 <wayne_> yes, i believe so
20:05:08 <ativelkov> arnaud: do you know if Mark has sent email to TC (Thierry?) about the Murano topic?
20:05:40 <arnaud> ativelkov, afaik Mark discussed with Thierry last week
20:05:49 <TravT> o/
20:06:11 <arnaud> ativelkov, maybe we can add an item to the agenda
20:06:14 <arnaud> to discuss about that later
20:06:14 <hemanth__> o/
20:06:15 <arnaud> ok?
20:06:18 <ativelkov> ok, sure
20:06:30 <arnaud> #topic metadefs
20:07:06 <arnaud> so, to give some context, we had an email thread yesterday, to figure out what we want to do with the metadefs patches
20:08:15 <arnaud> ideally, we would need to land these patches as soon as possible to have the Horizon team looking at the Horizon patches
20:08:38 <arnaud> however, from my perspective it doesn't seem reasonable to rush to much to land those
20:09:02 <arnaud> at least not in the next couple of days
20:09:32 <arnaud> so, I suggested to make it a priority to review to have those landed in Juno-3
20:09:46 <arnaud> and at the same time the Horizon team could start looking at the Horizon patches
20:09:55 <arnaud> are you guys fine with that?
20:10:02 <zhiyan> agreed, i think to make it landing in j3 makes more sense
20:10:32 <arnaud> TravT, doesn't that sound OK for you?
20:11:09 <TravT> i also don't like rushing things.  only reason was david lyle was resistant to reviewing without it being landed.
20:11:26 <TravT> but i think he's okay.
20:11:39 <arnaud> I think we should be able to review in parallel
20:11:45 <TravT> i do too
20:11:52 <TravT> i'm glad you said that in the email thread
20:12:31 <arnaud> so the idea for glance cores is to review in priority the metadefs stuff
20:12:39 <TravT> wayne is gonna get them a script to setup glance.  i'm also have zip file that will basically give them a mock glance API for metadefs
20:12:57 <arnaud> ok great
20:13:01 <TravT> so they shouldn't have much reason to push back on reviewing horizon standalone
20:13:14 <arnaud> maybe it would be nice to share the link with all of the information
20:13:16 <TravT> because i'm sure we'll need several rounds of reviews in horizon.
20:13:37 <arnaud> #link https://etherpad.openstack.org/p/glance-metadata-catalog-tasks
20:14:09 <arnaud> could you give an an update of the patches?
20:14:32 <arnaud> I mean, did you have the time to address the comments posted so far?
20:14:33 <TravT> well, our guys in Poland are generating a lot of tests right now
20:14:50 <TravT> lakshmiS and wayne___ can update on where they are
20:15:47 <lakshmiS> functionality is complete. adding more unit tests
20:16:21 <TravT> for horizon, i'm bringing the namespace admin console up to date with latest bootstrap changes. pawels is working on the widgets.
20:16:34 <arnaud> ok sounds good
20:16:38 <wayne_> db is functionally complete
20:17:09 <TravT> i was just looking at the python-glanceclient
20:17:16 <TravT> i think they need to make some renames
20:17:37 <zhiyan> the change on api stuff is complete and pushed up right?
20:17:44 <arnaud> I think from a glance perspective, the most important thing is the API part https://review.openstack.org/#/c/111455/ , even if we kinda agreed on the API at the meetup, it is also good to make sure everybody is happy with it
20:17:46 <TravT> a bunch of places they need to change metadata --> metadefs
20:18:08 <lakshmiS> API renaming and refactoring has been done is up for review in patch
20:18:16 <arnaud> ok cool lakshmiS
20:18:33 <zhiyan> nice lakshmiS
20:18:59 <arnaud> so I think we are OK with the metadefs at the moment
20:19:06 <arnaud> TravT, anything else you want to add?
20:20:02 <TravT> the glanceclient will still be a gating factor for final +2 in horizon
20:20:14 <TravT> so even if we can get horizon reviews started
20:20:35 <TravT> it won't be able to get merged until the client is there
20:20:58 <TravT> so, if we could plan this sooner than the very last day of Juno 3, it would be "helpful"
20:21:11 <arnaud> yes, OK
20:21:24 <TravT> thanks, we appreciate the time and reviews that you are all putting in!
20:21:37 <arnaud> I think we will sync up at each glance irc meeting to see what the status is for those 4 patches
20:21:46 <TravT> +1
20:22:35 <arnaud> you mentioned earlier some script to set things up? do you know where you will put them?
20:23:08 <TravT> hmmm... perhaps we can upload to wiki?
20:23:25 <arnaud> sounds good to me
20:23:45 <TravT> ok. we'll send that out.
20:24:14 <arnaud> please add the URL here: https://etherpad.openstack.org/p/glance-metadata-catalog-tasks, as soon as you have it
20:24:54 <arnaud> ok, I think we can move to the next item
20:25:04 <TravT> ok
20:25:09 <arnaud> #topic tasks
20:25:16 <arnaud> nikhil___, you around?
20:25:27 <nikhil___> yes
20:25:39 <nikhil___> so, just a quick status update
20:25:58 <nikhil___> I've made some changes to the patch as per zhi's awesome comments
20:26:14 <arnaud> do you have the link of the patch handy?
20:26:38 <nikhil___> yeah, getting the link
20:27:02 <nikhil___> however, I'm seeing some race conditions to the intergrations tests which result into failure intermittently
20:27:21 <nikhil___> we've observed that internally in our deployment infra as well
20:27:21 <zhiyan> https://review.openstack.org/#/c/44355/ ?
20:27:27 <nikhil___> yes, thanks
20:27:38 <nikhil___> haven't pushed them up yet
20:27:39 <arnaud> do you know approximately what is the reason for that?
20:27:53 <nikhil___> yeah, we've anrrowed down the reason
20:27:59 <nikhil___> and temporary hack
20:28:23 <nikhil___> the eventlet threads invoked while running those lifecycle tests do no finish before the test finishes
20:28:41 <nikhil___> so the sqllite db is destroyed and we see trace and sometime hang
20:29:11 <nikhil___> the hang is a new thing, possibly due to some latests improvements in the glance code so debugging that is taking time
20:29:12 <arnaud> nikhil___, would task flow solve the problem?
20:29:27 <nikhil___> don't think so, it the tests which need modification
20:29:34 <arnaud> oh I see ok
20:29:49 <nikhil___> anyways, don't want to block our progress
20:30:14 <arnaud> so, what's your recommendation for now?
20:30:24 <nikhil___> if we do not have a elegant solution by tuesday / next week wilkl push up a PS with time.sleep adter some tests
20:30:35 <nikhil___> it adds the testing time by a min or so more
20:30:53 <arnaud> ok
20:30:54 <nikhil___> however, I'm also looking at the concurrency patch
20:31:11 <arnaud> which patch? :)
20:31:27 <nikhil___> #link https://review.openstack.org/#/c/108427/
20:31:35 <nikhil___> that was sup to be discussed last week
20:31:49 <nikhil___> we could not due to the store meeting :)
20:31:58 <arnaud> ok
20:32:34 <arnaud> could you tell us more about that patch? is that related to the task patch?
20:32:52 <nikhil___> it's not , it's to do more about speeding up the glance tests
20:33:10 <zhiyan> nikhil___: interesting, now jenkins tests it ok. i'd like to verify it again, cherry-pick and run it locally.
20:33:22 <nikhil___> on some single/virtual core systems, they take almost half an hour to run
20:33:36 <nikhil___> zhiyan: yeah, that's what I was wondering too
20:34:19 <arnaud> do you have a number with/without that patch how it takes?
20:34:23 <zhiyan> nikhil___: would you mind i recheck/re-run jenkins on it one more?
20:34:29 <arnaud> based on the number of cores that you have :)
20:34:58 <nikhil___> arnaud: have some informal numbers atm
20:35:00 <nikhil___> they are
20:35:29 <zhiyan> arnaud: in my env, i have 4 vcpus, but i can't pass the tests due to i can see some race condition issue one some tests..
20:35:39 <nikhil___> for 4 core system, in parallel they take about 7-7.5 mins
20:36:04 <nikhil___> while sequentially, they take 20+
20:36:21 <arnaud> yes that's definitely much better...
20:36:31 <arnaud> let me try that too on my machine
20:36:49 <nikhil___> actually, this is worse on a VM server
20:37:04 <nikhil___> it's more than 30 mins for most of the runs
20:37:24 <nikhil___> all this is excluding the venv creation
20:37:47 <arnaud> yep... that's a pain
20:37:58 <zhiyan> double-check, currently jenkins vm within gate has 4 vcpu right? nikhil___
20:38:20 <nikhil___> not sure zhiyan
20:39:02 <zhiyan> i will check it, ok.
20:39:27 <arnaud> ok, so to sum up about the task: we should wait next tuesday before looking at, right?
20:39:43 <nikhil___> zhiyan: do you mind pasting a link to failing tests on the review (in a gist or paste) ?
20:40:03 <arnaud> btw, nikhil___ did you address the security issue file to file?
20:40:09 <nikhil___> arnaud: yeah, will try to summarize the situation until then and we can take the next best step
20:40:18 <zhiyan> sure, if i can get ones. and let me do "recheck no bug" on it.
20:40:28 <nikhil___> arnaud: will have it then (not yet)
20:40:39 <arnaud> ok, great
20:40:47 <nikhil___> I mean, it's wip (security concern)
20:40:56 <nikhil___> zhiyan: sure, thanks
20:41:27 <arnaud> ok, so next on our agenda is the glance.store lib
20:41:34 <arnaud> #topic glance.store
20:41:50 <arnaud> flaper87|afk, seems to be AFK
20:42:10 <arnaud> #link https://review.openstack.org/#/c/100636/
20:42:34 <arnaud> based on our poll last week, we decided to continue the efforts to have the glance.store library
20:43:12 <nikhil___> ok, great. so what's next for glance? or do we keep them separate for now?
20:43:41 <arnaud> so apparently flaper87|afk released an alpha version of the lib: https://pypi.python.org/pypi/glance.store/0.0.1a2
20:44:33 <arnaud> with that, there should not have other blockers to integrate with glance
20:45:08 <arnaud> however, we have a couple of patches in the stores that are in the glance codebase but not in the glance.store codebase
20:45:15 <zhiyan> #link https://review.openstack.org/#/c/100636/
20:45:19 <arnaud> so, we will need to port them
20:45:36 <arnaud> the problem being that it's not a clean patch from what I have seen
20:46:07 <nikhil___> I would prefer to wait until at least a stable beta is released
20:46:20 <nikhil___> however, +1 to getting this in j-3
20:46:48 <arnaud> so, I think the rule for now is to that: before accepting a store patch to glance, we need to have the patch proposed to to glance.store with green jenkins
20:47:02 <zhiyan> how to get the function/patch list for the port
20:47:09 <nikhil___> arnaud: yes, thanks wanted to express the same concern
20:47:15 <arnaud> https://review.openstack.org/#/q/status:open+project:openstack/glance.store,n,z
20:47:30 <arnaud> for now there is nothing to review, but I expect this to grow
20:47:30 <arnaud> :)
20:47:42 <nikhil___> also, do we have the links to those coulpe commits that are in glance and not in the glance.store lib ?
20:48:01 <arnaud> flaper87|afk, might have it
20:48:07 <arnaud> it should be easy to get
20:48:15 <nikhil___> sure
20:48:30 <arnaud> #action get the list of patches that are in glance and not glance.store
20:49:21 <arnaud> so hopefully this integration with glance will happen soon
20:50:01 <nikhil___> :)
20:50:12 <arnaud> ativelkov, would you mind giving an update on artifacts?
20:50:24 <ativelkov> sure
20:50:29 <arnaud> #topic artifacts
20:52:21 <ruhe> arnaud: ativelkov will reconnect in a second. he's got disconnected from irc bouncer
20:52:39 <ativelkov> I've updated the spec, API and data model based on what we had discussed on the mini-summit
20:52:39 <ativelkov> We'll submit for the review soon
20:52:45 <ativelkov> Got some feedback from TravT about the type-specific metadata field and their types
20:52:58 <ativelkov> did you get messages from me?
20:53:07 <arnaud> yes ativelkov
20:53:11 <ativelkov> Seems like I've gor some network issues, sorry
20:53:51 <arnaud> so, we are going to take a look at the updated spec then
20:54:07 <ativelkov> So, in general I am trying to align the artifact metadata definitions with the metadefs by now. Will need some help from TravT and his team with this
20:54:42 <nikhil___> is this feature planned for j-3 or k-1 now ?
20:54:58 <arnaud> yes, this is great, it will be nice if there is consistency between them
20:55:17 <TravT> ativelkov: yes
20:55:19 <ativelkov> nikhil___: still planning to fit this inside j3
20:55:25 <TravT> I can help
20:55:26 <nikhil___> ok, thanks
20:55:34 <ativelkov> Yet it takes longer then I expected initially
20:56:11 <TravT> also, once we get metadefs landed, i think lakshmiS and wayne_ will be able to help with code
20:56:18 <ativelkov> great, thanks!
20:56:45 <arnaud> ativelkov, you want to share the Murano proposal with the team?
20:56:51 <arnaud> we don't have much time left
20:57:05 <ativelkov> that's better question to ruhe, as he is Murano's PTL now
20:57:34 <ruhe> arnaud: i'd like to hear from Mark first
20:57:52 <ruhe> on the results of his discussion with Thierry
20:57:56 <arnaud> sure, no problem. Since we don't have time left anyway, that's better :)
20:58:08 <ativelkov> BTW, we'got one more man working with me on Glance from Mirantis' side
20:58:18 <ativelkov> rvasilets, welcome ;)
20:58:33 <arnaud> great welcome rvasilets
20:58:46 <arnaud> #topic open discussion
20:59:17 <ativelkov> If we have any "low hanging fruits" or something for rvasilets to get familiar with the codebase - that would help a lot
20:59:51 <arnaud> we definitely need to do a better job at tagging bugs...
21:00:07 <rvasilets> Hello to all. I'm assigned at glance. Can someone give me some small bug/ I want to fix it. Thanks, Roman.
21:00:27 <lakshmiS> any plans on merging https://review.openstack.org/#/c/103959/ soon. we can include this feature in metadefs once the patch merges or add this feature in next patch
21:00:44 <arnaud> have you looked at https://bugs.launchpad.net/glance/+bugs?field.tag=low-hanging-fruit ?
21:01:04 <arnaud> yes lakshmiS, this will land soon
21:01:12 <arnaud> I am going to re-review it later today
21:01:20 <arnaud> ok, we are overtime
21:01:23 <lakshmiS> ok thx
21:01:24 <arnaud> thanks guys
21:01:27 <arnaud> #endmeeting