20:02:35 <nikhil_k> #startmeeting Glance
20:02:35 <openstack> Meeting started Thu Oct 30 20:02:35 2014 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:38 <openstack> The meeting name has been set to 'glance'
20:02:49 <nikhil_k> #link Agenda https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:03:07 <nikhil_k> seems like we've a small group
20:03:14 <nikhil_k> we can do this quick
20:03:35 <nikhil_k> some general updates
20:03:39 <nikhil_k> #topic Updates
20:04:01 <nikhil_k> Next summit is in vancouver
20:04:10 <nikhil_k> and the one after is in APAC
20:04:24 <ativelkov> APAC?
20:04:35 <nikhil_k> iiuc, Asia Pacific
20:04:53 <nikhil_k> next one
20:04:59 <ativelkov> (google says APAC is in Uganda, don't want to go there)
20:05:07 <esheffield> o/
20:05:08 <nikhil_k> I know, it does say that
20:05:16 <nikhil_k> ativelkov: me neither
20:05:34 <nikhil_k> anyways, we got slap on the hand again from the release management
20:05:57 <nikhil_k> for not pushing bugs early in the RCs
20:06:16 <nikhil_k> so, this makes it even more important in kilo
20:06:32 <nikhil_k> that means, we def need informal freeze on the blueprints
20:06:39 <nikhil_k> something to help you all on that...
20:06:54 <ativelkov> and more formal tagging process, right?
20:07:01 <nikhil_k> #link https://review.openstack.org/#/c/131550/
20:07:09 <nikhil_k> ativelkov: yeah
20:07:23 <nikhil_k> there is a glance "bug team" in launchpad
20:07:33 <nikhil_k> I recommend everyone interested signing up for it
20:07:48 <nikhil_k> and keep an eye on the potential bugs to be listed in the RC
20:08:02 <nikhil_k> and see which are getting enough work/reviews
20:08:24 <ativelkov> what about having "Review days" - similar to the "bug days" we had?
20:08:38 <nikhil_k> ativelkov: let's get a vote on that
20:08:42 <ativelkov> to focus team's power specifically on reviewing
20:08:46 <nikhil_k> we'd a push back last time
20:09:09 <ativelkov> ah. What are the drawbacks in this?
20:09:17 <nikhil_k> anyone interested in conducting review day?
20:09:19 <nikhil_k> ativelkov: dunno
20:09:54 <ativelkov> I do believe that we at least should do some extra reviewing for the bugs tagged for backporting
20:10:10 <nikhil_k> yep
20:10:14 <ativelkov> as time is running fast, and K1 is not THAT far
20:11:05 <nikhil_k> 2014-12-18  -> k1
20:11:19 <nikhil_k> okay then, we can decide that after the summit when everyone is around for the review day proposal
20:11:34 <nikhil_k> next up
20:11:35 <ativelkov> so, my +1 for "review days" at least when approaching milestones. But yeah, let's wait for wider audience
20:11:43 <nikhil_k> cool
20:11:52 <nikhil_k> agenda for the summit
20:12:12 <nikhil_k> Hope everyone is at least "okay" with the topics and schedule
20:12:36 <nikhil_k> it's a bummer that we did not get to have either of our cross project topics
20:12:51 <nikhil_k> if not, please let me know soon-ish
20:13:12 <nikhil_k> even for any conflicts with glance sessions with cross-project ones (if that's applicable)
20:13:24 * nikhil_k should study the schedule further
20:13:51 <nikhil_k> anyways, there is a tiny-miniscule chance that a change to schedule is possible
20:14:24 <nikhil_k> Cool! That's good news.
20:14:38 <nikhil_k> next one
20:14:40 <ativelkov> But the slots (4 session wednesday + meetup on Friday) are fixed, aren't they?
20:14:57 <nikhil_k> they could change as well
20:15:03 <nikhil_k> though seems very tricky
20:15:26 <nikhil_k> as the scheduling is a complicated process
20:15:59 <nikhil_k> we need a fix / direction for https://bugs.launchpad.net/python-glanceclient/+bug/1382582
20:16:00 <uvirtbot> Launchpad bug 1382582 in python-glanceclient "untestable in Python 3.4" [Critical,In progress]
20:16:02 <nikhil_k> soon-ish
20:16:29 <nikhil_k> seems like our glance-client tests fail and is blocking py34 to be enabled on gate
20:16:48 <nikhil_k> that's a must fix or give alternative kinda bug
20:17:13 <nikhil_k> there was one volunteer for QA liaison, is he here?
20:17:57 <nikhil_k> okay then, we can move and deal with it later
20:18:10 <nikhil_k> survey
20:18:40 <nikhil_k> please try to take out 3 or so mins of your time to complete the survey
20:18:48 <nikhil_k> #link http://goo.gl/forms/mfDEXdY0DA
20:19:08 <nikhil_k> so, we can start planning on the next meetup
20:19:14 <nikhil_k> virtual or otherwise
20:19:38 * ativelkov has already filled this in
20:19:49 <nikhil_k> Thanks ativelkov
20:20:02 <nikhil_k> and to those who have already given your responses
20:20:05 <nikhil_k> much appreciated
20:20:13 <nikhil_k> it is really helpful
20:20:42 <TravT> will you share the results of the survey?
20:20:56 <nikhil_k> TravT: for sure
20:21:02 <nikhil_k> until now
20:21:19 <nikhil_k> we've everyone who liked our vitual summit
20:21:38 <nikhil_k> most do NOT want to get rid of face to face meetup
20:22:10 <nikhil_k> and most also said okay to having more of these video sessions
20:22:24 <nikhil_k> total responses = 5 (until a few hours back) :P
20:22:34 <nikhil_k> that's good though
20:22:40 <TravT> sounds positive
20:22:51 <nikhil_k> who all liked or disliked will try to give feedback soon-ish
20:23:12 <nikhil_k> and the rest of the population is pretty much neutral if they do not take the survey (by default)
20:23:39 <nikhil_k> moving on
20:23:45 <nikhil_k> #topic Meeting Times
20:24:04 <nikhil_k> Should we move all the meetings to 14UTC?
20:24:10 <nikhil_k> #vote
20:24:25 <nikhil_k> heh, only if I remembered how to do this
20:24:30 <ativelkov> #startvote
20:24:31 <openstack> Only the meeting chair may start a vote.
20:24:54 <nikhil_k> #startvote Should we move all the meetings to 14UTC?
20:24:55 <openstack> Begin voting on: Should we move all the meetings to 14UTC? Valid vote options are Yes, No.
20:24:56 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:25:10 <ativelkov> #vote Yes
20:25:49 <nikhil_k> hmm, may be we need to take this vote during the other meeting time too
20:26:02 <nikhil_k> unless there are some NOs here
20:26:07 <ativelkov> yes, seems like we don't have quorum today
20:26:13 <nikhil_k> not sure if arnaud is still around?
20:26:19 <arnaud> I am
20:26:24 <nikhil_k> ah
20:26:25 <arnaud> :)
20:26:33 * TravT looking at time zone conversion table
20:26:34 <nikhil_k> you are prolly most affected by this change
20:26:48 <arnaud> #vote Yes
20:26:58 <arnaud> but we might want to check with Zhi
20:27:38 <TravT> Can it be 1400 UTC until daylight time starts in US?  Then change to 1500 UTC?
20:27:43 <nikhil_k> sure
20:27:59 <nikhil_k> hmm, TravT we may have to check
20:28:01 <nikhil_k> one sec
20:28:15 <ativelkov> this probably depends on the slot availability
20:28:19 <ativelkov> This is shared channel
20:28:25 <arnaud> +1 ativelkov
20:28:29 <ativelkov> probably some other project may have this slot
20:29:00 <nikhil_k> we've one conflict
20:29:14 <nikhil_k> Manila Team meeting
20:29:59 <nikhil_k> wonder if they will let us use other channel for our meetings
20:30:27 <nikhil_k> #action nikhil_k: find if using other meeting channel is allowed to accomodate 15UTC Thursdays
20:30:51 <ativelkov> is 14:00 available on both weeks?
20:31:04 <nikhil_k> good point
20:31:12 <TravT> time change is next week.  to standard time.
20:31:35 <nikhil_k> seems so
20:31:43 <nikhil_k> yeah
20:31:57 <nikhil_k> we prolly won't change anything for at least 2 weeks
20:32:06 <nikhil_k> to accomodate travels etc
20:32:19 <nikhil_k> so, that's end of novemenber range
20:32:30 <nikhil_k> Better to do this on ML
20:32:52 <nikhil_k> #endvote
20:32:53 <openstack> Voted on "Should we move all the meetings to 14UTC?" Results are
20:33:02 <nikhil_k> #showvote
20:33:18 <ativelkov> Looks like the bot has died
20:33:23 <ativelkov> poor guy
20:33:36 <nikhil_k> openstack: ping
20:33:44 <nikhil_k> that prolly doesn't exist
20:33:52 <nikhil_k> anywhu
20:34:06 <nikhil_k> __hemanthm: around?
20:34:13 <TravT> well, my vote would be for an hour later during standard time.
20:34:14 <nikhil_k> ativelkov: your idea about the team page
20:34:38 <nikhil_k> I think Hemanth wanted to add some review guidelines stuff
20:34:54 <nikhil_k> so that we've less of back and forth and better reviews too
20:35:15 <nikhil_k> may be you guys can team up
20:35:40 <nikhil_k> cool, next one
20:35:43 <nikhil_k> #topic Image filtering
20:35:48 <ativelkov> Yes, we'll join
20:35:51 <nikhil_k> not sure who proposed that
20:35:58 <ativelkov> I pu it to agenda
20:36:03 <nikhil_k> thanks
20:36:06 <ativelkov> becuase the after of that commit pinged me about it
20:36:10 <ativelkov> author*
20:36:26 <nikhil_k> heh okay :)
20:36:39 <nikhil_k> I would say may be even a git repo should be fine
20:37:00 <ativelkov> thats https://review.openstack.org/#/c/125780/
20:37:22 <nikhil_k> ah, I got your wrong earlier
20:37:29 <nikhil_k> ativelkov: if you wanted to go ahead
20:37:46 <ativelkov> Yeah, just a topic to discuss about API compatibility
20:38:29 <ativelkov> commit author (wborkowski) want to filter images by "contains" filter
20:38:35 <ativelkov> instead of name equality
20:39:00 <ativelkov> so glance image-list --name cirros will return all images
20:39:14 <ativelkov> containing "cirros" inside the name
20:39:40 <nikhil_k> don't think we've any issues yet
20:39:42 <ativelkov> I believe it may be a good idea, but if implemented directly as it is proposed, it will break backwards compatibility
20:40:00 <ativelkov> so I've -1'ed the commit and called for wider discussion
20:40:15 <ativelkov> That's why the topic is in agenda :)
20:40:44 <TravT> if we do the search index, that api change won't be needed.
20:41:19 <nikhil_k> well for those who start using search index, at least right away
20:42:04 <TravT> if this is to be added, I'd think the API should be changed to have an option to go from contains to equality.
20:42:13 <TravT> vice versa
20:42:23 <nikhil_k> ativelkov: this seems tricky right
20:42:28 <ativelkov> TravT: agree. And default should have the old semantics, so we don't break backwards compatibility
20:42:41 <nikhil_k> we want to specify if complete match is needed or not
20:42:49 <nikhil_k> yeah
20:44:12 <ativelkov> I've actually expected Wlodzimerz to be here (that's why I've pu it to agenda so he could defend his position), but it turns out he is not here
20:44:34 <nikhil_k> we've a smaller group anyways, we can catch up post-summit on this
20:44:45 <nikhil_k> ativelkov: should we move on?
20:44:46 <TravT> well, I'm going to -1 it with the same reason ativelkov
20:45:10 <ativelkov> nikhil_k: yup
20:45:13 <nikhil_k> cool
20:45:19 <nikhil_k> another important bug
20:45:48 <nikhil_k> #topic bug1381419
20:45:56 <nikhil_k> https://bugs.launchpad.net/glance/+bug/1381419
20:45:59 <uvirtbot> Launchpad bug 1381419 in glance "glance.tests.unit.v2.test_images_resource.TestImagesController.test_index_with_marker failed in periodic stable job run" [Critical,New]
20:47:02 <nikhil_k> pardon me, forgot the context
20:47:05 <nikhil_k> :)
20:47:22 <nikhil_k> been almost 2 weeks
20:47:56 <nikhil_k> will move on for now and come back to this in the next meeting
20:48:14 <TravT> if this is blocking gate jobs, then it seems very important
20:48:27 <nikhil_k> Don't think it's blocking
20:48:34 <nikhil_k> its prolly recurrent
20:48:45 <ativelkov> we have rally job failing as well. Is anybody working on it?
20:48:59 <nikhil_k> think, it was fixed last night/eve
20:49:22 <ativelkov> ah, good. Didn't notice that
20:49:38 <nikhil_k> #topic Open Discussion
20:49:55 <nikhil_k> woot! we've managed to give 10 mins to this topic.. finally
20:50:16 <nikhil_k> nothing?
20:50:34 <wborkowski> Hi
20:50:42 <wborkowski> miss my part :(
20:51:00 <nikhil_k> no issues, we can discuss now
20:51:05 <ativelkov> wborkowski: hi. We have time for it now
20:51:26 <wborkowski> thx for review with name filter, just see similar request here: https://bugs.launchpad.net/python-glanceclient/+bug/917692
20:51:27 <uvirtbot> Launchpad bug 917692 in python-glanceclient "pattern matching for glance image-list filters" [Wishlist,Confirmed]
20:51:55 <wborkowski> I think it's related with it
20:52:33 <ativelkov> filtering by name-contains is definitely useful
20:52:49 <ativelkov> the question is about the implementation and proposed change to API
20:53:14 <wborkowski> ok
20:54:21 <ativelkov> what I am worried about is that your implementation implicitly changes the API to less-restrictive. Which is not a good thing to do for a service which is already in production.
20:55:16 <TravT> mark also has a comment in the bug about this having an impact on performance
20:56:24 <nikhil_k> true
20:56:41 <ativelkov> right, this will require full-text indexing on the name column
20:57:34 <wborkowski> ok, nice to have future, but I understand the consequences :S
20:57:43 <ativelkov> which is possible, yet I donno if it can be defined in Alchemy without divin into RDBMS specifics
21:00:02 <nikhil_k> wborkowski: wonder if an alternative approach for people who just want to use this might be okay
21:00:03 <TravT> btw, we'll have a POC demo of indexed auto completion to show next week.
21:00:31 <nikhil_k> wborkowski: just creating a property with name as substring and using that as the base
21:01:00 <ativelkov> TravT: that's great. Definitely wana see it
21:01:23 <nikhil_k> we are over time
21:01:30 <nikhil_k> Thanks all!
21:01:34 <nikhil_k> #endmeeting