15:00:18 <nikhil_k> #startmeeting Glance
15:00:18 <openstack> Meeting started Thu Jan 22 15:00:18 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:23 <openstack> The meeting name has been set to 'glance'
15:00:32 <kragniz> o/
15:00:34 <ativelkov> o/
15:00:37 <sigmavirus24> o/
15:00:45 <sigmavirus24> f/goto bops
15:00:49 <pennerc> o/
15:01:21 <nikhil_k> Let's get started!
15:01:24 <nikhil_k> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
15:01:41 <nikhil_k> #topic Updates
15:01:46 <TravT_> o/
15:01:50 <nikhil_k> The updates this week are about
15:01:58 <nikhil_k> 1. Mid-cycle meetup schedule ..
15:02:02 <nikhil_k> 2. K-2
15:02:10 <nikhil_k> 3. K3
15:02:22 <nikhil_k> #topic Mid-cycle meetup schedule
15:02:31 <nikhil_k> #link https://etherpad.openstack.org/p/kilo-glance-mid-cycle-meetup
15:03:08 <nikhil_k> if you have responded, you must have received an email.
15:03:49 <nikhil_k> If anyone has any questions on the venue, directions, topics, schedule, food etc
15:04:04 <nikhil_k> Please bring it up now or send an email to me
15:04:12 <sigmavirus24> How do remote participants request food? /kidding
15:05:29 <nikhil_k> #action everyone: please respond to the long lunch proposal either way soon
15:05:36 <nikhil_k> Next.
15:05:39 <nikhil_k> #topic K-2
15:05:46 <nikhil_k> https://launchpad.net/glance/+milestone/kilo-2
15:06:07 <nikhil_k> We've a long list of reviews
15:06:19 <nikhil_k> Please take a look at them on priority.
15:06:58 <nikhil_k> If the code has not major objections, and the spec is consistent with the code proposed it would be merged soon
15:07:14 <nikhil_k> You must already have received some feedback
15:07:33 * sigmavirus24 hasn't on the Policy blueprint
15:08:05 <nikhil_k> #action: everyone, the k2 bugs (if not necessary) can moved to k3 as long as corresponding code does not look in a good shape.
15:08:23 <nikhil_k> sigmavirus24: that one is dicey
15:08:39 <nikhil_k> let's see how things go on others in next couple of days
15:08:56 <nikhil_k> we need reviewers focused on small set of patches so that at least some get in
15:09:42 <sigmavirus24> Yeah, I figured mine would be okay for k-3 so I targetted there. Someone moved it to k-2 apparently
15:09:52 <nikhil_k> If anyone is worried about a patch not getting in soon, this might be a good time to speak up (or about something getting in that shouldn't be)
15:10:29 <nikhil_k> sigmavirus24: it was me :P (optimistically prioritizing)
15:10:41 <nikhil_k> Next.
15:10:44 <nikhil_k> #topic K3
15:11:10 <nikhil_k> The following features/additions/changes have been deferred to k3
15:11:13 <nikhil_k> 1. Catalog Service
15:11:18 <nikhil_k> 2. Artifacts
15:12:39 <nikhil_k> The deactivation of an image and policy changes *may* get in k2 . (due to some recent developments)
15:13:07 <nikhil_k> Other specs that have not received any significant reviews yet
15:13:27 <nikhil_k> They are just hard to focus on given other major changes that we are planning to adopt this cycle.
15:14:20 <nikhil_k> That was the updated part. We can leave some time here for feedback.
15:14:28 <nikhil_k> *update*
15:15:36 <TravT_> So, FYI, with catalog service, one of the tasks was to add notifications for metadefs.  You and Brian thought we should break that out.  So, I'll be putting up a spec on that.
15:15:51 <sigmavirus24> That review is already written, yes?
15:16:02 <nikhil_k> TravT_: Sounds like a good idea.
15:16:04 <sigmavirus24> (The actual metadef notification code)
15:16:14 <TravT_> yes, kamil has a good start on it
15:16:16 <krykowski> Yup, the implementation is ready (almost?)
15:16:43 <nikhil_k> It's fine to start off sluggish and keep a watch on the bugs.
15:17:10 <nikhil_k> Seems like metadef team has been actively resolving some as well as has been great with specs.
15:17:52 <nikhil_k> (Basically, we would be short of reviewers)
15:18:12 <nikhil_k> #topic Reviews/Bugs/Releases
15:18:23 <nikhil_k> 1. Glance client
15:18:24 <nikhil_k> https://launchpad.net/python-glanceclient/+milestone/v0.16.0
15:18:28 <nikhil_k> 2. glance_store
15:18:33 <nikhil_k> https://launchpad.net/glance-store/+milestone/v0.1.11
15:18:51 <nikhil_k> Those are the planned ones
15:19:15 <nikhil_k> kragniz: brought a good point that we should probably release SemVer style
15:19:16 <mfedosin> what about sorting features for v2 in the client?
15:19:44 <nikhil_k> So, yeah. Things like that - please mark it on the lp and
15:20:05 <nikhil_k> leave a message to sigmavirus24 kragniz jokke_ zhiyan or me to add it to the trello board
15:20:12 <nikhil_k> flapper87 too
15:20:50 <nikhil_k> sigmavirus24: I kinda stole your topic, did you have anything more important to point out?
15:20:59 <nikhil_k> (sorry about that)
15:21:06 <sigmavirus24> Nope. Just wanted to discuss it's progress :)
15:21:26 <nikhil_k> Cool. Looks like reviews for the most part.
15:21:28 <kragniz> I'm planning on writing release notes for client and store when some of the reviews are merged
15:21:37 <nikhil_k> kragniz: +1
15:21:52 <sigmavirus24> I thought PBR did that for us or something
15:22:04 <kragniz> sigmavirus24: not release notes
15:22:31 <nikhil_k> personal touch is always welcoming ;)
15:22:36 <kragniz> sigmavirus24: we went over this with dhellmann :P
15:22:47 <sigmavirus24> PBR confuses me
15:22:47 * nikhil_k means that in the modest possible way
15:24:18 <nikhil_k> Who's next?
15:24:28 <stpierre> is this a point where i can hop in? i need to find core reviewer(s) for https://review.openstack.org/#/c/145223/
15:24:28 <nikhil_k> Feature request:-
15:24:29 <nikhil_k> https://bugs.launchpad.net/glance/+bug/1411215
15:25:31 <sigmavirus24> Yeah I added that and wanted to bring attention to it. It seems useful but I'm not sure if it is really desirable
15:25:51 <sigmavirus24> Also I wanted to make sure no one things that anything other than a glob-like syntax is necessary
15:26:02 <nikhil_k> sigmavirus24: we've planning to work on the cloning feature for that
15:26:03 <sigmavirus24> Compiling regular expressions provided by the user seems like a badidea
15:26:55 <rosmaita> +1
15:27:06 <rosmaita> we want to push that stuff to the metadata indexing service
15:27:28 <sigmavirus24> stpierre: I'm not a core but I'll look at that today
15:28:21 <nikhil_k> stpierre: can we wait just a bit? would like to give some feedback in the open discussion
15:28:25 <stpierre> sure
15:28:32 <nikhil_k> Next.
15:28:48 <nikhil_k> https://bugs.launchpad.net/glance/+bug/1188532 nominated for juno and icehouse
15:29:10 <sigmavirus24> The OSSA requested someone nominate it for those but we haven't accepted the nominations
15:29:17 <sigmavirus24> (Or we hadn't as of last night)
15:29:57 <sigmavirus24> So I wanted feedback as to whether we do want to backport and someone to accept those. I'll backport them today since teh juno branch freeze starts on 30 Jan
15:30:01 <nikhil_k> sigmavirus24: the duplicate one has more info unfortunately https://bugs.launchpad.net/glance/+bug/1383973
15:30:40 <nikhil_k> sigmavirus24: I'd started work on it yday and could get to it only partially. It's tricky due to the glance_store changes. We can discuss more offline.
15:31:27 <TravT_> That looks like a good one to backport to me
15:31:46 <sigmavirus24> Okay
15:32:00 <sigmavirus24> I just wanted to bring it up since the next juno release is not far off
15:32:15 <ativelkov> May I for some attention on https://bugs.launchpad.net/glance/+bug/1412802 ?  Quite a nasty bug, and also worths backporting to I-J
15:32:56 <nikhil_k> sigmavirus24: this is the most active duplicate https://bugs.launchpad.net/glance/+bug/1398830
15:33:23 <sigmavirus24> Oh that's already nominated. Nevermind :)
15:33:59 <nikhil_k> yeah, lp needs a cleanup there ;)
15:35:03 <nikhil_k> ativelkov: can we get to you review after sigmavirus24's next one?
15:35:19 <TravT_> ativelkov: nikhil_k: I'm kind of surprised that is only a medium.  since it is data corruption \ loss.
15:35:24 <ativelkov> Sure, sorry for interrupting
15:36:01 <sigmavirus24> Next one is just the spec for passing real targets to the policy enforcer (which is now targetted for k-2)
15:36:05 <nikhil_k> TravT_: be back on that, sorry
15:36:09 * TravT_ shuts mouth too ;)
15:36:25 <nikhil_k> https://review.openstack.org/#/c/149112/
15:36:31 <sigmavirus24> so I'd love feedback on that and early review on the associated review is appreciated. I have ideas for tests as detailed in the spec but haven't added them
15:36:34 <sigmavirus24> yes, thanks nikhil
15:37:10 <nikhil_k> awesome, thanks for that pointer sigmavirus24 !
15:37:22 * sigmavirus24 hands torch to ativelkov
15:37:42 <ativelkov> Thanks sigmavirus24 :)
15:38:01 <ativelkov> Well, that's a data corruption issue I recently found
15:38:17 <ativelkov> The fix is here: https://review.openstack.org/#/c/148574/
15:39:00 <ativelkov> As it happens in Icehouse and Juno, I proposed to backport it (which is quite simple: the changed code haven't been modified for a long time)
15:40:02 * sigmavirus24 is reviewing
15:40:12 <nikhil_k> ativelkov: TravT_ : yeah, I think we can mark it critical.
15:40:42 <nikhil_k> Our initial discussion with ativelkov lead me to believe this was specific to stores, with the values associated to them
15:41:09 <nikhil_k> Thanks for the pointer TravT_ , much appreciated!
15:41:42 <sigmavirus24> Should we target that to k-2?
15:41:50 <nikhil_k> just did :)
15:42:08 <nikhil_k> Thanks
15:42:08 <ativelkov> If more reviews come, we may definetly release it in k2
15:42:38 <nikhil_k> might be a good idea to focus on critical bug sooner
15:42:48 <nikhil_k> ;)
15:43:01 <nikhil_k> Need to sync openstack/common from oslo-incubator:
15:43:10 <lakshmiS> Need to sync openstack/common from oslo-incubator for service module - catalog index service requires it for notifications listener
15:43:14 <nikhil_k> lakshmiS: ^ (seems like you)
15:43:15 <lakshmiS> Should i open a bug to import it?
15:43:34 <nikhil_k> that would be great
15:43:47 <lakshmiS> We are also looking at the service module to use as a framework for notification refactoring - similar to how ceilometer uses it for notifications.
15:44:15 <lakshmiS> are there any other ideas on refactoring notifications?
15:45:24 * sigmavirus24 hasn't looked at notifications in depth yet so I can't give useful feedback, yet
15:45:55 <krykowski> according to current work at notifications for metadata objects https://review.openstack.org/#/c/148546/ which is based on implementation from images
15:46:09 <nikhil_k> We are thinking about some notification refactoring in glance, this might come up in Nova-Glance common session at the mini-summit
15:46:35 <lakshmiS> is there a agenda for nova-glance common session?
15:46:39 <nikhil_k> Please free to float this idea on the summit etherpad, we can try to sneak it in >.>
15:46:47 <lakshmiS> ok
15:47:18 <nikhil_k> #topic Open Discussion
15:47:48 <nikhil_k> stpierre: about your spec
15:48:41 <nikhil_k> Looks like a good improvement. I'm just worried about it clashing with https://review.openstack.org/#/c/125156/ and (possibly) https://review.openstack.org/141331
15:49:16 <nikhil_k> Just with the code proposal path.
15:49:51 <nikhil_k> stpierre: if you've a draft ready, we can try to merge it faster than those two.
15:50:10 <nikhil_k> (unlikely for k2)
15:50:23 <stpierre> i don't have anything ready yet unfortunately
15:51:04 <nikhil_k> stpierre: no issues, not a possibility in next 2 weeks. So, anything after than is welcome :)
15:51:22 <stpierre> okay, i can definitely have something by then
15:51:41 <nikhil_k> sigmavirus24: would you like to be assigned to https://bugs.launchpad.net/glance/+bug/1398830 backports? (I can help as needed and in review too ;) )
15:51:47 <stpierre> the only potentially serious point of contention i see is with the "in-memory cache" in the first spec there; it doesn't describe how the in-memory cache will be populated. but even that should be fairly trivial since my change will just replace the current read/write operations with something consistent and easy :)
15:52:04 <stpierre> so all i need is a core reviewer to sign on and i can be off and writing code
15:52:23 <nikhil_k> stpierre: feel free to assign and bug me on this
15:52:26 <sigmavirus24> nikhil_k: go for it
15:52:31 <sigmavirus24> i'll assign myself
15:52:35 <nikhil_k> sigmavirus24: awesome!
15:52:46 <sigmavirus24> I'm going to prioritize juno though
15:52:47 <sigmavirus24> because deadlines
15:52:51 <stpierre> nikhil_k: tyvm
15:52:52 <nikhil_k> +1
15:53:01 <nikhil_k> stpierre: :)
15:54:54 <nikhil_k> If nothing else ...
15:55:37 <TravT_> looking forward to seeing many of you next week!
15:55:49 <sigmavirus24> TravT_: ;_;
15:55:54 <kragniz> TravT_: ;_;
15:56:03 <sigmavirus24> Also TravT_ sorry I misunderstood your spec. I read it totally wrong :)
15:56:10 <TravT_> yeah, wish you guys could be there.
15:56:39 <TravT_> sigmavirus24: no worries
15:56:39 <nikhil_k> Thanks all!
15:56:56 <nikhil_k> #endmeeting