14:00:00 <nikhil_k> #startmeeting Glance
14:00:01 <openstack> Meeting started Thu Feb 12 14:00:00 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'glance'
14:00:05 <jokke_> o/
14:00:09 <ativelkov> o/
14:00:13 <abhishekk> o/
14:00:16 <mfedosin> o/
14:00:16 <rosmaita> o/
14:00:17 <lakshmiS> o/
14:00:26 <nikhil_k> https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:46 <zhiyan> o/
14:00:57 <nikhil_k> Welcome all, good morning, afternoon, evening to all in resp. TZ!
14:01:15 <rosmaita> zhiyan: hope you are feeling better!
14:01:20 <sigmavirus24> o/
14:01:23 <nikhil_k> Let's get the party started
14:01:36 <nikhil_k> #topic Abandoning stale PS from review
14:01:43 <nikhil_k> was that you jokke_ ?
14:01:46 <jokke_> Yup
14:01:53 <zhiyan> rosmaita: thanks! I'm better now.
14:02:06 <nikhil_k> jokke_: please take over
14:02:12 <jokke_> I would like to adopt the principle some other projects like Nova is using
14:02:35 <jokke_> so if PS has been inactive for 3 weeks + we just abandon it to keep the review list clean and fresh
14:02:58 <jokke_> I think we have at the moment year(s) old changes still on the list
14:03:28 <nikhil_k> should we get a vote here and then take to ML if necessary?
14:03:44 <mfedosin> hm, before I would say it's a bad idea, but now, when we have lots of active reviewers I'm okay with it
14:04:44 <jokke_> mfedosin: ok let me refrase a bit ... lets say there is change that has bunch of -1 and the author just has not acted on those, so effectively already abandoned the change
14:05:07 <sigmavirus24> jokke_: right, I think that's something that needed to be clarified
14:05:14 <jokke_> If the change has 5 +1 and +2 we're not gonna drop it just because last activity was 21 days
14:05:18 <ativelkov> so, not just inacative, but inactive with negative feedback or broken tests, right?
14:05:34 <jokke_> but taking this on would help us to identify those changes that would be ready & good to go in
14:05:34 <pkoniszewski> o/
14:05:45 <sigmavirus24> ativelkov: I think negative review is enough
14:05:54 <sigmavirus24> Passing tests don't mean very much if no one wants the change :)
14:06:08 <nikhil_k> ativelkov: yes, only with a -1 (though even from jenkins)
14:06:10 <jokke_> ativelkov: yeah I think either one of those would be good enough trigger
14:06:20 <jokke_> nikhil_k: well formatted!
14:06:41 <nikhil_k> also, I think we can do this on Glance but not on some repos like glance-specs
14:06:44 <sigmavirus24> jokke_: I'm wondering about changes with a bunch of +1s during which Jenkins was broken and no one rechecked them
14:07:14 <nikhil_k> (as some specs would mean carry over to next cycle and will sit for a more than 3 weeks in some cases)
14:07:45 <jokke_> sigmavirus24: if author does not care enough to recheck the change in 3 weeks, I think it's good to drop ... specially when the owner can revive any abandone change later on if needed
14:08:09 <jokke_> nikhil_k: yes, I think -spec is special cupcake anyways
14:08:27 <ativelkov> Yes, and this should not happen during freezes: if we are close to release, some changes may lack attention for some time
14:08:29 <jokke_> sigmavirus24: or anyone else in that matter
14:09:01 <TravT_> 3 weeks seems slightly short.  is that what all the other projects did?
14:09:02 <jokke_> ativelkov: ++ I think this needs bit of game eye on holiday seasons, around freeze etc.
14:09:06 <nikhil_k> ativelkov: hmm, good point
14:09:12 <TravT_> i was just thinking of holiday
14:09:28 <mfedosin> and why exactly 21 days or not 28 or 14?
14:09:47 <sigmavirus24> Yeah I think an etherpad detailing the exact procedure should be the next step and have it sent to the ML? I think everyone here is in favor
14:09:52 <kragniz> o/
14:09:55 <ativelkov> mfedosin: cause 21 is 3x7, and 3+10 is 10, which is cool
14:09:58 <jokke_> I'm not proposing that we will do automated script or anything like that, but this would be just mandate for cores to clean up the list for those oldies no-one seems to care about
14:10:01 <sigmavirus24> We're all just nitpicking the details and finer mechanics so that's better suited for the ML
14:10:17 <nikhil_k> heh, I think that is probably a rythm within openstack of 3 weeks
14:11:15 <mfedosin> fast rhythm btw
14:11:29 <nikhil_k> jokke_: sigmavirus24 : ok, how about a email is sent to the ML and we announce a reminder in next weeks meeting for all those interested to respond accordingly
14:11:45 <mfedosin> okay, I don't mind just was a little bit curious
14:11:58 <nikhil_k> mfedosin: so, we've 6 weeks long intermediate milestones
14:11:59 <jokke_> nikhil_k: will try to get the etherpad/e-mail out there today or tomorrow latest
14:12:14 <nikhil_k> (like k-1, k2, etc.)
14:12:35 <nikhil_k> jokke_: Thanks!
14:12:44 <sigmavirus24> #action jokke_ to put together an etherpad and send a message to the mailing list
14:12:55 <nikhil_k> sigmavirus24: thanks, was just about to :)
14:12:56 <zhiyan> jokke_: i think automated script is better...
14:12:57 <sigmavirus24> =P
14:12:58 <jokke_> mfedosin: consistency
14:13:19 <pkoniszewski> Nova abandons  patches that are >4 weeks old, maybe we should keep the same time
14:13:27 <TravT_> btw is it 3 weeks since patch submitted or 3 weeks since first negative review?
14:13:33 <jokke_> pkoniszewski: is it 4?
14:13:46 <jokke_> TravT_: last activity
14:13:49 <pkoniszewski> it is 4, e.g., https://bugs.launchpad.net/nova/+bug/1246201/comments/22
14:13:49 <openstack> Launchpad bug 1246201 in OpenStack Compute (nova) "Live migration fails when the instance has a config-drive" [High,In progress] - Assigned to Tony Breeds (o-tony)
14:13:49 <mfedosin> TravT_, from las activity I suppose
14:13:51 <ativelkov> TravT_: since the last owner's activity
14:13:56 <mfedosin> *last
14:14:13 <sigmavirus24> Can we move on?
14:14:14 <jokke_> pkoniszewski: ok, thanks for catching that, 4 weeks it would be then ;)
14:14:16 <nikhil_k> author's or committer's ?
14:14:29 <nikhil_k> so, let's drill down on the details in the etherpad
14:14:33 <jokke_> yes
14:14:36 <jokke_> move on please
14:14:44 <nikhil_k> #topic CLI Sorting Argument Guidelines
14:14:51 <nikhil_k> https://review.openstack.org/#/c/145544/
14:15:12 <mfedosin> they're approved and it's nice
14:15:27 <nikhil_k> mfedosin: not yet
14:15:35 <nikhil_k> fyi ^ , there is a api-wg spec that has been approved
14:15:46 <nikhil_k> that is - https://review.openstack.org/#/c/145579/
14:16:14 <nikhil_k> so, for everyone to be on the look out for this change. Seems like it'd not affect anyone directly
14:16:34 * ativelkov bookmarks to check if artifacts API complies with it
14:16:36 <nikhil_k> but we will be having some changes on the g-api side that would involve minor version bump
14:16:43 <jokke_> There is no +A but looks pretty stronly that this will be the merging iteration of that spec ;)
14:16:44 <mfedosin> I heard we need a spec in glance for this
14:16:50 <sigmavirus24> At worst, the change that would affect people is allowing multiple sort-keys which is already in progress
14:17:04 <sigmavirus24> mfedosin: I didn't get to it yesterday since I was trying to re-review the k-3 specs that are important
14:17:14 <nikhil_k> mfedosin: yes, to document all the related links and the changes that would be made to Glance and the client
14:17:18 <mfedosin> I can write it today
14:17:18 <sigmavirus24> I'm also in meeting hell this morning but I can try to get to it this afternoon
14:17:23 <nikhil_k> as those are not evident in that spec
14:17:25 <sigmavirus24> Thanks mfedosin
14:17:37 <mfedosin> sigmavirus24, welcome :)
14:18:26 <nikhil_k> ok, moving on. thanks for the input everyone
14:18:29 <nikhil_k> #topic Cross-Repo Dependencies in Zuul
14:18:37 <sigmavirus24> #action mfedosin to write an sorting spec for changes in glance-api
14:18:46 <nikhil_k> http://osdir.com/ml/openstack-dev/2015-02/msg00785.html
14:18:54 <jokke_> So just heads up for everyone who missed that e-mail in mailing list
14:18:57 <kragniz> this is so cool!
14:19:34 <ativelkov> so, we may now set dependencies between commit to python-*client and API commit? Cool
14:19:35 <jokke_> there is cross repo dependency mechanism introduced with "Depends-On: <Gerrit change ID>" on commit message
14:19:35 <zhiyan> it's really great.
14:19:58 <nikhil_k> I believe this is documented in the openstack infra manuals
14:20:01 <nikhil_k> #link http://docs.openstack.org/infra/manual/developers.html#cross-project-dependencies
14:20:11 <jokke_> ativelkov: yes, we can make dependency chains to have client change depending on glance change depending on glance_store change
14:20:25 <sigmavirus24> I want to say we should all thank fungi but I know they didn't work on it alone
14:20:27 <mfedosin> wow, I really need that
14:20:33 <nikhil_k> So, I would strongly encourage all developers and reviewers to look into the manual
14:20:41 <jokke_> ++
14:20:44 <fungi> i definitely did not ;)
14:20:49 <TravT_> \o/
14:20:50 <nikhil_k> fungi: woot!
14:21:04 <zhiyan> fungi: :)
14:21:08 <fungi> jeblair did pretty much all of the implementation
14:21:15 <fungi> i merely reviewed most of it and nodded
14:21:31 <jokke_> fungi: kudos for both of you ;)
14:21:59 <fungi> mmm, actually that documentation link is for the wrong thing i think
14:22:13 <fungi> cross-repo dependency is what we're calling the depends-on bits
14:22:23 <fungi> but i may need to re-read the manual now
14:22:55 <fungi> ahh, yep, we cleaned that up, so it's the right thing now
14:22:56 <TravT_> so it says "another project" can the same thing be used within a project (sometime dependencies aren't all lined up - multiple dependencies)
14:22:57 <nikhil_k> huh, intersting
14:23:15 <jokke_> TravT_: between any two repo
14:23:22 <sigmavirus24> TravT_: isn't that the idea for dependent patches?
14:23:34 <sigmavirus24> Why not just rebase your patch on the patch it depends on?
14:23:36 <nikhil_k> fungi: ok, as I think it says cross project so was hoping that is all openstack wide and not confined to a program
14:23:38 <fungi> right, within the same project just make them naturally dependent series within git
14:23:42 <sigmavirus24> Also, this seem to be getting off topic
14:23:56 <jokke_> nikhil_k: as said any two repo
14:24:23 <fungi> cross-repo dependencies using the depends-on line are for when you need dependencies between changes (either because you don't want one merging before the other, or want them to be tested together in some integration test suite)
14:24:24 <nikhil_k> jokke_: I was just asking as he said earlier that it was wrong link
14:24:34 <TravT_> patches aren't always necessarily sequential with multiple workstreams dependent on multiple patches
14:24:38 <jokke_> nikhil_k: k
14:24:43 <fungi> but specifically between different git repositories
14:24:46 <TravT_> ok
14:24:47 <TravT_> thx
14:24:49 <fungi> anyway, sorry to hijack
14:24:54 <jokke_> TravT_: read the e-mail ... it's all expained there ;)
14:24:58 * fungi gets back to his regularly-scheduled morning
14:25:09 <nikhil_k> fungi: thanks :)
14:25:16 <nikhil_k> (for the info)
14:25:23 <nikhil_k> #topic Liberty Summit planning
14:25:33 <nikhil_k> jokke_: ?
14:25:36 <kragniz> we didn't get any lizards :(
14:25:39 <jokke_> So first of all ... we have name \\o \o/ o// o/7
14:25:55 <sigmavirus24> Yeah but it isn't the name we needed, it's the name we deserved
14:26:11 <nikhil_k> sigmavirus24: lol, batman fan much?
14:26:14 <sigmavirus24> =P
14:26:19 <jokke_> second of all ... Should we kick off planning for the summit ... end of MAy will be sooner than anyone expects
14:27:02 <nikhil_k> jokke_: I think we can wait until the end of cycle before we do that
14:27:13 <jokke_> nikhil_k: any objections to make our well proven etherpad and start collecting stuff together to ease the planning and avoiding the last minute rush again?
14:27:16 <nikhil_k> Like for juno we had enough time after j3
14:27:31 <sigmavirus24> Doesn't hurt to start the etherpad now
14:28:04 <nikhil_k> jokke_: yes, but this time I am hoping that the feature / psedo feature groups would update the etherpad proactively
14:28:16 <nikhil_k> I may send a reminder email every so often
14:28:36 <nikhil_k> sigmavirus24: I think we've 2 already would like to avoid more
14:28:52 <jokke_> sigmavirus24: that's what I thought and I noticed Doug was giving a shout for oslo one earlier so thought to bring it up
14:28:53 <sigmavirus24> fair enough :)
14:28:57 <nikhil_k> #info K3 etherpad https://etherpad.openstack.org/p/kilo-glance-k3
14:29:08 <nikhil_k> kragniz: do you have the whiteboard link handy?
14:29:18 <sigmavirus24> https://etherpad.openstack.org/p/glance-whiteboard
14:29:21 <sigmavirus24> #link https://etherpad.openstack.org/p/glance-whiteboard
14:29:31 * sigmavirus24 steals kragniz's thunder
14:29:34 <kragniz> sigmavirus24 beat me too it
14:29:50 <sigmavirus24> nikhil_k: it's just a wafer thin etherpad, certainly it's okay (Monty Python reference)
14:29:52 <nikhil_k> #info Whiteboard is not used for review priority, rather just for informal discussions
14:30:11 <nikhil_k> sigmavirus24: heh
14:30:38 <nikhil_k> #topic glance_store Releases
14:30:53 <nikhil_k> we are waiting on
14:30:59 <nikhil_k> https://review.openstack.org/#/c/141665/
14:31:00 <nikhil_k> and
14:31:09 <nikhil_k> https://review.openstack.org/#/c/137416/
14:31:13 <zhiyan> https://review.openstack.org/#/c/137416/ just get +Aed
14:31:44 <sigmavirus24> zhiyan: excellent. I was wondering when we'd ever get that approved =P
14:31:52 <nikhil_k> nice!
14:32:08 <nikhil_k> zhiyan: please update the blueprint status accordingly
14:32:14 <zhiyan> however, i'm not sure if i can put https://review.openstack.org/#/c/136039/ on the list as the latest (to me) one
14:32:16 <nikhil_k> appreciate the effort there
14:32:23 <zhiyan> nikhil_k: sure
14:32:55 <nikhil_k> #info try to review https://review.openstack.org/#/c/136039/ before next Tuesday else it will be postponed to next glance_store release
14:33:10 <zhiyan> nikhil_k: thanks for review/support
14:33:17 <nikhil_k> :)
14:33:18 <nikhil_k> #topic client release
14:33:23 <kragniz> nikhil_k: so glance_store release is probably next tuesday?
14:33:23 <nikhil_k> https://launchpad.net/python-glanceclient/+milestone/v0.16.0
14:33:33 <jokke_> nikhil_k: so the plan is to release at 18th?\
14:33:57 <nikhil_k> kragniz: hopefully, I deferrred it from this week to next to help reviewers relax a bit (right after k2)
14:34:07 * kragniz updates whiteboard
14:34:26 <jokke_> nikhil_k: good call also ref stable capping
14:35:15 <nikhil_k> About the client: do we need to clean up the dependent bugs for the next release?
14:36:02 <kragniz> dependant as in currently targeted for 0.16.0?
14:36:07 <nikhil_k> Seems like no objections?
14:36:41 <nikhil_k> #info Nikhil to clean up bugs related to the client for it's next release. Please contact if you need something to be released urgently.
14:36:50 <nikhil_k> Also, is anyone willing to volunteer to verify if we've no change that makes api backward incompatible
14:37:18 <kragniz> I can head up this one, since I think I was the last to complain about it
14:37:22 <jokke_> nikhil_k: could you rephrase that ...
14:37:37 <nikhil_k> jokke_: So, the concern that would brought up was..
14:37:39 <jokke_> nikhil_k: sorry ... got you
14:37:41 <kragniz> (mostly with semver stuff)
14:37:55 <nikhil_k> we need to ensure that the client releases need to be semantically correct
14:38:19 <jokke_> ah
14:38:23 <kragniz> we don't *need* to, but it would be nice
14:38:24 <nikhil_k> I'm trying to identify if there are enough who actually care about this (by that I mean are affect by this)
14:38:37 <sigmavirus24> I care about this
14:38:45 <wayne_> I posted this bug to the mailing list yesterday: https://review.openstack.org/#/c/154229/
14:38:47 <nikhil_k> and you're affected?
14:38:48 <jokke_> kragniz, nikhil_k: well tbh it's easier to do before rather than after they have been released
14:39:22 <nikhil_k> wayne_: ok, we should get to it in the open discussion
14:39:34 <kragniz> I also care about this
14:39:39 <kragniz> jokke_: what do you mean?
14:39:54 <nikhil_k> So, all those who care about this -
14:40:21 <nikhil_k> are you all willing to ensure that the client release is tagged appropriately in the launchpad
14:40:43 <nikhil_k> that would involve creating a release for minor version change and tagging bugs to it
14:40:45 <kragniz> totes
14:40:50 <sigmavirus24> yep
14:41:05 <jokke_> kragniz: it's easier to fix some inconsistencies if we find them now rather than after they've been out for a one release already
14:41:08 <nikhil_k> and if there are api back incompatible changes, then the release version is updated accordinly
14:41:15 <jokke_> consistency vs. backwards compatibility
14:41:36 <kragniz> nikhil_k: we can update release names/versions on launchpad?
14:41:45 <kragniz> I forget if you can change those
14:42:06 <kragniz> or create a new one and retarget
14:42:08 <nikhil_k> kragniz: it would be manual and tiresome process ( I believe) but not 100% on that
14:42:21 <sigmavirus24> Launchpad has an API, but let us never speak of it
14:42:34 <nikhil_k> ok, I will move on for now
14:42:34 <kragniz> sigmavirus24: I had a look at it once
14:42:37 <kragniz> ...once
14:42:45 <sigmavirus24> kragniz: never again
14:42:52 <nikhil_k> Let's discuss this offline, with all those who have time for this
14:42:57 <kragniz> nikhil_k: sounds good
14:43:05 <nikhil_k> #topic k2 released.
14:43:25 <nikhil_k> k2 released.
14:43:40 <nikhil_k> copy paste fail
14:43:43 <nikhil_k> https://bugs.launchpad.net/bugs/1412802
14:43:43 <openstack> Launchpad bug 1412802 in Glance juno "copy-from broken for large files and swift" [Critical,In progress] - Assigned to Alexander Tivelkov (ativelkov)
14:43:53 <nikhil_k> that bug just made in time and is an important one
14:44:14 <ativelkov> Thanks to all the reviewers
14:44:20 <nikhil_k> thanks to jokke_ who was available outside of this regular work hours for seeing this through
14:44:44 <nikhil_k> I hope that we will get a better velocity in k3
14:45:03 <jokke_> nikhil_k: NP ... just wanted to avoid k1 all over again ;)
14:45:03 <nikhil_k> reviews waiting for k3 are at  https://launchpad.net/glance/+milestone/kilo-3
14:45:17 <nikhil_k> jokke_: true that!
14:45:37 <nikhil_k> #topic code cleanup
14:45:50 <nikhil_k> looking for volunteers to look into this https://review.openstack.org/#/c/145223/
14:46:02 <nikhil_k> seems like we've some stale code
14:46:13 <nikhil_k> (possibly create a spec and see it working)
14:46:26 <nikhil_k> that was it
14:46:28 <jokke_> My guts are telling that we have loads of it
14:46:33 <zhiyan> i'd like to have a look
14:46:37 <nikhil_k> thanks zhiyan
14:46:43 <nikhil_k> #topic Review request for Reload configuration file on SIGHUP signal
14:46:43 <sigmavirus24> == jokke_
14:46:47 <zhiyan> due to i done before refacotrings
14:46:53 <nikhil_k> abhishekk: ?
14:47:04 <abhishekk> nikhil_k: hi
14:47:13 <abhishekk> just saw its marked in k3
14:47:26 <nikhil_k> ah ok, any significant change?
14:47:42 <abhishekk> no, I want some early feedback
14:47:49 * sigmavirus24 left feedback yesterday
14:47:52 <abhishekk> and approval for spec
14:47:53 <zhiyan> nikhil_k: actually i trend to believe we could to remove file queue and 'cleanup' logic
14:47:55 <nikhil_k> ah ok, yes. It's marked for early k3
14:48:12 <zhiyan> due to from juno we start to use db queue fully
14:48:21 <nikhil_k> #topic Open discussion
14:48:39 <zhiyan> i will check the spec and left things for discussion..
14:48:55 <nikhil_k> zhiyan: sure, can we get an informal proposal out , something that can be done in k3?
14:49:08 <nikhil_k> wayne_: glad that you brought it up
14:49:13 <ativelkov> What about backports of https://bugs.launchpad.net/bugs/1412802 to J/I?
14:49:13 <openstack> Launchpad bug 1412802 in Glance juno "copy-from broken for large files and swift" [Critical,In progress] - Assigned to Alexander Tivelkov (ativelkov)
14:49:29 <nikhil_k> https://review.openstack.org/#/c/154229/
14:49:31 <zhiyan> sure thing, i'd like to...it's on my list, thanks for propose it up for a formal spec!
14:49:39 <wayne_> Regarding bug https://review.openstack.org/#/c/154229/, are there any objections to me doing this?
14:49:59 <nikhil_k> wayne_: did you get a response back on/from the ML yet?
14:50:06 <kragniz> ativelkov: I know stuart is trying to come up with a smaller fix
14:50:09 <jokke_> ativelkov: you have any update on those backports?
14:50:22 <wayne_> no response yet.
14:50:34 <nikhil_k> ativelkov: yes, please try to review a related patch in glance_store
14:51:05 <nikhil_k> wayne_: ok, let's give it another couple days. We can sync up on #openstack-glance on Mon
14:51:10 <ativelkov> kragniz: jokke_: nikhil_k: that's what I wanted to ask - this is a patch in glance_store
14:51:26 <nikhil_k> ativelkov: but not for icehouse
14:51:32 <wayne_> ok
14:51:38 <ativelkov> it means it will be available in the next glance_store release
14:51:54 <sigmavirus24> wayne_: do I understand correctly that that was done in k-{1,2} ?
14:52:09 <ativelkov> nikhil_k: yes, it is not compatible with I, and I don't know if we may use newer glance_store with J - is it backwards compatible?
14:52:10 <nikhil_k> k1
14:52:12 <nikhil_k> sigmavirus24: ^
14:52:19 <nikhil_k> ah
14:52:41 <nikhil_k> ativelkov: let's mark the glance_store release blocked by that
14:52:48 <sigmavirus24> nikhil_k: so, perhaps I'm missing something, but aren't those alpha/beta-ish releases? Backwards incompatible changes between them is to be expected
14:52:50 <nikhil_k> zhiyan: np
14:53:03 <sigmavirus24> If I'm not misunderstanding, I'll reply to the ML with my thoughts on it so I can stir the pot for Wayne
14:53:04 <wayne_> sigmavirus24: yes K1
14:53:10 <nikhil_k> sigmavirus24: right, so we got blessings from ttx
14:53:24 <nikhil_k> Just trying to confirm if no one else if affected by this
14:53:28 <jokke_> glance_store is not currently capped on Juno\
14:53:41 <sigmavirus24> nikhil_k: yeah, I'll respond on the ML then
14:53:59 <zhiyan> nikhil_k: pkoniszewski do you think we can do it in k3 on time? https://review.openstack.org/#/c/147264 can you share some status info with me?
14:54:03 <wayne_> sigmavirus: thanks
14:54:11 <nikhil_k> sigmavirus24: cool, we are not expecting anyone besides horizon to be using it for now
14:54:28 <nikhil_k> but you never know
14:55:55 <nikhil_k> jokke_: that may change though, right?
14:56:38 <jokke_> nikhil_k: ofc it may ... I was just confirming that it's not ... so if we are planning to release glasnce_store that breaks Juno, we need to do something about that fact
14:56:54 <nikhil_k> zhiyan: I think we need that in k3
14:56:57 <pkoniszewski> zhiyan: I'm sure we can, change is really small - it exposes new flag over API so it is backward compatible
14:57:18 <zhiyan> ok..will check it asap
14:57:35 <nikhil_k> zhiyan: I think we need to get some reviews on https://review.openstack.org/#/c/148213/ along with the spec
14:57:47 <nikhil_k> to avoid the metadef tags like error again
14:57:48 <sigmavirus24> Yeah we might want to cap stable/juno's g-r to be safe until we can test it so -infra doesn't get really mad at us
14:57:49 <sigmavirus24> =P
14:58:20 <jokke_> sigmavirus24: infram is small problem on that :P
14:58:44 <zhiyan> nikhil_k: indeed, that's what i worried about..unlike the case in j-3
14:58:53 <nikhil_k> :)
14:58:54 <sigmavirus24> jokke_: right, but they've been dealing with problems like this repeatedly lately and I'm sure their patience is wearing thin. I don't want to add any more grey hairs to their heads
14:59:11 <sigmavirus24> They're all good people and reducing their stress is something we can help with =)
14:59:14 <jokke_> sigmavirus24: tru dat
14:59:34 <ativelkov> sigmavirus24: you suggest to cap it to the currently released version?
14:59:35 <jokke_> sigmavirus24: there was quite a heated discussion at X-Project meeting yesterday
14:59:49 <sigmavirus24> ativelkov: until we can show that it won't break stable/juno
14:59:52 <jokke_> and there has been quite heated discussions on the mailing list
15:00:02 <kragniz> we're out of time
15:00:06 <kragniz> last thing - we should now have pretty glance logs in devstack!
15:00:06 <nikhil_k> yep
15:00:06 <sigmavirus24> I think a pre-emptive cap will be good until we can test it out. There's no reason to break the gate for anyone integrating with glance
15:00:10 <kragniz> #link https://review.openstack.org/#/c/155024/
15:00:12 <jokke_> yup ... thnx!
15:00:16 <nikhil_k> Thanks all!
15:00:18 <sigmavirus24> Thanks everyone
15:00:21 <kragniz> thanks
15:00:22 <abhishekk> thank you
15:00:23 <ativelkov> thanks!
15:00:25 <nikhil_k> #endmeeting