14:00:09 <nikhil_k> #startmeeting Glance
14:00:10 <openstack> Meeting started Thu Mar 26 14:00:09 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <TravT> o/
14:00:13 <openstack> The meeting name has been set to 'glance'
14:00:32 <nikhil_k> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:41 <sigmavirus24> o/
14:00:58 <nikhil_k> Welcome all!
14:01:10 <nikhil_k> Looks like we've a good turnout :)
14:01:10 <ajayaa> o/
14:01:36 <nikhil_k> This shouldn't be a long one, hopefully
14:01:42 <jokke_> full house for proper moshpit :D
14:01:43 <nikhil_k> Let's get started
14:01:43 <sigmavirus24> nikhil_k: that's what they all say
14:01:53 <nikhil_k> #topic RC1
14:02:00 <nikhil_k> #link https://launchpad.net/glance/+milestone/kilo-rc1
14:02:18 <nikhil_k> 2 specs need some reviews:
14:02:19 <nikhil_k> https://blueprints.launchpad.net/glance/+spec/artifact-repository
14:02:20 <nikhil_k> and
14:02:25 <nikhil_k> https://blueprints.launchpad.net/glance/+spec/catalog-index-service
14:02:44 <nikhil_k> Please add some of your thougts on the CIS (Catalog Service glance-spec) if you feel so
14:02:57 <nikhil_k> #link https://review.openstack.org/#/c/138051/
14:03:49 <nikhil_k> #info We've until Monday evening (Tuesday morning in some places) to merge both of these or at least have 2 +2s (waiting on gate) for all the reviews on each of the specs
14:04:24 <nikhil_k> So, reviews are welcome from everyone
14:04:36 <TravT> Reviews are definitely appreciated!
14:04:52 <rosmaita> nikhil_k: do you mean reviews on the specs, or on the code patches?
14:04:57 <nikhil_k> They are in FFE period for those who might be unaware
14:05:08 <nikhil_k> rosmaita: on everything
14:05:19 <jokke_> that's a lot of LOCs to dump in over weekend :(
14:05:37 <nikhil_k> Here are some helpful links if you're in the mood of reviews:
14:05:39 <nikhil_k> https://review.openstack.org/#/q/topic:bp/artifact-repository,n,z
14:05:46 <nikhil_k> https://blueprints.launchpad.net/glance/+spec/catalog-index-service
14:07:00 <nikhil_k> ativelkov: and mfedosin are point of contacts for Artifacts reviews
14:07:11 <nikhil_k> points of contact*
14:07:22 <nikhil_k> and TravT is for CIS
14:07:32 <TravT> lakshmiS krykowski as well on CIS
14:07:52 <nikhil_k> That's about the specs from my side. If anyone has some more input please go ahead.
14:08:32 <nikhil_k> If not, moving on.
14:08:53 <nikhil_k> jokke_: was it you who added the glance_store and python-glanceclient stable branches point?
14:09:37 <sigmavirus24> maybe it was TravT ?
14:09:38 <nikhil_k> If so (or one who added to etherpad is online), let me create a new topic for this for easier navigation.
14:09:59 <jokke_> nikhil_k: yes
14:10:06 <nikhil_k> #topic glance_store and python-glanceclient stable branches
14:10:19 * nikhil_k hands over the mic to jokke_
14:11:06 <nikhil_k> jokke_: anything?
14:11:22 <jokke_> So as per the cross project spec (I do not have the link in hands now, will dig it out) all OS libs are expected to move to stable branching from this release
14:11:43 <jokke_> so we should start putting those branches in
14:12:01 <nikhil_k> this ->
14:12:01 <nikhil_k> https://review.openstack.org/#/c/155072/
14:12:08 <sigmavirus24> yes that
14:12:19 <sigmavirus24> #link https://review.openstack.org/#/c/155072/
14:12:22 <sigmavirus24> (for the minutes)
14:12:31 <flaper87> I think this is a good timing since we recently released the library
14:12:32 <jokke_> ++ thanks
14:13:25 <nikhil_k> sounds like a good idea. Let's make sure that interested people are aware of the effects like TravT maybe?
14:14:08 <flaper87> I'm happy to help with moving this forward
14:14:21 <nikhil_k> Ok, so jokke_ can we assign you to send an email to ML about we planning to implement this? or flaper87
14:14:40 <jokke_> so I would suggest we keep our stable maint team handling those two libs as well instead of making dedicated maintainers groups for those, objections?
14:14:40 <mclaren> I think this sounds great from a supportability/stability point of view. Really happy to see it happening
14:14:50 <sigmavirus24> mclaren: I agree
14:14:55 <flaper87> jokke_: ++
14:15:25 <jokke_> nikhil_k: I can send it out, I think we can figure out with flaper87 the actual work that needs to happen in repos
14:15:42 <nikhil_k> #action flaper87 and jokke_ to co-ordinate on stable branches for the client and libs incl. email to the ML
14:15:45 <nikhil_k> thanks jokke_ !
14:15:47 <mclaren> does this apply to clients aswell does anyone know?
14:15:55 <nikhil_k> mclaren: yes
14:15:56 <TravT> When does it take affect?
14:15:59 <jokke_> mclaren: it should yes
14:16:00 <mclaren> nikhil_k: thanks
14:16:10 <sigmavirus24> flaper87: jokke_ if you'd like help with that, I'll have more cycles after the summit probably
14:16:24 <jokke_> TravT: Kilo will be using the new stable and Liberty start following master
14:16:26 <sigmavirus24> TravT: it should take effect after approval. I forget if it's retroactive or not
14:16:27 <flaper87> sigmavirus24: thanks, I'd like to get this done before the summit
14:16:38 <flaper87> it shouldn't take long, it's a matter of submitting a couple of patches to -infra
14:16:40 <sigmavirus24> flaper87: I'll have fewer cycles before that, but I'll try
14:17:10 <nikhil_k> But please ensure that we've critical bugs covered for both client and lib before marking it stable or at least have them with info for why we could not include them.
14:17:25 <nikhil_k> (as applicable)
14:17:27 <flaper87> nikhil_k: even if we miss some, we can backport them
14:17:51 <jokke_> yes same backport rules apply and we can keep releasing stables when needed
14:18:29 <wko> I have a critical client bug that needs some attention - it's been sitting since K1 - https://review.openstack.org/#/c/138612/
14:18:35 <nikhil_k> sounds like a good idea. I don't believe we've security bugs in either at this point so, we can move forward with that plan
14:18:58 <nikhil_k> nice, thanks wko
14:19:23 <nikhil_k> jokke_: can you please co-ordinate trello for that too so that we can review them easier/faster?
14:19:27 <wko> welcome
14:19:41 <jokke_> nikhil_k: sure
14:19:47 <nikhil_k> thanks jokke_
14:20:01 <nikhil_k> can we move on to next topic?
14:20:05 <jokke_> #action jokke_ sets up trello cards for stable libs
14:20:32 <nikhil_k> (perfet)
14:20:36 <jokke_> nikhil_k: I think that was all for now
14:20:43 <nikhil_k> cool. thanks/
14:20:48 <nikhil_k> #topic RC potential
14:21:01 <nikhil_k> #link https://launchpad.net/glance/+milestone/kilo-rc1
14:21:55 <TravT> I think this one needs to be on there: https://review.openstack.org/#/c/166501/
14:22:00 <nikhil_k> I think we've a lot of bugs put in RC1. It has been tasked to keep only the critical ones as blockers and mark the rest of them with 'kilo-rc-potential' tag
14:22:31 <jokke_> nikhil_k: I'd like to see as many bugfixes landing as possible, but lets not wait them
14:23:09 <jokke_> more we get them in now the less probably we will have rc4 or rc5 in our hands because something blew up after all or got forgotten ;)
14:23:17 <nikhil_k> jokke_: yeah, that sounds like a good idea. May be in next meeting we can share an etherpad with the one we feel should go in asap and spend some time discussing them.
14:25:04 <nikhil_k> #info by Monday the RC1 bugs list would have fewer items and the rest of them marked with 'kilo-rc-potential' tag. If you need something in RC1 please bring it to team's attention and get it moved to Critical level.
14:25:07 <jokke_> perhaps bug day on week after next to check up what has came out of rc1?
14:25:19 <nikhil_k> sure
14:25:26 <sigmavirus24> jokke_: ++
14:25:26 <mclaren> bug day sounds like a good idea
14:25:37 * sigmavirus24 wishes we had those more frequently =P
14:26:13 <nikhil_k> Cool
14:26:19 <nikhil_k> Moving on..
14:26:41 <nikhil_k> #topic Adoptingno-downward-sql-migration
14:26:54 <nikhil_k> sigmavirus24: please take over
14:27:11 <sigmavirus24> So this is another cross-project spec
14:27:15 <nikhil_k> #link http://specs.openstack.org/openstack/openstack-specs/specs/no-downward-sql-migration.html
14:27:22 <sigmavirus24> #link http://specs.openstack.org/openstack/openstack-specs/specs/no-downward-sql-migration.html
14:27:25 <sigmavirus24> hah thanks nikhil_k
14:27:49 <sigmavirus24> Essentially downwards migrations are considered a harmful practice at this point
14:27:56 <sigmavirus24> The spec suggests deprecating tooling that allows for them
14:28:00 <nikhil_k> == sigmavirus24
14:28:01 <sigmavirus24> And not adding down migrations to new migrations
14:28:25 <sigmavirus24> So I'm proposing glance follows suit and deprecates using down migrations in its tooling in L
14:28:37 <sigmavirus24> And we should figure out when a good removal date should be in M or after
14:28:48 <mfedosin> so I deprecated downgrades in the latest commit
14:28:51 <sigmavirus24> mfedosin: has already started by not adding down migrations in 040 ;)
14:29:04 <nikhil_k> Sounds like a fair plan.
14:29:05 * sigmavirus24 thanks mfedosin
14:29:30 <sigmavirus24> that's all I have
14:29:40 * sigmavirus24 waits for objections or agreement
14:29:57 * mfedosin agree
14:29:58 <nikhil_k> Adds weight to our stability focus so, the team can hopefully move up it's priority for L.
14:30:07 * flaper87 agrees
14:30:13 * flaper87 +1'd that spec
14:30:15 <flaper87> :P
14:30:20 <jokke_> sigmavirus24: what are the actual things we're deprecating?
14:30:37 <nikhil_k> its*
14:30:38 <jokke_> sigmavirus24: cleaning the down parts from the migration scripts?
14:30:58 <sigmavirus24> jokke_: no
14:31:12 <sigmavirus24> Just deprecating any tooling that performs downward migrations
14:31:26 <sigmavirus24> And not adding new migrations with down pieces
14:31:37 <mfedosin> it's in test_migrations function walk_versions
14:31:45 <jokke_> sure, do you have list of such tooling?
14:32:05 <mfedosin> it has flag enable_downgrades or something
14:32:16 <nikhil_k> And adding recommendations for proper DB upgrades and suggestion for how to use earlier versions :)
14:32:19 <mfedosin> so now it is False
14:32:48 <sigmavirus24> Yeah, I think a glance specific spec will be useful for this work
14:32:55 * sigmavirus24 thinks that is what jokke_ is getting at
14:32:57 <jokke_> ++
14:32:59 <nikhil_k> sigmavirus24: +1
14:33:37 <jokke_> at least something to track what we're actually doing regarding this unless sigmavirus24 wants to take sole responsibility :P
14:33:56 <sigmavirus24> lol I don't
14:34:13 <nikhil_k> Someone who knows how to disappear can
14:34:19 * sigmavirus24 currently has a weird upstream/work balance at the moment
14:35:20 <nikhil_k> OK, can we move on for now ?
14:35:52 <nikhil_k> #topic NoSql backend support ( ajayaa )
14:35:59 <ajayaa> Hi guys.
14:36:04 <nikhil_k> hey
14:36:11 <jokke_> hi
14:36:19 <flaper87> o/
14:36:25 <ajayaa> I was wondering whether glance team would be willing to have a NoSql backend.
14:36:47 <flaper87> we've had this conversations before and I think there was some agreement on doing it
14:36:55 <flaper87> flwang worked on a mongodb impl, IIRC
14:37:06 <ajayaa> flaper87, I wasn't a part of it.
14:37:06 <flaper87> however, at this point, I think we'd need to discuss it over
14:37:18 <flaper87> ajayaa: yup, just giving you a summary :D
14:37:20 <ajayaa> It would be wonderful to read that conversation.
14:37:26 <ajayaa> :)
14:37:37 <ajayaa> that sounds cool.
14:37:38 <sigmavirus24> ajayaa: will you be at the summit?
14:37:41 <mclaren> no irrational hatred of the idea on my part
14:37:51 <ajayaa> sigmavirus24, not sure. :(
14:37:54 <sigmavirus24> mclaren: can't tell if sarcasm or not
14:37:55 <flaper87> I'm ok with the idea, FWIW
14:37:59 <mclaren> is this something that other projects are considering?
14:38:01 * sigmavirus24 is neutral
14:38:22 <ajayaa> mclaren, Yes. I have already proposed a spec to Keystone.
14:38:28 <ajayaa> They are happy with it.
14:38:36 <flaper87> I'd like to know what technology and how it's going to be implemented. A spec would be wonderful
14:38:47 <ajayaa> https://review.openstack.org/#/c/148521/
14:38:52 <mclaren> ajayaa: ah, I thought they could already use mongo? (Probably confusing with 'other' implementation)
14:39:01 <ajayaa> The above link is for Keystone btw.
14:39:10 <jokke_> I think it makes sense if there is wider pull for it across OS ... it kind of would not make sense having only in Glance
14:39:19 <mclaren> flaper87: agree -- it would need to be done like the sql stuff is, ie fairly consistently between projects
14:39:33 <ajayaa> rushiagr, ping
14:39:48 <nikhil_k> #link fwiw, https://blueprints.launchpad.net/glance/+spec/enable-mongo-db
14:39:53 <mclaren> jokke_: agreed. I'd ideally see this as Glance mainly consuming some kind of oslo effort
14:40:02 <rushiagr> I'm a colleague of ajayaa, from Reliance, and I'll be at the summit
14:40:49 <sigmavirus24> == mclaren, jokke_
14:40:57 * sigmavirus24 hopes no one notices the tuple unpacking exception
14:41:10 <mclaren> ajayaa: rushiagr the main motivation here is? to speed up image listing?
14:41:37 <ajayaa> mclaren, To have a scalable and fault torerant Openstack backend.
14:41:40 * nikhil_k raises exception.sigmavirus24()
14:41:54 <sigmavirus24> nikhil_k:++
14:42:06 <mclaren> ajayaa: and the specific benefit to users?
14:42:09 <jokke_> rushiagr: /me likes that motivation
14:42:25 <jokke_> - rush
14:42:47 <mclaren> (just trying to get a bit of understanding of where you're coming from, eg are there any existing bottlenecks you specifically want to address...)
14:42:48 <rushiagr> mclaren: data resiliency
14:43:26 <jokke_> ajayaa, rushiagr: so is mongo something you're planning to go with or do you have some other specific solution in mind for some specific reason?
14:43:43 <nikhil_k> rushiagr: Do you mean resiliency as in being able to handle custom metadata well and use flexible schema for such?
14:43:55 <ajayaa> jokke_, Right now we are evaluating Cassandra and MagnetoDB as the backend.
14:44:03 <flaper87> I don't think we need a strong motivation or benefits table to allow for this innovation to happen. A bit of experimentation in this area would be good. IMHO. However, I'm very curious to know what tecnologies are being evaluated and why
14:44:05 <mclaren> rushiagr: how will it be more resilient than eg mysql? (sorry I'm not a db expert)
14:44:20 <flaper87> especially because, if it happens, I'd like the nosql backend to be already part of openstack
14:44:26 <flaper87> for example, mongodb
14:44:30 <ajayaa> FYI, MagnetoDB is an Openstack project which provides dynamodb api.
14:44:31 <rushiagr> mclaren: mysql is a centralized solution, whereas we'll like a solution which works properly in case of failures
14:45:10 <sigmavirus24> So we need a spec and this seems like a good thing to discuss at the summit or on an email thread
14:45:13 <nikhil_k> There are solutions in sql for that too though, no?
14:45:26 <pkoniszewski> rushiagr: what about SQL databases deployed in HA?
14:45:28 <pkoniszewski> e.g. Galera
14:45:34 <nikhil_k> == pkoniszewski
14:46:21 <mclaren> I guess the motivation can be clarified in a spec/whatever.
14:46:24 <nikhil_k> pkoniszewski: Although, the ML discussion on Galera wasn't a pleasing one
14:46:56 <pkoniszewski> that's true
14:46:59 <jokke_> ajayaa, rushiagr: I think spec and even more cross project or oslo spec would be great ... as mclaren said, would be great if we did not need to reinvent the wheel but consume something common across OS
14:47:00 <sigmavirus24> nikhil_k: I now have another thing to search for
14:47:10 <sigmavirus24> == jokke_
14:47:23 <jokke_> and ++ for summit meetup around that
14:47:26 <flaper87> not oslo, pls!
14:47:28 <flaper87> :)
14:47:34 <flaper87> Either glance or cross-project spec
14:47:59 <nikhil_k> ajayaa: rushiagr: So, the takeaway from here can be - motivation for support of no-sql needs to be a bit more than HA and something that helps with the intricate design of Glance else we should pursure this as OpenStack wide subject discussion.
14:48:19 <nikhil_k> pursue*
14:48:32 <nikhil_k> == flaper87
14:48:38 <jokke_> well said nikhil_k
14:48:45 <mclaren> ajayaa: rushiagr is the keystone work very keystone specific?
14:49:13 <TravT> ajayaa: doesn't mongo have some ugly licensing associated with it
14:49:29 <flaper87> TravT: it's LGPL
14:49:30 <pkoniszewski> ouch, he timed out
14:49:39 <flaper87> lets not get in that mongodb license fight again
14:49:51 <jokke_> :)
14:49:52 <flaper87> As long as we don't force mongo into ppl's deployments, I think it's fine
14:49:57 <nikhil_k> heh
14:50:00 <jokke_> yeah
14:50:01 <sigmavirus24> TravT: LGPL is acceptable in OpenStack
14:50:03 <flaper87> and the proposed driver is just optional
14:50:18 <sigmavirus24> AGPL, GPL etc aren't
14:50:18 <rushiagr> sorry, our wifi router chose the worst time to stop working
14:50:34 <flaper87> or was it AGPL ?
14:50:35 <TravT> ok, in my last hp internal project we couldn't use mongo for some reason.
14:50:38 <ajayaa> Hey guys.
14:50:40 <sigmavirus24> rushiagr: if it's sentient, I would kill it with fire to prevent it from taking over the world
14:50:56 <flaper87> so, conclusion, spec :)
14:51:01 <sigmavirus24> flaper87: agreed.
14:51:03 <sigmavirus24> Next topic?
14:51:03 <ajayaa> AGPL
14:51:08 <rushiagr> sigmavirus24: :)
14:51:09 <flaper87> 10mins left
14:51:31 <nikhil_k> #topic Open Discussion
14:51:46 * rushiagr reads logs for missed outcome of nosql discussion
14:52:06 <mclaren> flaper87: (thanks for pointing out the license side of that)
14:52:29 <flaper87> mclaren: it was actually TravT, I'm just defending mongodb :P
14:53:02 <mclaren> TravT: (thanks for pointing out the license side of that, I know HP fears the AGPL)
14:53:15 <TravT> yeah, i've been hit by it before.
14:53:38 <flaper87> but again, it'd be an optional db so, nothing to fear
14:53:42 <jokke_> I'd like to drop a bomb at this point so we can just all agree it on last minute. There has been lots of work done on glance_store to separate it from glance. I think it would be time to start moving it to become oslo_store during Liberty :P
14:54:05 <flaper87> jokke_: nope
14:54:14 <flaper87> We had that discussion when we split it
14:54:22 <sigmavirus24> hm
14:54:24 <flaper87> and we decided that it should stay under glance
14:54:36 <jokke_> flaper87: as said we just could agree on it and start the work rather than argue about it :P
14:54:40 <sigmavirus24> So glance is the main consumer. Do other things want to use it?
14:54:49 <flaper87> because it's still related to how glance works, and it'll be used from cinder and nova in the future (ideally)
14:54:55 <jokke_> sigmavirus24: that was the reason why it was separated
14:54:57 <mclaren> gosh, there's been a lot of churn there, I'd like things to settle for a while before another change...
14:55:08 <nikhil_k> == mclaren
14:55:13 <flaper87> mclaren: yes
14:55:17 <flaper87> also, it's a core piece
14:55:27 <flaper87> if we move it to oslo, we need to split reviewers there too
14:55:29 <nikhil_k> L needs to be pow(lot, 1M) cooler than K
14:55:36 <flaper87> it's not like we can just say: "Hey oslo, it's now your problem"
14:55:54 * flaper87 is part of the oslo core team and hell there's enough work there :P
14:56:12 <jokke_> flaper87: so there is no difference under which project you break it? :P
14:56:13 <flaper87> Lets first get it adopted by other projects
14:56:19 <flaper87> and then we can discuss that point again
14:56:23 <flaper87> jokke_: LOL
14:56:26 <nikhil_k> flaper87: I agree with you. It's not being used by anyone else, so moving to oslo doesn't make sense. Once nova starts using it, may be we can revisit this topic.
14:56:50 <nikhil_k> (exactly what flaper87 said)
14:57:16 <sigmavirus24> yep
14:57:27 <jokke_> ok, can we then stop pretending it's not tied to glance and make sure it works for us first?
14:58:13 <nikhil_k> So, about the breakage. We really need better release management for that lib. It's not going to work if there is single point of failure.
14:58:28 <mclaren> I'm still not sure the degree to which glance_store has been 'codified', ie which bits we expect people are relying on and which bits we can change if we need to
14:58:55 <flaper87> mclaren: the refactor is still happening
14:59:02 <nikhil_k> My perpective on reviews has been a bit worrysome. We focus too hard to sync with oslo and not review stuff that can cause other breakage.
14:59:08 <flaper87> I mean, the spec is there, it hasn't been approved yet and Cindy is working on the refactor
14:59:19 <flaper87> as soon as a patch is up there, we can start re-reviewing the spec
14:59:30 <nikhil_k> We need dedicated effort on this flaper87 as far as I can tell.
14:59:31 <mclaren> flaper87: ok, thanks
14:59:40 <sigmavirus24> cpallares: if I can help, let me know
14:59:45 <nikhil_k> or frequent updates
14:59:48 <nikhil_k> == sigmavirus24
14:59:58 <nikhil_k> I've tried to reach out to her for the same a few times.
15:00:07 <flaper87> nikhil_k: yes, fwiw, I've been following up but I agree more updates are needed
15:00:16 * sigmavirus24 understands the problems with work/glance/real-life balance
15:00:17 <nikhil_k> anyways, we need to discuss this offline.
15:00:20 <nikhil_k> Thanks all!
15:00:20 <sigmavirus24> yep
15:00:21 <cpallares> thanks sigmavirus24, I will :P
15:00:23 <sigmavirus24> thanks
15:00:27 <nikhil_k> #endmeeting