14:00:10 <nikhil_k> #startmeeting Glance
14:00:10 <openstack> Meeting started Thu Apr 16 14:00:10 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <openstack> The meeting name has been set to 'glance'
14:00:13 <ativelkov> o/
14:00:14 <kragniz> o/
14:00:17 <bpoulos> o/
14:00:17 <ajayaa> o/
14:00:19 <pkoniszewski> o/
14:00:24 <rosmaita> o/
14:00:50 <nikhil_k> Cool, let's get started
14:00:54 <nikhil_k> #topic RC2
14:01:05 <lakshmiS> o/
14:01:22 <mfedosin> o/
14:01:40 <nikhil_k> #info ttx wanted us to release the same this week. I pointed a couple blockers for RC2 however, seems like only one would be able to get in now
14:01:50 <nikhil_k> #link https://review.openstack.org/#/c/171022/
14:02:10 <nikhil_k> Reviews on that would be appreciated as it would help everyone get moving.
14:02:26 <nikhil_k> #info RC2 planned to be last RC candidate for Kilo
14:02:53 <nikhil_k> Any reviews that we should be looking for and block RC2 on?
14:03:08 <lakshmiS> https://review.openstack.org/#/c/169813/1
14:03:08 <pkoniszewski> nikhil_k: i have one more thing there that may be possible RC candidate
14:03:36 <stevelle> o/
14:03:41 <lakshmiS> nikhil_k 169813 is required for interactions from horizon.
14:03:51 <sabari> o/
14:03:52 <nikhil_k> pkoniszewski: please give me the link so that I can put it where people can look at it at their convenience
14:03:55 <pkoniszewski> during work on functional tests for metadefs i found regression in tags
14:04:06 <pkoniszewski> it is now part of functional tests, but i will split it ASAP
14:04:10 <pkoniszewski> https://review.openstack.org/#/c/125010/23/glance/db/sqlalchemy/metadata.py
14:05:22 <nikhil_k> btw, I am adding them to
14:05:23 <nikhil_k> https://trello.com/c/CoZ9g13d/45-kilo-rc2
14:05:34 <nikhil_k> to help reviewers find them easily
14:06:12 <nikhil_k> pkoniszewski: creating a separate for RC2 would be great
14:06:29 <nikhil_k> as backporting the tests might be asking for too much
14:06:30 <pkoniszewski> sure, I'll do it in few minutes and provide link to that
14:06:41 <nikhil_k> appreciate that pkoniszewski
14:07:12 <nikhil_k> Any other concerns about RCs? Should we ask for RC3?
14:07:36 <nikhil_k> mclaren: hi
14:07:39 <nikhil_k> mclaren: you just missed my question
14:07:40 <nikhil_k> Any other concerns about RCs? Should we ask for RC3?
14:07:42 <jokke_> o/
14:07:49 <pkoniszewski> nikhil_k: do I need to register a bug on launchpad or is review enough?
14:07:59 <mclaren> nikhil_k: for the server? Nothing comes to mind
14:08:04 <nikhil_k> please register so that ttx can keep track of the same
14:08:09 <pkoniszewski> ok
14:08:18 <nikhil_k> mclaren: thanks
14:09:03 <jokke_> nikhil_k: I don't think there is anything critical enough atm. warranting RC3
14:09:16 <nikhil_k> jokke_: sounds great
14:09:30 <nikhil_k> #info We've started Liberty development.
14:09:33 <nikhil_k> #link https://review.openstack.org/#/c/171227/
14:10:02 <jokke_> nikhil_k: I approved one patch to a bug I tagged as rc-potential ... would be nice to have in RC2 (that was yesterday I think)
14:10:33 <nikhil_k> Any changes after the RC2 is released would be evaluated to be backported as per the criterion on
14:10:36 <nikhil_k> https://wiki.openstack.org/wiki/StableBranch
14:10:47 <nikhil_k> jokke_: can you please give a link?
14:11:46 <nikhil_k> Ok, while we wait for the link. Let's start discussion on the next topic.
14:11:54 <nikhil_k> #topic new client release/client stable branch
14:12:15 <nikhil_k> was that you jokke_ ?
14:12:17 <jokke_> nikhil_k: forget about it
14:12:25 <nikhil_k> ok
14:12:27 <jokke_> the bug mentioned
14:12:34 <mclaren> I can talk through the client stuff?
14:12:44 <jokke_> mclaren: please
14:12:59 <nikhil_k> yes please
14:13:27 <mclaren> There are a few fixes that I think are critical enough for both 1) a new client release and 2) putting that version into the global requirements for kilo
14:13:48 <mclaren> I've a few reviews up on the stable branch if folks have time to have a quick look
14:14:11 <mclaren> this is probably highest priority https://review.openstack.org/#/c/174293/
14:14:30 <mclaren> Chatting with ttx he seemed to suggest
14:14:56 <mclaren> that updating global requirements to >=0.17.1 once it's out would be ok
14:15:15 <mclaren> Are we ok time-wise to get that in do people think?
14:15:42 <jokke_> mclaren: please https://wiki.openstack.org/wiki/StableBranch#Proposing_Fixes we need the cherry-picked-from tags on the commit messages
14:16:07 <mclaren> (The context here is that in kilo nova/glance with https can't access glance to boot images etc.)
14:16:27 <nikhil_k> So, just to add some more context. We have until April 30th to work on release candidates.
14:16:49 <nikhil_k> However, we want to be able to get that sooner than later.
14:17:06 <nikhil_k> So, I would support relasing a new client version given:
14:17:24 <nikhil_k> 1. We've all the fixes needed for the same merged soon
14:17:35 <mclaren> jokke_: ok I can add that. It's a day for commit messages ;-)
14:17:42 <nikhil_k> 2. We release it before next week'e meeting
14:18:16 <mclaren> nikhil_k: thanks.
14:18:38 <jokke_> mclaren: so it seems ... the stable branches are quite more strict on those, so have a quick look through that wiki page and let me know when ready.
14:19:34 <mclaren> nikhil_k: once the client is out, is it ok to just go ahead and submit a patch to global requirements?
14:19:48 <mclaren> or is there more process this close to release?
14:20:03 <nikhil_k> mclaren: I think a WIP to global requirements right away wouldn't be so bad
14:20:13 <mclaren> nikhil_k: sure, good idea
14:20:19 <jokke_> ++
14:20:44 <mclaren> anyone know if there is a stable/kilo branch for global requirements yet?
14:21:11 <jokke_> mclaren: yes there is
14:21:31 <mclaren> ok thanks
14:21:54 <flaper87> o/
14:21:57 <mclaren> I'll put a WIP there aswell to give people a heads up
14:22:12 <nikhil_k> We good on this topic?
14:22:14 <jokke_> the problem is that it might come in time for our release, but does anyone has any idea how Nova is doing?
14:22:41 <jokke_> Are they gonna have RC still where that global requirements lands in time?
14:23:19 <nikhil_k> That's a good point and prolly needs to be raised on ML with [all] tag
14:23:46 <mclaren> yeah, cinder also need to pick it up for example
14:23:48 <jokke_> if not that's shame, fortunately it will only affect on upgrades from systems having those faulty versions installed
14:24:07 <flaper87> Have you guys already talked about this review? https://review.openstack.org/#/c/173646/
14:24:08 <jokke_> or actually having 17.0 installed
14:24:10 <flaper87> #link https://review.openstack.org/#/c/173646/
14:24:24 <kragniz> flaper87: not yet
14:24:27 <flaper87> It's flwang's patch for /CURRENT/SUPPORTED
14:24:31 * flaper87 shuts up and waits
14:24:32 <nikhil_k> mclaren: jokke_ may be we can put a SecurityImpact tag there
14:24:38 <nikhil_k> ?
14:24:54 <mclaren> nikhil_k: are you ok to send a mail once the global requirements change lands?
14:25:12 <nikhil_k> That gets noticed and systems would be prudently upgraded with latest version
14:25:40 <nikhil_k> mclaren: yes. Can we please co-ordinate this offline, may be on email to be in sync with reviews?
14:25:47 <jokke_> nikhil_k: it's not really a security impact per se ...
14:25:55 <mclaren> nikhil_k: sounds good
14:26:33 <jokke_> I'd warn all projects already before we have anything landing that the client will have critical patch release coming ... I can do that if needed
14:26:40 <nikhil_k> jokke_: yeah, I'm just trying to ensure that people pick it up. The alternative does not sound secure ?
14:26:59 <mclaren> There should be enough time between when testing of RCs start to be able to work through any client issues found
14:27:27 <jokke_> nikhil_k: well the alternative needs active action ... unfortunately we just blow stuff atm.
14:27:35 <nikhil_k> ok, if this does not get enough traction by Tuesday I will have  achat in the Cross Project meeting
14:27:47 <jokke_> nikhil_k: sounds good ...
14:28:24 <jokke_> #action jokke_ Will send e-mail to mailing list warning upcoming python-glanceclient stable 0.17.1
14:28:40 <mclaren> nikhil_k: nova can't boot a vm etc if https is enabled in glance
14:28:56 <mclaren> no it's less a security thing and more a not-working thing
14:29:00 <mclaren> no->so
14:29:01 <flaper87> mclaren: I'll review those patches
14:29:15 <mclaren> thanks flaper87
14:30:08 <nikhil_k> mclaren: heh, yeah. However, getting attention from people at this busy time might call for using Security tag
14:30:17 <kragniz> nikhil_k: I don't think we should add SecurityImpact just to gain attention
14:30:21 <nikhil_k> flaper87: great pointer. https://review.openstack.org/#/c/173646/
14:30:33 <nikhil_k> kragniz: ok, do you mind pushing this through then?
14:30:41 * flaper87 is so happy to have stable/kilo for glanceclient
14:30:43 <mclaren> well it's a form of denial of service I guess, but yeah security tag might confuse
14:30:45 <nikhil_k> and talk to all the people who do not want a release?
14:30:59 * mclaren also things stable is best thing ever
14:31:26 <kragniz> nikhil_k: a mail to -dev saying that nova is broken with the current release should be enough
14:31:33 <nikhil_k> I will not use that tag unless someone in the release team is okay with it
14:31:43 <flaper87> just put "nova is broken" in the subject
14:31:57 <flaper87> Even the Angels will reply
14:32:04 <nikhil_k> Well, "broken conditionally"
14:32:07 <mclaren> well 'glanceclient is broken with https -- affects nova' is closer
14:32:15 <nikhil_k> == mclaren
14:32:27 <mclaren> nova and cinder etc
14:32:31 <flaper87> ok, just put nova in the subject
14:32:37 <nikhil_k> basically, [all]
14:32:49 <nikhil_k> Because ironic might be affected too
14:33:03 <flaper87> ops, got disconnected
14:33:07 <kragniz> nikhil_k: we always forget about ironic
14:33:27 <nikhil_k> heh
14:33:48 <mclaren> ok, sounds like we have a plan :-)
14:34:52 <jokke_> [all][stable][glance} went out :)
14:35:38 <nikhil_k> I've added this
14:35:40 <nikhil_k> https://review.openstack.org/#/c/173646/
14:35:47 <nikhil_k> as RC2 blocker
14:35:55 <flaper87> +2
14:36:15 <flaper87> I'm ready to +2 and ping the doc team about it
14:36:32 <flaper87> Or we can add the flags and ninja-approve
14:36:42 <nikhil_k> Thanks, we should fix the commit message. It seems important change that all the operators should be aware about
14:36:52 <mclaren> I think there's a cherry-picked from missing in the commit msg.
14:36:56 <mclaren> Let me add that
14:37:02 <flaper87> ok, I can add those flags
14:37:05 <flaper87> mclaren: you do it
14:37:07 <flaper87> :D
14:37:27 <jokke_> the bug number should be flagged as well
14:37:38 <flaper87> we also need the backport of that patch
14:38:05 <nikhil_k> yes, we need a bug, need a backport and change in the commit message
14:38:40 <nikhil_k> But we have time with 2 other reviews blocking RC2 so we should have enough time to do this right
14:39:04 <jokke_> :)
14:39:29 <flaper87> I can keep an eye on this and stuart's patches
14:39:49 <nikhil_k> Thanks all for the hard work and being proactive on the release
14:39:59 <nikhil_k> I will move on for the next topic
14:40:10 <nikhil_k> #topic  Election reminder
14:40:15 <mclaren> flaper87 provides adult supervision
14:40:19 <nikhil_k> #info Anyone that voted in the 'first' election needs to recast their vote
14:40:30 <nikhil_k> mclaren: was that you or jokke_ ? Any thing else?
14:40:57 <mclaren> nikhil_k: me. I hadn't realised that my first vote was lost until kragniz pointed it out
14:41:10 <nikhil_k> ah ha, too many emails?
14:41:14 <mclaren> that's it. Just wanted folks to know
14:41:30 <mclaren> 200,000 in my inbox as we speak :-)
14:41:35 <nikhil_k> Also, if you have multiple emails in gerrit this might have been confusing
14:42:16 <nikhil_k> The link to vote should have come in the preferred email (set in gerrit)
14:42:30 <nikhil_k> Moving on..
14:43:00 <nikhil_k> #topic Open Discussion
14:43:53 <nikhil_k> Vancouver weather looks good http://forecast.io/#/f/49.2473,-123.1069
14:44:06 <sabari> I saw stable/kilo for glance_store yest, so we open for L right ?
14:44:20 <jokke_> what's our session planning status?
14:44:27 <mclaren> good point
14:44:34 <wokuma> Since we have liberty development, how do i get attention back on https://review.openstack.org/#/c/138612/ ?
14:44:53 <flaper87> I haven't seen many proposals on the etherpad
14:45:01 <kragniz> jokke_: there's an etherpad lurking https://etherpad.openstack.org/p/liberty-glance-summit-topics
14:45:04 <flaper87> which made me think I was looking at the wrong etherpad but I was not
14:45:10 <nikhil_k> wokuma: just answered your question sabari
14:45:33 <nikhil_k> thanks for pointing that link kragniz
14:45:56 <kragniz> #link https://etherpad.openstack.org/p/liberty-glance-summit-topics
14:46:16 <nikhil_k> Please do find other links at:
14:46:16 <nikhil_k> https://wiki.openstack.org/wiki/Design_Summit/Planning
14:46:58 <jokke_> ok so Call to action ... people lets get the topics up!
14:47:16 <mclaren> would it be useful to talk about the scope of the project at the summit?
14:47:23 <jokke_> ++
14:47:24 <nikhil_k> wokuma: Please remind us outside of the meeting too to get that reviwed. However, it might be on down on the priority list right now with more important things needing attention for RC2.
14:47:34 <flaper87> mclaren: proposa a session :)
14:47:39 <flaper87> propose*
14:47:41 <flaper87> I'm interested
14:47:51 <mclaren> ok I'll do that
14:47:51 <wokuma> nikhil_k: ok, thx
14:48:19 <nikhil_k> mclaren: I would strongly encourage that however, at the same time we need to have priority meeting before the summit to decide on the topics
14:48:48 <mclaren> nikhil_k: sure, I'll just put it on the etherpad
14:48:52 <nikhil_k> Kind of similar to what we did in Kilo
14:49:28 <flaper87> thanks everyone!
14:49:35 <jokke_> I'd like to have proposals on the etherpad so when we know which one of you guys is gonna be our fearless leader to Liberty we can start seriously planning the sessions ;)
14:49:53 <flaper87> ++
14:50:03 <flaper87> LOL
14:50:03 <rosmaita> mclaren: +1 to scope of glance session
14:50:19 <pkoniszewski> nikhil_k: since liberty specs dir is already merged, can you remove -2 from https://review.openstack.org/#/c/151194/ ?
14:50:51 <nikhil_k> done. thanks pkoniszewski
14:50:55 <pkoniszewski> thanks!
14:51:13 <nikhil_k> I should prolly try to find all the reviews that are currently blocked on my -2
14:51:32 <jokke_> nikhil_k: you have quite a few of them :D
14:51:40 <nikhil_k> heh
14:52:57 <nikhil_k> Thanks all!
14:53:02 <jokke_> anything else?
14:53:06 <jokke_> Thanks!
14:53:09 * flaper87 has gummy bears
14:53:12 <kragniz> nikhil_k: thanks
14:53:14 <flaper87> anyone ?
14:53:21 * flaper87 sends gummy bears to everyone
14:53:29 <nikhil_k> #endmeeting