14:00:30 <nikhil_k> #startmeeting Glance
14:00:31 <openstack> Meeting started Thu May 14 14:00:30 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <openstack> The meeting name has been set to 'glance'
14:00:45 <kragniz> o/
14:00:51 <nikhil_k> :-)
14:00:53 <kragniz> I totally forgot about the meeting this week
14:01:02 <nikhil_k> heh, no worries
14:01:07 <mfedosin> o/
14:01:10 <nikhil_k> seems like many did so
14:01:13 <mfedosin> +1 :)
14:01:25 <bpoulos> o/
14:01:32 <rosmaita> o/
14:01:38 <nikhil_k> Hi all
14:01:40 <nikhil_k> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:11 <nikhil_k> Seems like a slow meeting today
14:02:21 <nikhil_k> not much in the agenda either
14:02:42 <nikhil_k> I was mainly planning to update those folks who could not attend the virtual summit
14:02:55 <nikhil_k> however, doesn't look like there's anyone here who did not
14:03:10 <nikhil_k> So, if there isn
14:03:16 <nikhil_k> isn't much*
14:03:29 <nikhil_k> do we want to cancel the meeting?
14:04:11 <nikhil_k> Ok, let's go over the reviews then
14:04:15 <rosmaita> let's just adjourn early
14:04:26 <nikhil_k> sounds good
14:04:36 <jokke_> o/
14:04:41 <TravT> o/
14:04:47 <nikhil_k> #topic Reviews, releases
14:05:19 <nikhil_k> We released 0.5.0 store last week to help unblock Doug #link https://pypi.python.org/pypi/glance_store/0.5.0
14:06:01 <nikhil_k> It broke the gate as we did not have Glance' unit tests in store gate
14:06:02 <kragniz> sadly, it broke stuff, so it would be nice to have a 0.5.1 release
14:06:49 <nikhil_k> kragniz: Thanks for fixing this real fast; and to everyone else who chipped in -> https://review.openstack.org/#/c/182469/
14:07:10 <kragniz> there's also https://review.openstack.org/#/c/183005/
14:07:25 <kragniz> anyone have any objections to disabling that?
14:07:25 <nikhil_k> #action nikhil_k : track 0.5.1 store release and required changes for the same.
14:08:06 <nikhil_k> I think we should go ahead with that
14:08:37 <nikhil_k> Everyone please let me know if you need specific chanes for 0.5.1
14:09:21 <kragniz> nikhil_k: cool
14:09:24 <nikhil_k> To avoid such cases in the future and catch such breaking changes, flaper87 proposed to add glance unit testing in gate
14:09:51 <nikhil_k> #action add glance unit testing in store gate
14:10:04 <kragniz> +1 to that
14:10:07 <nikhil_k> Although, we may or may not want to release store during the summit week
14:10:15 <nikhil_k> or just before it
14:10:20 <nikhil_k> or on Friday :-)
14:10:55 <nikhil_k> So, let's see how things progress and we can decide offline whether to cut a release or not
14:11:03 <kragniz> nikhil_k: it's better than having a store version that makes people sad for a few weeks :P
14:11:12 <nikhil_k> That
14:11:31 <nikhil_k> That's true, I am hoping the next one should not do the same
14:12:04 <nikhil_k> We should do some dev/local testing before release and we have proper guards places at the gate
14:12:09 <kragniz> disabling that check is low risk, since it puts the behaviour back to how it worked in 0.4.0
14:12:13 <nikhil_k> placed*
14:12:30 <nikhil_k> cool
14:12:33 <kragniz> nikhil_k: I agree, but in this case I think we should put a fix out fairly promptly
14:13:11 <nikhil_k> hmm, sure. I also would like to know how many people are actually affected before doing so.
14:13:27 <kragniz> okay
14:13:31 <nikhil_k> If it's just a small set, then we can avoid another high risk operation.
14:14:08 <nikhil_k> If nothing more, let's discuss the reivew proposed.
14:14:11 <nikhil_k> #link https://review.openstack.org/#/c/177326/
14:14:20 <nikhil_k> Is the person present here?
14:14:29 <nikhil_k> sudipto: ^
14:15:06 <nikhil_k> If not, let's put our comments on the review and move on here.
14:15:17 <nikhil_k> #topic Open Discussion
14:15:37 <sudipto> nikhil_k, hi
14:15:42 <nikhil_k> hi
14:15:52 <sudipto> nikhil_k, sorry juggling between the nova meeting.
14:15:57 <nikhil_k> okay
14:16:06 <nikhil_k> what do you want to discuss about that review?
14:16:16 * flaper87 back from ice-cream-break
14:16:25 <flaper87> I'm working on those glance unit tests already
14:16:32 <flaper87> FWIW
14:16:47 <nikhil_k> nice, we will wait for another release then
14:16:50 <sudipto> nikhil_k, basically it's stuck for sometime now, I wanted to know if we are in common grounds with respect to the change proposed.
14:16:55 <kragniz> flaper87: excellent
14:17:34 <nikhil_k> sudipto: we have low reviwer bandwidth so you may see reviews after the summit
14:17:44 <sudipto> nikhil_k, ok sure.
14:18:27 <nikhil_k> sudipto: that does impact the API status, so we shoudl have DocImpact and APIImpact flags there.
14:18:34 <sudipto> nikhil_k, ok.
14:18:34 <nikhil_k> Do we need a minor version bump?
14:19:03 <nikhil_k> sudipto: and yes, UpgradeImpact as well
14:19:08 <jokke_> hmm-m ref that review
14:19:16 <sudipto> ok
14:19:17 <jokke_> I don't thing we should change it
14:19:48 <jokke_> it's v1 after all and it's not really that wrong either to return 403
14:21:08 <sudipto> ok, i did the changes keeping v2 in mind and the bug nikhil_k had filed...
14:21:09 <nikhil_k> :)
14:21:39 <nikhil_k> sudipto: yeah, we juggle about v1 like this
14:21:44 <sudipto> nikhil_k, ok :)
14:21:53 <nikhil_k> the reason why we need to get rid of it soon :-)
14:22:10 <sudipto> ok..
14:22:17 <kragniz> soon (tm)
14:22:28 <sudipto> so shall we leave the 403 stat for now?
14:22:39 <nikhil_k> jokke_: please feel free to add comments. I wanted v1 and v2 to return consistent result. This will unbreak nova images api when v1->v2 upgrade happens there.
14:22:49 <jokke_> I'd prefer leaving it as is ... I'm putting my comment in
14:23:17 <nikhil_k> sudipto: let's see. we are nice people when giving comments so no need to worry.
14:23:26 <sudipto> nikhil_k, ok sure :)
14:23:55 <nikhil_k> Anything else?
14:24:22 <nikhil_k> If nothing, safe travels all :-)
14:25:01 <nikhil_k> and, thanks!
14:25:07 <kragniz> other projects are talking about having a social on monday night of the sumit, do we want to do something similar?
14:25:39 <nikhil_k> kragniz: feel free to chat with rosmaita about it :-)
14:26:41 <nikhil_k> #endmeeting