#openstack-meeting-4: Glance

Meeting started by nikhil_k at 14:00:17 UTC (full logs).

Meeting summary

  1. Mid-cycle meetup (nikhil_k, 14:03:14)
    1. ACTION: everyone: Please review and suggest a location, date for mid-cycle meetup https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0 (nikhil_k, 14:05:33)

  2. APIWG process update (nikhil_k, 14:07:48)
    1. https://review.openstack.org/#/c/186836/ (nikhil_k, 14:08:12)

  3. Domain model and related refactor (nikhil_k, 14:09:43)
    1. https://etherpad.openstack.org/p/liberty-glance-domain-model (nikhil_k, 14:10:04)
    2. https://review.openstack.org/#/c/132898/ (nikhil_k, 14:12:05)
    3. https://review.openstack.org/#/c/132898/ (nikhil_k, 14:20:12)

  4. Discuss adopting Core Reviewer Hierarchy akin to Neutron's (nikhil_k, 14:21:49)
  5. racy status updates in v2 (nikhil_k, 14:23:59)
    1. https://github.com/openstack/glance/blob/master/glance/domain/__init__.py#L250 (nikhil_k, 14:24:35)
    2. https://github.com/openstack/glance/blob/master/glance/api/v2/images.py#L254-L306 (nikhil_k, 14:24:42)

  6. Discuss adopting Core Reviewer Hierarchy akin to Neutron's (nikhil_k, 14:27:06)
  7. Merging remaining artifacts commits with FastTrack (nikhil_k, 14:48:07)
    1. https://review.openstack.org/#/c/132898/ (ativelkov, 14:49:29)
    2. https://review.openstack.org/#/c/136629/ (ativelkov, 14:49:40)

  8. Making use_user_token param False by default (nikhil_k, 14:55:40)


Meeting ended at 15:01:08 UTC (full logs).

Action items

  1. everyone: Please review and suggest a location, date for mid-cycle meetup https://docs.google.com/spreadsheets/d/1w0eI6SPCA2IrOyHiEYC2uDO3fbYGzahZRUQSva0UD3Y/edit#gid=0


People present (lines said)

  1. nikhil_k (100)
  2. flaper87 (71)
  3. sigmavirus24 (50)
  4. ativelkov (34)
  5. mfedosin (25)
  6. mclaren (14)
  7. TravT (14)
  8. jokke_ (12)
  9. kragniz (5)
  10. openstack (3)
  11. lakshmiS (2)
  12. ivasilevskaya1 (2)
  13. rosmaita (2)
  14. bpoulos (1)
  15. ajayaa (1)


Generated by MeetBot 0.1.4.