14:01:24 <flaper87> #startmeeting Glance
14:01:25 <openstack> Meeting started Thu Oct  1 14:01:24 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:29 <openstack> The meeting name has been set to 'glance'
14:01:34 <flaper87> Courtesy meeting reminder: ativelkov, cpallares, flaper87, flwang1, hemanthm, ivasilevskaya, jokke_, kragniz, lakshmiS, mclaren, mfedosin, nikhil_k, Nikolay_St, Olena, pennerc, rosmaita, sigmavirus24, sabari, TravT, pkoniszewski, krykowski, ajayaa, GB21, bpoulos, harshs, abhishekk, bunting, dshakhray, wxy
14:01:35 <rosmaita> o/
14:01:36 <kragniz> o/
14:01:38 <nikhil> o/
14:01:42 <kairat> o/
14:01:45 <dshakhray> o/
14:01:50 <flaper87> yoooooooooooooooooooooooooo, everyone!
14:01:51 <abhishekk> o/
14:02:17 <flaper87> Awesome, we have quorum
14:02:20 <flaper87> #topic Agenda
14:02:24 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:43 <mfedosin> o/
14:02:52 <flaper87> that's our agenda for today. There are quite some topics to discuss. If yo uhave something urgent please, let me know and we can re-arrange at runtime
14:02:55 <lakshmiS> o/
14:02:59 <flaper87> #topic Updates
14:03:09 <flaper87> ativelkov: nikhil artifacts ?
14:03:26 <nikhil> I didn't see ativelkov ping
14:03:30 <mfedosin> Alex will miss this meeting
14:03:36 <nikhil> ok
14:03:43 <flaper87> mfedosin: updates fro myou?
14:03:49 <mfedosin> I think no artifact updates on this week
14:03:50 <nikhil> We had a full meeting this Monday.
14:04:33 <flaper87> something else? Otherwise we'll move on with drivers updates
14:04:33 <nikhil> :)
14:04:38 <nikhil> #link http://eavesdrop.openstack.org/meetings/glance_artifacts_sub_team/2015/glance_artifacts_sub_team.2015-09-28-14.01.html
14:04:55 <nikhil> Quite a few things there.
14:05:17 <flaper87> okidoki, I'll read through
14:05:24 <nikhil> Mostly updates on what to come reviews, API discussion and community App catalog
14:05:51 <mfedosin> okay, I was on sick leave on Monday. so wan't able to attend the meeting
14:05:54 <flaper87> Questions? concerns ? something the rest of the community can help with?
14:05:56 <nikhil> THere's some winding up for Liberty that's merely formality, I will try to get it through this week.
14:06:04 <flaper87> nikhil: ++
14:06:08 * nikhil done
14:06:10 <dhellmann> o/
14:06:16 <flaper87> dhellmann: welcome
14:06:35 <flaper87> Updates from drivers: I don't think there's much other than we disucssed lakshmiS patch
14:06:48 <flaper87> We've agreed to not backport that patch into Liberty
14:06:56 <nikhil> yes
14:07:07 <flaper87> lakshmiS: mind elaborating on the consecuences from a searchlight perspective?
14:07:15 <flaper87> so that we have those logged here
14:07:18 <lakshmiS> sure
14:07:35 <lakshmiS> without image member notifications searchlight RBAC will not be correct
14:08:02 <lakshmiS> searchlight users would have to reindex to get the member updates
14:08:22 <flaper87> Thanks and sorry about that
14:08:26 <lakshmiS> so the patch on glance generates member notifications
14:08:36 <flaper87> We can work on getting it merge soon for Mitaka
14:08:44 * flaper87 reviewed it yday
14:08:48 <nikhil> (that were missing until now)
14:08:48 <flaper87> or was that today?
14:08:51 <flaper87> mmh
14:09:17 <flaper87> lakshmiS: thanks for the updates
14:09:20 <flaper87> nikhil: ++
14:09:20 <lakshmiS> for now we are putting a release note on searchlight by linking it to the glance patch for users to manually apply it on top of glance liberty release
14:09:37 <flaper87> it'll remain a users choice
14:09:50 * nikhil nods
14:09:50 <flaper87> to backport it or wait until mitaka
14:09:54 <flaper87> coolio
14:09:57 <nikhil> One more affect point -- this also affects all the clouds that expose notifications.
14:10:16 <flaper87> yup
14:10:19 <jokke_> o/ sry being bit late
14:10:29 <flaper87> one more good reason for not rushing it
14:10:31 <flaper87> ok
14:10:33 <flaper87> moving on
14:10:34 <nikhil> (and or use them for other purposes -- I think no one has complained until now so most likely not a biggest of issues)
14:10:46 * nikhil shuts up
14:10:52 <flaper87> #topic More cores (nikhil)
14:11:14 <flaper87> nikhil: floor is yours
14:11:15 <nikhil> So, I started the part one rotation earlier in Sept
14:11:18 <nikhil> thanks flaper87
14:11:22 <nikhil> I will try to be quick
14:11:42 <nikhil> And I had refrained from making more changes as we have a few important discussions going on.
14:12:04 <flaper87> makes sense
14:12:27 <nikhil> Since this is a transition period, I wanted to raise this as a general question on what are our plans. Of course, I do not wish to propose rushing either way.
14:12:49 <flaper87> yeah, my personal feeling is that we should wait a bit more before expanding the core team
14:12:54 <nikhil> to keep these logged -- My observation in Liberty has been that Abhishek and Sabari have done good work overall and are good candidates. So, I would like to propose for them to be cores if/when we are planning to add more to the team.
14:13:26 <flaper87> That feeling is related to the upcoming discussions. That said, I do agree that both, Abhishek and Sabari have been great
14:13:37 <flaper87> If other folks have a different view, please, do share
14:13:54 <nikhil> Sort of felt like giving them a passive shout out for helping with critical reviews at certain phases of Liberty and make them valuable assets to the team.
14:13:56 * nikhil done
14:14:01 <abhishekk> thanks nikhil and flapper87
14:14:02 <flaper87> Otherwise, I think we can talk about this again after the summit
14:14:13 <flaper87> abhishekk: no, thank you for all your reviews
14:14:16 <rosmaita> my observation is that we've contracted the core team, so adding these 2 wouldn't really be expanding
14:14:35 <abhishekk> I will be keep doing the same :)
14:14:58 <rosmaita> sabari and abhishekk do both contribute detailed, high-quality reviews
14:15:08 <nikhil> rosmaita: +1
14:15:15 <flaper87> rosmaita: it's expanding its current size. :P Jokes apart, I'm not worried about expanding it but I'd like us to clarify our goals for mitaka so we can communicate them properly and help new members to get on board
14:15:21 <flaper87> rosmaita: +1 to that
14:15:22 <mfedosin> I agree with both
14:15:50 <jokke_> flaper87: ++
14:15:53 <rosmaita> flaper87: +1 to goal clarification
14:16:04 <nikhil> agree there flaper87
14:16:27 <flaper87> coolio, so. We agree these to humans are amazing and we'd like them in the core team
14:16:33 <rosmaita> +1
14:16:34 <flaper87> but lets wait until goals are written down
14:16:53 <flaper87> #agreed these to humans are amazing and we'd like them in the core team but we'll wait until the goals have been written down
14:16:58 * flaper87 is getting bot-fancy
14:17:00 <flaper87> ok
14:17:02 <flaper87> moving on
14:17:14 <flaper87> #topic Dashboard (flaper87)
14:17:38 <flaper87> not much to say here other than I put some time to create this dashboard for Glance reviews:
14:17:44 <flaper87> #link http://tinyurl.com/glance-review-dashboard
14:17:53 <flaper87> Hope you guys like it and that you'll help improving it
14:18:06 <mclaren> nice
14:18:13 <flaper87> it comes from this project:
14:18:15 <jokke_> that is really handy
14:18:17 <flaper87> #link http://github.com/stackforge/gerrit-dash-creator
14:18:36 <flaper87> I proposed a patch to merge the dashboard you'll on that link
14:18:43 <flaper87> but that can still be improved
14:18:43 <mclaren> I know the swift folks have something similar. Their PTL can mark high priority stuff with a star I think.
14:18:59 <flaper87> yup, I'm planning to do that by keeping topics updated
14:19:08 <rosmaita> mclaren: jokke_: what browser are you using, theat tinyurl gives me an error in firefox
14:19:12 <flaper87> I'll need some help from reviewers but nothing we can't do together
14:19:18 <jokke_> rosmaita: firefox
14:19:20 <flaper87> rosmaita: I'm on firefox
14:19:28 <flaper87> rosmaita: I'll pm you the long one
14:19:34 <rosmaita> ty
14:19:36 <flaper87> ok, moving on
14:19:43 <flaper87> #topic https://review.openstack.org/#/c/229220/ (nikhil_k)
14:19:49 <mfedosin> it doesn't work in firefox
14:19:49 <flaper87> (or nikhil )
14:19:51 <flaper87> :P
14:19:56 <nikhil> :)
14:20:37 <nikhil> So, I think this is mere formality but removing downgrade can mean a project wide impact
14:21:01 <flaper87> nikhil: agreed and I agree a spec would be nice to have
14:21:11 <nikhil> For example, all the scripts should be updated, all the other specs should be updated and marked an impact update etc
14:21:21 <flaper87> From the comments I can tell one is going to be written
14:21:50 <nikhil> yeah, I hope that the developer writes one (code review) for other updates
14:22:30 <flaper87> coolio,  I'll make sure you're added to that spec as soon as it shows up
14:22:31 <flaper87> :P
14:22:36 <flaper87> you just volunteered
14:22:41 <nikhil> Also, this means that new scripts wouldn't downgrades, can we improve the upgrade path a bit?
14:23:05 * nikhil done
14:23:26 <flaper87> all good points, it'd be probably worth discussing those on the spec as soon as it shows up
14:23:28 <flaper87> thanks
14:23:40 <flaper87> #topic https://review.openstack.org/#/c/228559/ (rosmaita)
14:23:41 <nikhil> As we are still waiting on lite-specs I was keeping an eye on some of the stuff like this. (waiting on lite-specs discussion to begin) :P
14:24:01 <flaper87> nikhil: speaking of that, I've some material for next drivers meeting :P
14:24:05 * flaper87 gets back on topic
14:24:09 <flaper87> rosmaita: floor is yours
14:24:10 <nikhil> flaper87: nice!
14:24:24 <flaper87> rosmaita: stop playing with the dashboard
14:24:26 <flaper87> :P
14:24:29 <rosmaita> sorry
14:24:36 <rosmaita> my comment is on the agenda
14:24:50 <rosmaita> which i hav ejust lost
14:24:56 <nikhil> rosmaita: that's a really good raise
14:25:06 <rosmaita> https://review.openstack.org/#/c/228559/ (rosmaita) - this is a fix so that 'deactivated' images cannot be downloaded by non-admin users.  The discussion on the patch is that the only circumstances under which Glance should allow an image to be downloaded are: (1) image status is 'active' (all users), or (2) image status is 'deactivated' (admin users only).  I think this makes sense, but think it's worth pointing this out to the wider Glance
14:25:13 <nikhil> I think this sort of overlaps with the re-upload to error state a bit.
14:25:28 <flaper87> Yeah
14:25:59 <rosmaita> like i said, i don't have a particular problem in mind, but thought it was worth pointing out
14:26:01 <flaper87> I agree w/ rosmaita on the reasoning about when an image should be able to be downloaded
14:26:07 <flaper87> rosmaita: ++
14:26:22 <jokke_> rosmaita: iiuc that fix is so deactivated images can be downloaded by admin user
14:26:41 <flaper87> jokke_: yup
14:26:44 <nikhil> possibly defining what happens on certain image-loc statuses
14:26:50 <rosmaita> jokke_: well, i think that was the bug, but the patch is evolving to be a bit more restrictive
14:26:50 <jokke_> ah no sorry
14:27:02 <jokke_> mixed with the previous one around that topic
14:27:09 <mclaren> So the big change is previously only active images could be downloaded by anyone? There's nothing jumping out at me  that it's a problem
14:27:35 <mfedosin> there is a mistake - should be 'not req.contex.is_admin'
14:27:37 <rosmaita> i think the prob is the admin restriction
14:27:44 <jokke_> mfedosin: I totally agree
14:27:59 <mclaren> rosmaita: problem in what sense?
14:28:03 <flaper87> mfedosin: good eye!
14:28:05 <jokke_> mfedosin: good catch
14:28:14 <jokke_> mfedosin: please add to the review comments ;)
14:28:27 <mfedosin> jokke_, already
14:28:43 <nikhil> well, we should backport this if it merges, thoughts?
14:28:49 <jokke_> my totally agree was for mclaren not to mfedosin ;)
14:29:19 <rosmaita> mclaren: i think previously admin could download any state, e.g., pending_delete ?
14:29:20 <mfedosin> lol :)
14:29:52 <mclaren> rosmaita: ah, thanks
14:29:54 <nikhil> rosmaita: then it looks like a breaking change
14:29:55 <flaper87> why is the bug targeted to glanceclient ?
14:29:57 <jokke_> rosmaita: and I think that's fine as well ... admin should be able to
14:29:59 <flaper87> prob a mistake
14:30:31 <rosmaita> jokke_: well, sabari pointed out that since there's an external scrubber, a pending_delete image could be scrubbed while you were trying to download
14:30:35 <flaper87> IIUC, rosmaita said that the patch is evolving into something more restrictive, which means we can't backport it
14:31:14 <flaper87> giving 1 more minute to this discussion. We can follow up on the review as well
14:31:31 <nikhil> I think it's a race condition issues that we should solve by locking mechanisms and not adding restrictions to the API
14:31:36 <nikhil> issue*
14:31:47 <mclaren> hmm an image could transition to pending_delete and get scrubbed if it started as active (during download)
14:31:48 <rosmaita> that's all from me, please put comments on the patch
14:32:04 <nikhil> or even delete
14:32:19 <rosmaita> mclaren: good point
14:32:21 <nikhil> or it  could be d/l from cache while deleted from backend too
14:32:29 <flaper87> sorry for changing topics, I'd like us to go through the agenda and this looks like something we can follow-up on the review
14:32:31 <flaper87> thanks rosmaita
14:32:37 <jokke_> yeah and that's end user facing, not just admin who has control over that scrubber as well if needed
14:32:40 <nikhil> so, I think this stuff is impl detail and not API detail
14:32:43 <mclaren> I guess download of pending delete is a gray area. I'm not overly concerned about it tbh.
14:32:52 <flaper87> #topic Mitaka summit sessions (flaper87)
14:33:04 <flaper87> #link https://etherpad.openstack.org/p/mitaka-glance-summit-topics
14:33:14 <flaper87> There's no much there, yet!
14:33:32 <flaper87> I've added a placeholder for the upload process discussion and put rosmaita name there
14:33:39 <flaper87> but, we should start adding more topics
14:33:51 <flaper87> I think it was nikhil that mentioned a pre-summit brainstorm
14:33:51 <mclaren> the nova v2 stuff?
14:33:57 <nikhil> yes
14:33:59 <flaper87> nikhil: do you want to elaborate?
14:34:03 <nikhil> flaper87: sure
14:34:20 <flaper87> mclaren: That's going to be a cross-project session, AFAIK. If not, it'll be a nova session.
14:34:29 <flaper87> mclaren: but it's a great topic and we should discuss it
14:34:31 <flaper87> ++
14:34:37 <nikhil> so, I think a lot of fuzziness exists on what's going around with the upload path, what are the possible priorities and summit topics for Tokyo
14:34:43 <mclaren> oh, ok. As long as it's not forgotten
14:35:20 <nikhil> And I find it useful to be prepared with concise thoughts around each topic that we plan to discuss as that usually means, it's going to show up on the priority and be implemented for cycle
14:35:22 <mfedosin> I hope there will be at least one about artifacts
14:35:40 <nikhil> sort of makes me feel like having a productive discussion on each topic
14:35:41 <mclaren> IMHO the priorities are the upload reload and the v2 nova/cinder stuff.
14:35:58 <flaper87> so
14:35:59 <nikhil> define the scope of implementation and the project universe (To think about)
14:36:01 <dhellmann> flaper87: if the session only affects 2 projects, we try to put it in one of their tracks, so either nova or glance should host the session for the v2 work
14:36:24 <dhellmann> mclaren: ++
14:36:29 <flaper87> dhellmann: yeah, I thought that would be the case
14:36:34 <flaper87> dhellmann: so, nova it is
14:36:44 <flaper87> I've talked w/ johnthetubaguy already about this
14:36:48 <dhellmann> flaper87: great
14:36:49 <flaper87> right, johnthetubaguy ?
14:36:50 <flaper87> :P
14:37:09 <nikhil> Sorry if I fail to understand if nothing else is likely to go?
14:37:11 <flaper87> so, I think it'd be super useful to have a clear list of what the summit will look like before the summit
14:37:39 <flaper87> I'd also like to encourage folks to write specs for their sessions as that helps having more useful conversations
14:37:58 <flaper87> I think we can decide based on the topics that are proposed whether a pre-summit brainstorm would be useful or not
14:38:11 <mclaren> flaper87: does the v2 stuff also affect cinder? if it affects cinder and nova should it be a glance session. (Not super important either way)
14:38:20 <flaper87> mclaren: yes
14:38:27 <jokke_> flaper87: it would be super useful to know what else we can fit on our bowl after those two ... so how much the Nova migration will be this team's problem and how much work wil be needed for that upload stuff for DefCore
14:38:59 <flaper87> mclaren: it affects ciner but there's lot to do in nova and it could use more nova folks in the room
14:39:06 <flaper87> so, I'd probably vote for doing a nova session
14:39:10 <mclaren> ok, whatever works
14:39:40 <jokke_> flaper87: ++ I think the topic need Nova attention
14:39:55 <flaper87> jokke_: yup, I think we'll be able to tell more once we have some draft for the specs written down. As in, there's lot to do on both sides. The Nova work is being split between both teams, which is super great.
14:40:14 <flaper87> The upload work is us in terms of implementation but it requires collaboration with the overall community as well
14:40:28 <flaper87> which brings me to the next topic, which will hopefully answer nikhil's question
14:40:39 <flaper87> (unless there's something else people want to add here)
14:40:41 <nikhil> sure
14:40:53 <nikhil> While upload is super important, I think we can still work on download, members, metadef improvements
14:41:08 <nikhil> not sure how much is in the bucket for those, but that can come in the priority list too.
14:41:23 <mclaren> sure, but if everything's a priority nothing is ...
14:41:30 <flaper87> mclaren: ++
14:41:33 <flaper87> ok, next topic
14:41:36 <flaper87> #topic Glance Priorities list (i.e: http://specs.openstack.org/openstack/nova-specs/priorities/liberty-priorities.html )
14:41:40 <flaper87> BAM!
14:41:45 <flaper87> sooooooooo
14:41:53 <nikhil> mclaren: how would you define a priority heirarchy?
14:42:05 <TravT> v2 affects horizon FYI.
14:42:12 <flaper87> one thing I think we as a team have failed to communicate internally and upstream is our priorities
14:42:12 <mclaren> nikhil: not sure
14:42:24 <flaper87> We've had etherpads and other things but no official process
14:42:44 <flaper87> I dug a bit into how nova handles this and they use what it's called "nova-priorities-list"
14:42:53 <flaper87> I'd like the glance team to do the same
14:42:57 <flaper87> TL;DR:
14:43:00 <mclaren> swift have this (review centric) https://wiki.openstack.org/wiki/Swift/PriorityReviews
14:43:18 <flaper87> The team agrees on what the priorities for the cycle are and puts extra efforts on that
14:43:33 <flaper87> I'm not going to get into the hows/whys of the workflow in this meeting
14:43:35 <flaper87> BUT
14:43:43 <flaper87> I'd love to get feedback from everyone
14:43:58 <flaper87> This list of priorities does not mean that things that aren't there won't land
14:44:04 <mclaren> Can we define things we must get done in the cycle?
14:44:13 <jokke_> mclaren: ++
14:44:16 <kairat> heat has an etherpad with priority review and they discuss progress on it every week during the meeting
14:44:16 <abhishekk> ++
14:44:16 <flaper87> It means that: 1) Things in that list are top-prio for reviews, patches, etch!
14:44:39 <kairat> so would it be enough for glance?
14:44:40 <flaper87> It also helps providing feedback for the rest of the community
14:44:53 <flaper87> and to provide a clear view of what glance mitaka will look like
14:45:10 <flaper87> mclaren: I think we should do that when we start defining that list
14:45:16 <flaper87> Nova uses a full session for that
14:45:35 <flaper87> and I'd like to have a pre-summit meeting about that
14:45:44 <mclaren> ok.
14:45:50 <flaper87> so that we go to the summit wit ha clear view and we can also prioritize topics based on that
14:46:06 <flaper87> If that makes sense, I'll schedule some time during the next meeting for this
14:46:14 <flaper87> So that people can start preparing topics
14:46:19 <rosmaita> +1
14:46:24 <mclaren> I think the community will be watching closely on the upload/v2 stuff over the cycle.
14:46:34 <flaper87> Note that this conversation will take some time, which means next meeting will be mostly abou this
14:46:49 <nikhil> flaper87:  may be write a review against glance-specs repo?
14:47:10 <flaper87> nikhil: yup, that's how nova does it and I'd like us to follow that pattern
14:47:23 <flaper87> I'll prepare the first draft
14:47:26 * nikhil ack
14:47:28 <mclaren> the priorities are recorded as a spec?
14:47:35 <flaper87> we can start commenting on it and complete it next week
14:47:37 <flaper87> mclaren: yes
14:47:43 <mclaren> sounds good I think
14:47:46 <flaper87> mclaren: Glance Priorities list (i.e: http://specs.openstack.org/openstack/nova-specs/priorities/liberty-priorities.html )
14:47:54 <mclaren> thanks
14:47:54 <abhishekk> nova does not accept any specs after milestone 1 and it will be submitted as backlog
14:48:05 <flaper87> mclaren: it's there, public and we can link to it to inform people and te overall community
14:48:15 <mclaren> and be held accountable to :-)
14:48:16 <flaper87> abhishekk: that brings me to the next topic :P
14:48:18 <nikhil> #link https://github.com/openstack/nova-specs/tree/master/priorities
14:48:24 <abhishekk> :)
14:48:25 <flaper87> mclaren: ++
14:48:47 <flaper87> #action flaper87 to write the draft for mitaka glance priorities
14:49:27 <flaper87> Actually, I'll let the next topic for next week, I'd like to leave time for open discussions since there are some reviews requests
14:49:45 <flaper87> #topic Open Discussion
14:49:59 <flaper87> https://review.openstack.org/#/c/221307/ (lakshmiS, TravT)
14:50:13 <mfedosin> flaper87, what is the weather in Japan? :)
14:50:21 <mclaren> did we cover that one?
14:50:23 <flaper87> This is the patch we agreed not to backport to RC2
14:50:38 <TravT> flaper87: thanks for one round of reviews on that.  I think lakshmiS has addressed your set of comments
14:50:44 <flaper87> mclaren: yup, but it'd be great to review it so it lands in early mitaka and Searchlight can link to it
14:50:46 <abhishekk> mclaren: yes
14:50:51 <flaper87> TravT: awesome!
14:50:54 <flaper87> mfedosin: Rainy
14:50:56 <flaper87> :D
14:50:56 <mclaren> ack
14:51:00 <TravT> we have a patch sitting in our queue for searchlight liberty actually that can listen to these notifications.
14:51:22 <flaper87> It'd be great to get one extra pair of eyes on that one
14:51:32 <TravT> and looking for reviews as soon as possible
14:51:39 <flaper87> it's adding new notifications for members and there's a contract related to that one
14:51:45 <TravT> of particular interest is the notifications names and content
14:51:51 <flaper87> As in, it's a public format that needs to be supported
14:52:10 * flaper87 's wording is terrible today
14:52:19 <flaper87> Glance store exceptions: https://bugs.launchpad.net/glance-store/+bug/1501443
14:52:19 <openstack> Launchpad bug 1501443 in glance_store "glance_store exceptions trigger child exceptions (which break Glance's error handling)" [Undecided,Opinion]
14:52:24 <flaper87> mclaren: jokke_ is that yours ^ ?
14:52:26 <mclaren> that's me
14:52:28 <TravT> since the names and content represent the API, basically
14:52:31 <flaper87> mclaren: shoot
14:52:39 <jokke_> flaper87: I take no credit on that
14:52:45 <flaper87> TravT: ++
14:52:49 <mclaren> So it look's to me like a lot of our exception handling doesn't work
14:53:04 <mclaren> But I'm interested to know of someone else could confirm, I may be seeing things
14:53:08 <mclaren> of/if
14:53:24 <dhellmann> flaper87, nikhil : I plan to use glance as a demo of a new release note management tool we're rolling out for the liberty stable releases. I'll ping you when those patches are ready.
14:53:43 <flaper87> dhellmann: awesome, thanks!
14:53:49 <mfedosin> mclaren, I wrote a fix for that
14:53:50 <jokke_> dhellmann: add me to the list ;)
14:53:56 <dhellmann> jokke_: ack
14:54:04 <mclaren> mfedosin: I think I have that change
14:54:06 <nikhil> dhellmann: sounds intriguing! Would love to learn more..
14:54:10 <flaper87> mclaren: I don't think you're seeing things but I'm curious to know how you hit that
14:54:25 <mfedosin> https://review.openstack.org/#/c/202083/
14:54:26 <mclaren> testing an upcoming policy fix
14:54:33 <flaper87> mclaren: ah-ha. gotcha
14:55:04 <flaper87> I think there's something fishy in there
14:55:11 <mclaren> mfedosin: ah, I can check if my version of the store has that -- thanks
14:55:17 <flaper87> it's probably related to the old store code being migrated to the library
14:55:24 <flaper87> which basically means it's my fault
14:55:25 <jokke_> mfedosin, mclaren: I thought I had seen fix for that!
14:55:26 <flaper87> :P
14:55:38 <mclaren> mfedosin: is that in a released version of the store?
14:55:41 <jokke_> mclaren: that fix has not merged yet
14:55:46 <flaper87> not merged
14:55:54 <mfedosin> mclaren, no, it's still on review
14:56:22 <mclaren> well that explains it!
14:56:27 <flaper87> I don't recall how big/invasive the fix is but it may even be good backport material
14:56:40 <jokke_> flaper87: looks like so
14:56:45 <mclaren> flaper87: yes I agree if feasible
14:56:52 <mclaren> there'll be a lot of 500s otherwise
14:57:07 <mfedosin> if you want I can update the commit message
14:57:09 <flaper87> mclaren: :(
14:57:10 <mclaren> mfedosin: I'll test that out and review, thanks again
14:57:17 <jokke_> flaper87: now when we have bug fir it :P
14:57:24 <flaper87> jokke_: ++
14:57:37 <mfedosin> mclaren, you're welcome
14:58:08 <flaper87> Anything else? Anyone?
14:58:18 <flaper87> Who's going to attend the summit?
14:58:30 <mclaren> o/
14:58:32 <mfedosin> o/
14:58:42 <dhellmann> o/
14:58:44 <rosmaita> o/
14:58:44 <abhishekk> o/
14:58:56 <flaper87> nnnnnnnnnnnnnnice!
14:58:57 <flaper87> jokke_: ?
14:59:02 <flaper87> o/
14:59:05 <nikhil> rc2 might be out soon (fyi)
14:59:09 <flaper87> nikhil: rosmaita ?
14:59:18 <rosmaita> o/
14:59:23 <jokke_> o/
14:59:27 <flaper87> nikhil: good news, thanks!
14:59:44 <flaper87> hope it's the last RC
14:59:46 <flaper87> :D
14:59:57 <nikhil> it's prolly not
14:59:58 <jokke_> nikhil: I think it is out ... I saw the config bug moving from committed to released
15:00:04 <flaper87> We should all give Glance-rc2 a crazy test session as soon as it's out
15:00:14 <nikhil> weird, wonder why I did not get a ping back
15:00:19 <nikhil> ++
15:00:31 <nikhil> lakshmiS: I am removing the liberty tag  from https://bugs.launchpad.net/glance/+bug/1441453
15:00:31 <openstack> Launchpad bug 1441453 in Glance "Image members CRUD doesn't generate notifications which impacts searchlight RBAC." [High,In progress] - Assigned to Lakshmi N Sampath (lakshmi-sampath)
15:00:42 <jokke_> 6min before meeting started
15:00:55 <nikhil> flaper87: that'w what we agreed, correct me if I am wrong
15:01:11 <flaper87> nikhil: we agreed that!
15:01:15 <nikhil> ty
15:01:17 <flaper87> no liberty, full mitaka
15:01:23 <flaper87> and we ran out of time!
15:01:28 <flaper87> Thanks everyone for attending
15:01:31 <flaper87> #endmeeting