14:01:14 <flaper87> #startmeeting Glance
14:01:15 <openstack> Meeting started Thu Oct  8 14:01:14 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:19 <flaper87> Courtesy meeting reminder: ativelkov, cpallares, flaper87, flwang1, hemanthm, ivasilevskaya, jokke_, kragniz, lakshmiS, mclaren, mfedosin, nikhil_k,
14:01:19 <openstack> The meeting name has been set to 'glance'
14:01:19 <nikhil> o/
14:01:21 <flaper87> Courtesy meeting reminder: Nikolay_St, Olena, pennerc, rosmaita, sigmavirus24, sabari, TravT, pkoniszewski, krykowski, ajayaa, GB21, bpoulos, harshs, abhishekk, bunting, dshakhray, wxy, dhellmann
14:01:23 <jokke_> o/
14:01:26 <bunting> o/
14:01:32 <rosmaita> o/
14:01:34 <ativelkov> o/
14:01:38 <nikhil> o/
14:01:45 <flaper87> w000h000! moar ppl, MOAR PPL
14:01:59 <flaper87> #topic Agenda
14:02:02 <dshakhray> o/
14:02:07 <flaper87> we've a short agenda for today
14:02:11 <flaper87> let's get to it
14:02:13 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:26 <flaper87> #topic Updates Artifacts
14:02:37 <flaper87> ativelkov: mfedosin nikhil
14:02:40 <flaper87> :)
14:02:43 <flaper87> go crazy
14:02:44 <abhishekk> o/
14:02:47 <mfedosin> o/
14:02:58 <ativelkov> So, a quick update
14:03:13 * nikhil stops typing
14:03:14 <ativelkov> Thanks to jokke_ and nikhil we had some discusssions on v3 interoperability
14:03:31 <ativelkov> And I think we've found a good design solution
14:03:48 <flaper87> great news
14:03:49 <ativelkov> There will be a set of public API calls which are plugin-independnent
14:04:00 <ativelkov> So, they will be "def-core" compliant
14:04:27 <flaper87> that's super important
14:04:35 <flaper87> is there a link/spec where we can read more about that?
14:04:53 <ativelkov> And the plugin-dependent ("dynamic") APIs may be considered plugin, i.e. the ones intended for the particular project (murano, heat, magnum etc) to interact with glance internally )within a cloud)
14:05:09 <ativelkov> flaper87: not yet, I am bad in finding time to document things )
14:05:19 <nikhil> here's a start
14:05:20 <ativelkov> Will do that in ML and later that article I am still trying to write
14:05:20 <nikhil> http://eavesdrop.openstack.org/meetings/glance_artifacts_sub_team/2015/glance_artifacts_sub_team.2015-10-05-14.01.html
14:05:23 <flaper87> ativelkov: aren't we all? aren't we?
14:05:25 <flaper87> :D
14:05:30 <flaper87> nikhil: thanks
14:05:37 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:05:40 <flaper87> #undo
14:05:42 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x999ce50>
14:05:44 <flaper87> #link http://eavesdrop.openstack.org/meetings/glance_artifacts_sub_team/2015/glance_artifacts_sub_team.2015-10-05-14.01.html
14:06:05 <flaper87> ativelkov: nikhil mfedosin question for you guys: Are you planning to have a session at the summit ?
14:06:16 <flaper87> I didn't see any proposal and it seemed weird
14:06:26 <flaper87> #link  https://etherpad.openstack.org/p/mitaka-glance-summit-topics
14:06:28 <flaper87> proposals go there
14:06:31 <flaper87> :D
14:06:44 <mfedosin> I would like to have one
14:06:45 <ativelkov> Thanks :) I'd like to discuss the v3, yup
14:06:55 <nikhil> I guess that's a question for the session proposals topic. and personally think we should at least have a work session.
14:07:17 <flaper87> ok, please, add it to that etherpad as we're in the phase of setting up the schedule
14:07:19 <rosmaita> it would be good to try to get some people from heat and magnum there, too ... want them to get ready to use artifacts
14:07:19 <nikhil> thanks for the reminder flaper87, yeah we'd ideally have something up already!
14:07:32 <nikhil> ++
14:07:37 <flaper87> I'd like to hav ethe schedule done by the end of next week
14:07:54 <flaper87> rosmaita: sounds like a good idea
14:08:18 <flaper87> nikhil: ativelkov mfedosin could any of you sync with folks from those team to make sure we can pick a slot that works for at least 1 person of each team?
14:08:20 <flaper87> :)
14:08:28 <flaper87> I know, I know. Scheduling things is hard
14:08:43 <nikhil> I can work with someone from heat
14:08:53 <flaper87> nikhil: that's a start, thanks
14:08:57 <nikhil> and will ping you all if I can reach out to magnum in short time
14:09:11 <flaper87> ativelkov: mfedosin you guys surely know someone from Murano
14:09:13 <rosmaita> nikhil: i can reach out to adrian otto
14:09:14 <flaper87> :)
14:09:20 <ativelkov> flaper87: I am from murano ;)
14:09:32 <ativelkov> And I'll ping Heat's PTL
14:09:42 <flaper87> ativelkov: I know, I forgot to tag that message
14:09:43 <nikhil> flaper87: so, we are looking at all the proposals listed by early next week? and final it by thursday or so?
14:10:12 <mclaren> anyone know how magnum plan to use artifacts?
14:10:33 <flaper87> nikhil: yes, that's the rough plan! If there are not enough proposals, we may come up with something or give those slots back
14:10:39 <flaper87> ok, lets move on
14:10:41 <ativelkov> mclaren: I don't know for sure, but I remember Adrian Otto saying that he is looking forward to use it
14:10:41 <rosmaita> mclaren: not sure, adrian otto was very interested, not sure why
14:11:04 <flaper87> #topic Updates drivers
14:11:32 <nikhil> mclaren:  there were a few small discussions earlier in liberty, we need to come up to sync now once we've a direction for the API
14:11:41 <flaper87> On our last meeting, we discussed a couple of topics. One is the inheritable image properties spec in nova
14:11:42 * nikhil shuts up
14:11:47 <mclaren> ok, thanks
14:11:54 <flaper87> Another one is the spec-lite process
14:12:18 <flaper87> For that last one, I'll start a thread on the ML to reach out to more people and get feedback from others
14:12:40 <flaper87> We didn't reach consensus on that process and there's more to be discussed
14:12:57 <flaper87> Did I forget something important from the last meeting?
14:13:17 <flaper87> ok, I'll take that as no
14:13:20 <flaper87> moving on
14:13:24 <nikhil> #link http://eavesdrop.openstack.org/meetings/glance_drivers/2015/glance_drivers.2015-10-06-14.01.log.html#l-24
14:13:48 <flaper87> #topic duplicate exceptions between glance_store and glance bunting
14:14:13 * flaper87 wonders if that's the same topic we discussed last week (or we didn't discuss it?). Perhaps mclaren started it
14:14:16 <flaper87> bunting: floor is yours
14:14:19 <bunting> When looking at the bug posted on the agenda I noticed that a few exceptions are duplicated between glance and glance_store
14:14:30 <ativelkov> wow, that sounds familiar
14:14:31 <bunting> I was wondering if we should 'merge' these exceptions
14:14:39 <ativelkov> mfedosin: you worked on that, right?
14:14:45 <mfedosin> yup
14:14:58 <bunting> These are the exceptions that are currently duplicated: paste.openstack.org/show/475612/
14:15:10 <nikhil> Are you sure we can merge them?
14:15:19 <mfedosin> but finally we decided to duplicate handlers in the code
14:15:32 <flaper87> glance_store is an independent library
14:15:50 <flaper87> sometimes we just need to catch those exceptions in glance and do something or re-raise
14:15:54 <jokke_> #link paste.openstack.org/show/475612/
14:15:59 <flaper87> mmh, perhaps Glance is the one that needs to be cleaned up
14:16:00 <mfedosin> https://review.openstack.org/#/c/200000/
14:16:12 <mclaren> so we have glance.ImageDataNotFound and glance_store.ImageDataNotFound. Any reason we can't just have glance_store ImageDataNotFound?
14:16:31 <flaper87> mclaren: I don't think there's anything preventing us from doing that
14:16:47 <nikhil> umm, wait a sec
14:16:51 <mfedosin> flaper87, it doesn't work, because ImageNotFound can be raised either in glance or in glance_store
14:16:56 <flaper87> unless I misunderstood
14:17:00 <mfedosin> so we have to catch them both
14:17:02 <nikhil> can those exceptions be used by cache logic and then re-worked?
14:17:22 <flaper87> mfedosin: ah right, that's the other thing
14:17:33 <mclaren> glance uses webob exceptions, any reason it can't use glance_store exceptions?
14:17:33 <jokke_> mfedosin: so what's the problem glance raising glance_store.ImageNotFound?
14:18:18 <flaper87> mmh, depends on when it is raising that exception
14:18:30 <flaper87> I think Glance raises ImageNotFound when it's not in the DB
14:18:46 <jokke_> perhaps we should spinn off new lib called glance_exceptions :P
14:18:47 <flaper87> in which case I don't think it should raise glance_store's exception
14:19:00 <flaper87> but my memory is bad and I need to read the code again
14:19:00 <mfedosin> but not ImageNotFound - just NotFound. We have to fix it in million places
14:19:27 <nikhil> eh
14:19:37 <nikhil> NotFound sounds like a parent exception
14:19:47 <nikhil> common for different assets -- tasks, metadefs etc
14:20:04 <nikhil> members..
14:20:12 <flaper87> bunting: I think the conclusion of the above is: ppl are not against you refactoring that code but there will likely be comments on the review (unless you find issues that won't allow you to move forward)
14:20:43 <bunting> flaper87: Thats, fine its just pointed out its odd we have the same exception twice :p
14:20:49 <mclaren> yeah, it's probably a case of we shouldn't start from here :-) (ie with 29 duplicate exception names)
14:20:52 <nikhil> While I think that we can reduce the duplicate exceptions, I don't think we can get rid of all of them
14:21:04 <nikhil> mclaren: yea
14:21:06 <flaper87> nikhil: I agree
14:21:28 <flaper87> let's let bunting dig more into this
14:21:32 <jokke_> I think first question is do we actually raise them all from both?
14:21:39 <flaper87> it sounds like a good clean up
14:21:48 <jokke_> or how much that is still remains of the separation and just copy over
14:21:48 <mfedosin> Let me explain
14:21:49 <flaper87> or attempt to
14:22:03 <mfedosin> NotFound from here https://github.com/openstack/glance_store/blob/master/glance_store/exceptions.py#L66
14:22:24 <mfedosin> is not exactly the same as NotFoundFrom here https://github.com/openstack/glance/blob/master/glance/common/exception.py
14:22:54 <mfedosin> it's more identical to https://github.com/openstack/glance/blob/master/glance/common/exception.py#L334
14:23:02 <flaper87> yeah, I think ppl get that. The question is not w.r.t the base exceptions but the ones inheriting from those that are duplicated
14:23:14 <mfedosin> so we can't use store's exception in Glance everywhere
14:23:50 <mclaren> sure, if they have different uses that's ok.
14:24:10 <flaper87> IMHo, glance shouldn't be raising glance_store exceptions. re-raising, fine. Raising from scratch, nope.
14:24:19 <nikhil> ++
14:24:26 <ativelkov> agree
14:24:29 <mfedosin> and the only one solution we found was duplicate them in the code. it's dirty, but it works
14:24:44 <mclaren> we may be at a point where we may just have to live with some confustion around same names
14:25:03 <mfedosin> like here https://github.com/openstack/glance/blob/master/glance/api/v2/images.py#L241
14:25:04 <flaper87> Let's let bunting dig into this if he's willing to
14:25:18 <bunting> flaper87: I'm willing to have a look
14:25:30 <mclaren> I think the question is: if the glance store didn't exist would we have duplicated any particular exception (case by case)?
14:25:30 <flaper87> bunting: awesome! You just won something
14:25:34 <flaper87> I don't know what but something
14:25:53 <rosmaita> whisky popcorn
14:26:02 <mclaren> a year's supply of exceptions
14:26:06 <flaper87> mclaren: we had store in glance and it was the same project so, no, we wouldn't
14:26:06 <bunting> ++
14:26:14 <flaper87> anyway, we gotta move on :D
14:26:34 <flaper87> #action bunting to dig into the "Attack of the cloned exceptions"
14:26:47 <flaper87> #topic Summit Schedule (flaper87)
14:27:01 <mfedosin> I was there - it hurts :)
14:27:13 <flaper87> As hinted before, we gotta get the schedule done!
14:27:25 <flaper87> The allocations were uploaded to sched.org
14:27:28 <flaper87> #link http://mitakadesignsummit.sched.org/type/glance#.VhZhTc-1RZK
14:27:44 <flaper87> and I've used 2 already for topics that we must discuss for sure :D
14:28:04 <flaper87> 1 is a fishbowl for the image import workflow refactor
14:28:19 <flaper87> and the second one (the last work room session) to finilize mitaka priorities
14:28:37 <flaper87> The rest of the slots we will all vote for and allocate rooms accordingly
14:28:46 <flaper87> please, do read the etherpad and add topics
14:28:54 <nikhil> oh the last work session is booked
14:28:54 <flaper87> #link https://etherpad.openstack.org/p/mitaka-glance-summit-topics
14:29:10 <flaper87> I probably meant latest
14:29:29 <flaper87> as in the one on Thursday at 17:20
14:29:46 * flaper87 can't change the topic of work sessions
14:29:47 <flaper87> :(
14:29:48 <nikhil> ack
14:30:07 <nikhil> yeah, it's on purpose to avoid large participation..
14:30:12 <flaper87> yup
14:30:15 <nikhil> wonder if that's still case for tokyo :/
14:30:26 <nikhil> as they aren't allowing a ton of people to design area
14:30:31 <nikhil> anyways..
14:30:37 * nikhil shuts up
14:30:56 <flaper87> if there's something you would like to discuss, please add it to the etherpad
14:31:02 <flaper87> Last week we'll be closing the schedule
14:31:20 <flaper87> #info Glance's summit schedule will be finalized on Thursday 15
14:31:27 <flaper87> #undo
14:31:27 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x9591090>
14:31:37 <flaper87> #info Glance's summit schedule will be finalized on Thursday October, 15th
14:32:03 <flaper87> questions? concerns? otherwise, we can move on
14:32:24 <flaper87> I'll take that as a no
14:32:30 <flaper87> #topic Cleanup old patches http://lists.openstack.org/pipermail/openstack-dev/2015-October/076232.html (flaper87)
14:32:45 <flaper87> I don't mean to go in deep details about this here because that's what the email thread is for
14:33:11 <flaper87> I just want to make sure people in this meeting know there's that discussion on the mailing list and that there's a workflow that is being planned to be followed
14:33:23 <flaper87> (at least once at the beginning of mitaka)
14:33:29 <jokke_> ++
14:33:51 <mclaren> I half followed the thread
14:34:05 <nikhil> I found cases when people wanted to restore patches and couldn't themselves
14:34:07 <flaper87> that said, the plans to improve the review bandwidth are different from that thread and they involve other activities
14:34:19 <mclaren> Are we still planning on marking patches abandoned?
14:34:19 <nikhil> It would be best to have a POC for those who wish to do so
14:34:35 <nikhil> "points" of contact*
14:34:35 <flaper87> nikhil: is that something we should mention to infra? what cases specifically?
14:34:49 <flaper87> nikhil: ha! that clears POC in that context
14:34:52 <flaper87> :D
14:35:06 <nikhil> flaper87: cases when people were inactive for along time and wanted to restore a patch
14:35:14 <nikhil> let me get one latest example
14:35:44 <flaper87> mclaren: as I mentioned, I'd like to run this at least once for mitaka. We'll see how it goes. The feedback on the thread is great!
14:36:01 <flaper87> but really, lets keep the discussion on the ML
14:36:10 <mclaren> If a patch is still potentially ok (doesn't need a rebase, is passing the tests) will we mark it abandoned?
14:36:14 <mclaren> oops, ok
14:37:06 <nikhil> eh, can't find it
14:37:07 <bunting> mclaren: I suggested that we should potentially try reviewing them instead of marking abandoned
14:37:09 <flaper87> mclaren: no, it'll be set back to not-in-work-in-progress. We can filter those out from the to-WIP list (think I mentioned this in the thread)
14:37:26 <nikhil> hmm, this one
14:37:29 <nikhil> #link https://review.openstack.org/#/c/206120/
14:37:30 <flaper87> bunting: and I told you that's the goal :D
14:37:44 * mclaren will go back and read the thread
14:37:49 <flaper87> that's one of the points of this process
14:37:55 <bunting> flaper87: Yeah, just mentioning as he said it half read it :p
14:37:58 <flaper87> I mean, identify those patches and move them forward
14:38:41 <flaper87> nikhil: thanks, I'll read through and try to understand why restoring it was not possible
14:39:06 <flaper87> perhaps is because of the -2?
14:39:08 * flaper87 shrugs
14:39:21 <flaper87> ok, please, chime in! This is important too.
14:39:35 <flaper87> moving on
14:39:50 <flaper87> #topic image import refactor is ready for discussion: https://review.openstack.org/#/c/232371/(rosmaita)
14:40:06 <flaper87> rosmaita: want to say something? or just a heads up?
14:40:30 <rosmaita> just a heads up
14:40:42 <flaper87> That spec will likely require several iterations. It'd be great if ppl interested could read it and comment on it
14:40:48 <mclaren> thanks for that rosmaita
14:41:00 <rosmaita> yes, i expect to be going through many patches
14:41:01 <flaper87> Things that will be discussed at the summit on that session depend on this spec
14:41:02 * jokke_ did first read through today
14:41:05 <mclaren> it's ok to comment on it now?
14:41:11 <rosmaita> mclaren: def want your help, too
14:41:16 <rosmaita> yes
14:41:22 <jokke_> thank rosmaita for takin the time to put it together
14:41:24 <flaper87> and it's a key part of Glance
14:41:27 * mclaren is chomping at the bit
14:41:56 <flaper87> And, of course, thanks rosmaita for taking the time to write this and leading the session.
14:42:04 * rosmaita blushes
14:42:07 <flaper87> you definitely will get whisky popcorn
14:42:11 <rosmaita> yay!
14:42:13 <jokke_> +s
14:42:32 <rosmaita> or a year's supply of exceptions
14:42:32 <flaper87> ok
14:42:43 <flaper87> rosmaita: you'll have to fight bunting for that
14:42:45 <bunting> rosmaita: thats my prise ;)
14:42:51 <flaper87> HA! see?
14:42:53 <flaper87> :D
14:43:00 <rosmaita> i imagine there's plenty to go around
14:43:20 <flaper87> ok, moving on
14:43:31 <flaper87> #topic Open Discussion
14:43:47 <flaper87> I think we'll have good attendance this year at the summit
14:43:50 <flaper87> that's awesome!
14:43:53 <flaper87> Lunch ?
14:44:02 <ativelkov> ++
14:44:02 <nikhil> I see that rosmaita proposed a cross-project topic here:
14:44:03 <flaper87> Or pop-corn party?
14:44:03 <nikhil> #link https://etherpad.openstack.org/p/mitaka-glance-summit-topics
14:44:12 <nikhil> is that approved yet rosmaita ?
14:44:21 <nikhil> line 83
14:44:38 <flaper87> cross-project discussion will happen next week
14:44:58 <nikhil> oh right, thanks
14:45:10 <ativelkov> I have a small topic
14:45:13 <flaper87> Monday 20:00 UTC we'll discuss topics, Tuesday at the TC meeting the votes
14:45:13 <nikhil> TC needs to be formed completely..
14:45:20 <flaper87> right
14:45:23 <flaper87> ativelkov: shoot
14:45:47 <flaper87> I heard bears are going hunting in Russia now
14:45:52 <flaper87> is that what you want to talk about?
14:45:55 <ativelkov> nope )
14:46:02 <flaper87> awwww :(
14:46:07 <ativelkov> Do you know Openstack:Now newletter?
14:46:15 <nikhil> I wonder if we should have that topic irrespective of what TC decides.. in Glance if nowhere else..
14:46:44 <flaper87> nikhil: oh, mmh, I thought that was implicit, tbh
14:46:51 <flaper87> ut it's good you brought it up
14:46:53 <nikhil> :)
14:46:58 <flaper87> I'd agree with that
14:47:08 <flaper87> we still have slots
14:47:28 <flaper87> Also, if there are free work sessions, I'd like us to use them to discuss the import workflow further
14:47:43 <flaper87> I've the feeling that fishbowl won't be enough
14:47:52 <flaper87> and a further face to face discussion would be useful
14:48:05 <nikhil> I see this page still have liberty etherpads
14:48:08 <nikhil> #link https://wiki.openstack.org/wiki/Design_Summit/Planning
14:48:12 <nikhil> has*
14:48:25 <flaper87> ativelkov: nope :/
14:48:32 <nikhil> flaper87: totally. +1 on more time..
14:48:58 <ativelkov> Next week there will be some kind of a "panel" discussion (online, google hangouts, I guess) about the "community app catalog". And the organizers are looking for particpants
14:49:00 <flaper87> nikhil: yup, it hasn't been updated yet. Some projects are still figuring the schedules out, I guess that's probably why
14:49:02 * flaper87 shrugs
14:49:08 <nikhil> I see
14:49:40 <nikhil> ativelkov: where's the signup list?
14:50:04 <ativelkov> There is no list, but they asked me to bring somebody from glance :)
14:50:05 <nikhil> I remember we wanting to have some discussion with them.
14:50:19 <flaper87> ativelkov: link?
14:50:22 <nikhil> I am willing to sign up.
14:50:32 <flaper87> if it's in a reasonable time, I might attend as well
14:50:56 <ativelkov> There is no link (yet), they dodn't announce the time, as they are trying to gree with the particpants
14:51:11 <flaper87> ativelkov: ok
14:51:23 <flaper87> let folks know in -glance when you have that info :D
14:51:35 <ativelkov> They are trying to invite the present and fromer Heat's PTLs - so, if flaper87 and nikhil can join, that would be awesome
14:51:49 <flaper87> ativelkov: I'm happy to
14:51:58 <flaper87> just need to make sure it's doable time-wise :D
14:52:01 <ativelkov> Also there will be somebody from Murano - and the PTL of the comunity app catalog, of course
14:52:07 <nikhil> ativelkov: I can def join. Please include me in the emails, lists, links :)
14:52:15 <ativelkov> sure
14:52:20 <flaper87> nikhil: you missed post-cards
14:52:22 <nikhil> ativelkov: someone from foundation?
14:52:30 <ativelkov> donno yet
14:52:32 <nikhil> flaper87: ha ! ye...a
14:52:44 <nikhil> I see
14:52:49 <ativelkov> It's mostly a PR initiave, they are trying to bring more attentioan to the app catalog
14:53:11 <ativelkov> But at the same time it may be a good chance to discuss the technical details
14:53:16 <nikhil> hmm, most likely another keynote prep :)
14:53:24 <nikhil> yes
14:54:01 <ativelkov> So, I'll send an email and give your contacts to organizers
14:54:43 <flaper87> awesome
14:54:45 <flaper87> thanks
14:54:49 <flaper87> anything else? Anyone?
14:54:58 <TravT> https://review.openstack.org/#/c/224991/
14:55:00 * nikhil ack
14:55:08 <flaper87> I'll figure out a day for our lunch in tokyo
14:55:28 <flaper87> we did a picnic in Vancouver, I don't think a picnic would be doable in Tokyo
14:55:30 <flaper87> :P
14:55:33 <flaper87> anyway
14:55:38 <mclaren> lucnh sounds cool
14:55:38 <flaper87> TravT: thanks
14:55:47 <jokke_> quick poll ... when people are arriving and leaving?
14:55:57 <flaper87> 25th-31st
14:56:13 <jokke_> I'll be in tokyo Sun evening or Mon morning and will have flight back at Sun morning 1st
14:56:14 <abhishekk> 25th-31st
14:56:22 <nikhil> TravT: most likely affects horizon directly?
14:56:38 <TravT> Yes, people were asking about it in the room over night
14:56:42 <TravT> hoping to get a review on it
14:57:09 <nikhil> sounds straightforward, I can take a quick peek
14:57:18 <TravT> cool, thx
14:57:20 <nikhil> jokke_: sun->sat
14:57:32 <ativelkov> 26th - 15th :)
14:57:32 <mfedosin> the same
14:57:44 <mfedosin> ativelkov, not with you =P
14:57:45 <nikhil> flaper87: you going out of japan in the meantime?
14:57:47 <jokke_> So Glance Drinks at Mon evening?
14:57:51 <flaper87> nope
14:58:02 <flaper87> but I'll be back in tokyo on the 25th
14:58:16 <nikhil> gotcha
14:58:39 <flaper87> nikhil: when are you getting in?
14:58:52 * nikhil was doing a timezone check
14:59:04 <nikhil> flaper87: sun evening
14:59:15 <flaper87> AWESOME!
14:59:15 <nikhil> 25th ie
14:59:27 <flaper87> okidoki
14:59:30 <flaper87> ran out of time!
14:59:34 <flaper87> thanks folks
14:59:37 <flaper87> #endmeeting