14:01:39 <flaper87> #startmeeting Glance
14:01:40 <openstack> Meeting started Thu Oct 15 14:01:39 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:42 <mfedosin> o/
14:01:44 <openstack> The meeting name has been set to 'glance'
14:01:44 <rosmaita> o/
14:01:47 <kairat> o/
14:01:49 <abhishekk> 0/
14:01:51 <flaper87> hey folks! welcome :)
14:01:53 <kragniz> o/
14:01:59 <nikhil> o/
14:02:18 <flaper87> awesome, we have quorum. I believe jokke_ is around too!
14:02:22 <flaper87> let's get started
14:02:27 <flaper87> #topic Agenda
14:02:30 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:44 <flaper87> as usual, our agenda is there and we have some interesting topics to discuss
14:02:59 <flaper87> #topic Artifacts updates
14:03:04 <flaper87> ativelkov: nikhil mfedosin
14:03:08 <flaper87> news?
14:03:09 <mfedosin> hi there!
14:03:20 <nikhil> hi
14:03:28 <mfedosin> Alex wrote a big message
14:03:39 <bunting> o/
14:03:43 <mfedosin> [openstack-dev] [app-catalog] [glance] [murano] Data Assets API for App Catalog
14:03:46 <sigmavirus24> o/
14:03:49 <flaper87> the email w.r.t the app catalog ?
14:03:50 <flaper87> ah yeah
14:03:57 <flaper87> planning to get to it tomorrow
14:04:25 <mfedosin> I haven't read it yet, but it's about next implementation of Glance v3 API
14:04:44 <flaper87> ok, I'll read it carefully and I'd like to encourage everyone to do that
14:04:52 <mfedosin> flaper87, we're waiting for your response on that matter
14:05:18 <flaper87> sure thing
14:05:22 <mfedosin> flaper87, everyone is welcome in the discussion :)
14:05:32 <mfedosin> thanks
14:05:49 <flaper87> I'd love to hear others opinions there. I think it's important
14:05:54 <flaper87> ok, moving on
14:06:00 <flaper87> #topic Drivers updates
14:06:10 <flaper87> We discussed a, hopefully, improvement for proposing small specs. These specs have been refered to as lite specs for a while and we didn't have a good way to manage them. In the hope of keeping the user's process simple, we've discussed using LP whislist bugs as lite specs and to implement a small process for it.
14:06:11 <flaper87> The discussion happened here:
14:06:14 <flaper87> #link http://eavesdrop.openstack.org/meetings/glance_drivers/2015/glance_drivers.2015-10-13-14.01.log.html
14:06:15 <flaper87> and I've started to document the process here:
14:06:17 <flaper87> #link https://review.openstack.org/#/c/234653/
14:06:19 <flaper87> The document needs some work and jokke_ has stated he doesn't like the idea at all, very clearly. (at least he did it in lowercase :P)
14:06:21 <flaper87> I'd like to encourage everyone to go through the logs and the proposal. It'd be great to get some further feedback on the process.
14:06:23 <flaper87> Personally, I believe this is worth a try and it's definitely something we can revert or move away from if it doesn't work out.
14:07:18 <flaper87> I think it'd be healthy to keep this discussion on that review but, if there are questions already, we can take some time now
14:07:52 <flaper87> The meeting logs are not very long and the docs could use more eyeballs
14:07:55 <flaper87> :)
14:08:18 <flaper87> concerns? Shall we move on to the next update ?
14:08:19 <flaper87> :D
14:08:24 <bunting> What will we do with the current bugs marked wishlist?
14:08:24 <nikhil> It doesn't hurt to try a beta
14:08:38 <flaper87> bunting: those will be triaged
14:08:42 <nikhil> meaning lets pick some potential lite-specs and see how people give feedback
14:08:54 <flaper87> yup, that's the goal
14:08:56 <abhishekk> ++
14:08:59 <nikhil> and then document the process 2-3 weeks after the summit
14:09:04 <flaper87> if it doesn't work, we can move to something else
14:09:23 <jokke_> o/
14:09:25 <nikhil> or mention in the doc that we are trying
14:09:32 <nikhil> I will comment
14:09:41 <flaper87> nikhil: ++
14:09:53 <flaper87> I did mention it's being introdued in Mitaka
14:09:57 <flaper87> introduced
14:10:03 <jokke_> I think it's gonna be really messy
14:10:22 <jokke_> but my comments are mainly on that doc change
14:10:50 <flaper87> ok
14:10:52 <flaper87> lets move on
14:10:56 <flaper87> #topic release updates
14:11:00 <flaper87> jokke_: floor is yours
14:11:19 <jokke_> So Glance got nice and shiny "11.0.0" Liberty tag just 35min ago
14:11:35 <rosmaita> yay
14:11:36 <flaper87> w00000h00000
14:11:41 <jokke_> Thanks everyone and big hand to nikhil for being on the wheel
14:12:06 <jokke_> also stable/kilo point release was tagged earlier this week
14:12:15 <flaper87> w000h000000
14:12:35 <flaper87> speaking about stable: glanceclient stable/juno gate works now
14:12:37 <jokke_> thanks for the help keeping our stable together as well for all the bugfixes and backporters!
14:12:45 <jokke_> flaper87: gr8!!!
14:12:55 <nikhil> flaper87: yeah, there were some inconsistencies in stable/juno for client
14:13:17 <nikhil> and the project mark for py3 support was partial so, mostly incorrect
14:13:23 <flaper87> back to green now, which is good now that juno will soon reach EOL
14:13:49 * flaper87 hates EOL'ing versions that don't have a working gate
14:13:57 <jokke_> yeah ... I'll try to have a look if there is something critical we should backport for that before closure
14:14:05 <nikhil> anyone are you aware of the deprecation dates for juno?
14:14:22 <flaper87> it's likely going to be decided at the summit
14:14:23 <nikhil> yeah, I don't remember the official deprecation dates
14:14:28 <nikhil> I see
14:14:30 <jokke_> nikhil: Iirc in 3months time or so ... the support for Juno was promised 15months
14:14:48 <flaper87> yeah, but there have been changes (or at least there were in YVR)
14:14:50 <nikhil> gotcha, thanks jokke_. but that's still a few months down ..
14:15:10 <jokke_> yeah we've had hope to keep bit overlap
14:15:10 <flaper87> there's an email thread about this, I should look it up
14:15:29 <jokke_> that's it from release front
14:15:32 <flaper87> ok, moving on if there's nothing else on this topic
14:15:34 <flaper87> good
14:15:42 <flaper87> #topic cross-project liaisons
14:15:49 <flaper87> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
14:16:00 <flaper87> There are a couple of things here:
14:16:26 <flaper87> 1) We need to update that wiki page, namely, we need volunteers for the several liaison roles.
14:16:42 <flaper87> I'll be pinging folks that are listed there to make sure they still have time for it
14:16:42 <mfedosin> I can be Glance<->Documentation liason, btw :)
14:17:03 <flaper87> BUT!if you want to volunteer for something, please, let me know. Even if there's someone listed there
14:17:06 <flaper87> mfedosin: awesome
14:17:07 <mfedosin> since I work with Olena
14:17:19 <flaper87> #info mfedosin wants to volunteer for the glance->docs liaison role
14:17:23 <jokke_> I'm happy to keep the Stable
14:17:24 <rosmaita> i think i already am cross-doc liason
14:17:26 <mclaren> I'll volunteer for security
14:17:43 <flaper87> w000h0000
14:17:47 <flaper87> many volunteers
14:17:54 <flaper87> keep it coming
14:17:57 <flaper87> we need one more
14:18:01 <nikhil> security for me too if there's room
14:18:21 <mfedosin> rosmaita, ah, okay. you are already there
14:18:29 <nikhil> nova<->glance needs update and I think flaper87 is the the POC ?
14:18:35 <flaper87> we need someone that can help attending the cross-project meetings that may/may not disappear in the future
14:18:37 <rosmaita> mfedosin: let's talk at the summit
14:18:45 <flaper87> nikhil: yeah
14:18:49 <nikhil> flaper87: I was gunna suggest that
14:19:15 <flaper87> I would attend those but they happen in a really bad time for me and I'd love to have some help there
14:19:18 <nikhil> planning to help with CPL meetings in Mitaka.
14:19:27 <flaper87> I know nikhil has attended some and <3 for that
14:19:30 <jokke_> flaper87: I can also share the workload on the release front if needed. Have been doing it (maybe too much) already ;)
14:19:35 <mfedosin> rosmaita, sure! frankly speaking I don't want to get another responsibility :)
14:19:46 <flaper87> jokke_: sweet, would love to work with you on that
14:20:20 <flaper87> nikhil: mind if to take the CPL meetings one instead of security (or with security)
14:20:21 <flaper87> :D
14:20:24 <nikhil> I can do infra+qa if there's no spot on secuity
14:20:44 <nikhil> flaper87: sure, I figured. the second one should be PTL
14:21:09 <nikhil> trying to find a big difference between infra and qa atm
14:21:50 <nikhil> flaper87: so, what's the difference between CPL and inter project liaisons?
14:22:04 <flaper87> nikhil: you mean the CPL should be just for PTLs? I guess that's how it was presented but it's really hard for me to attend. I've participated in some but can't do them all
14:22:08 <nikhil> flaper87: is that just CPL meetings liaisons
14:22:09 <nikhil> ?
14:22:16 <flaper87> nikhil: yeah
14:22:22 <jokke_> Anyone knows who Nate Ziemann is? :P
14:22:28 <nikhil> I do
14:22:30 <nikhil> work with me
14:22:31 <flaper87> we'll clarify a lot during the summit
14:22:41 <flaper87> since there'll be a session on this
14:22:53 <jokke_> Seems to be our Product Working Group liaison, but never heard of him ... just wondering if he has put his name on wrong line
14:22:56 <flaper87> Ok, thanks everyone for volunteering, I'll add you to the wiki if you're not there already
14:22:59 <nikhil> flaper87: I don't mind attending CPL meetings as I do that for awareness anyways..
14:23:11 <flaper87> we need to move on, many other topics to go through
14:23:28 <flaper87> nikhil: ++ lets talk offline
14:23:30 <flaper87> thanks, btw!
14:23:34 <nikhil> jokke_: he's prod mgr at IBM and active at the group there. I've had a chat with him in Liberty. He put his name them I sup..
14:23:42 <flaper87> #topic Trusts in glance (mfedosin, kairat) https://review.openstack.org/#/c/233601/2
14:23:58 <mfedosin> hey!
14:24:22 <mfedosin> just wanted to inform you that we started trusts implementation in Glance
14:24:45 <kairat> I would call it PoC at this stage)
14:25:07 <mfedosin> here's the basic code https://review.openstack.org/#/c/233601/
14:25:10 <flaper87> that's awesome
14:25:16 <jokke_> ++
14:25:18 <flaper87> #link Trusts in glance (mfedosin, kairat) https://review.openstack.org/#/c/233601/2
14:25:21 <flaper87> ops
14:25:23 <flaper87> #undo
14:25:24 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x9fe70d0>
14:25:27 <flaper87> #link https://review.openstack.org/#/c/233601/
14:25:43 <mfedosin> and we're going to insert it in appropriate places in glance
14:26:03 <nikhil> do we have a spec for this?
14:26:07 <flaper87> mfedosin: do you have an ETA?
14:26:08 <mfedosin> exactly in image uploading v1 and v2
14:26:10 <flaper87> nikhil: there's one
14:26:18 <mfedosin> nikhil yes
14:26:19 <nikhil> I am trying to get a sense of what the scope is
14:26:19 <kairat> flaper87, need to be updated
14:26:35 <kairat> flaper87, I am going to update it tommorow
14:26:42 <jokke_> #link https://review.openstack.org/#/c/229878/
14:26:45 <nikhil> got it, thanks!
14:26:46 <jokke_> ^^ the spec
14:26:49 <nikhil> :)
14:26:50 <mfedosin> kairat, yes please :)
14:27:06 <mfedosin> the problem was - how to pass trust into glance_store
14:27:13 <flaper87> please, keep the spec updated as we're in the process of digging into those
14:27:29 <mfedosin> because there is no keystoneclient dependency there
14:27:36 <mclaren> mfedosin: looking forward to chatting about this at the summit
14:27:46 <flaper87> would it be worth it having a session on this?
14:27:49 <flaper87> there are free slots
14:27:54 <jokke_> there is session proposed
14:27:57 <flaper87> where?
14:28:00 <flaper87> did I miss it?
14:28:02 <jokke_> on the etherpad
14:28:13 <mfedosin> but today after a discussion with Flavio we decided to add it as optional dependency to Swift backend
14:28:21 <nikhil> flaper87: late addition
14:28:21 <jokke_> deep blue just above x-proj
14:28:21 <flaper87> was that recently added?
14:28:22 <mfedosin> flaper87, I added it
14:28:25 <flaper87> ahhh
14:28:31 <flaper87> ok, I'm not crazy then
14:28:38 <flaper87> I mean...
14:28:40 <mfedosin> yesterday, I suppose
14:28:43 <flaper87> I am... but yeah
14:29:03 <flaper87> mfedosin: sounds great, I'll add it to the schedule
14:29:14 <mfedosin> without trust we can't use multitenant swift driver
14:29:30 <mfedosin> because it's unsecure
14:29:41 <mfedosin> (see my latest cve)
14:29:43 <flaper87> awesome!
14:29:47 <nikhil> mfedosin: are you planning to add that as an optional way to authN?
14:29:51 <mfedosin> so we should implement them asap I think
14:29:56 <flaper87> mclaren: it'd be great to get your review on the spec for this work
14:30:28 <mclaren> yup, I'm on it
14:30:34 <flaper87> mclaren: awesome, thank you
14:30:42 <flaper87> mfedosin: anything else?
14:30:48 <nikhil> because, with swift we still don't have a way upstream for operators to move away from bad old locations and prevent them from keeping swift auth v1.
14:30:52 <mfedosin> nikhil, I'm not sure right now, but yeah - we can reathenticate with trust to get new token
14:31:15 <nikhil> ok, let's discuss this on spec.
14:31:18 <nikhil> thanks.
14:31:19 <mfedosin> we can discuss it on the summit
14:31:24 <flaper87> ++ on spec
14:31:37 <flaper87> moving on
14:31:40 <flaper87> #topic Approach for location management policies (kairat)  https://review.openstack.org/#/c/233687/
14:31:42 <mfedosin> if you interested than put your name in the etherpad
14:32:22 <kairat> So I created a spec that changes the policy approach for get_image_location
14:32:38 <kairat> Now i see that light-spec should be different (will change it soon)
14:33:06 <flaper87> kairat: if you wrote the spec already, don't change it
14:33:07 <kairat> The change proposes just exclude location info from server response when policy doesn't allow it
14:33:12 <flaper87> it's there, we can review that
14:33:12 <kairat> flaper87, ok
14:33:30 <kairat> I would like to have some feedback on it
14:33:47 <nikhil> kairat: hmm, are we not using show direct url config option?
14:34:08 <kairat> Previously(in v2), we prohibited image-show, image-list of policy doesn't allow us
14:34:27 <kairat> nikhil, when it is true then policy should manage this
14:34:31 <kairat> IMO
14:34:33 <jokke_> yes we have config option for that and we support the policy limitations for to whom it's exposed
14:34:54 <flaper87> mmh, if we're adding policies, I wonder if we still need the config_option
14:34:56 <kairat> Additionally, i found a bug https://review.openstack.org/#/c/233687/
14:34:58 <flaper87> I'll comment on the spec
14:34:59 <mclaren> show direct url is off by default I think
14:35:05 <jokke_> mclaren: was just battling around this quite a bit so might be able to give bit more light there
14:35:11 <nikhil> may be we need it for v1 flaper87
14:35:18 <mclaren> (If I'm thinking of the right thing)
14:35:28 <mclaren> I can try
14:35:32 <flaper87> nikhil: oh, good point. I'll have to check
14:35:40 <mclaren> by default show multiple locations is off
14:36:04 <kairat> but when it is true then get_image_location is useless right now
14:36:06 <mclaren> if you switch it on and then restrict the get_locations policy then lots of things don't work properly
14:36:14 <kairat> because image-show image-list is also forbidden
14:36:23 <kairat> mclaren, +1
14:36:24 <mclaren> It's bad, but hopefully a corner case
14:36:29 <flaper87> mclaren: ++
14:36:33 <jokke_> there is bug open for that
14:36:43 <mclaren> you have to switch on two incompatible non-default things
14:36:57 <nikhil> yes
14:37:17 <nikhil> hopefully policies would be able to handle v1 too
14:37:18 <kairat> Also I noticed that we cannot add/delete location is show_multiple is off
14:37:21 <nikhil> then we can deprecate it
14:37:27 <flaper87> nikhil: that's my hope
14:37:34 <mclaren> and showing image locations is very brave IMHO :-)
14:37:45 <bunting> ++
14:37:46 <flaper87> deprecating the option would be ideal so we can just use policies
14:37:49 <nikhil> well people want to do that mclaren
14:37:55 <nikhil> like ironic
14:38:10 <flaper87> not everyone runs a public cloud
14:38:19 * nikhil nods
14:38:21 <jokke_> and I'm a lot against feature adds on v1 ... if it hasn't been needed so far, we probably won't need it at the corner of deprecation either
14:38:25 <mfedosin> mclaren, do you mean showing direct urls?
14:38:41 <mclaren> showing the location string
14:38:52 <kairat> mfedosin, and this also, I heard Ceph also need this
14:39:01 <nikhil> 'locations' is terrible
14:39:02 <kairat> *this=location_utl
14:39:08 <mclaren> yeah, cinder probably do stoo
14:39:13 <nikhil> it can be a confusion hell
14:39:14 <mclaren> too
14:39:23 <flaper87> ok, we need to move on. Sorry for limiting the time on the topic
14:39:29 <flaper87> lets follow-up on the spec
14:39:33 <kairat> ok
14:39:39 <nikhil> it should be a complete spec
14:39:42 <nikhil> not a lite one
14:39:45 <flaper87> kairat: thanks for the heads up and for putting the spec together
14:39:48 <flaper87> nikhil: agreed
14:39:49 <nikhil> but thanks kairat for already proposing a review
14:39:58 <flaper87> #topic Skip next week's meeting (flaper87)
14:40:07 <flaper87> I'd like to propose skipping next week's meeting
14:40:08 <nikhil> #vote yes
14:40:12 <flaper87> :P
14:40:15 <nikhil> :P
14:40:18 <kairat> )
14:40:28 <jokke_> I don't mind if the plane has wifi :P
14:40:40 <flaper87> unless someone screams in 3 ... 2... 1... I'll agree this
14:40:44 <rosmaita> #vote yes
14:40:45 <jokke_> an hour of travel time burned some way ;)
14:40:48 <flaper87> :P
14:40:56 <mclaren> #vote yes
14:41:03 <flaper87> just pay for the full wifi plan and you're good
14:41:18 <flaper87> #agreed Skip next week's meeting October 22nd
14:41:18 <jokke_> flaper87: _if_ it exists
14:41:37 <mfedosin> I don't care, but skipping something is always a pleasure
14:41:38 <flaper87> jokke_: man, don't get me started on airplane wifis
14:41:40 <flaper87> :D
14:41:45 <jokke_> :D
14:41:59 <flaper87> moving on
14:42:03 <flaper87> #topic Summit agenda (flaper87) http://mitakadesignsummit.sched.org/overview/type/glance
14:42:10 <flaper87> well, that's the agenda!
14:42:13 <jokke_> 19min and a lot in the agenda still
14:42:17 <flaper87> I'll add trusts to it
14:42:31 <flaper87> I created a schedule for the summit based on the topics that were added in the proposals etherpad:
14:42:32 <flaper87> #link https://etherpad.openstack.org/p/mitaka-glance-summit-topics
14:42:34 <flaper87> At the top of that etherpad, I added the agenda for the summit and, as you probably noticed already, we have 2 free slots. jokke_ mentioned that we could take some time to do a heads up on DefCore in one of our working sessions. I think it'd be useful for the team but I'd also like to encourage everyone to join the cross-project session on this topic:
14:42:36 <flaper87> #link http://mitakadesignsummit.sched.org/event/402c14d0efed29d1abd21b51f6785762
14:42:38 <flaper87> Anyhow, the link to our schedule is:
14:42:40 <flaper87> #link http://mitakadesignsummit.sched.org/type/glance#.Vh-J4s-1RZI
14:42:42 <flaper87> If you have another proposal OR if you have some conflicts in the current schedule, please, let me know and I'll do my best to make you happy.
14:42:50 <flaper87> we now have just 1 free slot (trusts took one)
14:42:50 <mclaren> Are we looking for topics to fill some of the free slots?
14:43:12 <flaper87> The free slot could be used to talk about defcore, interop and glance
14:43:18 <mclaren> I'm not sure, but we could potentially talk about image formats?
14:43:32 <flaper87> if there are other proposals we could use that time for it
14:43:33 <nikhil> flaper87: are you planning to add tags for other projects to some of the topics?
14:43:41 <mfedosin> or can discuss artifacts twice
14:43:45 <flaper87> nikhil: yes
14:43:51 <nikhil> cool
14:43:51 <jokke_> flaper87: mind to update the etherpad what you have put on the working sessions
14:44:10 <jokke_> or was it only the first one that had no details
14:44:11 <flaper87> the schedule is still a draft since I wanted to know if there were conflicts
14:44:22 <flaper87> jokke_: probably just the first one
14:44:23 <jokke_> it was ... sorry, my bad
14:44:26 <flaper87> the etherpad should be updated
14:44:28 <flaper87> :D
14:44:36 <flaper87> or, almost updated
14:44:57 <flaper87> again, session leaders, check your calendars and make sure there are no conflicts
14:45:06 <flaper87> I'll send an email out to the ML
14:45:16 <flaper87> but I thought about sharing it here as well
14:45:22 <flaper87> thanks to all the session leaders
14:45:26 <flaper87> we <3 y'all
14:45:34 <flaper87> at least I do :)
14:45:35 <rosmaita> flaper87: the two late sessions on thursday conflict with searchlight
14:46:08 <rosmaita> so maybe schedule stuff for people who don't care about searchlight at those times?
14:46:28 <flaper87> rosmaita: yeah, that's unfortunate. Everything conflicts this summit
14:46:43 <rosmaita> i know, that's the way it goes
14:47:12 <jokke_> priorities ... everyone should know how to prioritize glance ;P
14:47:19 <nikhil> :P
14:47:22 <flaper87> rosmaita: I'll see what can be done but I kinda think those two should be there because the image import should go after the fishbowl session
14:47:34 <rosmaita> don't worry
14:47:37 <flaper87> and we can't finilize the priorities before we talk about these sessions and other topics
14:47:45 <flaper87> I'll take another look there
14:47:58 <rosmaita> i only want to go to the very last searchlight session at 5:20
14:48:01 <nikhil> think like a traveling salesman
14:48:21 <rosmaita> so i will be at the image import follow up
14:48:29 <flaper87> mfedosin: next topic is yours but I'd like to give time to rosmaita's topic if you don't mind
14:48:42 <flaper87> we can talk about yours if there's more time at the end
14:48:52 <mfedosin> oh, okay then
14:48:57 <flaper87> mfedosin: thanks
14:48:57 <rosmaita> mine is real quick
14:49:00 <flaper87> #topic image import spec: https://review.openstack.org/#/c/232371/ (rosmaita) -
14:49:03 <flaper87> rosmaita: shoot
14:49:13 <rosmaita> i'm thinking of doing a quick revision to handle the smaller points that have come up and put in some "note" for the topics that still require discussion, but a new patch set hides the inline comments ... any advice?
14:49:34 <rosmaita> probably aimed mostly at people who have added comments already
14:49:53 <rosmaita> there are also a lot in the regular comments section, so those won't be hidden
14:49:53 <flaper87> mmh, if the new PS is a must then do it, we can always go bac in history
14:49:55 <nikhil> works for me, I still have them pending in draft :P
14:50:00 <flaper87> not in time, which is unfortunate
14:50:04 <jokke_> rosmaita: go for it ... the comments will show up on the previous PS anyways ... make a note that people should read them before commenting the new version (as it won't be last anyways)
14:50:28 <flaper87> what normally happens is that people keep discussing in older PS until the discussion is over
14:50:38 <nikhil> I don't mind porting the comments as the new PS seems vital
14:50:42 <flaper87> which it never is but I digress
14:50:47 <rosmaita> ok, sounds like new PS is OK then
14:50:53 <mclaren> rosmaita: I think we'll probably need a couple more revisions anyway
14:50:55 <flaper87> rosmaita: go go go go!
14:51:07 <rosmaita> i'll work onthat righrt away and then we can send out to the ML for more comments
14:51:19 <mclaren> cool
14:51:25 <flaper87> rosmaita: awesome, looking forward to that
14:51:25 <jokke_> rosmaita: I think it's better to get the annoyances away so folks can focus on the bikeshedding :P
14:51:32 <rosmaita> jokke_: ++
14:51:44 <flaper87> jokke_: bike what? there's no such thing
14:51:55 <flaper87> jokke_: although, I'd rather call it something else
14:52:00 <jokke_> flaper87: I can introduce :P
14:52:15 <flaper87> I mean, bikeshedding is not descriptive enough
14:52:17 <flaper87> :P
14:52:31 <flaper87> ok
14:52:32 * jokke_ puts the Internet Troll hat on before reviewing
14:52:35 <flaper87> #topic Schema validation for 'image-list' in glanceclient (mfedosin)
14:52:51 <flaper87> mfedosin: 5 mins so we can have open discussion (sorry for the timebox)
14:52:53 <mfedosin> I've got one question
14:53:10 <mfedosin> some time ago we removed schema validation from image-list
14:53:15 <mfedosin> https://review.openstack.org/#/c/211086/
14:53:25 <flaper87> #link https://review.openstack.org/#/c/211086/
14:53:38 <mfedosin> do we need it back as an optional feature?
14:53:49 <jokke_> can we just work towards removing fully validating the server responses?
14:53:59 <kairat> jokke_, ++
14:54:01 <flaper87> jokke_: ++
14:54:04 <nikhil> it should be either there or not, I don't see the value for it to be optional
14:54:06 <kairat> but it changes our client
14:54:15 <flaper87> that was my recommendation as well
14:54:33 <flaper87> we shouldn't have it there. If there's a good use-case for it I'm all ears
14:54:43 <jokke_> we can do gating tests that validates the server responses against schema, but we don't need to gate it on every client run
14:54:51 <nikhil> so, scrolling back some history pages
14:54:59 <mclaren> the only thing I could think of was admin use, but I'm not sure how strong a case that is
14:55:01 <mfedosin> but what about just 'get' a single image?
14:55:06 <mfedosin> do we need it here?
14:55:16 <nikhil> it was introduced so that people can know that the image records they are getting back are consistent with what the clouds says they should be
14:55:37 <flaper87> mfedosin: I'd say no
14:55:41 <nikhil> and for cases when changes happen to images, they can be picked rather quickly
14:56:22 <nikhil> if the image-meta remains in such a fluid state and constrained by policy, then the user can't know what to expect at a given point of time
14:56:26 <mfedosin> so, the final decision - we don't introduce optional feature for that :)
14:56:42 <nikhil> as the time bound expectation is rather dagenrous
14:56:43 <mfedosin> am I right?
14:57:09 <jokke_> mfedosin: I'm happy to review any such proposals :P
14:57:10 <nikhil> SO, I think it
14:57:14 <nikhil> it is important
14:57:26 <mclaren> nikhil: as an option or always on?
14:57:35 <nikhil> always on
14:57:38 <nikhil> mclaren: but
14:57:41 <kairat> nikhil, but we have cases when validation can fail
14:57:50 <kairat> for example you changes list of supported images
14:57:59 <jokke_> well we have had so far nothing but problems from it
14:58:01 <kairat> and one of formats were deleted
14:58:04 <mclaren> nikhil: not practical -- v1 can create images which don't comply with v2 validation
14:58:23 <nikhil> I'd love to hear examples
14:58:27 <nikhil> mclaren: ^
14:58:34 <mclaren> check the client bugs :-)
14:58:40 <jokke_> as said I'd be pro gating schema validations but it does not belong to our client
14:58:44 <flaper87> there have been cases, fwiw
14:58:49 <mfedosin> https://bugs.launchpad.net/python-glanceclient/+bug/1477910
14:58:49 <openstack> Launchpad bug 1477910 in python-glanceclient kilo "A user can prevent another user listing images via v2 (in certain cases)" [High,Fix committed] - Assigned to Stuart McLaren (stuart-mclaren)
14:58:54 <kairat> also we can't location when show_multiple_locations is false because of this
14:59:04 <kairat> *can't add/delete
14:59:21 <kairat> It just fails on client but server works correctly
14:59:24 <mclaren> there have been about 5 or 6 bugs I'm aware of with validation the cause
14:59:25 <flaper87> that said, I think we need to think this through. For example, I don't think v2 should return images that are not v2 compliant
14:59:39 <jokke_> nikhil: good example was the schema change that warranted RC2 (I think)
14:59:41 <flaper87> even if the image was created using v1
14:59:43 <nikhil> flaper87: agreed
14:59:56 <mclaren> ?
14:59:56 <jokke_> just a bug that blew our client without real reason
15:00:02 <nikhil> and we would have never caught it if not for validation jokke_ :)
15:00:06 <nikhil> it's a catch 22
15:00:22 <flaper87> ok folks, we're almost out of time
15:00:23 <rosmaita> i agree with jokke_ that the place to verify compliance is the gate
15:00:25 <nikhil> mclaren: flaper87: how about opening a new official tag that lists such cases and we can discuss on those bugs there?
15:00:28 <jokke_> nikhil: that's why I'm proposing gating those schemas, not blowing our client on them
15:00:31 <mclaren> from a users point of view if the image is usable via v1 then v2 is broken if they can't use the same image
15:00:52 <flaper87> I'd like this discussion to move forward a bit more before creating a new tag
15:00:57 <mclaren> nikhil: there was a mail on the mailing list from Jay Pipes recommending it gets switched off (fwiw)
15:00:58 <nikhil> may be it should be a post-list process on client
15:01:01 <flaper87> There's a bug for client validation, lets talk there
15:01:09 <flaper87> or just create a new thread on the mailing list
15:01:22 <mfedosin> flaper87, I'll write a message there
15:01:28 <mfedosin> in mailing list
15:01:31 <rosmaita> or discuss at next week's meeting :)
15:01:37 <nikhil> mclaren: I will look it up . thanks for the pointer.
15:01:40 <flaper87> mfedosin: thanks
15:01:42 <flaper87> LOL
15:01:45 <flaper87> ok, time's up!
15:01:45 <mfedosin> rosmaita, which is skipped
15:01:47 <flaper87> thanks everyone
15:01:53 <flaper87> #endmeeting