13:59:43 <flaper87> #startmeeting Glance
13:59:44 <openstack> Meeting started Thu Dec  3 13:59:43 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:48 <openstack> The meeting name has been set to 'glance'
13:59:55 <flaper87> #topic Roll Call
13:59:57 <ativelkov> o/
13:59:59 <dshakhray> o/
13:59:59 <kragniz> o/
14:00:07 <bpoulos> o/
14:00:31 <ativelkov> mfedosin will be here in a minute
14:00:31 * flaper87 has a quite flaky internet connection... expect some lags
14:00:38 <flaper87> ativelkov: thanks
14:00:40 <kairat> o/
14:00:49 <sabari> o/
14:00:51 <mfedosin> o/
14:00:55 <flaper87> sabari: O.O
14:01:01 <flaper87> sabari: glad to have you here
14:01:02 <nikhil> o/
14:01:04 <flaper87> :D
14:01:06 <avarner_> o/
14:01:09 * flaper87 hands a cup of coffee to sabari
14:01:18 <flaper87> #topic Agenda
14:01:21 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:25 <sabari> flaper87 The jetlag helped a bit :D
14:01:26 <flaper87> That's our agenda for today
14:01:31 <dhellmann> o/
14:01:46 <rosmaita_> o/
14:01:47 <flaper87> as usual, feel free to put stuff in there if you would like to talk about them
14:02:18 <flaper87> One thing w.r.t the agenda, now that we're talking about it. If you need to raise awareness on a specific spec, you should feel free to add it to the drivers agenda
14:02:36 <flaper87> It's fine and perfect to discuss it here if you need a broader community to chime in
14:02:52 <flaper87> but, if it's just to raise awareness and ask for review, remember we meet on Tuesdays to talk about that
14:03:00 <kairat> flaper87, ok, got it
14:03:05 <flaper87> you're not required to attend the meeting, we'll review the spec even if you're not there
14:03:08 <flaper87> :)
14:03:16 <flaper87> #link https://etherpad.openstack.org/p/glance-drivers-meeting-agenda
14:03:26 <flaper87> that's the link to the driver's agenda
14:03:30 <nikhil> you're spoiling the cats
14:03:30 <flaper87> coolio, moving on
14:03:38 <flaper87> :D
14:03:41 <flaper87> #topic Updates
14:03:52 <flaper87> Artifacts:
14:03:55 <flaper87> ativelkov: mfedosin ?
14:04:09 <nikhil> we met for a mins
14:04:13 <nikhil> the bot wasn't there
14:04:20 <nikhil> had a convo for about 20 mins
14:04:26 <flaper87> nikhil: :(
14:04:32 <nikhil> the gist of it is that we are waiting for the spec
14:04:42 <ativelkov> I am back to active work (sorry, took so long, but finally got the approve). We plan to have a Glance v3->Glarev0.1 spec to be ready by the next drivers meeting
14:04:45 <flaper87> to be written or reviewed ?
14:04:45 <nikhil> and some hint of thinking from ativelkov
14:04:58 <flaper87> ativelkov: awesome
14:05:05 <ativelkov> And so will the refactored API spec, hopefully
14:05:06 <nikhil> written, but I will let ativelkov chat
14:05:10 <flaper87> That sounds great!
14:05:35 * flaper87 is looking forward to that spec
14:05:46 <mfedosin> and as I promised I will prepare a spec about moving v3 to standalone service
14:05:50 <ativelkov> to be written, yes. We've also got some commitment from mfedosin and dshakhray to do the actual migration of code
14:06:14 <flaper87> nice, sweet!
14:06:21 <flaper87> Thanks folks
14:06:24 <nikhil> ativelkov: so to clarify, we are porting and not delete then write again ?
14:06:40 <ativelkov> for now - porting, yes
14:06:41 <flaper87> I think I -2'd the deletion patch
14:06:47 <flaper87> as I think porting is the way to go
14:06:49 <flaper87> cool
14:06:54 <nikhil> thanks, deletion sounds risky
14:06:56 <ativelkov> Just moving the current v3 to glare v0.1
14:07:00 <flaper87> ok, drivers updates
14:07:04 <kairat> I abandoned this patch
14:07:06 <nikhil> experimental prolly doesn't give us that contract right
14:07:22 <nikhil> thanks
14:07:29 <flaper87> Notm uch from our side. There have been more discussions on the new image import process and an attempt to simplify it
14:07:48 <flaper87> A new PS will be proposed and I hope we'll reach an agreement before the next drivers meeting
14:08:07 <flaper87> NExt week we'll start making decisions based on what we have because we need to move that forward
14:08:08 <nikhil> I have solid feedback and 2-3 use cases that will help shape it well
14:08:19 <flaper87> other than that, the db purge spec landed
14:08:26 <flaper87> and more reviews to the rest of the specs are coming
14:08:27 <nikhil> I have already communicated that to Brian and writing it down in a formatted manner
14:08:36 <flaper87> nikhil: awesome :D
14:08:39 <flaper87> thanks
14:08:42 <flaper87> rosmaita: ^
14:08:47 <flaper87> moving on
14:08:54 <flaper87> Updates on the Nova v1 -> V2 work
14:09:07 <mfedosin> I have good news
14:09:09 <flaper87> One of the feedbacks I got was that we hadn't provided news on what's going on there
14:09:18 <flaper87> Which is true
14:09:22 <flaper87> so, here's some feedback
14:09:26 <flaper87> actually, mfedosin you go for it
14:09:41 <mfedosin> currently we're able to do listing with v2
14:09:52 <flaper87> w0000h0000000
14:09:53 <mclaren> nice!
14:10:01 <mfedosin> changes-since works perfect with new filters
14:10:01 <mclaren> ship it!
14:10:08 <rosmaita> great!
14:10:09 <flaper87> some patches have been merged already
14:10:14 <flaper87> nnnnice
14:10:14 <flaper87> nice nice nice
14:10:18 <mfedosin> and all tempest tests pass
14:10:20 <sabari> awesome!
14:10:26 <flaper87> well done!
14:10:37 <mfedosin> delete and download work as well
14:10:41 <ativelkov> cool!
14:10:47 <flaper87> The nova core team is falling behind with some reviews on this work but I'm working with them to make sure there's nothing blocking reviews
14:10:59 <mfedosin> I need to concentrate and finish with 'update' today
14:11:06 <flaper87> There's a series of patches up for review: https://review.openstack.org/#/c/231696/
14:11:26 <flaper87> That is, things have been implemented and we mostly need to land them
14:11:46 <flaper87> mfedosin: thanks for the updates
14:11:53 <flaper87> #topic Cross project: backwards compat for libraries and clients (nikhil)
14:11:54 <mfedosin> welcome :)
14:11:55 <flaper87> nikhil: floor is yours
14:11:57 <nikhil> mfedosin et.al : excellent work
14:12:12 <nikhil> on the x-prj topic
14:12:30 <nikhil> now that we will be (semi-)enforced to implement this
14:12:44 <nikhil> (I will let the spec talk the details)
14:12:58 <nikhil> what do we all think about glance-store api refactor?
14:13:01 <flaper87> #link https://review.openstack.org/#/c/226157
14:13:16 <nikhil> I am not sure how feasible it is to keep that 100% back-compat!?
14:13:30 <nikhil> thanks flaper87
14:13:49 <nikhil> or do we mark this lib as an exception
14:13:59 <flaper87> I still think we should do it. The whole point about this refactor was not to delete everything and re-implement. The idea is to write the new API alongside the old one
14:14:11 <flaper87> so that it'll give time to consumers of the library to migrate
14:14:26 <flaper87> I think our current API is pure crap (pardon my language)
14:14:30 <nikhil> yeah, but then we need to maintain 2 APIs
14:14:37 <flaper87> and it was thought for internal use in Glance
14:14:44 <flaper87> nikhil: sure but we'll deprecate the old one
14:14:53 <flaper87> it's just to give time to projects to move to the new one
14:15:04 <flaper87> In openstack, glance is the only one using it for now
14:15:06 <flaper87> which makes it easier
14:15:08 <nikhil> so you are saying that store would need an exception
14:15:30 <flaper87> I don't think that spec says we can't deprecate stuff
14:15:43 <flaper87> What it says is that we *have* to commit to deprecate stuff
14:16:18 <mclaren> is this a priority for mitaka?
14:16:18 <flaper87> The plan with that refactor has always been to deprecate the old API and give time to migrate
14:16:27 <flaper87> it is not
14:16:39 <flaper87> but I believe nikhil is referring to the spec
14:16:46 <flaper87> which needs lots of work
14:16:58 <flaper87> I think it'll take a couple of months for that spec to be ready
14:17:07 <flaper87> which means it'll fall into the N cycle
14:17:20 <nikhil> flaper87: the back compat one or the refactor one?
14:17:43 <flaper87> nikhil: the refactor one
14:17:52 <nikhil> ok
14:18:13 <nikhil> but even with back compat one it's a painfully and hard to commit process
14:18:35 <nikhil> for instance supporting 2 APIs for 4 cycles is literally saying that you never get rid of it
14:18:45 <nikhil> the amount of catch up needed is humoungous
14:18:50 <flaper87> We can refactor the refactor spec and do a more progressive work towards something saner
14:19:50 <nikhil> even progressive work
14:19:54 <flaper87> I hate to assume stuff but here I go: I'd assume that many issues since migrating glance to the new glance_store API is most of the work
14:20:09 <nikhil> doesn't guarantee less catch required
14:20:23 <flaper87> True but at least it makes it more manageable
14:20:36 <flaper87> nikhil: may I ask what your suggestion is?
14:20:43 <nikhil> sure the API is, but not the x-prj enforcement
14:20:56 <nikhil> I think we have 3 choices:
14:21:08 <nikhil> 1. let things be as is and progress with x-prj requirements
14:21:43 <nikhil> 2. add exception to x-rpj list of libraries that do not warrant a API back compat contract, so that we can port it in a cycle or max 2
14:22:30 <nikhil> 3. put back store in glance or mark it as private library (or one w/o API guidelines) (we can refactor the API if it remains married to glance)
14:22:40 <kragniz> I personally think we either need a new api, or to move it back into the glance tree
14:22:56 <flaper87> so, to me, #3 is out of discussion
14:23:00 <kragniz> currently the library is a real pain to use
14:23:10 <flaper87> As of now, I'd go with #2 and add the exception
14:23:36 <sabari> do we need an exception for glance_store ? The spec seems to say we need to adhere to semver and can make breaking changes, right ?
14:23:42 <flaper87> Fix the API, make it consumable by other projects that still want to consume it (a.k.a Nova) and then commit to the backwards compat policy
14:23:48 <nikhil> sure, but still sanely maintainable. I fear a large refactor could potentially disrput any perf/reliability enhancement done
14:24:19 <flaper87> That we need to discuss on the spec. I think the whole way the spec started gave the wrong impression of what the goal is
14:24:40 <flaper87> A fourth option would be to start a whole new library and let glance_store die
14:24:57 <flaper87> That new library would do what glance_store is supposed to do but w/ a new API
14:25:14 <nikhil> sabari: seems to have a hidden clause. the feeling I got was breaking directly wasn't allowed
14:25:40 <flaper87> ok, we need to move on so, to have some action items
14:25:42 <nikhil> flaper87: sure, #4 is a good option too
14:25:51 <flaper87> Can we mention this on the x-proj spec?
14:25:56 <nikhil> I will
14:26:03 <nikhil> wanted to get early glance feedback, thanks/
14:26:08 <flaper87> We need a way to be able to either refactor glance_store or create a new one
14:26:22 <flaper87> I'm sure good feedback will come out from that spec and ppl following it
14:26:32 <flaper87> nikhil: thanks for bringing this up
14:26:50 <flaper87> #action nikhil to bring the glance_Store refactor discussion on the x-proj compat spec
14:27:02 <flaper87> ok, moving on unless there's something else critical here
14:27:18 <flaper87> #topic Cross-project work (flaper87)
14:27:36 <flaper87> on a similar note to what nikhil just mentioned, I think we need to improve our x-proj presence
14:27:47 <flaper87> nikhil: I believe you're the x-proj liaison, right?
14:27:55 <nikhil> yes
14:28:01 <flaper87> coolio
14:28:12 <flaper87> what do you think about having x-proj updates at the beginning of our meeting ?
14:28:19 <flaper87> Just like artifacts and drivers
14:28:31 <nikhil> it's mostly formalizing the process and getting some chasers to put on the list of people
14:28:40 <nikhil> flaper87: surely, I think the p
14:28:49 <nikhil> though the proposal was
14:29:07 <nikhil> you need to have a comment on the x-prj spec
14:29:26 <nikhil> but prolly still developing
14:29:40 <flaper87> yeah
14:29:52 <nikhil> I can request feedback in the meeting or outside depending on time constraints whatever you all prefere
14:30:03 <flaper87> I'm currently worried about our presence in the x-proj meetings and how much feedback we're giving on that area
14:30:15 <flaper87> I'm wondering if we should have 2 liaisons so that you have some help there
14:30:21 <nikhil> heh
14:30:28 <nikhil> we had one x-prj meeting in 3 weeks
14:30:35 <flaper87> yup
14:30:55 <flaper87> ok, lets start by having an x-proj specific topic in our meetings
14:31:01 <flaper87> I think that'd help a lot
14:31:09 <nikhil> ok
14:31:29 <flaper87> nikhil: btw, don't get me wrong. I think you're doing a great job. I hope this topic didn't come out the wrong way
14:31:36 <nikhil> and I am just back settling in catching up with backlog :/
14:31:47 <nikhil> flaper87: yeah, np
14:32:15 <flaper87> coolio, moving on unless there's something else here
14:32:29 <flaper87> #topic Community Recognitions
14:33:28 <flaper87> So, I don't really have a way to recognize ppl's work other than mentioning it publicly in our meetings. I think some folks have been doing an amazing job and I would like to, at the very least, recognize that here in a per-milestone basis
14:33:49 <flaper87> Just a shutout for folks to know that we love them :D
14:33:56 <flaper87> Here it goes:
14:34:19 <flaper87> From a bug squashing POV, I'd like to give a special thanks to bunting and kairat
14:34:32 <flaper87> They have been working like machines on killing as many bugs as possible
14:34:39 <flaper87> and it's been amazing to review all those patches
14:34:41 <sabari> bunting kairat ++
14:34:46 <bunting> Evil bugs :) Cheers!
14:34:52 <kairat> thanks)
14:34:55 <mfedosin> thanks folks
14:34:57 * nikhil claps
14:34:57 <flaper87> Please, do keep it up and sorry for all those -1's/-2's and nitpicks
14:35:15 <flaper87> Bare with us while we try to keep up with your work
14:35:30 <flaper87> I'd like to make one more recognition for this milestone
14:36:08 <flaper87> and it goes to mfedosin for his amazing work in making nova work with glance v2. It has not been easy and it's required a good deal of cross-project interaction, patience and tolerance
14:36:24 <flaper87> That's one of our priorities for Mitaka and it's moving forward quite well
14:36:42 <flaper87> So, thanks mfedosin again for your efforts there and please, don't give up. :D
14:36:52 <mfedosin> oh... it's not done yet, actually
14:37:02 <mfedosin> but will be very soon
14:37:07 <flaper87> I know it's not done, that's why I'm begging you to not give up
14:37:10 <flaper87> :D
14:37:12 <mfedosin> and trusts too
14:37:32 <mfedosin> I won't give up for sure :)
14:37:42 <mfedosin> thank you :)
14:37:57 <flaper87> It goes without saying that the whole team did an awesome job for M-1 and the review rate has been way better! But, I think this 3 folks deserve a special thank from all of us this time :)
14:38:08 * flaper87 sends beers to everyone
14:38:13 <flaper87> moving on
14:38:15 <flaper87> actually
14:38:36 <flaper87> if you would like to recognize someone's work, please, feel free to add this topic to the agenda at any time
14:38:51 <flaper87> I'll do it once per milestone at least
14:39:04 <flaper87> ok, now, for realz, moving on
14:39:11 <flaper87> #topic CORS headers in glance: https://review.openstack.org/#/c/219478/ (kairat)
14:39:33 <flaper87> kairat: floor is yours
14:39:50 <kairat> Ok, please look into review
14:40:08 <kairat> krotscheck would like to clarify what headers are required for glance
14:40:43 <kairat> but after analyzing the question it turned out that we have a lot of headers, because we are passing metadata as headers
14:41:11 <kairat> So I am wondering what minimal set of headers we should set as default for CORS
14:41:11 <mclaren> (that's v1 only I think?)
14:41:11 <flaper87> kairat: that's v1 only, though.
14:41:13 <flaper87> AFAIR
14:41:15 <flaper87> :D
14:41:17 <flaper87> mclaren: yup
14:41:31 <kairat> That's perfect
14:41:33 <mclaren> probably ok to support just v2?
14:41:39 <kairat> +100
14:41:40 <flaper87> mclaren++
14:41:45 <tsufiev> mclaren, no objections here
14:41:49 <mfedosin> yes
14:41:51 <flaper87> awesome, another happy customer. NEXT!
14:41:53 <flaper87> :D
14:41:58 <kairat> cool
14:42:21 <nikhil> it looks fine
14:42:22 <flaper87> kairat: tsufiev I take you're all set now
14:42:30 <tsufiev> still, just enabling CORS headers is not enough to solve the task of Glance images upload from Horizon (the one that CORS is going to solve)
14:42:36 <kairat> flaper87, yep
14:42:43 <tsufiev> flaper87, so, we're not ^^ :)
14:42:49 * flaper87 reads
14:43:07 <flaper87> tsufiev: what do you mean by "the task of glance images upload" ?
14:43:08 <kairat> tsufiev, I guess the next topic is about that
14:43:16 <flaper87> "task" is a dangerous term in this team
14:43:22 <tsufiev> flaper87, see https://blueprints.launchpad.net/horizon/+spec/horizon-glance-large-image-upload
14:43:25 <flaper87> :D
14:43:29 <nikhil> flaper87: topic change
14:43:31 <tsufiev> the last comment in w
14:43:36 <tsufiev> *in Whiteboard
14:44:14 <nikhil> I think we are talking about "multipart/form-data support in glance api "
14:44:22 <tsufiev> nikhil, yes
14:44:23 <nikhil> not that I want to shun this discussion :)
14:44:29 <mfedosin> flaper87: if we want to upload files to glance from Horizon we have to deal with multipart/form-data
14:44:30 <flaper87> nikhil: tsufiev ahhh
14:44:33 <flaper87> tsufiev: you hijacked the topic
14:44:36 <flaper87> bad bad bad tsufiev
14:44:40 <kairat> :)
14:44:41 <mclaren> I don't know much about this tbh -- is there anything here to consider around image import?
14:44:45 <flaper87> #topic multipart/form-data support in glance api (tsufiev)
14:44:50 <flaper87> now we can talk about that
14:45:00 <tsufiev> flaper87, sorry, I'm not familiar with local policies )
14:45:09 <flaper87> tsufiev: are you aware of the efforts going into revamp the import process for images?
14:45:21 <flaper87> tsufiev: np, I was joking
14:45:53 <flaper87> I think this is something that will have to be considered as an enhancement for the new import process
14:45:55 <tsufiev> flaper87, I had a discussion with Brian Rosmaita in spec CR comments, but according to him, Glance wants to offload this thing to Swift
14:46:11 <tsufiev> and that's the point I disagree with
14:46:15 <flaper87> tsufiev: oh yeah, that sounds outdated
14:46:18 <flaper87> :P
14:46:29 <flaper87> discussions have evolved since then
14:46:36 <flaper87> and direct upload is not going away
14:46:51 <tsufiev> flaper87, good to hear :)
14:47:01 <flaper87> Anyway, I think we'll have to take this under consideration for the revamped import process
14:47:04 <flaper87> mclaren: agreed ?
14:47:07 <nikhil> so, afair this is supported to an extent
14:47:10 <kairat> Soo
14:47:16 <flaper87> perhaps not in mitaka but at least for N
14:47:20 <tsufiev> hm...
14:47:23 <nikhil> oh wait, that's just reads
14:47:25 <nikhil> nvm
14:47:28 <tsufiev> flaper87, is there any blocker?
14:47:30 <kairat> Should we allow to upload image without task?
14:47:31 <nikhil> range writes is different
14:47:40 <nikhil> tsufiev: range writes is a complicated problem
14:48:01 <kairat> because we need to deal multipart/form-data in this case
14:48:04 <nikhil> tsufiev: I had a discussion with swift PTL and he mentioned it to be a PhD thesis
14:48:09 <flaper87> tsufiev: yup, we're not going to modify the current upload path. That's our current blocker
14:48:15 <mclaren> flaper87: yup
14:48:46 <flaper87> we're almost at the end and there's one more topic
14:48:48 <tsufiev> nikhil, flaper87: I heard that multpart/form-data decoder could be implemented as an additional middleware
14:48:56 <tsufiev> I think it was ativelkov who told me that
14:49:11 <flaper87> tsufiev: we'll explore that for sure, it just needs to wait a bit longer
14:49:21 <nikhil> last write wins and when you enable multiple uploads, guaranteed success rate of a data write will be significantly low
14:49:32 <flaper87> as we don't have cycles to discuss/implement that and it isn't part of the mitaka priorities
14:49:46 <flaper87> ok, moving on! (sorry for cutting the discussion)
14:49:49 <nikhil> tsufiev: ok, we should discuss this offline. I am interested in knowing more
14:49:49 <flaper87> #topic SHA-2 and openssl dependency
14:49:54 <flaper87> no idea who added that
14:49:56 <tsufiev> nikhil, ok
14:50:07 <hemanthm> that's me
14:50:15 <flaper87> hemanthm: hey! :D
14:50:23 <hemanthm> https://github.com/openstack/glance/blob/master/glance/common/signature_utils.py#L43-L48
14:50:27 * mclaren note to self: s3 objects seem to support multipart http://docs.aws.amazon.com/AmazonS3/latest/API/RESTObjectPOST.html
14:50:54 <hemanthm> So, image signing makes use sha-2 exclusively for digest
14:51:02 <flaper87> bpoulos: ^
14:51:23 <hemanthm> And, SHA-2 is supported by default on openssl 1.0.1 or higher versions
14:51:51 <hemanthm> now, on certain platforms like debian6, openssl only goes up to 0.9.8
14:52:02 <flaper87> ah mmh :(
14:52:02 <hemanthm> which doesn't support SHA-2 by default
14:52:13 <hemanthm> so, glance build is broken on those platforms
14:52:37 <flaper87> as dhellmann mentioned in the drivers meeting, can we pick the default based on the openssl version?
14:52:38 <flaper87> bpoulos: ^
14:53:03 * flaper87 throws some cookies in the channel to grab bpoulos attention
14:53:06 <nikhil> does anyone recollect what metadata is set?
14:53:51 <nikhil> configurability might affect resiliency, so a bit curious
14:53:52 <bpoulos> hemanthm: I'll take a look
14:53:56 <bpoulos> I wasn't aware of this dependency
14:54:02 <flaper87> I knew cookies would work
14:54:08 <hemanthm> :)
14:54:09 <bpoulos> haha
14:54:13 <hemanthm> bpoulos: thank you!
14:54:27 <flaper87> aaaaaaaaaaaaand another happy customer!
14:54:29 <flaper87> :D
14:54:41 <hemanthm> can I get some cookies too?
14:54:48 <flaper87> #action bpoulos to look into the openssl dependency for the default signature method
14:54:57 * flaper87 gives hemanthm cookies and a cup of coffee
14:55:21 <flaper87> I'd have thrown coffee in the channel but that'd have been a disaster
14:55:25 <flaper87> #topic Open Discussion
14:55:29 <flaper87> o/
14:55:57 <kairat> flaper87, there is one more topic from bunting as I can see
14:56:00 <flaper87> Last week I asked for feedback w.r.t the glance ocmmunity, thinks that are working and especially, thins that are broken
14:56:15 <bunting> Yeah
14:56:27 <bunting> I was gonna bring up what we were talking about in the glance room earlier
14:56:30 <flaper87> I've got some feedback but not as much as I'd love too. Here's another request for feedback :D
14:56:42 <flaper87> oh, I'm sorry, I didn't see it
14:56:47 <flaper87> there are 4 mins left
14:56:57 <flaper87> is that enough? or should we wait for next week?
14:57:00 <bunting> There might not be enought time
14:57:02 <flaper87> or discuss it in -glance ?
14:57:18 <nikhil> flaper87: may be carry over the discussion topics to next meeting (there are 3)
14:57:22 <nikhil> ?
14:57:35 <flaper87> yup, I'll do that
14:57:37 <avarner_> Can I get opinions on Bandit tests? Any particular tests that people think are important?
14:57:43 <flaper87> oh the Discussion Topics section
14:57:48 <flaper87> I totally skipped that
14:57:57 * flaper87 slaps himself
14:58:06 <flaper87> sorry about that
14:58:08 <nikhil> and I thought it was the time
14:58:18 <nikhil> :P
14:58:33 <flaper87> it was the time and my blindness
14:58:39 * flaper87 freaks out when he's running out of time
14:58:45 <flaper87> it's a dangerous situation to be in
14:58:48 <bunting> Haha don't worry
14:59:00 <bunting> It seems we had two topic sections
14:59:09 <flaper87> lets have a single section for all topics
14:59:16 <flaper87> we can use sub-bullets
14:59:38 <flaper87> ok, thanks folks
14:59:43 <flaper87> #endmeeting