13:59:05 <flaper87> #startmeeting glance
13:59:06 <openstack> Meeting started Thu Jan 21 13:59:05 2016 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:06 <flaper87> #topic agenda
13:59:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:07 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
13:59:09 <openstack> The meeting name has been set to 'glance'
13:59:27 <abhishekk> hi o/
13:59:36 <dshakhray> o/
13:59:37 <ativelkov> o/
13:59:38 <mfedosin> o/
13:59:40 <flaper87> o/
13:59:41 <kairat> o/
14:00:00 <flaper87> That's our agenda, as usual. Please, add new topics at the bottom if there are things you'd like to talk about
14:00:18 <flaper87> rosmaita: jokke_  ?
14:00:32 <rosmaita> o/
14:00:43 <flaper87> nikhil: ?
14:00:44 <flaper87> #topic Updates Artifacts
14:00:51 <flaper87> mfedosin: ativelkov floor is yours
14:01:07 <flaper87> I promised I would attend the artifacts meeting on Monday. I failed!
14:01:15 * flaper87 is a terrible terrible person
14:01:21 <mfedosin> So did I :(
14:01:22 <flaper87> I swear I have a good reason
14:01:27 <sabari> o/
14:01:31 <flaper87> #chair rosmaita mfedosin
14:01:32 <openstack> Current chairs: flaper87 mfedosin rosmaita
14:01:43 <flaper87> just in case my network goes south
14:01:49 <flaper87> ativelkov: any news from artifact's land?
14:01:50 <jokke_> o/
14:01:58 <ativelkov> We don't have much to update, since mfedosin was primarily busy with nova stuff
14:02:12 <flaper87> Sorry the spec hasn't been approved yet. I'd like to see some comments from sigmavirus24_awa and then we're good
14:02:30 <ativelkov> Since the Public API spec is in a good shape, we hope to get its first implemenation in several days from now
14:02:34 <flaper87> ativelkov: that's good news ( mfedosin being busy with nova, that is) :P
14:02:45 * flaper87 wants to get that nova stuff done. NOW!
14:02:46 <flaper87> :P
14:02:54 <flaper87> ativelkov: sounds promising
14:03:02 <ativelkov> Same do I, so no rush, nva is more important for sure
14:03:07 <ativelkov> nova*
14:03:23 <ativelkov> Also, I did couple of more reviosions to the v3 -> v0.1 migration patch
14:03:29 <ativelkov> minor nits mostly, plus rebase
14:03:31 * flaper87 does a wolves dances around a campfire to make sure the nova work will be completed
14:03:36 <flaper87> now, picture that ^
14:03:38 <ativelkov> one more rebase seems to be needed though
14:03:41 * flaper87 stfu
14:03:51 <flaper87> ativelkov: that one is on my review queue for today
14:03:59 <ativelkov> cool, thanks!
14:04:22 <flaper87> moving on, unless there's more
14:04:42 <ativelkov> Also we had a conversation with docaedo from comunity-app-catalog team, they want to start prototyping their glare-based backend soon, so the public api will be handy there
14:04:43 <flaper87> #topic Updates Drivers
14:04:48 <flaper87> ops
14:04:54 * ativelkov is done
14:05:03 <flaper87> ativelkov: that's good news
14:05:18 <flaper87> ok, not much from our side either
14:05:25 <flaper87> we've reviewed the SFE requests
14:05:35 <flaper87> 3 (or 2?) have landed already
14:05:40 <flaper87> one is left to review (glare's)
14:05:48 <flaper87> but we'll get to it before the end of the week
14:06:03 <mfedosin> it seems that gate is broken
14:06:08 <flaper87> Some spec lite were triaged
14:06:08 <flaper87> and now those patches can move forward
14:06:18 <flaper87> mfedosin: why? why? why do you have to do that to me? WHY?
14:06:27 * flaper87 runs around the team crying desperatedly
14:06:36 <flaper87> mfedosin: mmh, do we know the reason?
14:06:39 <nikhil> hi
14:06:43 <flaper87> I'll take a look after the meeting
14:06:50 <mfedosin> o_O me?
14:06:59 <flaper87> that's it!
14:07:01 <flaper87> #topic Updates Nova v1 -> v2
14:07:03 <kairat> flaper87, see [openstack-dev] [devstack] pip 8 no longer over-installs system packages [was: Gate failure]
14:07:04 <flaper87> mfedosin: yours
14:07:20 <flaper87> kairat: so, it's not just glance.... phew
14:07:25 <kairat> yep
14:07:36 <sabari> flaper87: we don't break things :P
14:07:36 <rosmaita> i think anything that uses argparse
14:08:18 <flaper87> mfedosin: so, v1 -> v2
14:08:18 <flaper87> sabari: lol
14:08:19 <mfedosin> okay... no big updates, but several big agreements are here
14:08:35 <mfedosin> first, we decided to cache glance version
14:08:48 <mfedosin> and do not request it each time
14:09:03 <flaper87> nice
14:09:04 <mfedosin> and also reload on SIG_HUP
14:09:10 <flaper87> Jay was against it, right?
14:09:13 <flaper87> gotcha
14:09:13 <flaper87> sounds good
14:09:19 <mfedosin> it will simplify the code dramatically
14:09:46 <mfedosin> also I updated compat patch in glanceclient
14:09:56 <mfedosin> so, please review it :)
14:10:10 <flaper87> will review. Did you address jokke_'s and my comments?
14:10:14 <mfedosin> https://review.openstack.org/#/c/266419/
14:10:19 <mfedosin> yes
14:10:30 <flaper87> We'll have to discuss it a bit further to reach consensus on what the direction should be
14:10:31 <flaper87> coolio
14:10:34 <flaper87> anything else?
14:10:46 <mfedosin> also I have a couple of suggestion that may help in this work
14:11:02 <mfedosin> but I'm going to talk about it later today
14:11:14 <mfedosin> xenplugin:
14:11:27 <mfedosin> I will remove explicit status updated
14:11:40 <flaper87> ok
14:11:42 <mfedosin> since it's not required
14:11:50 <flaper87> #topic FYI https://review.openstack.org/#/c/270752/ (flaper87)
14:11:57 <flaper87> #link https://review.openstack.org/#/c/270752/
14:12:00 <flaper87> That's M-2's tag
14:12:38 <flaper87> We were ready to tag on Tuesday but there's a sec fix on going that we wanted to wait for. It couldn't make it in time so the tag has been done w/o it
14:12:52 <flaper87> I'm saying that because the review effort was AWESOME!
14:12:58 <flaper87> thanks to everyone who jumped in
14:13:09 <flaper87> this tag contains several bug fixes for 500 errors
14:13:14 <flaper87> and a couple of other things
14:13:21 <flaper87> (IIRC, btw)
14:13:22 <flaper87> :P
14:13:35 <flaper87> questions? thoughts?
14:13:52 <jokke_> we probably should look into releasing store as well soon enough
14:14:04 <jokke_> to have common point for testing those two together
14:14:15 <flaper87> yeah. I'd like to hold off glanceclient until the compatibility layer lands, though.
14:14:18 <flaper87> ++
14:14:36 <flaper87> Let's work together on getting glance_store out next week
14:14:36 <jokke_> as a bridge to that
14:14:48 <flaper87> #action jokke_ and flaper87 to release glance_store next week
14:14:54 <jokke_> do we have topic for the metadef subcommanding?
14:15:09 <jokke_> in todays meeting?
14:15:10 <flaper87> don't think
14:15:30 <jokke_> ok, if we are going to do that we need to time it smart release wise
14:15:36 <flaper87> ok, moving on
14:15:49 <flaper87> pls add a topic :D
14:15:55 <flaper87> for today's meeting or next week's
14:16:13 <flaper87> #topic Re-think the Glance Drivers team
14:16:17 <flaper87> #link http://lists.openstack.org/pipermail/openstack-dev/2016-January/084562.html
14:16:28 <flaper87> who had time to read that email before the meeting?
14:16:34 <rosmaita> me
14:16:44 <nikhil> Yes. Let's do it. It's been waiting for a while.
14:16:48 <flaper87> From the email: Gonna cut the chase: I think we would do a better job on the specs (and light
14:16:50 <flaper87> specs) side if we get rid of the Glance Drivers team and encourage everyone
14:16:51 <flaper87> (especially from the core team) to weight in.
14:16:52 <nikhil> Would be good to try
14:16:52 <flaper87> "
14:16:53 <rosmaita> i think it makes sense, particularly wiht the spec-lite process
14:17:10 <jokke_> me
14:17:19 <flaper87> you
14:17:23 <nikhil> agree, spec lite is a bit too decoupled to triage
14:18:00 <flaper87> ok, I'll start working towards that. We'll still have a driver's meeting next Tuesday and I'll present a more formal proposal with a plan forward
14:18:08 <rosmaita> ++
14:18:33 <flaper87> w000h0000!
14:18:41 <flaper87> ok, if there are no objections, I'll move on
14:19:14 <flaper87> #topic https://bugs.launchpad.net/glance/+bug/1535900 (spec-lite for a new disk_format value) (rosmaita)
14:19:17 <flaper87> #link https://bugs.launchpad.net/glance/+bug/1535900
14:19:18 <openstack> Launchpad bug 1535900 in Glance "Add tar as a disk_format to glance" [Wishlist,In progress] - Assigned to Arun S A G (sagarun)
14:19:25 <flaper87> rosmaita:
14:19:34 <rosmaita> yeah, so in the spirit of flaper87's email, i wanted to bring this up at the meeting
14:19:46 <rosmaita> two questions, basically:
14:19:57 <rosmaita> (1) tar as a disk_format vs container_format
14:20:11 <rosmaita> (2) how to keep the image plugin for glare in sync with glance
14:20:34 <rosmaita> the patch for the spec-lite does the code change in the artifact plugin, not glance
14:20:45 <rosmaita> by mistake
14:21:11 <rosmaita> anyway, if you have an opinion, please comment on the spec-lite
14:21:21 <flaper87> mmh... so, I think we should put some extra reviews in the glare migration to get it done asap
14:21:23 <flaper87> that's one thing
14:21:32 <flaper87> re (1), I'm also torn there, TBH
14:21:35 <jokke_> I don't think the decoupling between the two is problem as long as the artifacts API is still considered as experimental
14:21:38 <flaper87> To me, it's a container
14:21:49 <nikhil> I wouldn't want to worry about keeping them in sync particularly and mark any lags in improvements under special tag for bugs in LP
14:22:08 <rosmaita> me too, but its a weird case ... i asked for clarification, so we'll see
14:22:33 <flaper87> from the bug: "There is no metadata in the tarball. By OS tarball i mean it is a compressed tar archive of a / (root filesystem)"
14:22:40 <flaper87> that's in reply to your comment
14:22:50 <nikhil> yeah, it's interesting case
14:22:53 <flaper87> I guess it could be either, tbh.
14:23:03 <flaper87> Can this be brought up in the mailing list?
14:23:04 <nikhil> can the disk be considered raw and container tar in this case?
14:23:11 <rosmaita> yeah, so we need to decide what makes the most sense
14:23:14 <flaper87> I think we could benefit from feedback from other teams
14:23:17 <rosmaita> ML is a good idea
14:23:20 <flaper87> Nova and Ironic, FWIW
14:23:28 <flaper87> s/FWIW/For example
14:23:36 * flaper87 can't acronym
14:23:41 <flaper87> rosmaita: want to take that task on?
14:23:42 <nikhil> cinder too I think
14:23:47 <rosmaita> flaper87: will do
14:23:53 <flaper87> rosmaita: ++
14:24:06 <flaper87> #action rosmaita to send an email requesting feedback on whether tar should be considered a container or a disk format
14:24:25 <flaper87> anything else?
14:24:29 <flaper87> Anyone ?
14:24:48 * flaper87 is still thinking about container vs disk format in the back of his head
14:24:55 <flaper87> #topic Implement purge_props flag in v2 image-update (part of Nova v1 -> v2 initiative) (mfedosin)
14:25:01 <flaper87> mfedosin: go go go
14:25:10 <mfedosin> okay, it's me again
14:25:38 <mfedosin> as you may know there are inconsistencies in removing props in v1 and v2
14:26:04 <mfedosin> in v1 you have to provide purge_props flag to image-update
14:26:27 <mfedosin> and if it's true then all unlisted properties in values will be removed
14:26:49 <mfedosin> in ve you have to provide list of prop you want to remove
14:27:03 <mfedosin> in remove_props param
14:27:11 * flaper87 likes v2's way of doing things
14:27:26 <mfedosin> Nova uses v1 and passes purge_props flag
14:27:44 <mfedosin> it's pretty easy to implement this on Nova side
14:27:55 <mfedosin> here's the example how I do it http://paste.openstack.org/show/484572/
14:28:01 <rosmaita> doesn't nova always set purge_props false?
14:28:22 <mfedosin> rosmaita, no
14:28:33 <rosmaita> ok
14:28:41 <mfedosin> at least there are several tempest test that fail
14:28:49 <flaper87> TBH, this is one of those cases where we can move Nova to v2 with a workaround on nova side
14:29:00 <flaper87> one of the things I'd like to see gone and not in the compat layer
14:29:11 <mfedosin> I want to implement this in glance client
14:29:19 <mfedosin> (support of purge_props)
14:29:27 <flaper87> If we can do it in nova, let's do it there.
14:29:37 <mfedosin> as you may see we make additional 'show' call
14:29:53 <mfedosin> to fetch all current properties
14:29:58 * jokke_ does not like the idea of having "Oops, I killed everything" flags around
14:30:05 <flaper87> right, that's one reason I think we shouldn't add it in the compat layer
14:30:13 <flaper87> jokke_: exactly my feeling
14:30:23 <flaper87> I had to remove some propos yday using an old glanceclient
14:30:32 <flaper87> I ended up doing it in mysql directly
14:30:39 <flaper87> I don't trust purge_props
14:30:39 <flaper87> :P
14:30:41 <mfedosin> flaper87, lol
14:31:08 <mfedosin> but it complicates the workflow
14:31:08 <flaper87> mfedosin: has anyone from Nova complained aout that piece of code?
14:31:22 <mfedosin> tempest complained
14:31:38 * flaper87 kicks tempest's ass
14:31:43 <flaper87> why?
14:31:49 <flaper87> what did it complain about?
14:32:02 <mfedosin> ah, no
14:32:08 <mfedosin> no one complained
14:32:19 <flaper87> ok ok
14:32:20 <flaper87> cool
14:32:22 <mfedosin> I thought about tests failing
14:32:39 <mfedosin> but if we leavi it in Nova then we will do additional 'show' call
14:33:16 <mfedosin> if it's okay, then let's do it like now
14:33:26 <flaper87> ok
14:33:33 <mfedosin> thanks
14:33:33 <flaper87> if there's a bigger complain, do let us know
14:33:39 <mfedosin> sure
14:33:54 <flaper87> #topic Incorrect glance v2 API behavior ( mfedosin)
14:34:03 <mfedosin> yes, it's mine again
14:34:03 <flaper87> #link http://developer.openstack.org/api-ref-image-v2.html
14:34:25 <mfedosin> me and Stuart found a wrong behavior in v2
14:35:09 <mfedosin> if image contains no data then glance has to return 204 code after image-download
14:35:30 <mfedosin> but now it's 200 and glance creates an empty file
14:35:33 <flaper87> mmh, is that during downloads ?
14:35:40 <mfedosin> yes
14:35:50 <mfedosin> uploads work fine
14:36:05 <flaper87> so, you're saying: When I try to download an image and there's no data, I get 200
14:36:05 <mfedosin> if we don't provide data then glance returns 204
14:36:24 <mfedosin> flaper87, correct
14:36:31 <flaper87> by no data you mean the file is empty or there hasn't been an actual upload?
14:36:39 <flaper87> mfedosin: which one?
14:36:39 <flaper87> :P
14:36:46 <flaper87> empty file?
14:36:46 <flaper87> or no upload has been done?
14:36:56 <mfedosin> this one <flaper87> so, you're saying: When I try to download an image and there's no data, I get 200
14:37:01 <flaper87> because, if the image is active and the file is empty, there's no way for glance to know that
14:37:26 <flaper87> if the image is queued and I try to download an image, then prob 204 (or error?) should happen
14:37:31 <rosmaita> mfedosin: when you say "no data" do you mean 0 byte file?
14:37:41 <mfedosin> rosmaita, yes
14:37:56 <nikhil> I think this is a bug
14:38:02 <nikhil> and not incorrect behavior
14:38:12 <nikhil> the checksum should fail
14:38:14 <rosmaita> mfedosin: so there is a location set, it just has 0 bytes?
14:38:27 <nikhil> for an "active" image with 0 bytes
14:38:28 <mfedosin> location is set, right
14:38:33 <rosmaita> nikhil: good point about the checksum
14:38:41 <mfedosin> and glance creates a file in store
14:38:58 <flaper87> so, it's a bug in the upload path
14:39:01 <flaper87> ?
14:39:14 <flaper87> as in, allowing uploads of empty files is not really what we want
14:39:20 <flaper87> or 0-sized files
14:39:26 <flaper87> s/files/images/
14:39:43 <mfedosin> here's the paste http://paste.openstack.org/show/484577/
14:39:44 <nikhil> It would be good to know who really needs a 0 byte file. Else, we need to fix this corner case.
14:39:56 <kairat> nikhil, AFAIK nova
14:40:00 <jokke_> there was discussion around this topic in ML I think
14:40:05 <flaper87> nikhil: there's a not so old thread about this in the mailing list
14:40:12 <nikhil> ah ha
14:40:14 <flaper87> there's a use cause for it in nova, that I don't fully agree with
14:40:16 <nikhil> scolling
14:40:19 <jokke_> the problem is that nova relies heavily on that behavior
14:40:31 <jokke_> flaper87: ++
14:40:54 <flaper87> I still think this is wrong and there should be a different way to do this from nova
14:40:58 <mfedosin> and what's happen during download http://paste.openstack.org/show/484578/
14:41:24 <flaper87> lol @ file "lalala"
14:41:30 * flaper87 notices mfedosin likes to sing
14:41:49 <jokke_> so IMO if we allow 0-size image to transition the image to active the output needs to be 0-size image file ;)
14:41:58 <mfedosin> flaper87, You saw through me
14:42:16 <flaper87> jokke_: ++
14:42:34 <mfedosin> then we have to update api specification
14:42:47 <flaper87> WE FOUND THE BUG!
14:42:52 <flaper87> it's in the specs
14:42:52 <flaper87> :D
14:42:54 <mfedosin> OMG
14:42:56 * flaper87 dances
14:43:06 * mfedosin sings
14:43:17 <flaper87> does anyone disagree with the above?
14:43:17 <flaper87> rosmaita: nikhil ?
14:43:24 <rosmaita> i am confused by the paste
14:43:25 <flaper87> where's mclaren?
14:43:44 <flaper87> rosmaita: first paste creates an image and uploads an empty file
14:43:44 <flaper87> sencond paste downloads it
14:43:44 <mfedosin> he's one how found it
14:44:03 <flaper87> the point mfedosin is making is that the second paste shouldreturn 204
14:44:20 <flaper87> I'd argue that 200 is correct becuase the image resource *does* have a file
14:44:23 <flaper87> it's just empty, which is not glance's problem
14:44:36 <nikhil> that's correct
14:44:38 <flaper87> rosmaita: does that make sense? ^
14:44:38 <rosmaita> sorry was looking at wrong one
14:44:43 <nikhil> but I think we should check RFC
14:44:46 * flaper87 roflk
14:45:01 <nikhil> will wait for sigmavirus24_awa's input
14:45:04 <rosmaita> yes, if it does have a file, shoudl return 200 and file content
14:45:11 <rosmaita> whcih is nothing in this case
14:45:14 <flaper87> yup, sigmavirus24_awa input would be cool
14:45:23 <flaper87> right
14:45:28 <nikhil> I am a bit torn on this idea
14:45:32 <flaper87> sigmavirus24_awa: ^ pls, read backlog and provide feedback
14:45:33 <jokke_> I think the problem is bit vague explanation in the API reference
14:45:37 <nikhil> anyways, will wait for sigmavirus24_awa
14:45:47 <jokke_> "If no image data exists, the call returns the HTTP 204 response code. "
14:46:01 <kairat> Are we going to create empty file in nova case?
14:46:18 <mfedosin> kairat, seems so
14:46:24 <kairat> Hmm
14:46:30 <flaper87> I guess so
14:46:38 <mfedosin> they promised to fix this behavior
14:46:41 <jokke_> so looking that reference the assumption indeed is that we return 204 if the image size is 0
14:46:45 <flaper87> I don't like the idea but to prevent that we'll have to forbid 0-sized files
14:46:48 <mfedosin> with empty images
14:46:52 <flaper87> which breaks the API
14:47:06 <flaper87> mfedosin: could you update the API reference?
14:47:11 <jokke_> ++
14:47:15 <flaper87> we can get sigmavirus24_awa review there
14:47:15 <mfedosin> okay
14:47:20 <sabari> IIRC, when glance_store throws NotFound we return a 204
14:47:39 <sabari> https://github.com/openstack/glance/blob/master/glance/api/v2/image_data.py#L304
14:47:42 <rosmaita> that would be compat with the API ref
14:47:50 <nikhil> yeah, but in this case it won't raise NotFound
14:48:05 <flaper87> sabari: what nikhil said ^
14:48:12 <jokke_> that's lunatic as well
14:48:22 <nikhil> right you are jokke_
14:48:36 <jokke_> why do we returnn 2XX if backend returns NotFound
14:48:40 <sabari> yeah so that's out defintion of no image data :)
14:48:48 <jokke_> and yes only error condition listed is 403
14:48:55 <mfedosin> I would prefer not to create empty file
14:49:01 <jokke_> horrible
14:49:02 <mfedosin> in store
14:49:13 <flaper87> ok, 10 mins left. Would like to have some time for Open Discussions
14:49:13 <flaper87> #action mfedosin to update the API ref
14:49:36 <flaper87> #action sigmavirus24_awa to attend meetings and review mfedosin patch
14:49:38 <flaper87> :P
14:49:47 <flaper87> #topic Open Discussion
14:49:55 <flaper87> Gooooooooo Crazy!
14:50:00 <abhishekk> hi, https://review.openstack.org/#/c/261288/2 is about request-id using hooks
14:50:06 <flaper87> shoot all your open questions
14:50:28 <abhishekk> i have implemented as per stuart and jokke_'s suggestion
14:50:45 <abhishekk> need early reviews ^^
14:51:22 <flaper87> abhishekk: ++
14:51:22 <flaper87> will review
14:51:25 <jokke_> What do we do about this https://review.openstack.org/#/c/218864/
14:51:30 <abhishekk> i know m2 is near but when you get time please review
14:51:46 <flaper87> abhishekk: m2 is out
14:51:59 <abhishekk> flaper87: thank you, great
14:52:12 <jokke_> For reference TC approved priority change to osc instead of individual project clients
14:52:39 <flaper87> jokke_: IMHO, we should have one last CLI release where we can fix some things, clean some others up and freeze it
14:52:54 <rosmaita> flaper87: ++
14:52:55 <jokke_> flaper87: Nice basis for fork?
14:52:59 <flaper87> s/priority change/cross-project spec/
14:53:15 <flaper87> jokke_: not my fork ;)
14:53:32 <flaper87> seriously, I know you don't like OSC
14:53:46 <flaper87> but pleeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeease, don't do crazy stuff
14:53:46 <flaper87> :P
14:53:56 <jokke_> not me
14:54:04 <flaper87> ok ok ok
14:54:07 * flaper87 hugs jokke_
14:54:13 <jokke_> it's the rest of the vocal community
14:54:41 <jokke_> I'm just trying to preserve last bits of sanity :P
14:54:49 <flaper87> we'll see how many forks come out of this
14:55:12 <jokke_> I hope len(forks) == len(projects)
14:55:15 <flaper87> I don't think there will be (many) but that's my perception
14:55:28 * nikhil need to run.
14:55:30 <nikhil> thanks all.
14:55:39 <flaper87> jokke_: FWIW, ppl could have done the same with current CLIs if they didn't like them
14:55:41 <flaper87> but ppl didn't do that
14:55:52 <flaper87> so, why should the same happen with OSC ?
14:55:55 <flaper87> anyway, that's just my opinion
14:56:01 <flaper87> good thing this is Open Discussion
14:56:01 <flaper87> but
14:56:05 <flaper87> 2s
14:56:07 <jokke_> flaper87: true ... telling that people have been happy with the clients provided
14:56:10 <jokke_> ;)
14:56:26 <flaper87> before we start insulting each other, as we normally do, let's stop and not do it here
14:56:32 <jokke_> ++
14:56:53 <flaper87> :D
14:56:57 * flaper87 hugs jokke_ ... again
14:57:16 <flaper87> ok, that's it folks
14:57:20 <jokke_> but that does not remove the question is that large refactoring warranted at this situation
14:57:25 <dshakhray> pls review) https://review.openstack.org/#/c/248359/
14:57:29 <jokke_> *hugsback*
14:57:47 <flaper87> dshakhray: ++
14:57:49 <flaper87> THANKS FOLKS!
14:57:51 <mfedosin> yes folks, please review Darja's code https://review.openstack.org/#/c/248359/
14:57:52 <flaper87> have a good one
14:57:57 <flaper87> and an even more awesome weekend
14:58:00 <flaper87> mfedosin: ++
14:58:03 <jokke_> o/~
14:58:04 <flaper87> #endmeeting