13:59:43 <flaper87> #startmeeting Glance
13:59:43 <openstack> Meeting started Thu Mar  3 13:59:43 2016 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:46 <openstack> The meeting name has been set to 'glance'
13:59:50 <flaper87> #topic Agenda
13:59:52 <flaper87> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
13:59:57 <flaper87> That's our agenda for today
13:59:58 <mfedosin> o/
14:00:11 <tjcocozz_> o/
14:00:17 <dshakhray> o/
14:00:24 <bunting> o/
14:00:57 <flaper87> Just a quick heads up. I won't be able to stay till the end of the meeting because I've a doctors appointment. Does anyone want to co-chair the meeting with me and end it?
14:01:04 <flaper87> Otherwise I'm just gonna rush through it
14:01:06 <flaper87> :D
14:01:15 <flaper87> ok, let me know as we go
14:01:18 <flaper87> :)
14:01:26 <flaper87> #topic Glare updates
14:01:35 <mfedosin> hey :)
14:01:44 <mfedosin> we've started the development
14:02:01 <mfedosin> there is my initial commit for glare v1 api
14:02:09 <mfedosin> but it's in wip state
14:02:30 <mfedosin> we're discussing the implementation with kairat all day
14:02:38 <mfedosin> and I'll update the code later
14:03:02 <mfedosin> there are some things we want to implement
14:03:02 <nikhil> o/
14:03:07 <flaper87> nice nice!
14:03:08 * nikhil sneaks in
14:03:09 <flaper87> great work
14:03:27 <ninag> o/
14:03:30 <mfedosin> 1. we want to create special middleware to catch all exceptions
14:03:44 <mfedosin> and map it to webob
14:03:58 <mfedosin> so, we won't do it in api
14:04:13 <flaper87> ok, I think reviews on the API will start 2 weeks from now
14:04:16 <flaper87> erm, spec
14:04:25 <flaper87> Realistically, that's when we'll cut RC1
14:04:33 <flaper87> until then, I'd rather have folks heads down on bugs
14:04:39 <flaper87> including you :P
14:04:40 <mfedosin> flaper87: okay, I don't mind
14:04:45 <flaper87> awesome
14:04:48 <flaper87> ok, moving on
14:04:54 <flaper87> #topic Updates cross project
14:05:03 <mfedosin> I wish to see your comment on you-know-what bug
14:05:24 <flaper87> nikhil: btw, mind co-charing with me the meeting? I can't stay till the end and I need someone to end it
14:05:40 <nikhil> flaper87: ok, sure
14:05:46 <flaper87> #chair nikhil
14:05:48 <openstack> Current chairs: flaper87 nikhil
14:05:54 <flaper87> nikhil: cross-prj updateS?
14:05:55 <nikhil> and that's the-prj topic
14:05:59 <flaper87> :D
14:06:01 <nikhil> there are not much
14:06:19 <nikhil> 1. First initial cross prj quotas mtg was success
14:06:28 <nikhil> we got nice participations and some excellent questions
14:06:55 <flaper87> awesome! Will try to catch up reading the logs
14:06:56 <nikhil> but it's mostly brainstorming for now and possible involve more CPL discussions in the coming weeks
14:07:04 <nikhil> sounds good
14:07:08 <nikhil> second thing
14:07:25 <rosmaita> nikhil: what channel is the quotas meeting held in?
14:07:30 <nikhil> 2. I wanted to remind everyone to please take a look at the default policy proposal for x-prj
14:07:56 <nikhil> #info Quotas WG meeting http://eavesdrop.openstack.org/#Cross-project_Quotas_and_Nested_Quotas_Working_Group_Virtual_Standup
14:08:02 <nikhil> rosmaita: ^
14:08:14 <rosmaita> ty
14:08:22 <flaper87> nikhil: link to the default policy proposal ?
14:08:25 <nikhil> 2. I knwo that I've brought this up before and I know people have been busy with releases so
14:08:43 <flaper87> that's a good reminder, I'd also love to see ppl's opinions there
14:08:46 <flaper87> at least a +1/-1
14:09:02 <nikhil> I will reach out to individuals (those who have things to say) and take some feedback prior to summit on the policy changes affecting us
14:09:23 <nikhil> flaper87: getting the link..
14:09:37 <nikhil> #info Common Default Policy https://review.openstack.org/#/c/245629
14:09:43 <flaper87> awesome, thanks
14:09:55 <nikhil> #action all: Please review the common default policy x-prj proposal
14:10:06 <flaper87> anything else? Questions ?
14:10:13 <nikhil> done
14:10:37 <flaper87> ok, moving on
14:10:41 <flaper87> #topic Releases
14:10:47 <flaper87> #link https://review.openstack.org/#/c/287750/ (client 2.0.0)
14:10:51 <flaper87> #link https://review.openstack.org/#/c/287175/ (glance M-3)
14:10:55 <flaper87> #link https://review.openstack.org/#/c/287495/ (glance_store 0.13.0)
14:11:00 <flaper87> Those are our 3 releases for this week
14:11:14 <nikhil> ++
14:11:16 <flaper87> glanceclient 2.0.0. We need a major because we dropped support for pypy,py26py33
14:11:23 <flaper87> Glance M-3 has been cut
14:11:35 <flaper87> and glance_store 0.13 is waiting (i think)
14:11:49 <flaper87> we need 0.13 because we had to add a config option to fix an incompatibility in the vmware store
14:11:59 <flaper87> I just want to say: AWESOME WORK EVERYONE!
14:12:03 <nikhil> has it been 2 cycles already dropping support for py26 on the client?
14:12:09 <nikhil> flaper87: one quick ques
14:12:33 <flaper87> all client libraries dropped support for py26 and the gate jobs are not running anymore
14:12:37 <nikhil> if we've dropped support for py26 on the client then the compat layer for nova xen api plugin won't work out of box with the client?
14:12:53 <nikhil> that's just food for thought
14:13:09 <flaper87> nikhil: that's a good point. We even have to support 2.4 for the xenplugin
14:13:14 <nikhil> and something to discuss in that compat layer discussion
14:13:18 <flaper87> yeah
14:13:21 <flaper87> nikhil: ++
14:13:48 <flaper87> Ok, what do these releases mean?
14:13:56 <flaper87> It means we'll now focus *only* on bug fixes
14:14:03 <flaper87> find bugs, fix them, land them
14:14:19 <flaper87> There are some critical ones that are public, there are some others that the sec team is working on
14:14:33 <flaper87> we'll have another review day next monday so please, join :)
14:14:43 <flaper87> oh, and next week is also the bugsquash marathon
14:14:54 <flaper87> but nikhil will fill up with some extra info in a bit
14:14:56 <rosmaita> smash and review
14:15:02 <flaper87> yeah!
14:15:07 <nikhil> ++
14:15:25 <flaper87> So, RC1 is 2 weeks from now. Ideally, we shouldn't need an RC2 so, lets try t oget as many bug fixes in as possible
14:15:42 <flaper87> As an advice, please, be very careful with API changes and config options
14:15:50 <flaper87> we shouldn't be doing any of those at this stage
14:16:02 <nikhil> how is the soft doc freeze going this cycle?
14:16:08 <flaper87> avoid anything that changes the behavior of the API (unless there's a super good reason but bring it up for discussion first)
14:16:15 <flaper87> and don't add new config options and stuff
14:16:24 <flaper87> It's starting this week as well
14:16:36 <flaper87> and it'll end 2 weeks from now
14:16:53 <flaper87> I haven't seen much changes on that area
14:16:57 <nikhil> so we will need exceptions for each of those ?
14:17:05 <flaper87> Likely, yep
14:17:29 <flaper87> ok, questions?
14:17:49 <flaper87> #topic Feature Freeze Exceptions
14:17:51 <nikhil> did the CIM one land?
14:17:56 <flaper87> nikhil: yup
14:17:59 <nikhil> cool
14:18:17 <flaper87> I wanted to have a topic for this because I find it super cool that we won't have FFE's this cycle
14:18:27 <flaper87> Literally all the pending features landed
14:18:40 <flaper87> There are 2 that are being moved to newton but those are for glance_Store
14:18:49 <flaper87> and there's the image refactor which we knew was not going to make it
14:18:57 <flaper87> So, again, AWESOME WORK everyone
14:19:14 <flaper87> thanks for all the reviews and let's now keep that effort going a bit longer to get many bugs fixed
14:19:21 <flaper87> #link http://specs.openstack.org/openstack/glance-specs/specs/mitaka/index.html
14:19:25 <flaper87> #link https://review.openstack.org/#/c/286728/
14:19:44 <flaper87> I'll be moving the image import refactor out of Mitaka soon. I want to finalize the discussion first
14:19:59 <flaper87> thanks. Seriously, thanks for all the code and reviews!
14:20:02 <flaper87> questions?
14:20:30 <flaper87> #topic Summit planning
14:20:41 <flaper87> I've started this etherpad:
14:20:44 <flaper87> #link https://etherpad.openstack.org/p/newton-glance-summit-planning
14:21:00 <flaper87> Please, start putting topics in there that you'd like to discuss in Austin
14:21:19 <nikhil> awesome!
14:21:20 <flaper87> I've put 2, I think
14:21:26 <flaper87> let's add lots of stuff there
14:21:31 <flaper87> comment on that, etc, etc
14:21:44 <flaper87> we'll be discussing those as part of our meetings to be able t ocome up with a nice schedule
14:21:53 <flaper87> and then work on the priorities for Newton
14:22:04 <flaper87> PTL Nominations are in 2 weeks.
14:22:27 <rosmaita> i nominage flaper87
14:22:31 <rosmaita> *nominate
14:22:38 <flaper87> If you know already whether you'll run or not for the PTL position, pls, let me know so we can work together :D
14:22:40 <flaper87> rosmaita: <3
14:22:43 * flaper87 hugs rosmaita
14:22:45 <flaper87> thanks
14:23:02 * flaper87 knows how to keep secrets
14:23:12 <flaper87> "except for that time when my sister said ..."
14:23:14 <flaper87> :P
14:23:17 <flaper87> ok, jokes apart!
14:23:22 <flaper87> Looking forward to all your proposals
14:23:32 <flaper87> this is going to be an awesome summit :)
14:23:41 <bunting> Can people not attending submit ideas for discussion?
14:23:46 <flaper87> of cours
14:23:49 <flaper87> of course
14:23:58 <flaper87> bunting: if you have a topic put it htere
14:24:11 <flaper87> we'll find someone that you can pair with to drive that session
14:24:28 <flaper87> If the planets align, we can even have a video call with you
14:24:31 <flaper87> :P
14:24:45 <bunting> Great :)
14:24:53 <flaper87> ok, folks. If there are no other questions, I'll start the open discussion and step out
14:25:19 <flaper87> #topic Open Discussion
14:25:27 <flaper87> nikhil: thanks for ending the meeting
14:25:37 <flaper87> I'll probably be out for the rest of the day. Not sure!
14:25:50 <flaper87> Please, keep an eye on gates since we just released a bunch of stuff
14:25:51 <nikhil> flaper87: ah , have fun
14:25:52 <flaper87> :)
14:25:57 <nikhil> or whatever your plan is :)
14:26:00 <flaper87> nikhil: doctor's appointment
14:26:03 <flaper87> ....
14:26:03 <nikhil> oops
14:26:05 <flaper87> :P
14:26:16 <flaper87> ttyl
14:28:07 <nikhil> Does anyone have anything?
14:28:22 <tjcocozz_> hey everyone just a quick question, sphinx is suppose to be generating module docs but i can't find them anywhere...
14:28:32 <tjcocozz_> any clues?
14:29:13 <nikhil> tjcocozz_: is that a general question or related to glance?
14:29:18 <tjcocozz_> yes
14:29:46 <nikhil> tjcocozz_: :) yes, as in general question?
14:29:58 <tjcocozz_> nikhil, yes it is a general glance question
14:30:03 <nikhil> heh
14:30:11 <tjcocozz_> nikhil, should i take it up in the channel?
14:30:57 <nikhil> tjcocozz_: I think you want to reach out to docs team for this
14:32:01 <nikhil> if nothing more, let's close the meeting
14:32:03 <tjcocozz_> nikhil, its inside the glance repo that it is setup. https://github.com/openstack/glance/blob/master/doc/source/conf.py#L34
14:32:11 <tjcocozz_> nikhil, okay i will try the doc team
14:32:40 <nikhil> tjcocozz_: yeah, it's setup that way to help keep things tightly coupled but it's setup by the doc team
14:33:45 <tjcocozz_> nikhil, oh good to know.  I just find it useful and i was trying to find it for glance.
14:33:48 <tjcocozz_> nikhil, thanks!
14:33:50 <nikhil> tjcocozz_: unless this is what you're looking for http://docs.openstack.org/developer/glance/
14:34:02 <nikhil> at the bottom of the page
14:34:27 <nikhil> #link http://docs.openstack.org/developer/glance/#glance-manual-pages
14:34:44 <tjcocozz_> nikhil, this is keystones: http://docs.openstack.org/developer/keystone/api/modules.html
14:35:29 <tjcocozz_> nikhil, i clicked through all the links and couldn't find it.
14:36:01 <nikhil> tjcocozz_: that's weird, sounds like a good bug then
14:36:43 <nikhil> tjcocozz_:  thanks for bringing it up! please do share your findings on -glance with us
14:36:49 <tjcocozz_> nikhil, if you look here keystone had to do something special in the conf.ph
14:36:50 <tjcocozz_> https://github.com/openstack/keystone/blob/master/doc/source/conf.py#L29
14:37:06 <tjcocozz_> i tried it in glance but it didn't help generate them.
14:37:45 <tjcocozz_> nikhil, okay lets not hold everyone up. if i find anything i will let you know
14:38:00 <nikhil> tjcocozz_: thanks!
14:38:06 <tjcocozz_> nikhil, thank you!
14:38:10 <nikhil> Thanks all!
14:38:42 <nikhil> #endmeeting