13:59:18 <nikhil> #startmeeting glance
13:59:18 <openstack> Meeting started Thu Mar 31 13:59:18 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:21 <openstack> The meeting name has been set to 'glance'
13:59:22 <nikhil> #chair jokke_
13:59:23 <openstack> Current chairs: jokke_ nikhil
13:59:37 <jokke_> woops
13:59:39 <nikhil> #topic roll call
13:59:41 <jokke_> o/
13:59:44 <bunting> o/
13:59:46 <nikhil> o/
14:00:26 <nikhil> jokke_: so you want to/had something to lead meeting today?
14:00:38 <wxy> o/
14:00:51 <nikhil> may be I am out of sync there, flavio said he will be out and ask me to conduct this one
14:00:57 <jokke_> nikhil: flaper87 is travelling and just asked if I would run it through ... feel free though
14:01:00 <mfedosin> o/
14:01:08 <rosmaita> o/
14:01:10 <nikhil> jokke_: ah, he's keeping back ups
14:01:14 <jokke_> oh so it was Flavio who was out of synk ;)
14:01:18 <dshakhray> 0/
14:01:20 <tjcocozz> o/
14:01:21 <jokke_> s/k/c
14:01:22 <nikhil> Mitaka is almost over
14:01:29 <jokke_> nikhil: go for it
14:01:31 <nikhil> we've the new rc2
14:01:48 <jokke_> yes, translations only
14:01:49 <nikhil> but it's i18n so, prolly nothing significant to come out of it
14:01:52 <nikhil> :)
14:02:01 <kairat> o/
14:02:02 <nikhil> guess we've a good turn out today
14:02:07 <nikhil> let's get started then
14:02:10 <nikhil> #topic agenda
14:02:16 <nikhil> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:35 <nikhil> Just wanted to quickly sync over a few items and start preparing for the summit
14:02:44 <nikhil> we've mostly bootstrapping newton at this point
14:02:52 <nikhil> that's what we will discuss today
14:02:58 <hemanthm> o/
14:03:07 <jokke_> by the looks of Mitaka is wrapped and ready for shipping
14:03:11 <nikhil> #topic Glare updates ( mfedosin )
14:03:17 <nikhil> jokke_: yeah!
14:03:49 <mfedosin> hey! we continue the developing of Glare
14:04:10 <mfedosin> a lot of new features were added last week
14:04:37 <mfedosin> and now we have functional tests that checks that everything is fine
14:04:51 <mfedosin> also there was defcore meeting yesterday
14:04:59 <mfedosin> and we were talking Glare
14:05:22 <mfedosin> so, afaiu, they have no concerns about Glare
14:05:22 <rosmaita> what review strategy should we be following on these? i've been ignoring the WIP patches, maybe that is a mistake
14:05:43 <nikhil> rosmaita: good question
14:05:45 <mfedosin> rosmaita: no, you're right
14:05:52 <nikhil> we need to decide on this asap
14:06:01 <mfedosin> currently we just develop the base code
14:06:14 <mfedosin> and it's easy for us to have it in one big commit
14:06:27 <jokke_> About that. I got couple of pings last night asking wtf is going on. Could we please stop selling Glare as replacement for Glance at least until we have a) stable API and b) some level of track record/testing that it actually is successfully working
14:06:30 <mfedosin> called Glare All-in-one
14:07:04 <jokke_> ^^ ref defcore meeting
14:07:29 <mfedosin> then we implement new features with [WIP] prefix and merge them in the big commit
14:08:10 <kairat> jokke_, at the current stage that seems more PoC to me
14:08:10 <mfedosin> jokke_: selling it as a glance replacement creates a hype around Glare :)
14:08:17 <nikhil> jokke_: interesting, that was more of a question rather than a sell. I think those defcore folks are not accurate on their assumptions. I'd love to clarify them.
14:08:44 <jokke_> mfedosin: and causes hell of a lot confusion in the community where we have already really bad reputation (warranted or not)
14:09:25 <tjcocozz> link for the all-in-one patch -> https://review.openstack.org/#/c/292327/
14:09:44 <mfedosin> thanks tjcocozz :)
14:09:45 <nikhil> over Mitaka, I found out the bad reputation is only within small pockets  and we need to identify those pockets and clear those confusions
14:09:58 <jokke_> mfedosin: I'm not picking fight at this point and I do understand that some level of hype is needed to get the traction to Glare, but we can't do it this way
14:09:59 <kairat> +1 to nikhil
14:10:33 <mclaren> It would be useful to have clarity on the relationship between the two. Maybe some documentation in one of the Glare patches?
14:10:37 <nikhil> and I agree with jokke_ that we'd live on realistic practices and avoid confusing hypes
14:11:11 <mfedosin> mclaren: there will be a spec
14:11:41 <mclaren> Ok, cool. Whatever gets us on the same page.
14:11:51 <jokke_> and misunderstandings around defcore was the root cause for last huge incident we were sorting through multiple sessions last Summit
14:12:05 <rosmaita> i think it would be good to get something about "the future" into the regular docs
14:12:14 <jokke_> rosmaita: ++
14:12:25 <nikhil> rosmaita: sounds good
14:13:01 <nikhil> #action nikhil: clarify "the future" stuff for Glance
14:13:19 <rosmaita> i can put up a patch with a lot of handwaving, and you can correct it
14:13:36 <nikhil> sure
14:13:53 <nikhil> anything else on this topic?
14:14:00 <nikhil> rosmaita: whatever gets us going
14:14:18 <nikhil> moving on
14:14:22 <nikhil> #topic Nova v1, v2
14:14:52 <nikhil> I'd a quick catch up with Nova team on the status of this (earlier in the week)
14:14:55 <nikhil> We've a few action items for Newton
14:15:29 <nikhil> Need to create a newton spec, clarify the individual reviews to ensure they correct the eventual goal
14:15:50 <nikhil> basically Nova team thinks that some reviews need more context on why they exist
14:16:22 <nikhil> Matt has tentatively scheduled a cross session with Glance
14:16:43 <nikhil> We will know if it makes it or not in their final proposal
14:16:48 <mfedosin> I'll take the spec
14:16:57 <mfedosin> but one thing I really like
14:16:58 <jokke_> good news is that he also publicly put this on the Nova Newton priorities ;)
14:17:00 <nikhil> mfedosin: thanks
14:17:10 <mfedosin> they agreed to keep this code in Nova
14:17:16 <jokke_> mfedosin: ++
14:17:17 <mfedosin> without compat layer
14:17:28 <nikhil> yes, for this cycle it will be a small concise change
14:17:29 <jokke_> mfedosin: that sounds great
14:17:33 <jokke_> makes sense
14:17:34 <nikhil> most of what mfedosin has already done
14:17:44 <mfedosin> all patches are there
14:17:47 <nikhil> there are a few testing improvements that we may have to do
14:18:00 <nikhil> but testing impr. is a research item
14:18:05 <nikhil> volunteers are welcome
14:18:07 <mfedosin> I just need to address rosmaita concern about lowering headers
14:19:01 <nikhil> any questions?
14:19:23 <nikhil> moving on
14:19:36 <nikhil> #topic Cross project updates
14:19:51 <nikhil> The etherpad for session proposals is up
14:19:59 <nikhil> #link https://etherpad.openstack.org/p/newton-cross-project-sessions
14:20:06 <nikhil> quite a few sessions up there already
14:20:34 <nikhil> besides that
14:20:50 <nikhil> there was a meeting yesterday
14:21:28 <nikhil> Most of what was discussed was a follow up on the CP specs so that people are aware of them
14:21:45 <nikhil> there was update from release team on the automating their process
14:22:14 <nikhil> a heads up + call for reviews on quotas and service catalog tng
14:22:51 <nikhil> moreover, you can find a gist of CP updates in our community newsletter
14:23:11 <jokke_> ref that release process update
14:23:22 <nikhil> nothing significant, that the glance team need to look into this or next week
14:23:30 <nikhil> jokke_: please go ahead
14:23:42 <jokke_> that mainly affects non-managed release mode projects, so really does not affect us
14:23:54 <jokke_> we keep requesting the tags as usual :)
14:24:46 <nikhil> totally
14:25:01 <nikhil> those release changes shouldn't affect glance
14:25:14 <jokke_> just that if anyone is thinking of taking up that liaison post, it's quite straight forward ;)
14:25:34 <nikhil> if you work on other projects too and see anomalies in the process, then that update is for you
14:25:43 <nikhil> jokke_: ah ha
14:25:46 <nikhil> good call
14:26:05 <nikhil> #info all: glance team is looking for release liaison
14:26:32 <nikhil> #topic     Releases
14:26:41 <nikhil> I'd switched topic before :)
14:26:59 <nikhil> nevertheless, summer is coming
14:27:09 <nikhil> and if you're making early holiday plans
14:27:21 <nikhil> the schedule is conveniently available to you
14:27:24 <nikhil> #link http://releases.openstack.org/newton/schedule.html
14:27:53 <nikhil> #info glance team would love to have cores available a week before and on the week of releases
14:28:14 <jokke_> #info Glance RC2 tagged. Diff RC1..RC2 translations
14:28:40 <nikhil> I'd a question yesterday on backports
14:28:44 <jokke_> #info glance_store & python-glanceclient has not had anything major during the freeze
14:28:59 <kairat> glance_store has
14:29:00 <nikhil> if you're looking to propose changes to stable branches, it should follow stable guidelines
14:29:01 <kairat> I think
14:29:25 <kairat> https://review.openstack.org/#/c/297665/
14:29:28 <nikhil> #link http://docs.openstack.org/project-team-guide/stable-branches.html
14:30:16 <nikhil> kairat: that looks possible from first glance
14:30:18 <jokke_> kairat: let me refrase, has not merged anything that would need to be released for Mitaka
14:30:32 <kairat> ah, ok
14:30:57 <jokke_> #undo
14:30:58 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xb38bfd0>
14:31:00 <jokke_> #undo
14:31:01 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xb38b690>
14:31:14 <nikhil> for backports, please propose change against master first and then based on reviews we will move for likely backport
14:31:33 <jokke_> #info glance_store & python-glanceclient has not merged anything to be included in Mitaka for release time
14:31:41 <jokke_> #link http://docs.openstack.org/project-team-guide/stable-branches.html
14:32:11 <mclaren> kairat's fix looks important
14:32:33 <jokke_> nikhil: and on top of that: Please make sure that there is bug for it. We will not backport without and doing that after merge to master is pain
14:33:14 <mclaren> how do we handle glance_store fixes coming up to release?
14:33:16 <nikhil> jokke_: okies.. bug first it is!
14:33:24 <jokke_> :)
14:33:30 <jokke_> makes life easier
14:33:34 <nikhil> mclaren: can you elaborate?
14:33:54 <mclaren> sure
14:34:15 <mclaren> eg do we tag RCX-candidate or anything?
14:34:23 <nikhil> ah
14:34:40 <jokke_> mclaren: with both glance_store and python-glanceclient we do not follow any stable release schedule so we can backport and release as needed, new deployments should pick those up within the requirements
14:34:42 <nikhil> we now follow SemVer for clients and non-client libs
14:35:19 <mclaren> It looks like if you upgrade to mitaka you could  get hit by bug 297665. So ideally we'd have a release of glance_store to prevent that?
14:35:39 <nikhil> yes
14:35:57 <nikhil> we will have a separate release candidate for mitaka
14:36:03 <jokke_> mclaren: so no RCs, the releases we did that was base for the stable/mitaka brnaching is effectively our stable/mitaka release from those libs. then we just make patch releases as needed from that point onwards
14:36:20 <jokke_> mclaren: this was done ~3-4 weeks ago
14:36:37 <mclaren> I understand that in principle they are separated.
14:37:05 <mclaren> I'm just saying that we should do what we can to avoid people hitting 297665 when they deploy mitaka.
14:37:28 <nikhil> mclaren: yes and for that they will be expected to deploy stable mitaka
14:37:32 <nikhil> for eg. iirc, we'd a 0.10.x released for mitaka
14:37:41 <jokke_> mclaren: the one thing I like having glance_store as separate from glance service is the ease of releasing when we have something we want to have fixed in production
14:37:41 <nikhil> the fixes will go to 0.10.x+1
14:37:55 <nikhil> and for newton it will be 0.11.x series
14:38:05 <jokke_> nikhil: correct
14:38:24 <nikhil> the requirements are then updated to reflect the bug fix in stable/mitaka
14:38:35 <nikhil> jokke_: thanks for confirming!
14:39:02 <mclaren> I don't see why releasing a glance_store fix is easier than releasing a glance stable fix?
14:39:19 <nikhil> it is somewhat easier
14:40:01 <nikhil> I mean, you can debate on this but..
14:40:07 <nikhil> because you can now control the fix through requirements
14:40:08 <jokke_> mclaren: mainly due to the appearance :)
14:40:19 <nikhil> you've a better visibility on what's fixed and what's not
14:40:49 <nikhil> you can switch the fix back if you need to by a simple requirement contraint change
14:41:04 <nikhil> constraint*
14:41:34 <nikhil> glance_store release documentation will also have the info for it (ideally)
14:42:09 <jokke_> btw, sorry to interrupt, but we probably should move one and take this offline with interested parties
14:42:13 <jokke_> running out of time
14:42:15 <nikhil> we're running out of time, but if you've more concerns we can wait a couple more mins
14:42:50 <nikhil> ok, offline then. moving on for now.
14:43:04 <nikhil> #topic  Use policy files to control deletion of deactivated images. (bunting)
14:43:11 <bunting> Me
14:43:15 <nikhil> #link https://review.openstack.org/#/c/256381/
14:43:20 <nikhil> bunting: go go go :D
14:44:02 <bunting> It was suggested to bring this to the attention of the group to use policy files rather than the config options as a potential pattern to use in future patches
14:44:56 <nikhil> sure
14:45:02 <bunting> More of an info topic then anything that needs discussing
14:45:04 <nikhil> I see the comments on PS5 and they make sense
14:45:31 <nikhil> alrite then
14:45:57 <jokke_> regardless how it might be controlled, I'd like to see spec (at least lite unless this discussion is getting complex) as the proposed is directly against what the original deactivate/activate spec is specifying as behavior
14:46:07 <nikhil> #info please help review Halt deletion if image is deactivated patch https://review.openstack.org/#/c/256381/
14:46:53 <nikhil> thanks for bring this bunting!
14:46:55 <nikhil> moving on
14:46:57 <mclaren> do we really need a spec for a 45 line change?
14:47:07 <nikhil> heh
14:47:13 <mclaren> 40 lines are tests btw
14:47:23 <nikhil> well, let's discuss the approach on the review
14:47:38 <nikhil> if it changes the API behavior we may need a (lite)spec
14:47:50 <nikhil> if it's just policies, I think we'd be fine
14:48:03 <mclaren> we have an APIchange commit tag
14:48:05 <nikhil> but we definitely need the latest documented behavior on deactivation
14:48:14 <nikhil> so we need to update history on the older spec
14:48:21 <nikhil> make sense?
14:48:21 <kairat> ++ to mclaren
14:48:49 <jokke_> mclaren: I don't think the amount of code is the driving reson for specs, as said we have spec that specifies the current behavior. Just want to have it documented in the same place why we changed it so that in Ocata there is no bug removing these things as they are bug against the spec it should behave
14:49:14 <nikhil> jokke_: very well put
14:49:39 <jokke_> s/spec it/spec how it/
14:49:59 <nikhil> motto being: let's avoid back and forth discussions and changes and keep the code sensible for operators
14:50:14 <nikhil> moving on
14:50:17 <nikhil> #topic     Glance priorities for Newton
14:50:27 <nikhil> #link     https://etherpad.openstack.org/p/glance-newton-priorities
14:50:35 <nikhil> I've added a few items
14:50:57 <nikhil> etherpad was created by Flavio (last week I think)
14:51:07 <nikhil> we'd use it at the contri meetup
14:51:13 <nikhil> (at the summit)
14:51:23 <nikhil> this was a info update
14:51:24 <nikhil> moving on
14:51:49 <nikhil> #topic     CP summit sessions
14:52:20 <nikhil> we need volunteers to be present at the _different_ CP sessions
14:52:32 <nikhil> I'd like to co-ordinate with the team so that we cover the breadth
14:53:02 <nikhil> #action nikhil: create etherpad to gather info regarding CP sessions interest from glance team
14:53:15 <nikhil> moving on
14:53:18 <nikhil> #topic     Glance mid cycle
14:53:36 <nikhil> I got a first confirmation regarding the midcycle to happen in Boston
14:53:46 <nikhil> it will be from June 8-10
14:54:00 <mfedosin> why so early?
14:54:01 <nikhil> let me know by Tuesday next week if you've any concerns
14:54:10 <nikhil> otherwise that will be the final plan
14:54:16 <nikhil> it's right after m1
14:54:26 <jokke_> it's overlapping with OpenStack Day Ireland
14:54:29 <nikhil> and we'd have the spec freezer around m2
14:54:37 <jokke_> which is at 10th
14:54:51 <nikhil> jokke_: so would people prefer Mon-Wed instead?
14:55:01 <mclaren> I saw a mail, but was there some discussion on the venue at all?
14:55:12 <nikhil> mclaren: I'm trying to move fast this time
14:55:18 <nikhil> as I want to discuss import work
14:55:26 <nikhil> at the mid cycle too
14:55:37 <nikhil> Boston is almost at the midpoint for
14:55:42 <nikhil> west coast and EU zone
14:55:48 <jokke_> Honestly don't take my comments too heavy in. Just wanted to point that out. I'm unlikely to participate anyways
14:56:01 <nikhil> I'd love to have mclaren sabari rosmaita to the very least at the venue
14:56:10 <nikhil> make sense?
14:56:26 <nikhil> feel free to give me your suggestions
14:56:41 <mclaren> I was going to blow people's minds and suggest a non-US venue for a change (we've hosted a couple of mid-cycles here in Galway for example)
14:56:45 <nikhil> this is WIP right now, nothing final no commitments made yet
14:56:55 * rosmaita mind is blown
14:57:03 * nikhil too
14:57:05 <mclaren> lol, too easy
14:57:29 <mclaren> anyway, wanted to throw that out there rather than put a spanner in the works
14:57:37 <nikhil> absolutely
14:57:42 <jokke_> if it's Galway, I might be more likely preset (in the case I will be let into the building) :P
14:57:44 <mfedosin> mclaren: +1 for Galway - you have good beer
14:57:51 <rosmaita> +1
14:57:54 <jokke_> ++
14:57:57 <nikhil> and thanks for proposing (assuming: and willing to sponsor :D)
14:58:21 <rosmaita> quick poll: likely to get more attendance in galway vs. boston?
14:58:24 <jokke_> iirc flaper might be here around that time as well ;)
14:58:33 <nikhil> btw, 2 mins
14:58:38 <nikhil> reply to that thread
14:58:51 <nikhil> I want to know who can and can't make it there
14:59:03 <mclaren> I'd probably be able to make both I think
14:59:09 <rosmaita> ok, will check with my manager this afternoon
14:59:14 <rosmaita> i really want to go to galway
14:59:22 <jokke_> 1min!
14:59:27 <jokke_> ;)
14:59:29 <mfedosin> Galway!
14:59:33 <mclaren> we have outdoor and indoor activities :-)
14:59:37 <nikhil> we can discuss summit topics next meeting
14:59:57 <jokke_> lets get the Galway option to the mailchain
14:59:59 <mclaren> http://blog.petercmurphy.com/wp-content/uploads/2012/06/DSC_1928.jpg  http://dd73muqoroywk.cloudfront.net/images/detailed/5/G6046.jpg?t=1428042089
15:00:00 <rosmaita> and on the etherpad .... please record your interest, everyone
15:00:04 <jokke_> and/or ML
15:00:08 <nikhil> I will have another theard around virtual meetup before summit
15:00:17 <rosmaita> etherpad for design topics, i mean
15:00:25 <nikhil> jokke_: only if there won't be delay
15:00:34 <jokke_> Thanks all!
15:00:37 <nikhil> otherwise I'm going with what's planned
15:00:41 <jokke_> we're out of time
15:00:42 <nikhil> Thanks all for joining!
15:00:44 <nikhil> #endmeeting