14:00:40 <nikhil> #startmeeting glance
14:00:42 <openstack> Meeting started Thu Apr 14 14:00:40 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:46 <openstack> The meeting name has been set to 'glance'
14:00:48 <nikhil> #topic agenda
14:00:49 <jokke_> specially the ones that has coffee and buns
14:00:57 <nikhil> :)
14:00:59 <nikhil> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:59 <hemanthm> o/
14:01:10 <flaper87> o/
14:01:23 <nikhil> Looks like the agenda filled up pretty recently
14:01:28 <rosmaita> o/
14:01:33 <nikhil> we should need the full hour more or less
14:01:42 <nikhil> #topic     Update from other teams
14:01:53 <nikhil> #info Glare updates ( mfedosin )
14:01:59 <mfedosin> hello!
14:02:09 <mfedosin> no big changes during last week
14:02:24 <mfedosin> we stabilize our code and preparing to a big demo
14:02:41 <mfedosin> kairat added tooz support to prevent race conditions
14:02:56 <nikhil> that's great news!
14:03:03 <mfedosin> dshakhray implemented filtering and sorting support for artifacts
14:03:35 <mfedosin> all desired features are imlemented so I'm going to concentrate on the spec next week
14:03:56 <nikhil> kudos
14:04:19 <nikhil> Thanks mfedosin
14:04:29 <mfedosin> welcome :)
14:04:35 <nikhil> moving on
14:04:36 <nikhil> #info Nova v1 v2
14:04:45 <nikhil> mfedosin: that's mostly you
14:04:49 <mfedosin> I updated the spec
14:05:06 <mfedosin> #link https://review.openstack.org/#/c/301741/4
14:05:20 <mfedosin> I think it's ready to merge
14:05:27 <nikhil> :)
14:05:56 <mfedosin> also I fixed race conditions in commits and waiting John to remove -2
14:06:13 <mfedosin> not race conditions, sorry
14:06:17 <mfedosin> merge conflicts
14:06:55 <nikhil> ok
14:06:59 <nikhil> headsup: I read some of the latest comments from matt and sean on ML that indicate we need to sync and decide on glanceclient scope for this spec
14:07:03 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/092153.html
14:07:05 <mfedosin> nikhil: may I ask you about summit session?
14:07:14 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/092158.html
14:07:16 <nikhil> mfedosin: sure
14:07:24 <mfedosin> it will be combined with Nova team, right?
14:07:46 <nikhil> it's officially nova session that is tagged for glance too
14:08:07 <mfedosin> when will it be?
14:08:12 <mfedosin> do you remember?
14:08:16 <nikhil> so, we can expect turn-out from both teams
14:08:24 <nikhil> all glance tagged sessions are here:
14:08:34 <nikhil> #info glance tagged summit sessions https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=glance
14:08:56 <nikhil> #info nova session with glance on image v2 https://www.openstack.org/summit/austin-2016/summit-schedule/events/9083?goback=1
14:09:21 <nikhil> anything else?
14:09:36 <mfedosin> no, thanks :)
14:09:57 <nikhil> yw
14:10:14 <nikhil> #info cross-project updates
14:10:24 <nikhil> there was no meeting and nothing raised this week
14:10:39 <nikhil> as usual, do visit the community blog post
14:10:53 <nikhil> the cross project session list is up in schedule
14:11:23 <nikhil> I have requested a few signups for cross project session attendees here:
14:11:25 <nikhil> #link https://etherpad.openstack.org/p/newton-glance-summit-planning
14:11:34 <nikhil> line 345 onwards
14:11:57 <nikhil> basically we should try to cover as many sessions as possible as a team
14:12:24 <nikhil> for someone signed up on two sessions at the same time, please add your name instead if you are free then
14:12:50 <nikhil> I wanted to correct some information that I provided during the sync
14:13:10 <nikhil> tuesday full day design summit is CP but there are still main summit tracks that run parallel to this
14:13:43 <nikhil> so in case you _do_ have signed up for a session, you can re-think about your priority towards main summit session too if that's relevant
14:14:07 <nikhil> another note: all sessions marked as in the etherpad (**) are important for us
14:14:11 <nikhil> that's it
14:14:34 <nikhil> #topic announcements
14:14:51 <nikhil> wanted to get a quick poll on the next two meetings
14:15:16 <nikhil> #startvote have the meeting on april 21 (next week)? yes, no, maybe
14:15:16 <openstack> Begin voting on: have the meeting on april 21 (next week)? Valid vote options are yes, no, maybe.
14:15:17 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:15:50 <nikhil> I will take no answer as "NO" (as I don't have agenda)
14:15:58 <nikhil> #vote no
14:16:08 <nikhil> counting 1
14:16:12 <nikhil> counting 2
14:16:13 <hemanthm> #vote no
14:16:14 <avarner> #vote maybe
14:16:15 <mclaren> #vote maybe
14:16:18 <rosmaita> #vote maybe
14:16:24 <abhishek> #vote maybe
14:16:33 <rosmaita> mclaren: maybe we can have import meeting in this timeslot if no reg meeting
14:16:59 <nikhil> #endvote
14:16:59 <jokke_> #vote yes
14:17:00 <openstack> Voted on "have the meeting on april 21 (next week)?" Results are
14:17:01 <openstack> maybe (4): avarner, abhishek, mclaren, rosmaita
14:17:02 <openstack> no (2): hemanthm, nikhil
14:17:09 <mclaren> rosmaita: fine by me
14:17:11 <nikhil> ok, we will see
14:17:25 <nikhil> I will update on wednesday if agenda is updated or not
14:17:59 <nikhil> #info We won't have the weekly meeting during summit ie on April 28th
14:18:14 <nikhil> Thanks for your input
14:18:18 <nikhil> moving on
14:18:34 <nikhil> #topic descriptions of the summit sessions
14:18:57 <nikhil> firstly, find the list of all glance sessions:
14:19:02 <nikhil> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Glance%3A
14:19:32 <nikhil> #info the above list refers to design summit Glance sessions
14:20:02 <nikhil> and that query doesn't show sessions tagged by other teams
14:20:34 <nikhil> also, we need to update the descriptions of the Fishbowl sessions specifically
14:20:58 <nikhil> I took the liberty to copy over data from the summit planning etherpad and modified a little bit (mostly grammar)
14:21:26 <nikhil> I need input from you so that the sessions cover the following items in the description (copying from my email):
14:21:43 <nikhil> what's the problem it's trying to solve
14:21:50 <nikhil> what's currently out there
14:21:55 <nikhil> what are best practices, feedback and experiences from cross-prj or other teams
14:21:59 <nikhil> what is the scope of the current proposal or are you posing questions via. this topic
14:22:03 <nikhil> what has been discussed, what are/were the blockers and any other reference information
14:22:25 <nikhil> We need a good chunk of that info up in the descriptions so that people know what they are about
14:22:44 <nikhil> Although, this rule also applies to work sessions, I am insisting on FB ones first
14:23:03 <nikhil> if I don't get input, I will take the liberty to update them myself as per my perspective
14:23:15 <nikhil> questions?
14:23:30 <rosmaita> timeframe for completion?
14:23:55 <nikhil> the cut off time from summit planners is EOW (this week)
14:24:12 <nikhil> so, any time by 7pm ET tomorrow should work
14:24:20 <rosmaita> thanks
14:24:34 <nikhil> moving on
14:24:39 <nikhil> #topic Mid-cycle
14:25:18 <nikhil> I've announced this on the ML, just bringing it here so that it's not lost in your inbox. I noticed that a few people missed my ML updates.
14:25:25 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/092009.html
14:26:10 <rosmaita> could we maybe get a list of people who are interested in remote attendance?
14:26:20 <nikhil> The etherpad (wiki) is in the email. Please start planning your travel as soon as possible. I know it's a bit hectic period, close to summit, but after the summit may delay things.
14:26:22 <rosmaita> (it suddenly looks like i will be one of those people)
14:27:02 <nikhil> rosmaita: sure, please feel free to create a section for remote attendance or add remote, maybe remote, etc. tags against your RSVP name on the etherpad
14:28:20 <nikhil> #action all: please RSVP your confirm or tentative plans for the mid-cycle on https://etherpad.openstack.org/p/newton-glance-midcycle-meetup . It would be good to get a list of remote attendance.
14:28:51 <nikhil> questions?
14:29:12 <nikhil> moving on
14:29:20 <nikhil> #topic Provide a list of request ids to the caller (abhishekk)
14:29:26 <abhishek> hi,  https://blueprints.launchpad.net/python-glanceclient/+spec/return-request-id-to-caller was accepted for mitaka and needs to be changed to newton
14:29:57 <abhishek> and https://review.openstack.org/#/c/261288/  is up for quite long time, needs review
14:30:23 <jokke_> abhishek: have you proposed change for that move in the specs repo?
14:30:35 <jokke_> or someone else?
14:30:58 <abhishek> jokke_: specs was not submitted for this as it is approved in cross-project specs
14:31:31 <abhishek> then as per your suggestion, I have created a specs-lite last time
14:31:44 <jokke_> oh cool
14:32:07 <abhishek> jokke_: please refer, https://launchpad.net/bugs/1525259
14:32:18 <openstack> abhishek: Error: Could not gather data from Launchpad for bug #1525259 (https://launchpad.net/bugs/1525259). The error has been logged
14:32:18 <jokke_> just something we can track off so if there is spec lite (as in wishlist bug) we're tracking it
14:32:38 <nikhil> abhishek: oh nice, might be a good idea to quickly link that lite spec with the bp (as a URL for specification)
14:32:41 <jokke_> abhishek: as we agreed, there is no need to transfer that to the new lite-spec format for this cycle
14:33:04 <abhishek> nikhil: i will do that
14:33:07 <nikhil> thanks for bringing this up abhishek!
14:33:10 <abhishek> jokke_: ok
14:33:45 <abhishek> thank you, thats it from my side
14:33:45 <nikhil> I will talk about reviews and review day in the later in the meeting (impromptu addition)
14:33:45 * jokke_ really needs to fix the lite-spec documentation
14:34:09 <nikhil> we need to talk about that, prolly during contri meetup last session
14:34:32 <nikhil> anyway, let's give enough time for import :)
14:34:36 <nikhil> moving on
14:34:42 <nikhil> #topic Notes on image import implementation tactics (mclaren)
14:35:03 <nikhil> mclaren:  thanks for the link
14:35:05 <nikhil> #link https://etherpad.openstack.org/p/glance-image-import-implementation-tactics
14:35:08 <mclaren> Sure
14:35:21 <nikhil> firstly, how is this different from what we want to discuss at the summit
14:35:27 <mclaren> This is just a bit of a brain dump really
14:35:55 <nikhil> ah I see, thanks
14:36:03 <mclaren> But having thought it through it does look like we can avoid some complex stuff
14:36:09 <rosmaita> i think it's a good clarification
14:36:29 <mclaren> eg having to store two image blobs at once
14:37:13 <mclaren> I'd be interested if folks wanted to read through and see if they generally agreed/spotted any holes
14:37:55 <mclaren> (eg drop me a mail)
14:38:21 <nikhil> mclaren: I think all are browsing through it atm
14:38:24 <rosmaita> oops, i already started putting comments right on the etherpad
14:38:39 <mclaren> oh yeah, that works too!
14:38:57 <nikhil> mclaren:  It's pretty detailed and explicitly written. Only have my love for it atm!
14:39:22 <nikhil> in fact, I was planning to start some tiny discussions around this
14:39:47 <nikhil> may be we go ahead and start defining (formally in a spec) what we want to target for newton
14:40:02 <mclaren> Thanks. If we really can punt on some of the complex stuff it does make getting something that 'works' sooner possible
14:40:39 <nikhil> agreed.
14:41:04 <mclaren> I'll check for feedback on the ether pad later. Thanks, that's all I had.
14:41:43 <nikhil> looks like a excellent plan
14:42:20 <nikhil> in the meanwhile: I will try to gauge interest, internal commitments, preferences, etc. and plan a timeline around this
14:43:17 <nikhil> And then use the plan your poise along with developer/reviewer time to sketch out the remnanats
14:43:21 <rosmaita> jokke_: is that you putting comments in purple?
14:44:07 <jokke_> rosmaita: yup
14:44:36 <nikhil> rosmaita: I had a feeling that defcore would be lenient on the timeline and not need 3 cycles?
14:44:58 <rosmaita> well, i'm not sure the timeline is really the issue
14:45:17 <rosmaita> as far as defcore is concerned, they would like glance to have a single API for end-users to get images into the cloud
14:45:35 <rosmaita> the API can be "flexible" as outlined on the spec
14:45:50 <rosmaita> but we need to hit the widest use cases first, as stuart says
14:46:04 <nikhil> widest == most popular ?
14:46:26 <mclaren> not that it matters, but I wasn't really thinking about widest use cases, more minimally scoped code.
14:46:28 <rosmaita> i guess so, measured in number of clouds, not number of users
14:46:46 <nikhil> I see
14:46:52 <nikhil> thanks rosmaita
14:47:08 <rosmaita> mclaren: i'm thinking of the point you made in the pre-summit conference aobut even a physics dept cloud should use image import, not direct upload
14:47:18 <rosmaita> even though all users are smart and trusted
14:47:35 <rosmaita> that way, it's same interface across all clouds
14:47:42 <mclaren> sure
14:47:57 <rosmaita> so to make that happen, i think we need to go with stuart's plan for glance-direct first implementation
14:48:14 <rosmaita> (much as i'd rather do the swift-based one)
14:48:20 <mclaren> rosmaita: then we aim for a sociology dept? ;-)
14:48:21 <nikhil> yes, and I doubt if there's any other way
14:48:25 <nikhil> LOL
14:48:42 <rosmaita> mclaren: not sure i can handle postmodern virtual machine images
14:48:46 <mclaren> lol
14:48:57 <nikhil> rosmaita: yeah, I doubt if this will be MVP (or considered MVP by some) unless we implement swift based one too
14:49:19 <mclaren> anyway, we've a skeleton to talk through at the summit I guess
14:49:22 <nikhil> it being that main reason for this refactor
14:49:50 <nikhil> how about we start working on a spec for this before the summit so that we know what we are discussing on?
14:50:01 <rosmaita> ummm... i think we have a spec
14:50:06 <rosmaita> approved, and everything
14:50:08 <jokke_> rosmaita: ++
14:50:13 <nikhil> well it's a direction
14:50:22 <rosmaita> spec actually says glance-direct will be done first
14:50:31 <nikhil> we still don't have implementation details and know what are our constraints
14:50:50 <nikhil> for eg. what are the operator impacts with this import way vs. regular way
14:50:57 <mclaren> not sure a spec is needed -- let's discuss at summit?
14:50:59 <nikhil> (ref. staging area)
14:51:50 <nikhil> sure, I don't mind having this in a etherpad (no spec in that case) just need to know what, when, how for newton
14:51:56 <rosmaita> my feeling is let's work on stuart's etherpad (within the constraints of the approved spec) before hte summit, then at the summit we'll be in a good position to assign work items and realistically see what can be deliverd in newton
14:53:06 <nikhil> because, I can't be really tentative in my communications of 1) proposer: we have this feature for newton, will you be able to get that in ? -- ans (nikhil): I don't know, I can't say 2) proposer: when will you know ? nikhil: I don't know
14:54:06 <nikhil> as long as we agree to agree (and not agree to disagree or more) at the summit, it's fine with me
14:54:30 <rosmaita> well, we will know more at the summit ... i mean, the api is set, no more arguing about that, we (me & stuart) can work on implementation details between now and hte summit
14:54:59 <nikhil> rosmaita: cool, that sounds good. I'd love to be involved in the implementation details too.
14:55:08 <nikhil> let me move on for now
14:55:20 <nikhil> #topic open discussion
14:55:21 <rosmaita> oh, sure, don't mean to exclude anyone ... everyone is welcome to join in the mess!
14:55:53 <mfedosin> folks, do you know about an issue in glance v1?
14:55:56 <nikhil> rosmaita: I think it's a fun challenging work item! Can't wait to get my hands on (some or more) of the code for this!!!!!
14:56:05 <jokke_> mfedosin: plenty :)
14:56:15 <mfedosin> you can't sort by public images there
14:56:22 <nikhil> mfedosin: well, it's glance v1 for first :P
14:56:26 <mclaren> mfedosin: how do you mean?
14:56:29 <avarner> This will be my last weekly meeting, due to a change in job responsibilities. I'm no longer working on glance, although I do plan to finish the items assigned to me.
14:56:37 <mfedosin> if you provide is_public=true then it list all images
14:56:49 <mclaren> heh, give me one second, there's a link for that
14:56:58 <mfedosin> darja told me today, but I haven't checked yet
14:57:03 <nikhil> avarner:  Thanks Drew, for letting us know! I'd like to sync offline a bit more on that with you.
14:57:12 <jokke_> avarner: sorry to hear, are you staying withing OpenStack still, and thanks for everything you have done!
14:58:08 <mclaren> mfedosin: http://docs.openstack.org/developer/glance/glanceapi.html Note Use of the is_public parameter is restricted to admin users. For all other users it will be ignored.
14:58:44 <avarner> jokke_, I'll be working on container stuff in IBM, probably not much Openstack
14:58:45 <mfedosin> mclaren: ah, cool! thank you
14:58:50 <nikhil> btw, do people need email sent from me endorsing the utmost necessity for your presence at the mid-cycle to help you talk with the managers? (this is serious question)
14:59:07 <jokke_> avarner: well best of luck then for your future adventures
14:59:14 <rosmaita> nikhil: yes for me, don't know if it will have any effect, though
14:59:24 <mclaren> mfedosin: the v1 is_public filter was always kinda broken
14:59:24 <avarner> jokke_, thanks!
14:59:27 <nikhil> rosmaita: it doesn't hurt to try!
14:59:28 <nikhil> :)
14:59:28 <jokke_> nikhil: won't change a thing
14:59:39 <nikhil> jokke_: oopsie :/
14:59:51 <mfedosin> "Use of the is_public parameter is restricted to admin users" but it doesn't work even for admins now
15:00:19 <rosmaita> mfedosin: we've had to disable image-list for admins by policy in our cloud
15:00:26 <nikhil> yeah
15:00:28 <rosmaita> too many images
15:00:32 <mfedosin> we had to disable v1
15:00:43 <nikhil> yeah -> is_public filtering is tricky indeed
15:00:58 <nikhil> we're out of time
15:01:04 <mclaren> mfedosin: hmm, might be a bug so?
15:01:04 <nikhil> Thanks all for joining!
15:01:07 <jokke_> thanks!
15:01:15 <rosmaita> nova uses image_type to distinguish base images from snapshots
15:01:33 <mfedosin> will check in a moment
15:01:35 <nikhil> guys, I think SL team is waiting for us to finish
15:01:41 <nikhil> let's sync on -glance
15:01:45 <nikhil> thanks again
15:01:48 <nikhil> #endmeeting