14:00:18 <nikhil> #startmeeting glance
14:00:23 <openstack> Meeting started Thu May 19 14:00:18 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:26 <openstack> The meeting name has been set to 'glance'
14:00:29 <nikhil> #topic agenda
14:00:36 <nikhil> Welcome everyone
14:00:38 <bpoulos> o/
14:00:40 <nikhil> we've a small agenda today
14:00:41 <sudipto> o/
14:00:46 <nikhil> ohai bpoulos
14:00:49 <nikhil> welcome back
14:00:51 <bpoulos> hello, thanks!
14:00:51 <nikhil> congrats!!!
14:00:58 <jokke_> bpoulos: \o
14:01:02 <bpoulos> thank you :)
14:01:05 <rosmaita> o/
14:01:08 <nikhil> how's your 'boy?'?
14:01:10 <jokke_> bpoulos: all good?
14:01:17 <bpoulos> doing very well, 15 pounds already!
14:01:24 <mfedosin> how did you call him?
14:01:27 <tsymanczyk> mazel tov
14:01:28 <bpoulos> Gregory
14:01:58 <nikhil> nice! good news indeed :)
14:02:19 <nikhil> so, here's the agenda for today:
14:02:25 <nikhil> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:41 <nikhil> Please be mindful of the dates when you propose the agenda
14:03:05 <nikhil> I usually keep next week's agenda open in case this week's full
14:03:33 <nikhil> We have decided to limit the agenda to only 4 items per meeting (besides updates and open discussion)
14:03:52 <nikhil> #action nikhil update the etherpad with more info on adding items to agenda
14:04:09 <nikhil> Let's get started.
14:04:15 <nikhil> #topic Updates
14:04:25 <nikhil> #info Glare updates ( mfedosin )
14:04:42 <mfedosin> hello again
14:04:52 <mfedosin> two main things
14:05:02 <mfedosin> 1. api spec
14:05:15 <mfedosin> I think we are ready to public discussion
14:05:50 <mfedosin> for that reason I'll update the spec, add API examples that Darja made and upload new PS today
14:06:09 <mfedosin> then I'm going to send a message to ML and ask for review
14:06:30 <mfedosin> I hope it will be done early tomorrow
14:06:49 <mfedosin> 2. Glare code
14:07:12 <mfedosin> Kairat and Darja are fixing bugs
14:07:26 <mfedosin> 6 of known 7 are done
14:07:38 <mfedosin> that means that code is pretty stable at the moment
14:07:41 <jokke_> nice
14:07:49 <nikhil> mfedosin: this is good news indeed
14:07:58 <nikhil> we're getting to discussion early in cycle
14:08:03 <mfedosin> we still have to add several features
14:08:29 <nikhil> ok
14:08:31 <mfedosin> but my proposal, that in early June we'll start to prepare the code for merging
14:08:51 <mfedosin> kairat: dshakhray correct me if I'm wrong
14:09:07 <kairat> I hope so
14:09:31 <mfedosin> but now, we need to concentrate on the spec
14:10:13 <mfedosin> if API is agreed, then we can start implementing glare client
14:11:00 <mfedosin> I think this is all the updates at the moment.
14:11:06 <nikhil> mfedosin: I think we need next meeting to decide on the features later (including more code like client). we agreed to a skeleton patch first, just to make sure that the team can focus on the bare minimum code.
14:11:21 <nikhil> mfedosin: and on the note to ML please link all tags that were interested. we need everyone on same page when it comes to the API!
14:11:37 <mfedosin> yeah, sure
14:11:51 <nikhil> #info Nova v1, v2 ( mfedosin , sudipto )
14:11:59 <nikhil> #link https://review.openstack.org/#/c/301741/
14:12:21 <mfedosin> hooray
14:12:22 <nikhil> SO, great news
14:12:36 <mfedosin> thanks sudipto and flaper87
14:12:36 <nikhil> we have 3 different people +2 on it already
14:12:47 <nikhil> great job all three!
14:13:00 <sudipto> cheers mfedosin nikhil
14:13:02 <nikhil> (Acutally let's inclde Eddie on this good news too)
14:13:24 <nikhil> SO, what remains?
14:13:33 <nikhil> sudipto: mfedosin  ?
14:13:48 <mfedosin> emm, I think we need some clarification about v2 gate
14:14:07 <nikhil> mfedosin: I can update that later
14:14:18 <sudipto> from the coding front, i think we are sorted.
14:14:35 <nikhil> there was a mention about some code changes required in sudipto 's later spec patches?
14:14:35 <mfedosin> because it blocks me from writing the code
14:15:00 <nikhil> k
14:15:02 <mfedosin> also I updated sudipto's second patch
14:15:16 <mfedosin> and fixed unit tests there
14:15:28 <mfedosin> will upload new PS in a moment
14:15:47 <nikhil> thx mfedosin
14:16:07 <mfedosin> also, as I mentioned, code is done
14:16:15 <mfedosin> it's WIP but anyway
14:16:33 <mfedosin> #link https://review.openstack.org/#/c/316440/
14:17:17 <mfedosin> unit tests will be fixed in sudipto's commit
14:17:33 <sudipto> yeah
14:17:59 <sudipto> So i am in sync with mfedosin and we should be able to put out all the reviews shortly after the spec is merged.
14:18:18 <mfedosin> the main point is that all tempests are good :)
14:18:35 <mfedosin> sudipto: even earlier :)
14:18:58 <sudipto> mfedosin, sure. Also I will work on the driver changes - that still use v1 - like i discussed with you.
14:19:24 <sudipto> mfedosin, i think we might be able to merge the spec today :)
14:19:25 <nikhil> ok, great stuff.
14:19:25 <mfedosin> what driver again?
14:19:32 <mfedosin> ah
14:19:33 <nikhil> Let's focus on the spec first
14:19:50 <mfedosin> now spec is not our job
14:20:08 <mfedosin> let's nova team review and merge it :)
14:20:13 <nikhil> That should be our priority, but looks good for now. Just keep an eye out for any last minute reviews :/
14:20:13 <mfedosin> *let
14:20:33 <sudipto> nikhil, sure.
14:20:37 <mfedosin> also I have related question...
14:20:49 <mfedosin> but let's postpone it to Open Discussion
14:20:55 <nikhil> mfedosin: this is openstack, we can only talk about merge only after the release. there are no guarantees until then.
14:21:11 <nikhil> let
14:21:28 <nikhil> let's move on, we need to have this detailed sync 30 mins before artifacts meeting on monday
14:21:35 <nikhil> let's keep our thursday updates small
14:21:51 <nikhil> Thanks much sudipto  mfedosin
14:21:58 <nikhil> #info Releases
14:22:14 <nikhil> So, we're approaching newton-1
14:22:21 <nikhil> newton-1 Thursday June 2:
14:22:33 <mfedosin> oh... so fast
14:22:35 <nikhil> http://releases.openstack.org/newton/schedule.html
14:22:51 <nikhil> yes, so just one more week and the week after we will tag newton 1
14:23:13 <nikhil> although the release page says thursdays are generally the dates when the release is cut
14:23:14 <nikhil> let
14:23:35 <nikhil> let's make sure that we get things done by Monday so that release team can cut the same on Tuesdays
14:24:03 <nikhil> That means all reviews to be done by Friday and keeping Monday for gate, last minute additions, etc. reviews
14:24:17 <nikhil> Thanks!
14:24:23 <nikhil> #info Announcements
14:24:56 <nikhil> 1) Should we cancle the mid-cycle or there's last minute interest developed? Last time I checked there were 4 who were almost confirmed.
14:25:09 * nikhil waits for feedback
14:25:31 <tsymanczyk> things have changed slightly here. i don't know that i could get approved anymore.
14:25:36 <mfedosin> unfortunately I won't be able to come :(
14:25:43 <jokke_> same here
14:26:00 <rosmaita> by "cancel" i assume you mean "make into a virtual meeting" ?
14:26:11 <mfedosin> right
14:26:36 <nikhil> rosmaita: surely. but the plan is to have regular (~monthly) virtual meetings so, not exactly substitution.
14:27:12 <nikhil> I was going to propose a virtual one right after newton 1
14:27:30 <nikhil> and the one after can be around our midcycle dates.
14:27:36 <rosmaita> works for me
14:27:57 <kairat> +1 to virtual only
14:28:08 <nikhil> Atleast for a few things, so that we're not proposing another 4 hour slots everytime.
14:28:19 <nikhil> ok, thanks all.
14:28:42 <nikhil> #agreed Glance midcycle meetup to be cancelled cc/ sabari
14:28:55 <nikhil> #info Priorities
14:29:22 <nikhil> I started a WIP review last week but due to ML discussions it is in delay.
14:29:31 <nikhil> here's a patch up:
14:29:36 <nikhil> #link https://review.openstack.org/#/c/315752/
14:30:09 <nikhil> I've also sent announcement email on the priorities and processes. Will be taking that into account before this is final.
14:30:36 <nikhil> Good points brought up by a few people over last few weeks, something that's been communicated in different threads:
14:30:53 <nikhil> Side-priorities (in Mitaka it was called priorities w/o clear plan)
14:30:54 <mfedosin> nikhil: just curious about Glare there
14:31:11 <nikhil> Elements that will need more baby sitting, are non-controvertial and less research or dependencies.
14:31:27 <nikhil> They should be considered side-priorities.
14:31:46 <mfedosin> I think we have to say several words about artifacts in this doc, right?
14:31:57 <nikhil> Currently, we've Glare, registry and v1 deprecation and part of categorization effort. Also, we should include lite-specs.
14:32:24 <nikhil> mfedosin: correct, this is all as per what we agreed at the summit.
14:32:29 <hemanthm> can we document them as well?
14:32:35 <nikhil> mfedosin: the more info we can provide the better it will be.
14:33:02 <mfedosin> also I think we must include sudipto in Nova v1-v2 work
14:33:18 <nikhil> hemanthm: yes, I plan to include as much info on that review. you can provide feedback on gerrit while we work on them collaboratively. BUT we need to stay very close to what has been agreed at the summit.
14:33:28 <mfedosin> nikhil: currently only me, you and flaper87 are listed there
14:33:31 <hemanthm> nikhil: +1
14:33:39 <nikhil> mfedosin: noted
14:34:04 <nikhil> mfedosin: you not giving me any cake for all my reviews on your spec ;-) (jk)
14:34:19 <nikhil> anything else?
14:34:40 <nikhil> moving on, then..
14:34:48 <nikhil> #topic Lite-specs process finalizing
14:34:49 <mfedosin> nick-ma: in Barselona
14:34:59 <mfedosin> *nikhil:
14:35:39 <nikhil> mfedosin: ?
14:35:57 <nikhil> mfedosin: if not on lite-specs we need to discuss later. running short of time atm.
14:36:03 <sudipto> nikhil, guess he means the cake. :)
14:36:27 <nikhil> sudipto: mfedosin : gotcha. I am looking forward to it. you said it now ;)
14:36:34 <mfedosin> sudipto: correct :)
14:36:37 <nikhil> #link https://review.openstack.org/#/c/315339/
14:36:41 <jokke_> there was lots of good comments in the review for lite-spec doc change
14:36:50 <nikhil> yes, thanks!
14:37:01 <nikhil> So, we need the following:
14:37:13 <nikhil> 1) use-case, very good problem statement
14:37:31 <nikhil> 2) all the affected domains (notification, security, operator, end user, etc)
14:37:48 <jokke_> if we're using the same template, it's quite self explanary
14:37:54 <nikhil> 3) scope of the implementation, hurdles or any workarounds that we need to do
14:38:28 <nikhil> As of current proposal by flaper87 , there's no enforcement on using that template.
14:38:45 <hemanthm> I think that was implied
14:38:56 <nikhil> there's loose coupling with what we need and what's expected.
14:39:08 <hemanthm> use the template for the content on the commit message
14:39:33 <jokke_> I did read that ... I'd like to see us enforcing renos and proper commit messages before we agree using them as lite-specs
14:39:53 <nikhil> #action all interested on lite-specs: please explicitly state what your thougts are on the proposal(s)
14:39:53 <jokke_> no-one is writing them currently
14:39:59 <nikhil> ok, good point jokke_
14:40:01 <kairat> ok
14:40:15 <kairat> I am also in favor of reno and cm only
14:40:23 <nikhil> let's make sure that we get that in the reviewer's guide
14:40:30 <kairat> we don't have enough review bandwidth for specs
14:40:30 <nikhil> I don't mind as long as:
14:40:31 <hemanthm> although I'm not sure if we can drop indexing like flaper87 mentioned in his latest comment
14:40:36 <nikhil> 1) they are discoverable
14:40:49 <nikhil> 2) they can be used for referencing outside of glance or code
14:41:12 <nikhil> 3) people won't have to click on 15 pages underneath the doc page to look for them
14:41:29 <nikhil> we're getting a lot of heat on documentation so we need to ensure we increase docs at least two folds
14:42:01 <nikhil> kairat: having them in specs makes us aware of the review bandwidth we can commit to them in a cycle
14:42:34 <nikhil> the point I'm tring to make is we get specs and lite-specs done first in cycle (before 15th June on soft freeze and early July on hard freeze)
14:42:45 <jokke_> that's the second problem there ... the drivers to move lite-specs to the glance-specs repo were following: 1) no-one is writing the renos 2) we need to document out new features at least somewhere where they are all easily findable 3) amendments to the old specs like Niall's deactivation stuff
14:42:48 <nikhil> that way we know what's in the pipe and what we can actually tackle
14:43:44 <jokke_> yes bandwith planning was the number 4
14:43:52 <hemanthm> with what flaper87 proposed, we don't have to do spec reviews separately for lite-specs
14:43:55 <kairat> Hmm, I am not sure review for specs will give us enough info about planning
14:44:12 <kairat> because usually it just doubles review time for me
14:44:16 <kairat> will describe that in spec
14:44:21 <nikhil> but we don't know how much we need to review and how much we can ignore in a cycle
14:44:44 <nikhil> I don't want proposers thinking and pushing before newton-3 that it's possible for them to propose something and get it merged
14:44:57 <nikhil> we need a way to avoid many behavior changes in one cycle
14:45:05 <nikhil> and we need to do that early
14:45:09 <hemanthm> +1
14:45:25 <nikhil> ok, we can keep this discussion going on the review
14:45:34 <hemanthm> I guess having the lite-spec and code in the same commit doesn't help with planning much
14:45:50 <nikhil> right
14:45:55 <nikhil> So, there are good points raised here, please make sure you jot them down completely on that review patch.
14:45:56 <jokke_> sure I retype my points there as gerrit was so nice and wiped my last round earlier today
14:46:08 <nikhil> (please do not be implicit)
14:46:46 <nikhil> ok, moving on for now.
14:47:10 <nikhil> #topic Codec can't encode characters
14:47:17 <nikhil> #link https://review.openstack.org/#/c/316054/
14:47:28 <nikhil> dshakhray: floor is yours
14:47:30 <mfedosin> okay, it's dshakhray's fix
14:47:54 <mfedosin> I thinks she wants you to review the code
14:48:24 <nikhil> k
14:48:37 <dshakhray> yes, only review)
14:48:39 <mfedosin> headers were encoded in HTTPclient
14:49:07 <mfedosin> but when we started to use SessionClient they are not
14:49:20 <mfedosin> so Darja fixed it :)
14:49:33 <nikhil> cool
14:49:45 <nikhil> let's get that reviewed then
14:50:04 <nikhil> #topic open discussion
14:50:18 <nikhil> there's another request for review here:
14:50:18 <mfedosin> I wanted to ask one thing...
14:50:23 <nikhil> Return request-id to caller
14:50:31 <jokke_> dshakhray: change itself seems to make sense. Please be bit more verbal on the commit message. Currently the commit message and the change are not telling the same story
14:50:38 <abhishek> hi, need reviews for return request id to caller, have proposed two solutions, https://review.openstack.org/#/c/261288/ and https://review.openstack.org/#/c/316052/
14:50:45 <nikhil> https://review.openstack.org/#/c/261288/
14:50:46 <nikhil> https://review.openstack.org/#/c/316052/
14:51:00 <abhishek> 2nd one is proposed by Brant and Cao, please provide your feedback on it as per time permits
14:51:03 <nikhil> +1 to jokke_  on commit message
14:51:14 <nikhil> mfedosin: please go ahead
14:51:32 <mfedosin> in Nova for some deployments we have to enable show_multiple_locations
14:52:07 <mfedosin> and if you read message from Heat in ML they always need it to use Glance v2
14:52:17 <jokke_> abhishek: do those overlap with 7150ceee1ac72361f75b3a4187e10a884166870d that I noticed had been merged lately
14:52:19 <nikhil> well
14:52:27 <mfedosin> but this option has a vulnerability
14:52:51 <abhishek> jokke_: let me have a look
14:53:24 <nikhil> mfedosin: for long term this is what we want to do https://review.openstack.org/#/c/313936/
14:53:35 <mfedosin> so, I propose to change image_location_quota default from 10 to 1
14:53:57 <mfedosin> nikhil: doesn't matter
14:54:04 <nikhil> that does reduce it a bit
14:54:17 <mfedosin> for Heat and Nova we have to allow to set custom locations for all users
14:54:35 <jokke_> that is really really problematic
14:54:46 <nikhil> mfedosin: I don't know why we need to allow for all users
14:54:47 <kairat> mfedosin, it may break some templates after glance upgrade
14:54:52 <abhishek> jokke_: could you please provide a link
14:55:16 <mfedosin> nikhil: to make snapshot, for example
14:55:16 <jokke_> the whole locations code is really really problematic as long as we do not have service tokens
14:55:26 <mfedosin> if this option is disabled...
14:55:31 <jokke_> abhishek: I don't have one ... that's commit id from glanceclient git log
14:56:09 <abhishek> jokke: ok I will have a look and let you know
14:56:23 <wxy> Here is one situation: Heat want to use Glance v2 instead of v1. But we can't set locations as v1 did by default.
14:56:23 <mfedosin> this won't work https://github.com/openstack/nova/blob/824c3706a3ea691781f4fcc4453881517a9e1c55/nova/virt/libvirt/imagebackend.py#L967
14:56:39 <mfedosin> https://github.com/openstack/nova/blob/824c3706a3ea691781f4fcc4453881517a9e1c55/nova/virt/libvirt/driver.py#L1517
14:56:43 <jokke_> mfedosin: are you saying that currently every deployment is changing that locations option on?
14:56:49 <nikhil> mfedosin: I thought that driver was already using v2 and image locations ?
14:56:56 <kairat> yes, because it uses v1
14:57:10 <mfedosin> no, it uses v1 to set location
14:57:11 <nikhil> mfedosin: and our scope should not increase beyond that driver
14:57:13 <kairat> wxy, thanks, i forgot about that
14:57:28 <nikhil> mfedosin: nova folks need to be more aware apparently
14:57:31 <nikhil> mfedosin: ok
14:57:34 <wxy> Heat team want to upgrade to v2
14:57:42 <nikhil> wxy: I am aware of that
14:57:56 <nikhil> wxy: and I have responded very clearly. but no response back !
14:58:16 <jokke_> nikhil: ++
14:58:20 <mfedosin> so, reducing this parameter from 10 to 1 will prevent a lot of bad issues
14:58:46 <nikhil> mfedosin: so for the 'lot' part, please start a email thread with the glance-core-sec for now
14:58:54 <nikhil> mfedosin: we can then involve people who have more to say
14:59:14 <mfedosin> ikay
14:59:16 <mfedosin> okay
14:59:21 <nikhil> rosmaita: you got a min
14:59:22 <jokke_> 2min
14:59:28 <jokke_> 1 left :P
14:59:32 <rosmaita> more like 30 sec
14:59:37 <nikhil> :)
14:59:39 <jokke_> type faster
14:59:47 <rosmaita> have a nice day, everyone
14:59:54 <nikhil> TravT: is generous in not kicking us out :)
14:59:55 <rosmaita> i will bug people individually in glance channel
15:00:04 <nikhil> ok
15:00:07 <TravT> :)
15:00:07 <nikhil> Thanks all!
15:00:14 <mfedosin> thanks
15:00:19 <jokke_> thanks all
15:00:20 <nikhil> #endmeeting