14:00:52 <rosmaita> #startmeeting glance
14:00:52 <openstack> Meeting started Thu Jun 30 14:00:52 2016 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:53 <rosmaita> #topic agenda
14:00:53 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:53 <rosmaita> hello everyone
14:00:53 <rosmaita> hope you are having/have had a pleasant day in your time zone
14:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:56 <openstack> The meeting name has been set to 'glance'
14:01:13 <hemanthm> o/
14:01:20 <rosmaita> hello everyone
14:01:21 <rosmaita> hope you are having/have had a pleasant day in your time zone
14:01:23 <bpokorny> o/
14:01:26 <kragniz> o/
14:01:50 <rosmaita> nikhil is on a much deserved vacation
14:01:59 <tsymanczyk> o/
14:02:03 <nikhil> :-)
14:02:05 <rosmaita> not a lot on the agenda for today
14:02:09 <bunting> o/
14:02:10 <hemanthm> is he? :)
14:02:14 <rosmaita> apparently not!
14:02:15 <mfedosin> o/
14:02:35 <mfedosin> let's talk about Glare
14:02:39 <rosmaita> cool
14:02:41 <dshakhray> o/
14:02:45 <abhishekk> o/
14:02:50 <nikhil> Im sorta in a conf/mtg. Listening on irc on phone for next 3min.
14:02:50 <rosmaita> #topic glare update
14:03:00 <rosmaita> mfedosin: what do you have for us?
14:03:40 <mfedosin> rosmaita: thanks for your comments in spec commit
14:03:49 <mfedosin> I'll try to address it today
14:03:55 <rosmaita> excellent
14:04:24 <mfedosin> I developed sqlalchemy backend
14:04:36 * nikhil goes afk
14:04:47 <mfedosin> and rewrote artifact sorting and filtering
14:04:56 <rosmaita> you have been busy
14:05:11 <mfedosin> kairat made a titanic work on artifact lock
14:05:22 <rosmaita> go kairat!
14:05:30 <mfedosin> it's a thing to prevent race conditions :)
14:05:55 <mfedosin> also we have new team member Serg Skripnick
14:06:08 <rosmaita> welcome Serg
14:06:24 <mfedosin> he'll start working on Glance/Glare next Monday
14:07:05 <rosmaita> i've noticed a lot of patches for glare, most marked WIP
14:07:05 <mfedosin> so, if you have something to say about Glare api - it's the best time to do it in the spec
14:07:21 * rosmaita should shut up and let mfedosin talk
14:07:25 <mfedosin> rosmaita: yeah, we continue developing of glare
14:07:41 <mfedosin> but also there is a set of patches that are not wip
14:07:50 <mfedosin> and we consider them as stable
14:07:53 <rosmaita> ok, cores, please review the glare API spec
14:08:05 <mfedosin> rosmaita: thanks Brian
14:08:25 <rosmaita> ok, so any glare patches not specifically marked WIP are ready for review
14:08:30 <rosmaita> we better get started!
14:08:33 <mfedosin> yes
14:08:35 <rosmaita> it's a lot of stuff to look at
14:08:50 <rosmaita> (but high quality, and not much in the way of race conditions!)
14:08:59 <mfedosin> #link https://review.openstack.org/#/c/330458/
14:09:15 <mfedosin> it's a top commit in the series
14:09:30 <mfedosin> I think I'll update it tomorrow
14:10:00 <mfedosin> the latest glare code we have is located here
14:10:02 <mfedosin> #link https://review.openstack.org/#/c/292327/
14:10:41 <mfedosin> it's a development branch :)
14:11:03 <mfedosin> one thing I want to add
14:11:20 <mfedosin> now we consider Glare code is stable
14:11:44 <mfedosin> and that's why we are going to start implementing artifact types for openstack services
14:12:03 <mfedosin> tomorrow we begin with Murano artifact type
14:12:39 <mfedosin> our plans are to seat with Alex Tivelkov and Kirill Zaitsev and implement some POC
14:13:01 <mfedosin> and next week we want to do the same with Heat team
14:13:22 <mfedosin> Heat AT is much easier than Murano one
14:13:55 <rosmaita> implementing those should help shake out any corner cases
14:14:01 <mfedosin> I'll make a big update next week, when these artifact types are implemented
14:14:39 <mfedosin> I think that's all for today
14:14:42 <rosmaita> sounds good
14:14:47 <mfedosin> yeah
14:14:52 <rosmaita> i just want to repeat: the glare code is ready for reviews
14:14:59 <mfedosin> we have a huge progress
14:15:16 <rosmaita> also, if you haven't seen the API spec, please look now or forever hold your peace!
14:15:39 <rosmaita> thanks mike!
14:15:46 <mfedosin> welcome :)
14:15:51 <rosmaita> moving along
14:15:54 <rosmaita> #topic v2 adoption across services
14:16:07 <rosmaita> there are two items to discuss, here are the links
14:16:07 <rosmaita> #link https://bugs.launchpad.net/glance/+bug/1595335
14:16:08 <openstack> Launchpad bug 1595335 in Glance "Add image location fails when show_multiple_locations = false" [Undecided,Confirmed]
14:16:08 <rosmaita> #link https://review.openstack.org/#/c/320039/
14:16:21 <rosmaita> bpokorny: you have the floor
14:16:28 <bpokorny> Thanks
14:16:51 <bpokorny> So tsufiev and I have been working on the Horizon changes to fully support Glance v2.
14:17:08 <bpokorny> We have most things implemented at this point.
14:17:45 <bpokorny> But the latest thing I ran into is the bug just linked above (159535).
14:18:49 <mfedosin> it's a big inconsistency in glance, imho
14:18:58 <bpokorny> So I was wondering if people here have thoughts on whether we're doing something wrong in Horizon, or if there's a glance bug that needs fixing.
14:19:58 <mfedosin> bpokorny: afaik glance v2 developers wanted to make adding custom locations admin only operation
14:20:18 <mfedosin> and there is a reason for this
14:20:46 <mfedosin> v2 supports multiple locations for an image
14:21:15 <mfedosin> and it may break promised image immutability - user may change image locations after activation
14:21:45 <mfedosin> I think about this issue for a long time
14:22:17 <mfedosin> currently we have two options how to fix it: easy and right :)
14:22:34 <bpokorny> :)
14:22:53 <mfedosin> 1. easy - deprecate show_multiple_locations and make it True by default
14:23:14 <mfedosin> limit max locations size to 1
14:23:31 <mfedosin> it brings behavior we have in glance v1
14:24:08 <mfedosin> but it completely breaks multiple locations feature
14:24:30 <mfedosin> and I think people who use it will be unhappy
14:24:51 <mfedosin> 2. right - deprecate show_multiple_locations and make it True by default
14:25:23 <mfedosin> set policies that only admin can add custom locations to images
14:26:01 <mfedosin> send related requests from Horizon user directly
14:26:34 <mfedosin> Horizon user has admin privileges
14:27:02 <mfedosin> so, in short: create image with user context, add location with Horizon context
14:27:38 <mfedosin> Now I want to hear what community thinks about it :)
14:27:40 <rosmaita> i guess that would give horizon the opportunity to somehow "screen" the location?
14:27:43 <hemanthm> that means anyone can add image locations
14:27:49 <rosmaita> what hemanthm said
14:28:12 <mfedosin> with v1 anyone can add image location
14:28:36 <bpokorny> Also, all operations from Horizon are made with the credentials of the user, so there's currently no concept of a Horizon service user.
14:28:51 <rosmaita> ok, well that's good to know
14:28:59 <hemanthm> yeah, but that won't solve the problems that forced us turn or multiplie locations, right? or am I missing anything here?
14:29:14 <hemanthm> *turn off
14:29:37 <mfedosin> bpokorny: the same story for Nova - currently on some deployments we have to enable show_multiple_locations to make it work
14:30:15 <rosmaita> i think we need a multiple-image-locations task force
14:30:16 <bpokorny> Ah, good to know.
14:30:29 <rosmaita> i don't understand the feature and the related use cases
14:30:43 <rosmaita> it's obviously used by some people
14:30:48 <rosmaita> but it's also kind of dangerous
14:31:09 <hemanthm> ++ rosmaita
14:31:29 <rosmaita> it would be good to have some solid use cases before we redesign/deprecate it
14:31:53 <rosmaita> or, if anyone here already knows, please point them out to us
14:32:23 <rosmaita> bpokorny: not sure how heplful this discussion has been?
14:33:12 <bpokorny> rosmaita: Actually, very helpful. I understand now there's some discussion on how to handle multiple locations.
14:33:28 <bpokorny> Does anyone know how Nova is dealing with the issue?
14:33:40 <mfedosin> I know :)
14:33:46 <rosmaita> tell us!
14:33:47 <mfedosin> because I wrote it
14:33:53 <rosmaita> :)
14:34:00 <bpokorny> Yay!
14:34:08 <mfedosin> nohow :)
14:34:23 <mfedosin> we just enabled show_multiple_locations and that's all
14:34:48 <mfedosin> and now I'm afraid that some deployments may be in danger after this change
14:34:59 <bpokorny> Yeah. when an operator installs nova for the first time and uses Glance v2..
14:35:04 <rosmaita> i guess if you have multiple glance nodes, you can enable it for the ones nova talks to and not for the public ones
14:35:38 <bpokorny> They need to know to enable multiple locations.
14:36:11 <bpokorny> So is the plan to document that somewhere, or ??
14:36:41 <rosmaita> i guess it is action item time
14:37:13 <rosmaita> #action someone figure out something about showing multiple locations
14:37:22 <rosmaita> guess that's not very helpful
14:37:33 <tsymanczyk> :)
14:37:36 <mfedosin> what solution do we have for Horizon - send requests to private glances?
14:37:37 <hemanthm> haha
14:38:00 <mfedosin> the best action item I have seen
14:38:09 <bpokorny> It makes sense for the situation we have now :)
14:38:20 <mfedosin> we can continue this talk in mailing list
14:38:35 <rosmaita> is it a "solution' to say that horizon should not expose this, you must use the api?
14:38:38 <mfedosin> maybe people would suggest somithing useful for us
14:38:42 * rosmaita ducks
14:38:56 <rosmaita> mfedosin: ++
14:38:57 <bpokorny> Haha
14:39:45 <bpokorny> For Horizon, we're targeting Newton to merge the v2 changes.
14:39:56 <rosmaita> so you need some action on this quick
14:40:21 <rosmaita> any volunteers to kick off the ML discussion?
14:40:27 <bpokorny> For now, we could just document as a limitation that people need to set multiple locations = True for it to work.
14:40:36 <mfedosin> I'll try to help
14:41:04 <bpokorny> Cool. Thanks, mfedosin and rosmaita.
14:41:06 <rosmaita> mfedosin: let's work together on a draft of an email ... i am worried about where the discussion might go if it's not carefully constrained
14:41:26 <bpokorny> I'll let the other Horizon guys know to watch for the email too.
14:41:30 <mfedosin> rosmaita: okay, I'll send you a draft
14:41:52 <rosmaita> #action mfedosin rosmaita nikhil will work on getting the multiple image locations discussion started on the ML
14:42:04 <rosmaita> bpokorny: thank you!
14:42:11 <bpokorny> Also, just an FYI if anyone wants to start reviewing the Horizon patch: https://review.openstack.org/#/c/320039/
14:42:16 <mfedosin> btw, Heat has the same issue
14:42:21 <rosmaita> great
14:42:29 <rosmaita> any other comments on this topic?
14:42:38 <bpokorny> The Jenkins failure you see in that review is due to the issue we just talked about, so you can ignore that failure for now.
14:42:56 <bpokorny> That's all I had. Thanks, all!
14:43:15 <rosmaita> #link https://review.openstack.org/#/c/320039/
14:43:26 <rosmaita> (horizon patch ^^)
14:43:32 <rosmaita> ok, moving along
14:43:43 <rosmaita> #topic clarifications to glance contributors' guide
14:43:49 <mfedosin> thank bpokorny!
14:43:59 <rosmaita> (this one is me)
14:44:02 <rosmaita> this is a follow up on an action item i had from last week's meeting
14:44:17 <rosmaita> (Policy concerning changes to "old" db migration scripts)
14:44:30 <rosmaita> i put up a patch for your perusal, especially cores
14:44:32 <rosmaita> #link https://review.openstack.org/335688
14:44:46 <rosmaita> i also added a statement about non-type-safe changes to tests, which follows the policy we've had on a series of reviews over the past few cycles, i figured we might as well have it written down somewhere
14:44:59 <rosmaita> i don't think it's controversial, but please review
14:45:08 <rosmaita> ok, that's all from me
14:45:22 <rosmaita> #topic 500 error if member_id > 255 chars
14:45:27 <rosmaita> #link https://bugs.launchpad.net/glance/+bug/1585917/comments/2
14:45:27 <openstack> Launchpad bug 1585917 in Glance "member-create will raise 500 error if member-id is greater than 255 characters" [Undecided,Confirmed] - Assigned to Abhishek Kekane (abhishek-kekane)
14:45:37 <rosmaita> abhishekk: this is your item
14:45:38 <abhishekk> hi
14:45:52 <abhishekk> I have added my comment on the bug
14:46:02 <abhishekk> and need inputs from the team
14:46:34 <abhishekk> there is a problem with input and output for member-create api
14:46:55 <abhishekk> it accepts member as a request body and gives member-id as a response
14:47:18 <rosmaita> i wonder whether we should have a specific schema for the member-create request
14:47:18 <abhishekk> because of this its difficult to add schema validation for member-create api
14:48:31 <rosmaita> i guess another option would be to do a "oneOf" in the schema
14:48:56 <abhishekk> rosmita: I need to check about "oneOf"
14:49:10 <rosmaita> abhishekk: me too, i am talking out of my hat here
14:49:29 <rosmaita> but it think we can say only one of those is accepted, not both
14:49:46 <rosmaita> i don't like having both in the schema in your example
14:49:52 <abhishekk> right, me too
14:50:00 <rosmaita> if we can do oneOf, then the response can always have member_id
14:50:11 <rosmaita> and the request could accept one or the other but not both
14:50:26 <abhishekk> another one is to do a string validation for greater length in controller itself
14:50:31 <hemanthm> I thought 'OneOf' is for specifying types? not completely sure though :P
14:50:52 <rosmaita> hemanthm: you may be right
14:51:04 <rosmaita> i am having some wishful thinking here
14:52:01 <abhishekk> thats it, please add your suggestions on the bug
14:52:14 <rosmaita> ok, thank you abhishekk
14:52:24 <abhishekk> thank you :)
14:52:49 <rosmaita> #action please comment on https://bugs.launchpad.net/glance/+bug/1585917/
14:52:49 <openstack> Launchpad bug 1585917 in Glance "member-create will raise 500 error if member-id is greater than 255 characters" [Undecided,Confirmed] - Assigned to Abhishek Kekane (abhishek-kekane)
14:53:01 <rosmaita> #topic open discussion
14:53:10 <rosmaita> anyone?
14:53:36 <mfedosin> I have nothing to say...
14:53:36 <hemanthm> I do
14:53:47 <rosmaita> hemanthm: go for it!
14:53:59 <hemanthm> Just want to introduce Dharini to all the folks here
14:54:12 <rosmaita> welcome Dharini!
14:54:20 <dharinic__> Hello all. :)
14:54:26 <mfedosin> welcome Dharini :)
14:54:39 <hemanthm> Dharini is a new member of the Openstack Innovation Center
14:54:59 <mfedosin> I haven't heard about it
14:55:06 <mfedosin> what's is it?
14:55:07 <hemanthm> I won't blame you :)
14:55:25 <hemanthm> https://osic.org/
14:55:34 <dharinic__> Thank you. :) I will be working in Glance from Castle. I recently joined the OSIC team.
14:55:42 <rosmaita> #link https://osic.org/
14:56:01 <rosmaita> "Castle" is the name of the Rackspace office in San Antonio, Texas, USA
14:56:09 <rosmaita> well, nickname
14:56:28 <hemanthm> That's all I've got.
14:56:35 <rosmaita> we are happy to have new people working on glance!
14:57:12 <rosmaita> anything else?
14:57:12 <dharinic__> Very happy to be working in Glance. :)
14:57:38 <mfedosin> dharinic_: look at Glare as well ;)
14:57:41 <rosmaita> reminder: please look at Glare API spec
14:57:43 <rosmaita> #link https://review.openstack.org/#/c/283136/
14:58:40 <mfedosin> I'll be very happy
14:58:57 <rosmaita> :)
14:59:10 <rosmaita> looks like that's all for today
14:59:14 <rosmaita> thanks everyone
14:59:20 <mfedosin> seems so
14:59:25 <mfedosin> thanks
14:59:45 <rosmaita> #endmeeting