14:00:13 <nikhil> #startmeeting glance
14:00:13 <openstack> Meeting started Thu Jul  7 14:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <kairat__> o/
14:00:17 <openstack> The meeting name has been set to 'glance'
14:00:19 <bunting> o/
14:00:23 <nikhil> #topic roll call
14:00:31 <tsymanczyk> o/
14:01:06 <nikhil> let's give a couple of mins for people to show up
14:01:09 <mfedosin> o/
14:01:13 <hemanthm> o/
14:01:33 <rosmaita> o/
14:01:37 <nikhil> ok, let's get started
14:01:39 <nikhil> #topic agenda
14:01:42 <nikhil> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:45 <itisha> o/
14:01:50 <itisha> o/
14:01:51 <nikhil> small agenda today
14:02:18 <nikhil> let's make sure we raise any important concerns if any
14:02:28 <nikhil> #topic Glare updates ( mfedosin )
14:02:57 <mfedosin> hello
14:03:23 <mfedosin> so, we implemented artifact type for murano and tested it
14:03:42 <mfedosin> several small bugs were found and fixed
14:04:08 <mfedosin> and in general murano is ready to switch to glare v1 when it's merged
14:04:30 <mfedosin> tomorrow I'll attend a meeting with Heat team
14:04:41 <mfedosin> and will try to implement artifact type for them
14:05:13 <mfedosin> also Serg Skripnick implemented some POC for app-catalog
14:05:22 <wxy> o/
14:05:38 <sskripnick1> true
14:06:06 <mfedosin> we implemented a lot of functional tests for glare and now it's pretty stable and works really nice
14:06:50 <mfedosin> for sure there are many bugs, but all required functionality and common scenarios work
14:07:03 <sigmavirus> :thumbsup:
14:07:26 <mfedosin> spec was reviewed and we got +2 from Brian
14:07:42 <mfedosin> rosmaita: thanks for you support
14:07:49 <rosmaita> :)
14:08:04 <mfedosin> so, all people are waiting when it's merged
14:08:27 <mfedosin> btw, I added a small doc about installation of glare in devstack
14:08:33 <mfedosin> there is a link in the spec
14:08:39 <mfedosin> but I'll copy it here
14:08:54 <mfedosin> #link https://review.openstack.org/#/c/283136/
14:09:14 <mfedosin> #link https://docs.google.com/document/d/1KyY8VB00XvehtpBcLDo_Andx0BDgG-C7E_TdhfvcGv4/edit
14:10:06 <mfedosin> I wrote it mostly for myself, but all required commands are there
14:10:35 <mfedosin> nikhil: is there any chance that you'll review the spec?
14:10:52 <bunting> Is there an offical doc for the installation guidelines?
14:11:15 <nikhil> mfedosin: yes, I will review it. I have thought about some overlap with glance and will test those with your installtion link.
14:11:15 <kairat__> I guess we can't release doc for non-merged functionality
14:11:27 <nikhil> what kairat__ said
14:11:37 <mfedosin> bunting: yeah, it's a temporary doc
14:11:48 <bunting> Makes sense
14:12:27 <mfedosin> so, we have end of N-2 next week
14:12:42 <mfedosin> 15th of July afair
14:13:25 <mfedosin> as far as I know no features are allowed to be merged after that, right?
14:14:06 <nikhil> july 29th is spec freeze
14:14:18 <nikhil> 2weeks before newton-3 is feature freeze
14:14:56 <mfedosin> nikhil: it's good to hear
14:15:05 <nikhil> newton-2 is next week, but we will try to release it on tuesday not thursday ie. on 12th
14:15:42 <mfedosin> ppl from other projects want glare to be merged in n-2
14:16:04 <mfedosin> so they will be able to implement poc in Newton
14:16:19 <mfedosin> I mean Murano, Newton and App-Catalog
14:16:46 <mfedosin> since all code is done and tested
14:17:19 <mfedosin> can we do it on Monday, for example?
14:18:30 <nikhil> you want multiple thousands of lines of code to be merged in one day?
14:19:01 <mfedosin> there was a month for review of code
14:19:05 <jokke_> o/
14:19:51 <mfedosin> there is not so much code btw
14:20:06 <mfedosin> and will split it in 10 small patches
14:20:37 <sigmavirus> o/ jokke_
14:20:38 <mfedosin> currently there are 7, but we added sqlalchemy db, locks and schemas
14:20:45 <mfedosin> jokke_: o/
14:22:14 <nikhil> afaict, there is no review on glare patches today
14:22:27 <mfedosin> we can begin with spec :) nikhil jokke_ your feedback is very welcome
14:22:45 <nikhil> can't speak for others, but I would be hesitent to +W those
14:22:58 <nikhil> I can try to push the spec by newton-2 though
14:24:39 <nikhil> personally, with different events in june I didn't get enough time for consolidated reviews. our june focus was to move forward on specs and different types of proposals.
14:25:09 <mfedosin> nikhil: again, if glare v1 is not available till the end of n2 then none of external projects will be able to use it in Newton
14:25:45 <kzaitsev_mb> hm, that probably pushes adoption even furhter to O cycle
14:25:52 <kzaitsev_mb> i have a deja vu feeling =)
14:25:58 <nikhil> this is news to me and am unable to understand why they think so
14:26:33 <kzaitsev_mb> last couple of cycles there were very similar concerns (most of them about glance v3 though)
14:27:35 <jokke_> well I do understand that they can't merge any changes that depends glare before glare is actually merged, but I don't see why they can't start the work while we are reviewing the code, latest after the spec has been approved and there is likelyhood us merging the code in Newton
14:27:58 <nikhil> mfedosin: I think we need to have all the glare stakeholders at glare meeting on monday to discuss all such issues.
14:28:36 <nikhil> the glance v3 fallout seems to be hitting us back badly. clarification on the difference seems necessary.
14:29:06 <mfedosin> nikhil: I don't mind to discuss it with stakeholders on Monday
14:29:20 <mfedosin> but app-catalog is going to switch to glare
14:29:40 <mfedosin> now they use outdated html pages
14:30:02 <mfedosin> and people have to push edits on review to add things there
14:30:32 <mfedosin> they have been waiting glare so badly for last six month
14:31:11 <jokke_> what comes to the sudden urgency about this, there is two things that needs to be kept in mind a) merging that code needs to happen so that it's comfortable for glance community as glare is part of glance b) what I was surprisedly asking already right after summit, glare is not part of glance priorities this cycle
14:31:14 <mfedosin> and what's the problem to merge the code now? glare is a separate service, it doesn't affect glance at all
14:31:26 <nikhil> all of this isn't a strong enough reasoning to compromise on our reviews
14:31:45 <jokke_> I don't think it's realistic expect that it becomes suddenly priority when there is few weeks left of the development cycle
14:32:49 <mfedosin> nikhil: what have you been doing all last month? why I haven't seen reviews from your side? and now you want more time for what?
14:32:58 <jokke_> that said, I'd be more than happy to see it being stable and merged sooner rather than later, but I can't be speaking on behalf of the whole community
14:33:21 <nikhil> I would like for the community to be civil about priorities, process, lite-specs, etc. things. the appropriate time to discuss that was pre-summit, summit and a bit of time after that.
14:33:53 <nikhil> I don't have to explain my schedule to everyone
14:34:09 <mfedosin> jokke_: when adoption begins we can address issues much quicker, now we're in development vacuum - only functional tests are there. so I agree with you
14:34:23 <nikhil> if you have attended events and the follow up stuff, you know what we have been focusing on.
14:35:50 <mfedosin> nikhil: one question - what are we waiting for now?
14:36:00 <nikhil> I fail to understand why there isn't a single review on the glare code?
14:36:47 <nikhil> if I have to review many specs, I can't spend entire day on one single feature
14:37:04 <rosmaita> i suspect it's because of the '[WIP]' in the commit message title?
14:37:11 <rosmaita> (why no reviews, i mean)
14:37:29 <nikhil> I tried to encourage sudipto, abhishek and other new members interested in glance to review glare
14:37:44 <kairat__> we split the code as requested, one single patch is convenient for updates
14:37:56 <kairat__> because it does not ddos reviewers
14:37:57 <mfedosin> 1. there were reviews - we addressed them
14:38:17 <nikhil> after many conversations with new members and many motivation pushes to them, they have disappeared giving me their feedback privately.
14:39:36 <wxy> rosmaita: for myself, I will not review the WIP patch, because it means the patch is no ready IMO. just my personal idea.
14:39:59 <rosmaita> wxy: my point exactly
14:40:23 <mfedosin> there is a set of stable patches that are ready for review https://review.openstack.org/#/c/330458/
14:40:31 <kairat__> sorry, that's not true
14:40:32 <kairat__> https://review.openstack.org/#/q/status:open+project:openstack/glance+branch:master+topic:bp/glare-api
14:40:50 <jokke_> Honestly I've had three main reasons where the later 2 are directly impacted by the first 1) limitations of my time 2) The spec has not been agreed on / merged making it difficult to review if we are implementing by the desing 3) as Brian mentioned [WIP] has been generally the indication "This is not ready for review, pushed to gerrit to see how tests behaves against the change"
14:41:01 <nikhil> rosmaita: there's confusion on what is WIP and what is ready for review
14:41:15 <mfedosin> we prepared these patches specially for community reviews
14:41:26 <jokke_> so for me reviewing something that has the points 2) & 3) is not good use for the limited time I have in my disposal
14:42:39 <kairat__> so we discussed this at virtual summit
14:42:41 <nikhil> this doesn't seem like a productive debate
14:42:46 <kairat__> and concern was the saem
14:43:04 <kairat__> that we will be lack of reviews if sped won't be merged
14:43:23 <kairat__> now we failed with the same case AFAIU
14:43:55 <mfedosin> #link https://etherpad.openstack.org/p/newton-glance-virtual-midcycle
14:44:02 <mfedosin> scroll till the end
14:44:41 <jokke_> mfedosin, kairat__: I will re-review the spec after this meeting again
14:44:42 <mfedosin> we had reviews before July, 5th
14:44:55 <mfedosin> jokke_: thanks :)
14:45:45 <nikhil> kairat__: it's rarely (or small part) about the process. we really need to work as a community.
14:46:05 <nikhil> having said that, I think for spec good work has been done. we've really good number of reviews there.
14:47:11 <nikhil> and many +1s have come rather recently which is why I am positive about spec before newton-2 but not the code
14:47:50 <nikhil> for instance, no one from others teams who want to use glare (in a rush) have bothered to review the code
14:48:04 <mfedosin> do you remember that there are plans to make v1 stable in n3
14:48:18 <mfedosin> it will be almost impossible without any adoption
14:48:37 <nikhil> to add to that, they are imposing a deadline on glance team without discussion even at the summit or after, which is unacceptable
14:49:32 <rosmaita> we probably need to move on ... what is the summary of the above discussion?
14:49:53 <mfedosin> I think there is no summary
14:49:55 <rosmaita> (or do we need a cooling-down period before summarizing)
14:50:08 <mfedosin> we're waiting for nikhil to review the spec
14:50:16 <nikhil> also, on lack of reviews, I want to stress that we do have a separate meeting and we need to use it to move forward community discussions
14:50:54 <rosmaita> mfedosin: maybe send a reminder of the glare sync to ML for interested parties?
14:51:11 <nikhil> until now, most of the feedback given to me was that people don't understand glare completely
14:51:36 <rosmaita> the spec will fix that, it is extremely thorough
14:51:51 <kairat__> +1 to rosmaita
14:51:56 <nikhil> I can share some of my findings that seem critical (but is untested) in the -glance channel right after this meeting.
14:52:04 <jokke_> lets give this bit cooldown, and continue offline ... we have 9 min, so nikhil how about moving on?
14:52:05 <kairat__> that;s why we wrote use cases in spec
14:52:17 <rosmaita> if someone is vague about glare after reading that spec, they probably should take up a different line of work
14:52:50 <nikhil> rosmaita: it will be clear when I state some of my concerns on why people think so
14:53:09 <nikhil> (I was of same opinion that spec should clarify all things)
14:53:53 <nikhil> #topic Project mascot for glance
14:54:11 <nikhil> so a new initiative and it's around marketing
14:54:44 <nikhil> we need to finalize on this by jul 27th
14:54:57 <rosmaita> here is my suggestion: http://largestfastestsmartest.co.uk/wp-content/uploads/2006/09/wpc0bc5e54_0f.jpg - don't know if it's a good marketing tool, though
14:55:30 <nikhil> so, I need initial suggestions by tuesday so that if there's overlap with other projects we get time
14:55:48 <nikhil> criterion: anything from the natural world—an animal, fish, plant, or natural feature such as a mountain or waterfall
14:56:01 <bunting> Should it be related to glance if possible?
14:56:02 <jokke_> nikhil: that's nice and well planned heads up for such
14:56:04 <rosmaita> (my suggestion is both glancing and glaring)
14:56:31 <nikhil> #action all: send nikhil suggestion for project mascot
14:57:28 <nikhil> #topic open discussion
14:57:53 <rosmaita> i think item 3.2 will require a bit of time, but the idea is that we should structure db changes a bit in this release to help with eventual rolling upgrades
14:58:14 <rosmaita> for item 3.3, i would like to take this to the api-wg in an hour unless there are objections
14:58:29 <rosmaita> https://bugs.launchpad.net/glance/+bug/1585917/comments/3
14:58:29 <openstack> Launchpad bug 1585917 in Glance "member-create will raise 500 error if member-id is greater than 255 characters" [Undecided,Confirmed] - Assigned to Abhishek Kekane (abhishek-kekane)
14:58:49 <rosmaita> unless people think this schema proposal is absurd
14:59:34 <hemanthm> rosmaita: what we have currently is absurd too
14:59:45 <rosmaita> nikhil: is it ok if i float the idea with api-wg, or do you want me to wait a week?
14:59:51 <nikhil> rosmaita: works for me
14:59:59 <nikhil> rosmaita: api-wg
15:00:02 <rosmaita> ty, i will see what they say
15:00:11 <hemanthm> rosmaita: +1 to reach api-wg
15:00:28 <nikhil> rosmaita: if you can link me when they are discussing, that would be helpful.
15:00:28 <jokke_> rosmaita: I think it's ok to ask their feedback even if we're not decided yet
15:00:34 <rosmaita> #action rosmaita to take member schema proposal to api-wg
15:00:34 <nikhil> and we're out of time
15:00:40 <jokke_> thanks all!
15:00:40 <nikhil> thanks all for joining
15:00:47 <nikhil> #endmeeting