#openstack-meeting-4: glance

Meeting started by nikhil at 14:00:44 UTC (full logs).

Meeting summary

  1. Glare Updates ( mfedosin ) (nikhil, 14:04:47)
    1. agenda for today https://etherpad.openstack.org/p/glance-team-meeting-agenda (nikhil, 14:05:10)
    2. https://review.openstack.org/#/c/343787/ (mfedosin, 14:06:32)
    3. glance project specific dates : http://lists.openstack.org/pipermail/openstack-dev/2016-May/094780.html (nikhil, 14:19:27)
    4. ACTION: nikhil : add the dates to a permanant location (see if release team is still accepting updates) (nikhil, 14:20:00)

  2. Nova v1, v2 updates ( nikhil ) (nikhil, 14:21:15)
    1. use_glance_v1 defaults to false, glance v1 deprecated in nova, move to glance v2 to upgrade nova to ocata (nikhil, 14:21:25)
    2. https://github.com/openstack/nova/blob/11f8c1bc3ce07cb5ffe52f6dbd5d4892bfa9c4e3/nova/conf/glance.py#L51-L74 (nikhil, 14:21:50)
    3. http://specs.openstack.org/openstack/nova-specs/specs/newton/approved/deprecate-api-proxies.html (nikhil, 14:21:57)
    4. http://eavesdrop.openstack.org/irclogs/%23openstack-nova/%23openstack-nova.2016-07-20.log.html#t2016-07-20T16:07:54 (nikhil, 14:22:04)
    5. https://bugs.launchpad.net/python-glanceclient/+bug/1596602 (nikhil, 14:22:34)
    6. https://review.openstack.org/#/c/328390/ (jokke_, 14:24:31)
    7. ACTION: nikhil: start a full spec collaboration on glance v1 deprecation (nikhil, 14:27:35)
    8. VOTE: Voted on "Should we (glance team) start v1 deprecation in Newton?" Results are, yes: 7 (nikhil, 14:30:24)

  3. Releases ( nikhil ) (nikhil, 14:30:42)
    1. glanceclient 2.2.0 http://lists.openstack.org/pipermail/openstack-announce/2016-July/001363.html (nikhil, 14:30:58)
    2. glance_store 0.14.0 http://lists.openstack.org/pipermail/openstack-dev/2016-July/099660.html (nikhil, 14:31:06)
    3. all: please type your/interest/proposer irc nick after your topic in meeting agenda (nikhil, 14:34:31)

  4. Glance has been introducing policies to address specific use cases; Glare is using more general policies with specific use cases met by carefully constructed rules ( kairat , bunting ) (nikhil, 14:34:45)
    1. https://review.openstack.org/#/c/256381/ (nikhil, 14:35:16)
    2. https://review.openstack.org/#/c/309346/ (bunting, 14:43:18)
    3. https://review.openstack.org/#/c/292327/48/glance/common/glare/policy.py (mfedosin, 14:48:49)

  5. open discussion (nikhil, 14:54:35)


Meeting ended at 15:00:45 UTC (full logs).

Action items

  1. nikhil : add the dates to a permanant location (see if release team is still accepting updates)
  2. nikhil: start a full spec collaboration on glance v1 deprecation


Action items, by person

  1. nikhil
    1. nikhil : add the dates to a permanant location (see if release team is still accepting updates)
    2. nikhil: start a full spec collaboration on glance v1 deprecation


People present (lines said)

  1. nikhil (106)
  2. kairat (62)
  3. jokke_ (32)
  4. mfedosin (28)
  5. rosmaita (26)
  6. hemanthm (23)
  7. bunting (19)
  8. openstack (8)
  9. abhishekk (1)
  10. croelandt (1)
  11. itisha (1)


Generated by MeetBot 0.1.4.