14:00:00 <nikhil> #startmeeting glance
14:00:01 <openstack> Meeting started Thu Aug 18 14:00:00 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:04 <openstack> The meeting name has been set to 'glance'
14:00:09 <bunting> o/
14:00:09 <nikhil> #topic roll call
14:00:12 <tsymanczyk> \o
14:00:14 <nikhil> hi bunting
14:00:22 <bunting> nikhil: Hello!
14:00:24 <itisha> o/
14:00:26 <liwei> o/
14:00:33 <dharinic> Hello all.
14:00:36 <Jokke_> o/
14:00:39 <nikhil> welcome all
14:00:45 <nikhil> We've a short agenda today.
14:00:47 <rosmaita> o/
14:00:49 <nikhil> let's get started
14:00:54 <nikhil> #topic agenda
14:00:56 <nikhil> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:18 <nikhil> if any one needs to add one or two items, we still have space/time
14:01:33 <nikhil> but you can choose to do so in open discussion as well
14:01:45 <nikhil> #topic Community Images Updates
14:02:21 <nikhil> Yesterday, the champions/liaisons of this features met on #openstack-glance and determined the state
14:02:43 <nikhil> from the looks of it, the implementation is looking to be a tad more complicated than it was expected
14:02:57 <nikhil> but nothing we can't achieve in the next couple of months
14:03:31 <nikhil> also, there's this issue of making sure client release matches with the release of the API as we will expect API impact
14:03:51 <nikhil> client behavior needs to be adjusted according to what's required and what's preferred
14:03:59 <nikhil> but all of that will be possible when API is ready
14:04:17 <nikhil> Plan of action on this feature is being updated at:
14:04:19 <nikhil> #link https://etherpad.openstack.org/p/community-images-work-items
14:04:38 <nikhil> The tentative timeline is API targetted just before the summit
14:04:49 <Jokke_> nikhil: so expectation is that it will be ready to merge when Ocata opens?
14:04:56 <nikhil> and client, tests outside source tree and docs for o-2
14:05:31 <nikhil> Jokke_: not sure, we've about 6 weeks for Ocata to officially start
14:05:38 <nikhil> but ocata opens much before
14:05:50 <nikhil> i.e. right when n-3 is cut (which is in 2 weeks)
14:06:06 <tsymanczyk> it will not be done in 2 weeks.
14:06:08 <nikhil> so, I don't think API will be ready in 2 weeks
14:06:15 <Jokke_> Ocata opens when RC1 is cut, not N-3, right
14:06:17 <Jokke_> ?
14:06:58 <nikhil> Jokke_: I think the stable/newton is cut at n-3 and backports are done starting/in rc-1 too
14:07:26 <nikhil> it will be hard to get this in even if we get a FFE
14:07:35 <Jokke_> oh, that's new ... and totally crap plan. Oh well, we'll see how it works out.
14:08:19 <Jokke_> I would not be comfortable to try to get this in for Newton anymore
14:08:22 <nikhil> Jokke_: can you please elaborate on your dislike about the plan? may be we can reconsider alternate plan for community images
14:08:36 <Jokke_> nikhil: I was more worried about the release
14:08:42 <nikhil> I see
14:09:14 <Jokke_> normally there has been stabilization between Rel-3 and RC1 to keep focus on fixing stuff rather than doing new
14:09:39 <Jokke_> if that period is gone, this will just shift everyones focus away 2 months early
14:09:44 <nikhil> Jokke_: I will confirm the dates on the cut of stable/newton, but at this point that's where am at.
14:10:16 <nikhil> noted
14:10:51 <nikhil> I was able to keep up with a few updated to the project team guide, and ML emails but I would like to point out references before I claim authority over dates.
14:10:56 <nikhil> updates*
14:11:08 <Jokke_> so my assumption for "by start of Ocata" was expectation of ~6-7 weeks from now, not 2 ;)
14:11:38 <nikhil> Jokke_: yeah :) it's a tricky understanding
14:12:02 <nikhil> Jokke_: officially ocata is supposed to start at the summit week (At least that's what I've been communicated before)
14:12:34 <nikhil> but technically, any commit that doesn't go in stable/newton will be Ocata
14:13:46 <nikhil> and that's what I really meant by Ocata (the release notes, updates to docs and communication to packagers/ops) will need to be done accordingly. However, from a developer perspective ocata features may not officially start until after 6 weeks. (as there are restrictions on what can get in until then)
14:14:49 <Jokke_> cool ... move on ... sorry for hijacking
14:14:51 <nikhil> Either way, I won't be able to give much attention to CI (Community Images) until after Newton is stabilized.
14:15:16 <nikhil> So, there is expected delay to this development and we will try our best to get it done before the summit.
14:15:34 <nikhil> Please see the updates on the etherpad linked above.
14:15:37 <nikhil> Thanks!
14:15:46 <nikhil> #topic Import Refactor
14:16:07 <nikhil> So, this is the only major feature that needs core attention from here on to newton is released.
14:16:12 <nikhil> We've about 5 commits:
14:16:18 <nikhil> https://review.openstack.org/#/q/topic:import-refactor-newton
14:16:29 <nikhil> I've picked up: https://review.openstack.org/270980
14:16:44 <nikhil> and rosmaita has picked up 2 https://review.openstack.org/267209 https://review.openstack.org/312972
14:16:58 <nikhil> these are WIP and patches will be up when a good commit is up
14:17:11 <nikhil> we are trying to avoid pushing WIP stuff to gerrit
14:17:31 <nikhil> as it could potentially result into red herring (like before in the early phase of the cycle)
14:18:01 * Jokke_ starts stretching
14:18:08 <nikhil> The glance gate has been cleaned for about a month now and only 2-4 other commits look solid candidats for newton
14:18:53 <nikhil> Also, I expect to push another commit/amend to the spec that writes up "declaration of intent"
14:19:21 <nikhil> this will include details from our conversation early in the cycle and at the defcore ML (plus other details like defcore test spec)
14:19:48 <nikhil> oops, not defcore ML but defcore midcycle
14:20:15 <nikhil> Concrete stuff by next meeting.
14:20:24 <nikhil> comments?
14:21:13 <Jokke_> waiting for that ... honestly I'm worried about the late time for this, but we'll see
14:22:05 <nikhil> oh well, we'd do only so much with no one dedicated to it the whole cycle and defcore being the bottleneck the whole time.
14:22:34 <nikhil> I forgot to mention, the above 3 commits are expected to cover the Discovery call needed for the import refactor.
14:22:54 <Jokke_> nikhil: not saying that. I'm more concerned rushing it in now than the fact that we have had headwind pretty much last 2 cycles now
14:23:22 <nikhil> That's the first phase of the plan, I think there's a few updates required to good work from stuart right after that.
14:23:46 <nikhil> Jokke_: totally get that. I think we can discuss things around your concerns on the declaration of intent
14:24:05 <Jokke_> just want to remind everyone to be careful with the reviews. Once we release that endpoint and it's behavior we need to stick with it
14:24:17 <rosmaita> +1
14:24:20 <nikhil> the community issues have been resolved to great extent and people will have to think twice if not thrice before blaming glance about anything!
14:24:56 <nikhil> Jokke_: absolutely
14:25:09 <nikhil> particularly the discovery bit
14:26:32 <nikhil> moving on
14:26:41 <nikhil> #topic Releases updates ( nikhil )
14:27:05 <nikhil> release schedule is:
14:27:07 <nikhil> #link http://releases.openstack.org/newton/schedule.html
14:27:25 <nikhil> Plan is to cut newton-3 by Aug 31st
14:27:34 <nikhil> but really depends on our momentum
14:28:00 <nikhil> "Not official yet" final releases of:
14:28:06 <nikhil> glance_store is 0.17.0
14:28:12 <nikhil> #link https://review.openstack.org/#/c/356857/
14:28:21 <nikhil> python-glanceclient is 2.4.0
14:28:29 <nikhil> #link https://review.openstack.org/#/c/356855/
14:28:45 <nikhil> but I hope that they are final (and we don't have to deal with any bugs)
14:28:54 <nikhil> comments/questions?
14:29:38 <Jokke_> so we are feature complete for Newton?
14:29:59 <Jokke_> In a sense that at least nothing will anymore be merged to the client?
14:30:21 <nikhil> yeah
14:30:34 <nikhil> nothing is WIP in client or store
14:31:14 <nikhil> any spcs that were approved and not implemented will be moved to ocata for implementation (no need for reapproval) . this includes specs from privious cycles.
14:31:26 <Jokke_> wow
14:32:07 <nikhil> Jokke_: wow as in bad wow or good wow?
14:32:13 <nikhil> or worried wow :)
14:32:29 <nikhil> (just trying to make sure we don't get last minute surprises)
14:32:30 <Jokke_> Not sure yet ;)
14:32:43 <Jokke_> Surprised at least ;)
14:32:48 <nikhil> ok
14:33:12 <nikhil> I think we've had good attention for client and store in terms of reviews as compared to their size relative to glance.
14:34:14 <nikhil> moving on
14:34:30 <nikhil> #topic Barcelona Design Summit space needs
14:34:53 <nikhil> So, for Austin we had  allocation as : 3fb, 5wr, cm:full (2 half days)
14:35:12 <nikhil> but here's the list of major constraints for Ocata
14:36:09 <nikhil> There's going to be change in the design summit style/conferences. So, Ocata will be *much* shorter cycle -- only 15 weeks between the design summit and feature freeze, including thanksgiving and other end-of-year holidays
14:36:35 <nikhil> ttx has indicated that we don't need to plan much work for the same.
14:37:01 <Jokke_> In that perspective our work is also pretty much planned for short release
14:37:19 <Jokke_> if we are going to take that import refactoring seriously
14:37:36 <nikhil> The slots are lesses than Austin and they had to squeeze in the design sessions a bit to accomodate ops meetup to not overlap with cross project workshops.
14:37:45 <nikhil> lesser*
14:38:25 <nikhil> So, contributors' meetup will only be maximum one half day (ie. only Friday afternoon)
14:38:45 <nikhil> as the sessions will be scheduled until Friday morning.
14:40:06 <nikhil> #info All: Plan your travel to summit/Barcelona to attend if ops meetup then Tues or if only cross project + project meetups then Tues evening 4pm onward and *back* on Saturday.
14:40:35 * Jokke_ is gonna be there Sun-Sat all booked already
14:41:00 <nikhil> The contributions to the project and activity etc will be taken into consideration before the slots are allocated to us.
14:41:25 <nikhil> We still need to give our preferences to the planners:
14:42:06 <nikhil> they want to be done by Aug 31st so here's my take on what will work for us
14:42:29 <nikhil> 2FB, 4WR, 1CM
14:42:46 <nikhil> our request is lesser than Austin and it's not too less.
14:42:50 <Jokke_> I'd say even 2+2 would be likely enough for us
14:42:55 <abashmak> sorry, can you expand the acronyms?
14:43:00 <nikhil> Also, like Jokke_ rightly pointed out we've a bit of backlog too.
14:43:18 <rosmaita> fishbowl, workroom, contributors' meetup
14:43:21 <nikhil> FB == Fishbowl ( Our traditional largish rooms organized in fishbowl style, with
14:43:21 <nikhil> advertised session content on the summit schedule for increased external
14:43:21 <nikhil> participation. Ideal for when wider feedback is essential.)
14:43:33 <nikhil> thos are (from Wednesday 4pm to Friday noon)
14:43:44 <nikhil> WR == Workroom sessions (from Wednesday 4pm to Friday noon)
14:43:45 <nikhil> Smaller rooms organized in boardroom style, with topic buried in the
14:43:45 <nikhil> session description, in an effort to limit attendance and not overcrowd
14:43:45 <nikhil> the room. Ideal to get work done and prioritize work in small teams.
14:43:56 <nikhil> CM == Contributors meetup (Friday afternoon)
14:43:56 <nikhil> Half-day session on Friday afternoon to get into the Ocata action while
14:43:56 <nikhil> decisions and plans are still hot, or to finish discussions started
14:43:56 <nikhil> during the week, whatever works for you.
14:43:58 <Jokke_> 2+2+1 I mean
14:45:11 <nikhil> so for work session, I think what we need is:
14:45:16 <nikhil> 1 for ops meetup (like in Austin -- may be useful for rolling upgrades)
14:45:17 <nikhil> 1 for defcore meetup (casual updates and get to know plus communicate awarenss)
14:45:43 <nikhil> 1 for updates on the code for CI and import (half each)
14:46:12 <nikhil> and 1 for anyone who has a idea (we could potentially accomodate new contributors to ensure our team keeps growing and reviews are not stalled)
14:46:31 <hemanthm> rolling upgrades?
14:46:35 <rosmaita> i don't think the defcore one is necessary?
14:46:58 <rosmaita> i think we need 1 wr for image import for sure, dont' think we should split it
14:47:11 <rosmaita> and we will need community images (CI)
14:47:23 <nikhil> hemanthm: that was just my take, I don't know how much feedback we still need from ops
14:47:54 <nikhil> ops meetups have always helped put a good perspective
14:48:01 <Jokke_> nikhil: I thought you said there is this time dedicated time for the ops meetup so we don't need to use design sessions for that
14:48:17 <hemanthm> we are working on three big changes for Ocata: image import, community images and rolling upgrades. And, the ocata dev cycle is much shorter as pointed out earlier
14:48:28 <nikhil> rosmaita: the defcore one was to indicate collaboration between osc/infra/defcore/glance/glare. but upto the team on what they think is a good idea.
14:48:40 <Jokke_> Well I hope we wouldn't need community Images as nikhil pointed out that it's best case scenario merged by summit
14:48:41 <hemanthm> are we comfortable with tackling those three big changes in a short cycle?
14:49:10 <nikhil> Jokke_: if people are expecting to go to ops meetup then surely we can avoid that. I am just taking the prior experiences into account.
14:49:43 <nikhil> well, I don't think we need to include all the changes that we discuss at the summit in that specific cycle itself
14:49:58 <Jokke_> hemanthm: I'm sure we can comfortably take them on and not deliver :P
14:50:09 <nikhil> but if we are going to have specs discussions, then it's best to take every opportunity to have some F2F time
14:50:18 <Jokke_> ++
14:50:45 <rosmaita> i think rolling upgrades are important, we need a devoted session
14:50:49 <nikhil> having F2F time reduces the risk of red herrings
14:50:51 <hemanthm> true, but it helps to manage/set expectations
14:50:56 <Jokke_> I also think we need to make decision at least what we & glare folks are going to do about glance_store
14:50:57 <hemanthm> we can't leave it open ended
14:51:12 <nikhil> yep
14:51:18 <nikhil> Jokke_: ^
14:51:25 <Jokke_> we likely need to at least come together and see if we are going to refactor it for both projects or forget about it
14:52:40 <Jokke_> nikhil: just noticed we have 8min ... was there something else in the agenda?
14:52:41 <nikhil> hemanthm: yes, for planning we need interested people at the CM, to be able to come to a common understanding about the cycle plans.
14:52:53 <nikhil> Jokke_: nothing from me
14:53:00 <nikhil> we can continue this in open discussion
14:53:05 <nikhil> #topic open discussion
14:53:25 <Jokke_> our "short agenda" ;)
14:53:33 <nikhil> :)
14:53:40 <tsymanczyk> he wasn't wrong.
14:53:57 <nikhil> 0:)
14:54:19 <nikhil> ty tsymanczyk (I indeed wasn't under the impression this mtg will stretch so long)
14:54:49 <nikhil> hemanthm: and rosmaita : you're currently driving rolling upgrade specs. so I don't want to enforce having a session on you guys.
14:55:10 <nikhil> but asking a slot for it is still better than not asking for it in the first place
14:55:18 <Jokke_> tsymanczyk: so quick question. Some acute issues you're fighting with on the community images?
14:55:20 <rosmaita> yes, we definitely want a slot
14:55:27 <nikhil> we can always concede our slot later but can't necessarily ask for more
14:55:47 <hemanthm> ++ rosmaita
14:56:10 <rosmaita> my point earlier is that i think we need a full slot for rolling upgrades
14:56:23 <nikhil> rosmaita: and any objections for it to be shared with ops/sync but I guess we don't have to plan that now
14:56:25 <nikhil> ?
14:56:34 <nikhil> rosmaita: I see
14:56:43 <rosmaita> i think it needs to be RG focused
14:56:53 <nikhil> should I start a etherpad for summit planning?
14:57:03 <rosmaita> yes!!!
14:57:08 <nikhil> aight
14:57:15 <rosmaita> we can discuss all this on the etherpad
14:57:44 <nikhil> #action nikhil: start a etherpad to discuss the slots needed for Barcelona summit
14:58:00 <nikhil> any more items?
14:58:13 <rosmaita> nikhil: was there a deadline for submission for design summit slot requests?
14:58:45 <Jokke_> rosmaita: it was 31st
14:58:59 <nikhil> rosmaita: latest Aug 31st is when the data needs to be sent from our end
14:59:03 <rosmaita> ty
14:59:17 <rosmaita> Jokke_: about community images: https://etherpad.openstack.org/p/community-images-work-items
14:59:37 <nikhil> 30 secs :)
15:00:00 <nikhil> rosmaita: -glance?
15:00:04 <nikhil> Thanks all!
15:00:22 <nikhil> rosmaita: yt?
15:00:32 <rosmaita> yup
15:00:50 <nikhil> rosmaita: want a min or should we chat on the other channel?
15:00:50 <rosmaita> nikhil: took me a minute to realize what you meant!
15:00:51 <matt-borland> o/
15:01:03 <david-lyle> o/
15:01:08 <nikhil> ok, let's end this meeting
15:01:14 <nikhil> crowd here for next one
15:01:16 <nikhil> #endmeeting